[PATCH v2] squashfs: Add posix acl support

2018-04-09 Thread Geliang Tang
Add posix acl (Access Control Lists) support for squashfs, which is marked as a todo item in squashfs' documentation. This patch implements the squashfs_get_acl function to read file's acl information from its xattr lists. Signed-off-by: Geliang Tang --- Changes in v2: -

Re: [RFC bpf-next] bpf: document eBPF helpers and add a script to generate man page

2018-04-09 Thread Alexei Starovoitov
On Mon, Apr 09, 2018 at 02:25:26PM +0100, Quentin Monnet wrote: > > Anyway, I am fine with keeping just signatures, descriptions and return > values for now. I will submit a new version with only those items. Thank you. Could you also split it into few patches? include/uapi/linux/bpf.h |

Re: [PATCH 1/2] perf: riscv: preliminary RISC-V support

2018-04-09 Thread Palmer Dabbelt
On Mon, 09 Apr 2018 00:07:11 PDT (-0700), alan...@andestech.com wrote: On Thu, Apr 05, 2018 at 09:47:50AM -0700, Palmer Dabbelt wrote: On Mon, 26 Mar 2018 00:57:54 PDT (-0700), alan...@andestech.com wrote: >This patch provide a basic PMU, riscv_base_pmu, which supports two >general hardware

Re: [PATCH] squashfs: Add posix acl support

2018-04-09 Thread kbuild test robot
Hi Geliang, Thank you for the patch! Yet something to improve: [auto build test ERROR on v4.16] [also build test ERROR on next-20180409] [cannot apply to squashfs/master] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https

Re: [PATCH v4 10/10] dt-bindings: gpio: Add bindings for Cadence I3C gpio expander

2018-04-09 Thread Rob Herring
On Fri, Mar 30, 2018 at 09:47:51AM +0200, Boris Brezillon wrote: > Document the Cadence I3C gpio expander bindings. > > Signed-off-by: Boris Brezillon > --- > Changes in v4: > - Use GPIO_ and IRQ_TYPE_ macros instead of raw numbers > - Fix the unit-address in the

Re: [PATCH v4 08/10] dt-bindings: i3c: Document Cadence I3C master bindings

2018-04-09 Thread Rob Herring
On Fri, Mar 30, 2018 at 09:47:49AM +0200, Boris Brezillon wrote: > Document Cadence I3C master DT bindings. > > Signed-off-by: Boris Brezillon > --- > Changes in v4: > - Fix example to match the new representation > --- >

Re: [PATCH v4 04/10] dt-bindings: i3c: Document core bindings

2018-04-09 Thread Rob Herring
On Fri, Mar 30, 2018 at 09:47:45AM +0200, Boris Brezillon wrote: > A new I3C subsystem has been added and a generic description has been > created to represent the I3C bus and the devices connected on it. > > Document this generic representation. > > Signed-off-by: Boris Brezillon

Re: [PATCH 2/3] mm: replace __HAVE_ARCH_PTE_SPECIAL

2018-04-09 Thread David Rientjes
On Mon, 9 Apr 2018, Christoph Hellwig wrote: > > -#ifdef __HAVE_ARCH_PTE_SPECIAL > > +#ifdef CONFIG_ARCH_HAS_PTE_SPECIAL > > # define HAVE_PTE_SPECIAL 1 > > #else > > # define HAVE_PTE_SPECIAL 0 > > I'd say kill this odd indirection and just use the > CONFIG_ARCH_HAS_PTE_SPECIAL symbol

Re: [PATCH 2/3] mm: replace __HAVE_ARCH_PTE_SPECIAL

2018-04-09 Thread Christoph Hellwig
> -#ifdef __HAVE_ARCH_PTE_SPECIAL > +#ifdef CONFIG_ARCH_HAS_PTE_SPECIAL > # define HAVE_PTE_SPECIAL 1 > #else > # define HAVE_PTE_SPECIAL 0 I'd say kill this odd indirection and just use the CONFIG_ARCH_HAS_PTE_SPECIAL symbol directly. -- To unsubscribe from this list: send the line

[PATCH] sched/fair: add support to tune PELT ramp/decay timings

2018-04-09 Thread Patrick Bellasi
The PELT half-life is the time [ms] required by the PELT signal to build up a 50% load/utilization, starting from zero. This time is currently hardcoded to be 32ms, a value which seems to make sense for most of the workloads. However, 32ms has been verified to be too long for certain classes of

Re: [PATCH 0/3] move __HAVE_ARCH_PTE_SPECIAL in Kconfig

2018-04-09 Thread Laurent Dufour
On 09/04/2018 18:03, Vineet Gupta wrote: > On 04/09/2018 06:57 AM, Laurent Dufour wrote: >> The per architecture __HAVE_ARCH_PTE_SPECIAL is defined statically in the >> per architecture header files. This doesn't allow to make other >> configuration dependent on it. > > So I understand this

Re: [PATCH 0/3] move __HAVE_ARCH_PTE_SPECIAL in Kconfig

2018-04-09 Thread Vineet Gupta
On 04/09/2018 06:57 AM, Laurent Dufour wrote: The per architecture __HAVE_ARCH_PTE_SPECIAL is defined statically in the per architecture header files. This doesn't allow to make other configuration dependent on it. So I understand this series has more "readability" value and I'm fine with this

Re: [PATCH 0/3] move __HAVE_ARCH_PTE_SPECIAL in Kconfig

2018-04-09 Thread Jerome Glisse
On Mon, Apr 09, 2018 at 04:07:21PM +0200, Michal Hocko wrote: > On Mon 09-04-18 15:57:06, Laurent Dufour wrote: > > The per architecture __HAVE_ARCH_PTE_SPECIAL is defined statically in the > > per architecture header files. This doesn't allow to make other > > configuration dependent on it. > >

Re: [PATCH V2 3/9] dt-bindings: Tegra186 tachometer device tree bindings

2018-04-09 Thread Mikko Perttunen
On 04/09/2018 04:21 PM, Rob Herring wrote: On Mon, Apr 9, 2018 at 12:38 AM, Mikko Perttunen wrote: Rob, Please don't top post to lists. this binding is for a specific IP block (for measuring/aggregating input pulses) on the Tegra186 SoC, so I don't think it fits into any

Re: [PATCH 0/3] move __HAVE_ARCH_PTE_SPECIAL in Kconfig

2018-04-09 Thread Michal Hocko
On Mon 09-04-18 15:57:06, Laurent Dufour wrote: > The per architecture __HAVE_ARCH_PTE_SPECIAL is defined statically in the > per architecture header files. This doesn't allow to make other > configuration dependent on it. > > This series is moving the __HAVE_ARCH_PTE_SPECIAL into the Kconfig

[PATCH 3/3] mm: remove __HAVE_ARCH_PTE_SPECIAL

2018-04-09 Thread Laurent Dufour
It is now replaced by Kconfig variable CONFIG_ARCH_HAS_PTE_SPECIAL. Signed-off-by: Laurent Dufour --- arch/arc/include/asm/pgtable.h | 2 -- arch/arm/include/asm/pgtable-3level.h| 1 - arch/arm64/include/asm/pgtable.h | 2 --

[PATCH 2/3] mm: replace __HAVE_ARCH_PTE_SPECIAL

2018-04-09 Thread Laurent Dufour
Replace __HAVE_ARCH_PTE_SPECIAL by the new configuration variable CONFIG_ARCH_HAS_PTE_SPECIAL. Signed-off-by: Laurent Dufour --- Documentation/features/vm/pte_special/arch-support.txt | 2 +- include/linux/pfn_t.h | 4 ++-- mm/gup.c

[PATCH 1/3] mm: introduce ARCH_HAS_PTE_SPECIAL

2018-04-09 Thread Laurent Dufour
Currently the PTE special supports is turned on in per architecture header files. Most of the time, it is defined in arch/*/include/asm/pgtable.h depending or not on some other per architecture static definition. This patch introduce a new configuration variable to manage this directly in the

[PATCH 0/3] move __HAVE_ARCH_PTE_SPECIAL in Kconfig

2018-04-09 Thread Laurent Dufour
The per architecture __HAVE_ARCH_PTE_SPECIAL is defined statically in the per architecture header files. This doesn't allow to make other configuration dependent on it. This series is moving the __HAVE_ARCH_PTE_SPECIAL into the Kconfig files, setting it automatically when architectures was

Re: [PATCH v2 7/9] trace_uprobe/sdt: Fix multiple update of same reference counter

2018-04-09 Thread Ravi Bangoria
On 04/09/2018 07:02 PM, Ravi Bangoria wrote: > Hi Oleg, > > On 04/09/2018 06:47 PM, Oleg Nesterov wrote: >> I didn't read this version yet, just one question... >> >> So now it depends on CONFIG_MMU_NOTIFIER, yes? I do not see any changes in >> Kconfig >> files, this doesn't look right... >

[PATCH v11 0/4] set VSESR_EL2 by user space and support NOTIFY_SEI notification

2018-04-09 Thread Dongjiu Geng
1. Detect whether KVM can set set guest SError syndrome 2. Support to Set VSESR_EL2 and inject SError by user space. 3. Support live migration to keep SError pending state and VSESR_EL2 value. 4. ACPI 6.1 adds support for NOTIFY_SEI as a GHES notification mechanism, so support this

[PATCH v11 4/4] arm64: handle NOTIFY_SEI notification by the APEI driver

2018-04-09 Thread Dongjiu Geng
Add a helper to handle the NOTIFY_SEI notification, when kernel gets the NOTIFY_SEI notification, call this helper and let APEI driver to handle this notification. Signed-off-by: Dongjiu Geng --- arch/arm64/include/asm/system_misc.h | 1 + arch/arm64/kernel/traps.c

Re: [RFC bpf-next] bpf: document eBPF helpers and add a script to generate man page

2018-04-09 Thread Quentin Monnet
2018-04-09 12:52 UTC+0200 ~ Markus Heiser > >> Am 09.04.2018 um 12:08 schrieb Daniel Borkmann : > [...] > >>> May I completely misunderstood you, so correct my if I'am wrong: >>> >>> - ./scripts/bpf_helpers_doc.py : produces reST markup from

Re: [PATCH v2 7/9] trace_uprobe/sdt: Fix multiple update of same reference counter

2018-04-09 Thread Ravi Bangoria
Hi Oleg, On 04/09/2018 06:47 PM, Oleg Nesterov wrote: > On 04/04, Ravi Bangoria wrote: >> +static void sdt_add_mm_list(struct trace_uprobe *tu, struct mm_struct *mm) >> +{ >> +struct mmu_notifier *mn; >> +struct sdt_mm_list *sml = kzalloc(sizeof(*sml), GFP_KERNEL); >> + >> +if (!sml)

[PATCH v11 2/4] arm/arm64: KVM: Add KVM_GET/SET_VCPU_EVENTS

2018-04-09 Thread Dongjiu Geng
This new IOCTL exports user-invisible states related to SError. Together with appropriate user space changes, it can inject SError with specified syndrome to guest by setup kvm_vcpu_events value. Also it can support live migration. Signed-off-by: Dongjiu Geng Change

[PATCH v11 3/4] ACPI / APEI: Add SEI notification type support for ARMv8

2018-04-09 Thread Dongjiu Geng
ACPI 6.x adds support for NOTIFY_SEI as a GHES notification mechanism, so add new GHES notification handling functions. Expose API ghes_notify_sei() to arch code, arch code will call this API when it gets this NOTIFY_SEI. Signed-off-by: Dongjiu Geng ---

[PATCH v11 1/4] arm64: KVM: export the capability to set guest SError syndrome

2018-04-09 Thread Dongjiu Geng
Before user space injects a SError, it needs to know whether it can specify the guest Exception Syndrome, so KVM should tell user space whether it has such capability. Signed-off-by: Dongjiu Geng --- Documentation/virtual/kvm/api.txt | 11 +++

Re: [PATCH v2 7/9] trace_uprobe/sdt: Fix multiple update of same reference counter

2018-04-09 Thread Oleg Nesterov
On 04/04, Ravi Bangoria wrote: > > +static void sdt_add_mm_list(struct trace_uprobe *tu, struct mm_struct *mm) > +{ > + struct mmu_notifier *mn; > + struct sdt_mm_list *sml = kzalloc(sizeof(*sml), GFP_KERNEL); > + > + if (!sml) > + return; > + sml->mm = mm; > +

Re: [RFC bpf-next] bpf: document eBPF helpers and add a script to generate man page

2018-04-09 Thread Quentin Monnet
2018-04-09 11:01 UTC+0200 ~ Daniel Borkmann > On 04/06/2018 01:11 PM, Quentin Monnet wrote: >> eBPF helper functions can be called from within eBPF programs to perform >> a variety of tasks that would be otherwise hard or impossible to do with >> eBPF itself. There is a

Re: [PATCH V2 3/9] dt-bindings: Tegra186 tachometer device tree bindings

2018-04-09 Thread Rob Herring
On Mon, Apr 9, 2018 at 12:38 AM, Mikko Perttunen wrote: > Rob, Please don't top post to lists. > this binding is for a specific IP block (for measuring/aggregating input > pulses) on the Tegra186 SoC, so I don't think it fits into any generic > binding. What is it hooked up to

Re: [PATCH v2 7/9] trace_uprobe/sdt: Fix multiple update of same reference counter

2018-04-09 Thread Oleg Nesterov
On 04/04, Ravi Bangoria wrote: > > +static void sdt_add_mm_list(struct trace_uprobe *tu, struct mm_struct *mm) > +{ > + struct mmu_notifier *mn; > + struct sdt_mm_list *sml = kzalloc(sizeof(*sml), GFP_KERNEL); > + > + if (!sml) > + return; > + sml->mm = mm; > +

[PATCH] squashfs-tools: Add posix acl support

2018-04-09 Thread Geliang Tang
Add posix acl (Access Control Lists) support for mksquashfs and unsquashfs tools. Signed-off-by: Geliang Tang --- squashfs-tools/read_xattrs.c | 2 ++ squashfs-tools/squashfs_fs.h | 12 +++- squashfs-tools/unsquashfs_xattr.c | 4 +++- 3 files changed,

[PATCH] squashfs: Add posix acl support

2018-04-09 Thread Geliang Tang
Add posix acl (Access Control Lists) support for squashfs, which is marked as a todo item in squashfs' documentation. This patch implements the squashfs_get_acl function to read file's acl information from its xattr lists. Signed-off-by: Geliang Tang ---

Re: [PATCH] Fixed typo in onewire generic doc

2018-04-09 Thread Jonathan Corbet
On Mon, 09 Apr 2018 02:56:49 +0300 Evgeniy Polyakov wrote: > Hi everyone > > I'm really sorry for that long delay. > > Was this patch accepted or should I push it upstream? > > 20.12.2017, 22:09, "Gergo Huszty" : > > Onewire devices has 6 byte

Re: [RFC bpf-next] bpf: document eBPF helpers and add a script to generate man page

2018-04-09 Thread Markus Heiser
> Am 09.04.2018 um 12:08 schrieb Daniel Borkmann : [...] >> May I completely misunderstood you, so correct my if I'am wrong: >> >> - ./scripts/bpf_helpers_doc.py : produces reST markup from C-comments >> - ./scripts/kerne-doc : produces reST markup from C-comments

Re: [RFC bpf-next] bpf: document eBPF helpers and add a script to generate man page

2018-04-09 Thread Daniel Borkmann
On 04/09/2018 11:35 AM, Markus Heiser wrote: > >> Am 09.04.2018 um 11:25 schrieb Daniel Borkmann : >> >> On 04/09/2018 11:21 AM, Markus Heiser wrote: >> [...] >>> Do we really need another kernel-doc parser? >>> >>> ./scripts/kernel-doc include/uapi/linux/bpf.h >>> >>>

Re: [RFC bpf-next] bpf: document eBPF helpers and add a script to generate man page

2018-04-09 Thread Markus Heiser
> Am 09.04.2018 um 11:25 schrieb Daniel Borkmann : > > On 04/09/2018 11:21 AM, Markus Heiser wrote: > [...] >> Do we really need another kernel-doc parser? >> >> ./scripts/kernel-doc include/uapi/linux/bpf.h >> >> should already do the job (producing .rst). For more

Re: [RFC bpf-next] bpf: document eBPF helpers and add a script to generate man page

2018-04-09 Thread Markus Heiser
On 04/06/2018 01:11 PM, Quentin Monnet wrote: >> eBPF helper functions can be called from within eBPF programs to perform >> a variety of tasks that would be otherwise hard or impossible to do with >> eBPF itself. There is a growing number of such helper functions in the >> kernel, but

Re: [RFC bpf-next] bpf: document eBPF helpers and add a script to generate man page

2018-04-09 Thread Daniel Borkmann
On 04/09/2018 11:21 AM, Markus Heiser wrote: [...] > Do we really need another kernel-doc parser? > > ./scripts/kernel-doc include/uapi/linux/bpf.h > > should already do the job (producing .rst). For more infos, take a look at This has absolutely zero to do with kernel-doc, but rather

Re: [RFC bpf-next] bpf: document eBPF helpers and add a script to generate man page

2018-04-09 Thread Daniel Borkmann
On 04/06/2018 01:11 PM, Quentin Monnet wrote: > eBPF helper functions can be called from within eBPF programs to perform > a variety of tasks that would be otherwise hard or impossible to do with > eBPF itself. There is a growing number of such helper functions in the > kernel, but documentation

Re: [PATCH v2 9/9] perf probe: Support SDT markers having reference counter (semaphore)

2018-04-09 Thread Ravi Bangoria
Hi Masami, On 04/09/2018 12:58 PM, Masami Hiramatsu wrote: > Hi Ravi, > > On Wed, 4 Apr 2018 14:01:10 +0530 > Ravi Bangoria wrote: > >> @@ -2054,15 +2060,21 @@ char *synthesize_probe_trace_command(struct >> probe_trace_event *tev) >> } >> >> /* Use

Re: [PATCH v2 9/9] perf probe: Support SDT markers having reference counter (semaphore)

2018-04-09 Thread Masami Hiramatsu
Hi Ravi, On Wed, 4 Apr 2018 14:01:10 +0530 Ravi Bangoria wrote: > With this, perf buildid-cache will save SDT markers with reference > counter in probe cache. Perf probe will be able to probe markers > having reference counter. Ex, > > # readelf -n

Re: [PATCH 1/2] perf: riscv: preliminary RISC-V support

2018-04-09 Thread Alan Kao
On Thu, Apr 05, 2018 at 09:47:50AM -0700, Palmer Dabbelt wrote: > On Mon, 26 Mar 2018 00:57:54 PDT (-0700), alan...@andestech.com wrote: > >This patch provide a basic PMU, riscv_base_pmu, which supports two > >general hardware event, instructions and cycles. Furthermore, this > >PMU serves as a