Re: [PATCH RFC V2 2/6] hwmon: Add support for RPi voltage sensor

2018-05-23 Thread Robin Murphy
On 22/05/18 20:31, Stefan Wahren wrote: [...] +static int rpi_hwmon_probe(struct platform_device *pdev) +{ + struct device *dev = >dev; + struct rpi_hwmon_data *data; + int ret; + + data = devm_kzalloc(dev, sizeof(*data), GFP_KERNEL); + if (!data) +

Re: [PATCH v4 2/2] ThunderX2: Add Cavium ThunderX2 SoC UNCORE PMU driver

2018-05-04 Thread Robin Murphy
Hi Kim, On 04/05/18 01:30, Kim Phillips wrote: On Tue, 1 May 2018 12:54:05 +0100 Will Deacon wrote: Hi Kim, Hi Will, thanks for responding. On Fri, Apr 27, 2018 at 11:56:25AM -0500, Kim Phillips wrote: On Fri, 27 Apr 2018 17:09:14 +0100 Will Deacon

Re: [PATCH v3 06/10] drivers/peci: Add a PECI adapter driver for Aspeed AST24xx/AST25xx

2018-04-17 Thread Robin Murphy
Just a drive-by nit: On 10/04/18 19:32, Jae Hyun Yoo wrote: [...] +#define PECI_CTRL_SAMPLING_MASK GENMASK(19, 16) +#define PECI_CTRL_SAMPLING(x) (((x) << 16) & PECI_CTRL_SAMPLING_MASK) +#define PECI_CTRL_SAMPLING_GET(x) (((x) & PECI_CTRL_SAMPLING_MASK) >> 16) FWIW, already

Re: [PATCH v2 2/2] mm: remove odd HAVE_PTE_SPECIAL

2018-04-10 Thread Robin Murphy
On 10/04/18 16:25, Laurent Dufour wrote: Remove the additional define HAVE_PTE_SPECIAL and rely directly on CONFIG_ARCH_HAS_PTE_SPECIAL. There is no functional change introduced by this patch Signed-off-by: Laurent Dufour --- mm/memory.c | 23

Re: [PATCH v3 2/4] soc: qcom: Add GENI based QUP Wrapper driver

2018-03-08 Thread Robin Murphy
On 08/03/18 06:46, Karthik Ramasubramanian wrote: On 3/6/2018 2:56 PM, Stephen Boyd wrote: Quoting Karthik Ramasubramanian (2018-03-02 16:58:23) +   return iova; +} +EXPORT_SYMBOL(geni_se_tx_dma_prep); + +/** + * geni_se_rx_dma_prep() - Prepare the Serial Engine for RX DMA transfer + *

Re: [PATCH 1/2] tty: pl011: Work around QDF2400 E44 stuck BUSY bit

2017-02-08 Thread Robin Murphy
On 08/02/17 00:57, Christopher Covington wrote: > The Qualcomm Datacenter Technologies QDF2400 family of SoCs contains a > custom (non-PrimeCell) implementation of the SBSA UART. Occasionally the > BUSY bit in the Flag Register gets stuck as 1, erratum 44 for both 2432v1 > and 2400v1 SoCs.

Re: [PATCH 2/2] security: Change name of CONFIG_DEBUG_SET_MODULE_RONX

2017-01-19 Thread Robin Murphy
Hi Laura, On 19/01/17 01:29, Laura Abbott wrote: > > Despite the word 'debug' in CONFIG_DEBUG_SET_MODULE_RONX, this kernel > option provides key security features that are to be expected on a > modern system. Change the name to CONFIG_HARDENED_MODULE_MAPPINGS which > more accurately describes

Re: [PATCH 2/2] swiotlb: Add swiotlb=nobounce debug option

2016-11-07 Thread Robin Murphy
Hi Geert, On 07/11/16 15:41, Geert Uytterhoeven wrote: > Hi Robin, > > On Tue, Nov 1, 2016 at 12:46 PM, Robin Murphy <robin.mur...@arm.com> wrote: >>>>> To aid debugging and catch devices not supporting DMA to memory outside >>>>> the 32-bit ad

Re: [PATCH 2/2] swiotlb: Add swiotlb=nobounce debug option

2016-11-01 Thread Robin Murphy
On 31/10/16 18:20, Geert Uytterhoeven wrote: > Hi Robin, > > On Mon, Oct 31, 2016 at 6:41 PM, Robin Murphy <robin.mur...@arm.com> wrote: >> On 31/10/16 15:45, Geert Uytterhoeven wrote: >>> On architectures like arm64, swiotlb is tied intimately to the cor

Re: [PATCH 2/2] swiotlb: Add swiotlb=nobounce debug option

2016-10-31 Thread Robin Murphy
Hi Geert, On 31/10/16 15:45, Geert Uytterhoeven wrote: > On architectures like arm64, swiotlb is tied intimately to the core > architecture DMA support. In addition, ZONE_DMA cannot be disabled. To be fair, that only takes a single-character change in arch/arm64/Kconfig - in fact, I'm amused to

Re: [PATCH v2 4/6] common: DMA-mapping: add DMA_ATTR_PRIVILEGED_EXECUTABLE attribute

2016-07-11 Thread Robin Murphy
On 09/07/16 03:09, Mitchel Humpherys wrote: > This patch adds the DMA_ATTR_PRIVILEGED_EXECUTABLE attribute to the > DMA-mapping subsystem. DMA_ATTR_PRIVILEGED. We can worry about the (much bigger) executable vs. NX issue some other time. > Some architectures require that writable mappings also

Re: [PATCH] arm64:swiotlb:Enable only when Input size through command line

2016-06-24 Thread Robin Murphy
Hi Konrad, On 24/06/16 11:46, Konrad Rzeszutek Wilk wrote: > On Fri, Jun 24, 2016 at 10:57:29AM +0800, Jisheng Zhang wrote: >> Dear Konrad, >> >> On Thu, 23 Jun 2016 12:06:10 -0400 Konrad Rzeszutek Wilk wrote: >> >>> On June 23, 2016 10:30:34 AM EDT, Catalin Marinas >>>

Re: [PATCH] arm64:swiotlb:Enable only when Input size through command line

2016-06-23 Thread Robin Murphy
On 23/06/16 13:13, Manjeet Pawar wrote: From: Rohit Thapliyal swiotlb default size of 64M is too big as default value therefore it is made configurable through command line through swiotlb_size parameter. swiotlb allocation shall be done only when the swiotlb size is