[PATCH v2 0/3] SysFS driver for QEMU fw_cfg device

2015-08-11 Thread Gabriel L. Somlo
From: "Gabriel Somlo" This patch set makes QEMU fw_cfg blobs available for viewing (read-only) via SysFS. New since v1: 1/3: - renamed sysfs path components: s/fw_cfg/qemu_fw_cfg/g, at Greg's suggestion s/by_select/by_key/g since it

[PATCH v2 1/3] firmware: introduce sysfs driver for QEMU's fw_cfg device

2015-08-11 Thread Gabriel L. Somlo
From: "Gabriel Somlo" Make fw_cfg entries of type "file" available via sysfs. Entries are listed under /sys/firmware/qemu_fw_cfg/by_key, in folders named after each entry's selector key. Filename, selector value, and size read-only attributes are included for each entry. Also, a "raw" attribute a

[PATCH v2 2/3] kobject: export kset_find_obj() to be used from modules

2015-08-11 Thread Gabriel L. Somlo
From: "Gabriel Somlo" Signed-off-by: Gabriel Somlo --- lib/kobject.c | 1 + 1 file changed, 1 insertion(+) diff --git a/lib/kobject.c b/lib/kobject.c index 0554077..8f07202 100644 --- a/lib/kobject.c +++ b/lib/kobject.c @@ -847,6 +847,7 @@ struct kobject *kset_find_obj(struct kset *kset, const

[PATCH v2 3/3] firmware: fw_cfg: create directory hierarchy for fw_cfg file names

2015-08-11 Thread Gabriel L. Somlo
From: "Gabriel Somlo" Each fw_cfg entry of type "file" has an associated 56-char, nul-terminated ASCII string which represents its name. While the fw_cfg device doesn't itself impose any specific naming convention, QEMU developers have traditionally used path name semantics (i.e. "etc/acpi/rsdp")