Re: [EXT4 set 3][PATCH 1/1] ext4 nanosecond timestamp

2007-07-12 Thread Aneesh Kumar K.V
Kalpak Shah wrote: On Tue, 2007-07-10 at 16:30 -0700, Andrew Morton wrote: On Sun, 01 Jul 2007 03:36:56 -0400 Mingming Cao <[EMAIL PROTECTED]> wrote: This patch is a spinoff of the old nanosecond patches. I don't know what the "old nanosecond patches" are. A link to a suitable changlog for

Re: Random corruption test for e2fsck

2007-07-12 Thread Andi Kleen
On Thu, Jul 12, 2007 at 04:16:24PM -0600, Andreas Dilger wrote: > On Jul 12, 2007 13:09 +0200, Andi Kleen wrote: > > > "dd if=/dev/urandom bs=1k ..." than to spin in a loop getting 16-bit > > > random numbers from bash. We would also be at the mercy of the shell > > > being identical on the user

Re: Random corruption test for e2fsck

2007-07-12 Thread Andreas Dilger
On Jul 12, 2007 13:09 +0200, Andi Kleen wrote: > > "dd if=/dev/urandom bs=1k ..." than to spin in a loop getting 16-bit > > random numbers from bash. We would also be at the mercy of the shell > > being identical on the user and debugger's systems. > > With /dev/urandom you have the guarantee yo

Re: [EXT4 set 2][PATCH 2/5] cleanups: Add extent sanity checks

2007-07-12 Thread Andrew Morton
On Thu, 12 Jul 2007 08:57:51 -0500 Dave Kleikamp <[EMAIL PROTECTED]> wrote: > On Thu, 2007-07-12 at 12:38 +0100, Andy Whitcroft wrote: > > Andrew Morton wrote: > > >> +if (ext4_ext_check_header(inode, > > >> ext_block_hdr(bh), > > >> +

Re: Initial results of FLEX_BG feature.

2007-07-12 Thread Jose R. Santos
On Wed, 11 Jul 2007 18:14:25 -0400 Theodore Tso <[EMAIL PROTECTED]> wrote: > On Wed, Jul 11, 2007 at 12:30:04AM -0500, Jose R. Santos wrote: > > Right now what I've done is allocate the bitmaps and inode tables at the > > beginning of each group of 64 BG. Still need to work on fsck since just > >

Re: Initial results of FLEX_BG feature.

2007-07-12 Thread Jose R. Santos
On Wed, 11 Jul 2007 18:14:25 -0400 Theodore Tso <[EMAIL PROTECTED]> wrote: > On Wed, Jul 11, 2007 at 12:30:04AM -0500, Jose R. Santos wrote: > > Right now what I've done is allocate the bitmaps and inode tables at the > > beginning of each group of 64 BG. Still need to work on fsck since just > >

Re: [PATCH 4/7][TAKE5] support new modes in fallocate

2007-07-12 Thread Andreas Dilger
On Jul 12, 2007 13:56 +0530, Amit K. Arora wrote: > As you suggest, let us just have two modes for the time being: > > #define FALLOC_ALLOCATE 0x1 > #define FALLOC_ALLOCATE_KEEP_SIZE 0x2 > > As the name suggests, when FALLOC_ALLOCATE_KEEP_SIZE mode is passed it > will r

Re: [PATCH 4/7][TAKE5] support new modes in fallocate

2007-07-12 Thread Amit K. Arora
On Thu, Jul 12, 2007 at 11:13:34PM +1000, David Chinner wrote: > On Thu, Jul 12, 2007 at 12:58:13PM +0530, Suparna Bhattacharya wrote: > > > > Why don't we just merge the interface for preallocation (essentially > > enough to satisfy posix_fallocate() and the simple XFS requirement for > > space

Re: [EXT4 set 2][PATCH 2/5] cleanups: Add extent sanity checks

2007-07-12 Thread Dave Kleikamp
On Thu, 2007-07-12 at 12:38 +0100, Andy Whitcroft wrote: > Andrew Morton wrote: > >> + if (ext4_ext_check_header(inode, ext_block_hdr(bh), > >> + depth - i - 1)) { > >> + err = -EIO; > >> +

Re: [PATCH 4/7][TAKE5] support new modes in fallocate

2007-07-12 Thread David Chinner
On Thu, Jul 12, 2007 at 12:58:13PM +0530, Suparna Bhattacharya wrote: > > Why don't we just merge the interface for preallocation (essentially > enough to satisfy posix_fallocate() and the simple XFS requirement for > space reservation without changing file size), which there is clear agreement >

Re: [EXT4 set 3][PATCH 1/1] ext4 nanosecond timestamp

2007-07-12 Thread Kalpak Shah
On Tue, 2007-07-10 at 16:30 -0700, Andrew Morton wrote: > On Sun, 01 Jul 2007 03:36:56 -0400 > Mingming Cao <[EMAIL PROTECTED]> wrote: > > > This patch is a spinoff of the old nanosecond patches. > > I don't know what the "old nanosecond patches" are. A link to a suitable > changlog for those pa

Re: [EXT4 set 5][PATCH 1/1] expand inode i_extra_isize to support features in larger inode

2007-07-12 Thread Kalpak Shah
On Tue, 2007-07-10 at 16:32 -0700, Andrew Morton wrote: > On Sun, 01 Jul 2007 03:38:01 -0400 > Mingming Cao <[EMAIL PROTECTED]> wrote: > > > This patch is on top of the nanosecond timestamp and i_version_hi > > patches. > > This sort of information isn't needed (or desired) when this patch hits

Re: [EXT4 set 2][PATCH 2/5] cleanups: Add extent sanity checks

2007-07-12 Thread Andy Whitcroft
Andrew Morton wrote: > On Sun, 01 Jul 2007 03:36:22 -0400 > Mingming Cao <[EMAIL PROTECTED]> wrote: > >> with the patch all headers are checked. the code should become >> more resistant to on-disk corruptions. needless BUG_ON() have >> been removed. please, review for inclusion. >> >> ... > >> @@

Re: [EXT4 set 5][PATCH 1/1] expand inode i_extra_isize to support features in larger inode

2007-07-12 Thread Andy Whitcroft
The next version of checkpatch.pl (0.08) should have support for a number of the missed sylistics you mention. Will let them soak for a bit to ensure we're not majorly regressing anything else. -apw ERROR: braces {} are not necessary for single statements #4: FILE: Z11.c:1: +if (EXT4_I(inode)->i

Re: Random corruption test for e2fsck

2007-07-12 Thread Andi Kleen
On Wed, Jul 11, 2007 at 11:19:38PM -0600, Andreas Dilger wrote: > On Jul 11, 2007 17:20 +0200, Andi Kleen wrote: > > If you use a normal pseudo random number generator and print the seed > > (e.g. create from the time) initially the image can be easily recreated > > later without shipping it arou

Re: [PATCH 4/7][TAKE5] support new modes in fallocate

2007-07-12 Thread Amit K. Arora
On Thu, Jul 12, 2007 at 12:58:13PM +0530, Suparna Bhattacharya wrote: > On Wed, Jul 11, 2007 at 10:03:12AM +0100, Christoph Hellwig wrote: > > On Tue, Jul 03, 2007 at 05:16:50PM +0530, Amit K. Arora wrote: > > > Well, if you see the modes proposed using above flags : > > > > > > #define FA_ALLOCAT

Re: [PATCH 4/7][TAKE5] support new modes in fallocate

2007-07-12 Thread Suparna Bhattacharya
On Wed, Jul 11, 2007 at 10:03:12AM +0100, Christoph Hellwig wrote: > On Tue, Jul 03, 2007 at 05:16:50PM +0530, Amit K. Arora wrote: > > Well, if you see the modes proposed using above flags : > > > > #define FA_ALLOCATE 0 > > #define FA_DEALLOCATE FA_FL_DEALLOC > > #define FA_RESV_SPACE