Re: [f2fs-dev] [PATCH 27/30] block: replace fmode_t with a block-specific type for block open flags

2023-06-08 Thread Christian Brauner
On Thu, Jun 08, 2023 at 01:02:55PM +0200, Christoph Hellwig wrote: > The only overlap between the block open flags mapped into the fmode_t and > other uses of fmode_t are FMODE_READ and FMODE_WRITE. Define a new > blk_mode_t instead for use in blkdev_get_by_{dev,path}, ->open and > ->ioctl and

[f2fs-dev] [PATCH 22/30] mtd: block: use a simple bool to track open for write

2023-06-08 Thread Christoph Hellwig
Instead of propagating the fmode_t, just use a bool to track if a mtd block device was opened for writing. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner Acked-by: Richard Weinberger --- drivers/mtd/mtd_blkdevs.c| 2 +- drivers/mtd/mtdblock.c

[f2fs-dev] [PATCH 27/30] block: replace fmode_t with a block-specific type for block open flags

2023-06-08 Thread Christoph Hellwig
The only overlap between the block open flags mapped into the fmode_t and other uses of fmode_t are FMODE_READ and FMODE_WRITE. Define a new blk_mode_t instead for use in blkdev_get_by_{dev,path}, ->open and ->ioctl and stop abusing fmode_t. Signed-off-by: Christoph Hellwig Acked-by: Jack Wang

[f2fs-dev] [PATCH 30/30] fs: remove the now unused FMODE_* flags

2023-06-08 Thread Christoph Hellwig
FMODE_NDELAY, FMODE_EXCL and FMODE_WRITE_IOCTL were only used for block internal purposed and are now entirely unused, so remove them. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Reviewed-by: Christian Brauner --- include/linux/fs.h | 7 --- 1 file changed, 7

[f2fs-dev] [PATCH 29/30] block: store the holder in file->private_data

2023-06-08 Thread Christoph Hellwig
Store the file struct used as the holder in file->private_data as an indicator that this file descriptor was opened exclusively to remove the last use of FMODE_EXCL. Signed-off-by: Christoph Hellwig --- block/fops.c | 14 -- 1 file changed, 8 insertions(+), 6 deletions(-) diff

[f2fs-dev] [PATCH 28/30] block: always use I_BDEV on file->f_mapping->host to find the bdev

2023-06-08 Thread Christoph Hellwig
Always use I_BDEV(file->f_mapping->host) to find the bdev for a file to free up file->private_data for other uses. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- block/fops.c | 18 -- 1 file changed, 8 insertions(+), 10

[f2fs-dev] [PATCH 25/30] block: move a few internal definitions out of blkdev.h

2023-06-08 Thread Christoph Hellwig
All these helpers are only used in core block code, so move them out of the public header. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- block/blk.h| 23 +-- include/linux/blkdev.h | 27 ---

[f2fs-dev] [PATCH 24/30] ubd: remove commented out code in ubd_open

2023-06-08 Thread Christoph Hellwig
This code has been dead forever, make sure it doesn't show up in code searches. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner Acked-by: Richard Weinberger --- arch/um/drivers/ubd_kern.c | 7 --- 1 file changed, 7 deletions(-) diff --git

[f2fs-dev] [PATCH 21/30] nvme: replace the fmode_t argument to the nvme ioctl handlers with a simple bool

2023-06-08 Thread Christoph Hellwig
Instead of passing a fmode_t and only checking it fo0r FMODE_WRITE, pass a bool open_for_write to prepare for callers that won't have the fmode_t. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- drivers/nvme/host/ioctl.c | 62

[f2fs-dev] [PATCH 26/30] block: remove unused fmode_t arguments from ioctl handlers

2023-06-08 Thread Christoph Hellwig
A few ioctl handlers have fmode_t arguments that are entirely unused, remove them. Signed-off-by: Christoph Hellwig Acked-by: Christian Brauner Reviewed-by: Hannes Reinecke --- block/blk-zoned.c | 4 ++-- block/blk.h | 6 +++--- block/ioctl.c | 14 +++--- 3 files changed,

[f2fs-dev] [PATCH 13/30] rnbd-srv: don't pass a holder for non-exclusive blkdev_get_by_path

2023-06-08 Thread Christoph Hellwig
Passing a holder to blkdev_get_by_path when FMODE_EXCL isn't set doesn't make sense, so pass NULL instead. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner Acked-by: Jack Wang --- drivers/block/rnbd/rnbd-srv.c | 2 +- 1 file changed, 1 insertion(+), 1

[f2fs-dev] [PATCH 17/30] fs: remove sb->s_mode

2023-06-08 Thread Christoph Hellwig
There is no real need to store the open mode in the super_block now. It is only used by f2fs, which can easily recalculate it. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- fs/f2fs/super.c| 10 ++ fs/nilfs2/super.c | 1 -

[f2fs-dev] [PATCH 20/30] scsi: replace the fmode_t argument to ->sg_io_fn with a simple bool

2023-06-08 Thread Christoph Hellwig
Instead of passing a fmode_t and only checking it for FMODE_WRITE, pass a bool open_for_write to prepare for callers that won't have the fmode_t. Signed-off-by: Christoph Hellwig Reviewed-by: Martin K. Petersen Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- block/bsg-lib.c

[f2fs-dev] [PATCH 23/30] rnbd-srv: replace sess->open_flags with a "bool readonly"

2023-06-08 Thread Christoph Hellwig
Stop passing the fmode_t around and just use a simple bool to track if an export is read-only. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner Acked-by: Jack Wang --- drivers/block/rnbd/rnbd-srv-sysfs.c | 3 +-- drivers/block/rnbd/rnbd-srv.c |

[f2fs-dev] [PATCH 18/30] scsi: replace the fmode_t argument to scsi_cmd_allowed with a simple bool

2023-06-08 Thread Christoph Hellwig
Instead of passing a fmode_t and only checking it for FMODE_WRITE, pass a bool open_for_write to prepare for callers that won't have the fmode_t. Signed-off-by: Christoph Hellwig Reviewed-by: Martin K. Petersen Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner ---

[f2fs-dev] [PATCH 19/30] scsi: replace the fmode_t argument to scsi_ioctl with a simple bool

2023-06-08 Thread Christoph Hellwig
Instead of passing a fmode_t and only checking it for FMODE_WRITE, pass a bool open_for_write to prepare for callers that won't have the fmode_t. Signed-off-by: Christoph Hellwig Reviewed-by: Martin K. Petersen Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- drivers/scsi/ch.c

[f2fs-dev] [PATCH 15/30] block: use the holder as indication for exclusive opens

2023-06-08 Thread Christoph Hellwig
The current interface for exclusive opens is rather confusing as it requires both the FMODE_EXCL flag and a holder. Remove the need to pass FMODE_EXCL and just key off the exclusive open off a non-NULL holder. For blkdev_put this requires adding the holder argument, which provides better debug

[f2fs-dev] [PATCH 11/30] swsusp: don't pass a stack address to blkdev_get_by_path

2023-06-08 Thread Christoph Hellwig
holder is just an on-stack pointer that can easily be reused by other calls, replace it with a static variable that doesn't change. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke --- kernel/power/swap.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git

[f2fs-dev] [PATCH 05/30] cdrom: track if a cdrom_device_info was opened for data

2023-06-08 Thread Christoph Hellwig
Set a flag when a cdrom_device_info is opened for writing, instead of trying to figure out this at release time. This will allow to eventually remove the mode argument to the ->release block_device_operation as nothing but the CDROM drivers uses that argument. Signed-off-by: Christoph Hellwig

[f2fs-dev] [PATCH 16/30] block: add a sb_open_mode helper

2023-06-08 Thread Christoph Hellwig
Add a helper to return the open flags for blkdev_get_by* for passed in super block flags instead of open coding the logic in many places. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- fs/btrfs/super.c | 5 + fs/nilfs2/super.c |

[f2fs-dev] [PATCH 06/30] cdrom: remove the unused mode argument to cdrom_release

2023-06-08 Thread Christoph Hellwig
Signed-off-by: Christoph Hellwig Reviewed-by: Phillip Potter Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- drivers/cdrom/cdrom.c | 2 +- drivers/cdrom/gdrom.c | 2 +- drivers/scsi/sr.c | 2 +- include/linux/cdrom.h | 2 +- 4 files changed, 4 insertions(+), 4 deletions(-)

[f2fs-dev] [PATCH 14/30] btrfs: don't pass a holder for non-exclusive blkdev_get_by_path

2023-06-08 Thread Christoph Hellwig
Passing a holder to blkdev_get_by_path when FMODE_EXCL isn't set doesn't make sense, so pass NULL instead and remove the holder argument from the call chains the only end up in non-FMODE_EXCL blkdev_get_by_path calls. Exclusive mode for device scanning is not used since commit 50d281fc434c

[f2fs-dev] [PATCH 12/30] bcache: don't pass a stack address to blkdev_get_by_path

2023-06-08 Thread Christoph Hellwig
sb is just an on-stack pointer that can easily be reused by other calls. Switch to use the bcache-wide bcache_kobj instead as there is no need to claim per-bcache device anyway. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke --- drivers/md/bcache/super.c | 2 +- 1 file changed,

[f2fs-dev] decouple block open flags from fmode_t v2

2023-06-08 Thread Christoph Hellwig
Hi all, this series adds a new blk_mode_t for block open flags instead of abusing fmode_t. The block open flags work very different from the normal use of fmode_t and only share the basic READ/WRITE flags with it. None of the other normal FMODE_* flags is used, but instead there are three

[f2fs-dev] [PATCH 03/30] cdrom: remove the unused mode argument to cdrom_ioctl

2023-06-08 Thread Christoph Hellwig
Signed-off-by: Christoph Hellwig Reviewed-by: Phillip Potter Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- drivers/cdrom/cdrom.c | 2 +- drivers/cdrom/gdrom.c | 2 +- drivers/scsi/sr.c | 2 +- include/linux/cdrom.h | 4 ++-- 4 files changed, 5 insertions(+), 5 deletions(-)

[f2fs-dev] [PATCH 09/30] block: remove the unused mode argument to ->release

2023-06-08 Thread Christoph Hellwig
The mode argument to the ->release block_device_operation is never used, so remove it. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner Acked-by: Jack Wang [rnbd] --- arch/um/drivers/ubd_kern.c | 4 ++--

[f2fs-dev] [PATCH 08/30] block: pass a gendisk to ->open

2023-06-08 Thread Christoph Hellwig
->open is only called on the whole device. Make that explicit by passing a gendisk instead of the block_device. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner Acked-by: Jack Wang [rnbd] --- arch/um/drivers/ubd_kern.c | 5

[f2fs-dev] [PATCH 10/30] block: rename blkdev_close to blkdev_release

2023-06-08 Thread Christoph Hellwig
Make the function name match the method name. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- block/fops.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/block/fops.c b/block/fops.c index 6a3087b750a6cd..26af2b39c758e1

[f2fs-dev] [PATCH 07/30] block: pass a gendisk on bdev_check_media_change

2023-06-08 Thread Christoph Hellwig
bdev_check_media_change should only ever be called for the whole device. Pass a gendisk to make that explicit and rename the function to disk_check_media_change. Signed-off-by: Christoph Hellwig Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- block/disk-events.c | 18

[f2fs-dev] [PATCH 02/30] cdrom: remove the unused bdev argument to cdrom_open

2023-06-08 Thread Christoph Hellwig
Signed-off-by: Christoph Hellwig Reviewed-by: Phillip Potter Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- drivers/cdrom/cdrom.c | 3 +-- drivers/cdrom/gdrom.c | 2 +- drivers/scsi/sr.c | 2 +- include/linux/cdrom.h | 3 +-- 4 files changed, 4 insertions(+), 6 deletions(-)

[f2fs-dev] [PATCH 04/30] cdrom: remove the unused cdrom_close_write release code

2023-06-08 Thread Christoph Hellwig
cdrom_close_write is empty, and the for_data flag it is keyed off is never set. Remove all this clutter. Signed-off-by: Christoph Hellwig Reviewed-by: Phillip Potter Reviewed-by: Hannes Reinecke Acked-by: Christian Brauner --- drivers/cdrom/cdrom.c | 15 ---

[f2fs-dev] [PATCH 01/30] block: also call ->open for incremental partition opens

2023-06-08 Thread Christoph Hellwig
For whole devices ->open is called for each open, but for partitions it is only called on the first open of a partition, e.g.: open("/dev/vdb", ...) open("/dev/vdb", ...) - 2 call to ->open open("/dev/vdb1", ...) open("/dev/vdb", ...) - 2 call to ->open open("/dev/vdb", ...)

[f2fs-dev] [PATCH] f2fs-tools: fix to call assert() if f2fs_dentry_hash() fails

2023-06-08 Thread Chao Yu
f2fs_dentry_hash() may return -ENOMEM due to malloc() failure, however caller won't check validaty of return value, result assign or check wrong hash value, fix to call assert() for such case. Signed-off-by: Chao Yu --- lib/libf2fs.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)

Re: [f2fs-dev] [PATCH] f2fs-tools: fix wrong write pointer check for non-zoned areas

2023-06-08 Thread Chao Yu
On 2023/6/7 1:39, Daeho Jeong wrote: From: Daeho Jeong Do not check F2FS_ZONED_HM for the whole device. We need to do this for each area of devices. Signed-off-by: Daeho Jeong Reviewed-by: Chao Yu Thanks, ___ Linux-f2fs-devel mailing list

Re: [f2fs-dev] [PATCH 06/31] cdrom: remove the unused mode argument to cdrom_release

2023-06-08 Thread Phillip Potter
On Thu, Jun 08, 2023 at 11:04:44AM +0200, Christoph Hellwig wrote: > On Thu, Jun 08, 2023 at 09:47:27AM +0100, Phillip Potter wrote: > > Yes indeed - I was under the impression it was appropriate for a > > maintainer to signal their approval of a patch to maintained code using > > a Signed-off-by

Re: [f2fs-dev] [PATCH] f2fs: enable nowait async buffered writes

2023-06-08 Thread Chao Yu
On 2023/6/6 19:13, Yangtao Li wrote: On 2023/6/6 14:43, Chao Yu wrote: On 2023/5/31 22:40, Yangtao Li wrote: This adds the async buffered write support to f2fs, the following is the relevant test data. Yangtao, Could you please provide detailed test command? Use fio to test, the

Re: [f2fs-dev] [PATCH 06/31] cdrom: remove the unused mode argument to cdrom_release

2023-06-08 Thread Phillip Potter
On Thu, Jun 08, 2023 at 10:41:29AM +0200, Christoph Hellwig wrote: > On Wed, Jun 07, 2023 at 12:00:57AM +0100, Phillip Potter wrote: > > Looks good, thanks. > > > > Signed-off-by: Phillip Potter > > Hmm, these signoffs don't really make sense here. Were they intended > as Reviewed-bys? > Hi

Re: [f2fs-dev] [PATCH 06/31] cdrom: remove the unused mode argument to cdrom_release

2023-06-08 Thread Christoph Hellwig
On Thu, Jun 08, 2023 at 09:47:27AM +0100, Phillip Potter wrote: > Yes indeed - I was under the impression it was appropriate for a > maintainer to signal their approval of a patch to maintained code using > a Signed-off-by tag due to their involvement in the submission process? > Apologies if I've

Re: [f2fs-dev] [PATCH 06/31] cdrom: remove the unused mode argument to cdrom_release

2023-06-08 Thread Christoph Hellwig
On Wed, Jun 07, 2023 at 12:00:57AM +0100, Phillip Potter wrote: > Looks good, thanks. > > Signed-off-by: Phillip Potter Hmm, these signoffs don't really make sense here. Were they intended as Reviewed-bys? ___ Linux-f2fs-devel mailing list

[f2fs-dev] [Bug 216050] f2fs_gc occupies 100% cpu

2023-06-08 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=216050 Daan Geurts-Doorenbos (daangeu...@pm.me) changed: What|Removed |Added CC|