Re: [f2fs-dev] [PATCH] f2fs: move all the bio initialization into __bio_alloc

2013-12-19 Thread Gu Zheng
Hi Kim, Yu,
Thanks for your review!

On 12/19/2013 04:59 PM, Jaegeuk Kim wrote:

> Hi Gu,
> 
> I agreed with Chao.
> It is more readable to use something like "is_read" instead of "rw".

Agree. I'll follow it.

Regards,
Gu

> Thanks,
> 
> 2013-12-19 (목), 09:23 +0800, Chao Yu:
>> Hi Gu,
>>
>>> -Original Message-
>>> From: Gu Zheng [mailto:guz.f...@cn.fujitsu.com]
>>> Sent: Wednesday, December 18, 2013 6:29 PM
>>> To: Kim
>>> Cc: fsdevel; linux-kernel; f2fs
>>> Subject: [f2fs-dev] [PATCH] f2fs: move all the bio initialization into 
>>> __bio_alloc
>>>
>>> Move all the bio initialization into __bio_alloc, and some minor cleanups 
>>> are
>>> also added.
>>
>> Looks more neat!
>>
>>> @@ -178,17 +179,16 @@ void f2fs_submit_page_mbio(struct f2fs_sb_info *sbi, 
>>> struct page *page,
>>> block_t blk_addr, struct f2fs_io_info *fio)
>>>  {
>>> enum page_type btype = PAGE_TYPE_OF_BIO(fio->type);
>>> -   struct block_device *bdev = sbi->sb->s_bdev;
>>> struct f2fs_bio_info *io;
>>> -   int bio_blocks;
>>> +   int rw = is_read_io(fio->rw);
>>
>> Maybe it's more neat to use 'is_read' to instead of 'rw'.
>>
>> Thanks
>>
> 



--
Rapidly troubleshoot problems before they affect your business. Most IT 
organizations don't have a clear picture of how application performance 
affects their revenue. With AppDynamics, you get 100% visibility into your 
Java,.NET, & PHP application. Start your 15-day FREE TRIAL of AppDynamics Pro!
http://pubads.g.doubleclick.net/gampad/clk?id=84349831&iu=/4140/ostg.clktrk
___
Linux-f2fs-devel mailing list
Linux-f2fs-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linux-f2fs-devel


Re: [f2fs-dev] [PATCH] f2fs: move all the bio initialization into __bio_alloc

2013-12-19 Thread Jaegeuk Kim
Hi Gu,

I agreed with Chao.
It is more readable to use something like "is_read" instead of "rw".
Thanks,

2013-12-19 (목), 09:23 +0800, Chao Yu:
> Hi Gu,
> 
> > -Original Message-
> > From: Gu Zheng [mailto:guz.f...@cn.fujitsu.com]
> > Sent: Wednesday, December 18, 2013 6:29 PM
> > To: Kim
> > Cc: fsdevel; linux-kernel; f2fs
> > Subject: [f2fs-dev] [PATCH] f2fs: move all the bio initialization into 
> > __bio_alloc
> > 
> > Move all the bio initialization into __bio_alloc, and some minor cleanups 
> > are
> > also added.
> 
> Looks more neat!
> 
> > @@ -178,17 +179,16 @@ void f2fs_submit_page_mbio(struct f2fs_sb_info *sbi, 
> > struct page *page,
> > block_t blk_addr, struct f2fs_io_info *fio)
> >  {
> > enum page_type btype = PAGE_TYPE_OF_BIO(fio->type);
> > -   struct block_device *bdev = sbi->sb->s_bdev;
> > struct f2fs_bio_info *io;
> > -   int bio_blocks;
> > +   int rw = is_read_io(fio->rw);
> 
> Maybe it's more neat to use 'is_read' to instead of 'rw'.
> 
> Thanks
> 

-- 
Jaegeuk Kim
Samsung



--
Rapidly troubleshoot problems before they affect your business. Most IT 
organizations don't have a clear picture of how application performance 
affects their revenue. With AppDynamics, you get 100% visibility into your 
Java,.NET, & PHP application. Start your 15-day FREE TRIAL of AppDynamics Pro!
http://pubads.g.doubleclick.net/gampad/clk?id=84349831&iu=/4140/ostg.clktrk
___
Linux-f2fs-devel mailing list
Linux-f2fs-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linux-f2fs-devel


Re: [f2fs-dev] [PATCH] f2fs: move all the bio initialization into __bio_alloc

2013-12-18 Thread Chao Yu
Hi Gu,

> -Original Message-
> From: Gu Zheng [mailto:guz.f...@cn.fujitsu.com]
> Sent: Wednesday, December 18, 2013 6:29 PM
> To: Kim
> Cc: fsdevel; linux-kernel; f2fs
> Subject: [f2fs-dev] [PATCH] f2fs: move all the bio initialization into 
> __bio_alloc
> 
> Move all the bio initialization into __bio_alloc, and some minor cleanups are
> also added.

Looks more neat!

> @@ -178,17 +179,16 @@ void f2fs_submit_page_mbio(struct f2fs_sb_info *sbi, 
> struct page *page,
>   block_t blk_addr, struct f2fs_io_info *fio)
>  {
>   enum page_type btype = PAGE_TYPE_OF_BIO(fio->type);
> - struct block_device *bdev = sbi->sb->s_bdev;
>   struct f2fs_bio_info *io;
> - int bio_blocks;
> + int rw = is_read_io(fio->rw);

Maybe it's more neat to use 'is_read' to instead of 'rw'.

Thanks


--
Rapidly troubleshoot problems before they affect your business. Most IT 
organizations don't have a clear picture of how application performance 
affects their revenue. With AppDynamics, you get 100% visibility into your 
Java,.NET, & PHP application. Start your 15-day FREE TRIAL of AppDynamics Pro!
http://pubads.g.doubleclick.net/gampad/clk?id=84349831&iu=/4140/ostg.clktrk
___
Linux-f2fs-devel mailing list
Linux-f2fs-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linux-f2fs-devel