Re: [PATCH 3/3] pinctrl: qcom: handle input-enable pinconf property

2015-01-30 Thread Bjorn Andersson
On Fri 30 Jan 02:27 PST 2015, Stanimir Varbanov wrote: This enables support of 'input-enable' pinconf generic property in the pinctrl driver. Patch looks good, but I think the api is broken for boolean properties. Signed-off-by: Stanimir Varbanov svarba...@mm-sol.com ---

Re: [RFC PATCH] gpio: support for GPIO forwarding

2015-01-30 Thread Rafael J. Wysocki
On Friday, January 30, 2015 03:48:30 PM Linus Walleij wrote: On Thu, Jan 22, 2015 at 5:12 PM, Rafael J. Wysocki r...@rjwysocki.net wrote: On Thursday, January 22, 2015 09:17:38 AM Linus Walleij wrote: If the kernel anyway has to supply some kind of workaround for the issue, it is more a

Re: [PATCH v2 2/4] gpio: add parameter to allow the use named gpios

2015-01-30 Thread Dmitry Torokhov
On Fri, Jan 30, 2015 at 02:16:00PM -0800, Dmitry Torokhov wrote: On Fri, Jan 30, 2015 at 11:12:53AM -0800, Bryan Wu wrote: On Fri, Jan 30, 2015 at 5:46 AM, Linus Walleij linus.wall...@linaro.org wrote: On Wed, Jan 21, 2015 at 10:33 PM, Olliver Schinagl o.schin...@ultimaker.com wrote:

Re: [PATCH v2 2/4] gpio: add parameter to allow the use named gpios

2015-01-30 Thread Dmitry Torokhov
On Fri, Jan 30, 2015 at 11:12:53AM -0800, Bryan Wu wrote: On Fri, Jan 30, 2015 at 5:46 AM, Linus Walleij linus.wall...@linaro.org wrote: On Wed, Jan 21, 2015 at 10:33 PM, Olliver Schinagl o.schin...@ultimaker.com wrote: From: Olliver Schinagl oli...@schinagl.nl The gpio binding

Re: [PATCH v2 2/4] gpio: add parameter to allow the use named gpios

2015-01-30 Thread Bryan Wu
On Fri, Jan 30, 2015 at 5:46 AM, Linus Walleij linus.wall...@linaro.org wrote: On Wed, Jan 21, 2015 at 10:33 PM, Olliver Schinagl o.schin...@ultimaker.com wrote: From: Olliver Schinagl oli...@schinagl.nl The gpio binding document says that new code should always use named gpios. Patch

Re: Fw: [3.18.3] poll() on gpio pins broken

2015-01-30 Thread Michael Welling
On Thu, Jan 29, 2015 at 04:29:02PM +0100, folkert wrote: Hi, For timekeeping I wrote a program which waits for interrupts on gpio-pins and then tells the local ntp daemon the clock offset. I'm aware of the pps support in recent kernel but that does not work (yet) on all platforms (eg

Re: [RFC PATCH] gpio: support for GPIO forwarding

2015-01-30 Thread Linus Walleij
On Thu, Jan 22, 2015 at 5:12 PM, Rafael J. Wysocki r...@rjwysocki.net wrote: On Thursday, January 22, 2015 09:17:38 AM Linus Walleij wrote: If the kernel anyway has to supply some kind of workaround for the issue, it is more a question of where to place it. Whether it does so by patching the

Re: [PATCH 1/3][v2] gpiolib: add gpiod_get_array and gpiod_put_array functions

2015-01-30 Thread Alexandre Courbot
On Fri, Jan 30, 2015 at 6:44 PM, Linus Walleij linus.wall...@linaro.org wrote: On Wed, Jan 21, 2015 at 5:46 PM, Rojhalat Ibrahim i...@rtschenk.de wrote: Introduce new functions for conveniently obtaining and disposing of an entire array of GPIOs with one function call. Suggested-by:

[PATCH 0/3] pinctrl: qcom: enable generic pinconf and input-enable

2015-01-30 Thread Stanimir Varbanov
Here is splitted version of the previous patch at [1]. The major change is in 3/3 where now we check oe_bit in control register instead of in_bit in io register. regards Stan [1] https://lkml.org/lkml/2015/1/26/514 Stanimir Varbanov (3): pinctrl: qcom: delete pin_config_get/set pinconf

[PATCH 1/3] pinctrl: qcom: delete pin_config_get/set pinconf operations

2015-01-30 Thread Stanimir Varbanov
The .pin_config_get/set operation are not supported in qcom pinctrl driver. As the pinconf core is smart enough it doesn't complain about that. Signed-off-by: Stanimir Varbanov svarba...@mm-sol.com --- drivers/pinctrl/qcom/pinctrl-msm.c | 17 - 1 files changed, 0 insertions(+),

[PATCH RFT] gpio: mb86s70: Return error if requesting an already assigned gpio

2015-01-30 Thread Axel Lin
Signed-off-by: Axel Lin axel@ingics.com --- drivers/gpio/gpio-mb86s7x.c | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/gpio/gpio-mb86s7x.c b/drivers/gpio/gpio-mb86s7x.c index 21b1ce5..ee93c0a 100644 --- a/drivers/gpio/gpio-mb86s7x.c +++ b/drivers/gpio/gpio-mb86s7x.c @@ -58,6

[PATCH 3/3] pinctrl: qcom: handle input-enable pinconf property

2015-01-30 Thread Stanimir Varbanov
This enables support of 'input-enable' pinconf generic property in the pinctrl driver. Signed-off-by: Stanimir Varbanov svarba...@mm-sol.com --- drivers/pinctrl/qcom/pinctrl-msm.c | 11 +++ 1 files changed, 11 insertions(+), 0 deletions(-) diff --git

Re: [PATCH] gpio: max732x: add set_multiple function

2015-01-30 Thread Linus Walleij
On Wed, Jan 21, 2015 at 6:17 PM, Mans Rullgard m...@mansr.com wrote: This adds a set_multiple function to the MAX732x GPIO driver, allowing for performance gains when using gpiod_set_array(). Signed-off-by: Mans Rullgard m...@mansr.com Patch applied, thanks Måns! BTW: are you interested in

Re: [PATCH 2/2] gpio: sysfs: fix memory leak in gpiod_sysfs_set_active_low

2015-01-30 Thread Linus Walleij
On Mon, Jan 26, 2015 at 12:02 PM, Johan Hovold jo...@kernel.org wrote: Fix memory leak in the gpio sysfs interface due to failure to drop reference to device returned by class_find_device when setting the gpio-line polarity. Fixes: 0769746183ca (gpiolib: add support for changing value

Re: [PATCH] pinctrl: rockchip: Only mask interrupts; never disable

2015-01-30 Thread Linus Walleij
On Mon, Jan 26, 2015 at 5:24 PM, Doug Anderson diand...@chromium.org wrote: The Rockchip GPIO interrupt controller totally throws away all status about an interrupt when you disable the interrupt. That has unfortunate consequences in the following situation: 1. An edge-triggered interrupt

[PATCH 2/3] pinctrl: qcom: enable generic pinconf

2015-01-30 Thread Stanimir Varbanov
This makes the pinctrl driver to use the generic pinconf interface. Mainly it gives us a way to use debugfs to dump group configurations. Signed-off-by: Stanimir Varbanov svarba...@mm-sol.com --- drivers/pinctrl/qcom/pinctrl-msm.c |4 +--- 1 files changed, 1 insertions(+), 3 deletions(-)

Re: [PATCH 1/3][v2] gpiolib: add gpiod_get_array and gpiod_put_array functions

2015-01-30 Thread Linus Walleij
On Wed, Jan 21, 2015 at 5:46 PM, Rojhalat Ibrahim i...@rtschenk.de wrote: Introduce new functions for conveniently obtaining and disposing of an entire array of GPIOs with one function call. Suggested-by: Alexandre Courbot acour...@nvidia.com Signed-off-by: Rojhalat Ibrahim i...@rtschenk.de

[PATCH v3 1/3] pinctrl: qcom: increase variable size for register offsets

2015-01-30 Thread Stanimir Varbanov
From: Joonwoo Park joonw...@codeaurora.org On newer TLMM hardware blocks the registers are spread and we need an offsets upper than 16 bits to address them. Increase the register offset variables to 32 bits size. Signed-off-by: Joonwoo Park joonw...@codeaurora.org Signed-off-by: Stanimir

[PATCH v3 2/3] DT: pinctrl: Document Qualcomm MSM8916 pinctrl binding

2015-01-30 Thread Stanimir Varbanov
Adds devicetree binding documentation. Signed-off-by: Stanimir Varbanov svarba...@mm-sol.com Reviewed-by: Bjorn Andersson bjorn.anders...@sonymobile.com --- .../bindings/pinctrl/qcom,msm8916-pinctrl.txt | 186 1 files changed, 186 insertions(+), 0 deletions(-) create

[PATCH v3 0/3] pinctrl: Qualcomm msm8916 pinctrl driver

2015-01-30 Thread Stanimir Varbanov
Changes since v2: - addressed all Andy's comments --- Changes since v1: - correct the subject and description in 1/3 - not break the fields in msm8916_groups[] array in 3/3 - added Reviewed-by tags on all three

Re: [PATCH 1/2] gpio: max732x: use an inline function for container cast

2015-01-30 Thread Måns Rullgård
Linus Walleij linus.wall...@linaro.org writes: Cast the struct gpio_chip into a max732x_chip using an inline macro and move the assignment to the variable declaration to save lines and simplify things. Cc: Semen Protsenko semen.protse...@globallogic.com Cc: Mans Rullgard m...@mansr.com

Re: [PATCH 1/3] pinctrl: qcom: delete pin_config_get/set pinconf operations

2015-01-30 Thread Linus Walleij
On Fri, Jan 30, 2015 at 11:27 AM, Stanimir Varbanov svarba...@mm-sol.com wrote: The .pin_config_get/set operation are not supported in qcom pinctrl driver. As the pinconf core is smart enough it doesn't complain about that. Signed-off-by: Stanimir Varbanov svarba...@mm-sol.com Patch applied

Re: [PATCH v2 1/4] gpio: use sizeof() instead of hardcoded values

2015-01-30 Thread Linus Walleij
On Wed, Jan 21, 2015 at 10:33 PM, Olliver Schinagl o.schin...@ultimaker.com wrote: From: Olliver Schinagl oli...@schinagl.nl gpiolib uses a fixed string for the suffixes and defines it at 32 bytes. Later in the code snprintf is used with this fixed value of 32. Using sizeof() is safer in

Re: [PATCH v2 2/4] gpio: add parameter to allow the use named gpios

2015-01-30 Thread Linus Walleij
On Wed, Jan 21, 2015 at 10:33 PM, Olliver Schinagl o.schin...@ultimaker.com wrote: From: Olliver Schinagl oli...@schinagl.nl The gpio binding document says that new code should always use named gpios. Patch 40b73183 added support to parse a list of gpios from child nodes, but does not make

Re: [PATCH v3 2/3] DT: pinctrl: Document Qualcomm MSM8916 pinctrl binding

2015-01-30 Thread Linus Walleij
On Fri, Jan 30, 2015 at 11:04 AM, Stanimir Varbanov svarba...@mm-sol.com wrote: Adds devicetree binding documentation. Signed-off-by: Stanimir Varbanov svarba...@mm-sol.com Reviewed-by: Bjorn Andersson bjorn.anders...@sonymobile.com Patch applied, as you're obviously working on enabling the

Re: [PATCH v3 1/3] pinctrl: qcom: increase variable size for register offsets

2015-01-30 Thread Linus Walleij
On Fri, Jan 30, 2015 at 11:03 AM, Stanimir Varbanov svarba...@mm-sol.com wrote: From: Joonwoo Park joonw...@codeaurora.org On newer TLMM hardware blocks the registers are spread and we need an offsets upper than 16 bits to address them. Increase the register offset variables to 32 bits size.

Re: Re: [PATCH v4 1/3] pinctrl: add driver for Amlogic Meson SoCs

2015-01-30 Thread Linus Walleij
On Fri, Jan 23, 2015 at 3:25 AM, 48169172 48169...@163.com wrote: Hi Linus, I do not find the meson dir, https://git.kernel.org/cgit/linux/kernel/git/linusw/linux-pinctrl.git/tree/drivers/pinctrl?h=devel Is there something wrong? Maybe I took time pushing it out? It's certainly there now,

Re: [PATCH] gpio: max732x: add set_multiple function

2015-01-30 Thread Måns Rullgård
Linus Walleij linus.wall...@linaro.org writes: On Wed, Jan 21, 2015 at 6:17 PM, Mans Rullgard m...@mansr.com wrote: This adds a set_multiple function to the MAX732x GPIO driver, allowing for performance gains when using gpiod_set_array(). Signed-off-by: Mans Rullgard m...@mansr.com Patch

[PATCH 2/2] gpio: max732x: convert to GPIOLIB_IRQCHIP

2015-01-30 Thread Linus Walleij
Take a sweep to bring the irq support for the MAX732x expanders into the gpiolib core to cut down on duplicated code. Only compile tested! I need some feedback from people using this expander with interrupts to tell me if things go right or wrong when I do this. Cc: Semen Protsenko