Re: [PATCH 10/16] RDMA/efa: Use ib_copy_validate_udata_in_cm()
On Thu, Mar 12, 2026 at 09:08:58AM -0300, Jason Gunthorpe wrote: > On Thu, Mar 12, 2026 at 08:20:20AM -0300, Jason Gunthorpe wrote: > > On Thu, Mar 12, 2026 at 01:03:59PM +0200, Gal Pressman wrote: > > > On 12/03/2026 2:24, Jason Gunthorpe wrote: > > > > Add the missed check for unsupported comp_mask bits. > > > > > > Is it really missed? IIRC, it's intended. > > > > > > See the comment above your hunk, and efa_user_comp_handshake()? > > > > No, that is an illegal way to use a field called comp_mask. > > > > If the driver wants that it needs a new field "suggested feature flags > > to enable" > > > > comp_mask is strictly to say that new fields are present and must be > > processed by the kernel, and nothing else. > > We could also rename the struct field away from comp_mask ? It is > easier to add a comp_mask later.. > > Jason Agree that this field should be renamed as we shouldn't fail when unsupported value is requested. I'll send a patch. Michael
Re: [PATCH 10/16] RDMA/efa: Use ib_copy_validate_udata_in_cm()
On Thu, Mar 12, 2026 at 08:20:20AM -0300, Jason Gunthorpe wrote: > On Thu, Mar 12, 2026 at 01:03:59PM +0200, Gal Pressman wrote: > > On 12/03/2026 2:24, Jason Gunthorpe wrote: > > > Add the missed check for unsupported comp_mask bits. > > > > Is it really missed? IIRC, it's intended. > > > > See the comment above your hunk, and efa_user_comp_handshake()? > > No, that is an illegal way to use a field called comp_mask. > > If the driver wants that it needs a new field "suggested feature flags > to enable" > > comp_mask is strictly to say that new fields are present and must be > processed by the kernel, and nothing else. We could also rename the struct field away from comp_mask ? It is easier to add a comp_mask later.. Jason
Re: [PATCH 10/16] RDMA/efa: Use ib_copy_validate_udata_in_cm()
On Thu, Mar 12, 2026 at 01:03:59PM +0200, Gal Pressman wrote: > On 12/03/2026 2:24, Jason Gunthorpe wrote: > > Add the missed check for unsupported comp_mask bits. > > Is it really missed? IIRC, it's intended. > > See the comment above your hunk, and efa_user_comp_handshake()? No, that is an illegal way to use a field called comp_mask. If the driver wants that it needs a new field "suggested feature flags to enable" comp_mask is strictly to say that new fields are present and must be processed by the kernel, and nothing else. Jason
Re: [PATCH 10/16] RDMA/efa: Use ib_copy_validate_udata_in_cm()
On 12/03/2026 2:24, Jason Gunthorpe wrote: > Add the missed check for unsupported comp_mask bits. Is it really missed? IIRC, it's intended. See the comment above your hunk, and efa_user_comp_handshake()?
