[PATCH 2/2] Input: joystick - use sizeof(VARIABLE) in documentation

2013-12-16 Thread Antonio Ospite
Use the preferred style sizeof(VARIABLE) instead of sizeof(TYPE) in the joystick API documentation, Documentation/CodingStyle states that this is the preferred style for allocations but using it elsewhere is good too. Also fix some errors like sizeof(struct mybuffer) which didn't mean anything.

[PATCH 1/2] Input: joystick - refer to /dev/input/js0 in documentation

2013-12-16 Thread Antonio Ospite
Nowadays the joystick device nodes are created under /dev/input, reflect this in the documentation in order to make copy and paste easier for users. Signed-off-by: Antonio Ospite osp...@studenti.unina.it --- Documentation/input/joystick-api.txt | 2 +- Documentation/input/joystick.txt | 8

Re: [PATCH 2/2] Input: joystick - use sizeof(VARIABLE) in documentation

2013-12-16 Thread Dmitry Torokhov
Hi Antonio, On Mon, Dec 16, 2013 at 09:57:15AM +0100, Antonio Ospite wrote: @@ -181,7 +181,7 @@ at a time using the typical read(2) functionality. For that, you would replace the read above with something like struct js_event mybuffer[0xff]; - int i = read (fd, mybuffer,

Re: [PATCH 2/2] Input: joystick - use sizeof(VARIABLE) in documentation

2013-12-16 Thread Antonio Ospite
On Mon, 16 Dec 2013 01:51:41 -0800 Dmitry Torokhov dmitry.torok...@gmail.com wrote: Hi Antonio, On Mon, Dec 16, 2013 at 09:57:15AM +0100, Antonio Ospite wrote: @@ -181,7 +181,7 @@ at a time using the typical read(2) functionality. For that, you would replace the read above with

[PATCH] Input: add i2c/smbus driver for elan touchpad

2013-12-16 Thread Duson Lin
This driver adds support for elan i2c/smbus touchpad found on some laptops PC Signed-off-by: Duson Lin duson...@emc.com.tw --- drivers/input/mouse/Kconfig| 10 + drivers/input/mouse/Makefile |1 + drivers/input/mouse/elan_i2c.c | 908 3 files

Re: Recent change to hid-core.c

2013-12-16 Thread Jiri Kosina
On Sun, 15 Dec 2013, Mark Lord wrote: The recent update 08ec2dcc3527a20c619aca2fb36f800908256bac Merge branches 'for-3.11/multitouch', 'for-3.11/sony' and 'for-3.11/upstream' into for-linus included an unexpected change to the return code handing for -raw_event() calls. A HID driver's

Re: Recent change to hid-core.c

2013-12-16 Thread Mark Lord
On 13-12-16 08:24 AM, Jiri Kosina wrote: On Sun, 15 Dec 2013, Mark Lord wrote: The recent update 08ec2dcc3527a20c619aca2fb36f800908256bac Merge branches 'for-3.11/multitouch', 'for-3.11/sony' and 'for-3.11/upstream' into for-linus included an unexpected change to the return code handing

Re: Recent change to hid-core.c

2013-12-16 Thread Jiri Kosina
On Mon, 16 Dec 2013, Mark Lord wrote: The recent update 08ec2dcc3527a20c619aca2fb36f800908256bac Merge branches 'for-3.11/multitouch', 'for-3.11/sony' and 'for-3.11/upstream' into for-linus included an unexpected change to the return code handing for -raw_event() calls. ,, Was

[PATCH v3] if xen_platform_pci=0 is set don't blow up.

2013-12-16 Thread Konrad Rzeszutek Wilk
The first patch: [PATCH v3 1/2] xen/pvhvm: If xen_platform_pci=0 is set don't blow up I would like to commit to stable as it is fixing an eggregious bug - where we blow up if the guest config has: xen_platform_pci=0 setup. This bug has been in existence for years and it is time to stamp it out.

[PATCH v3 2/2] xen/pvhvm: Remove the xen_platform_pci int.

2013-12-16 Thread Konrad Rzeszutek Wilk
Since we have xen_has_pv_devices,xen_has_pv_disk_devices, xen_has_pv_nic_devices, and xen_has_pv_and_legacy_disk_devices to figure out the different 'unplug' behaviors - lets use those instead of this single int. Signed-off-by: Konrad Rzeszutek Wilk konrad.w...@oracle.com ---

[PATCH v3 1/2] xen/pvhvm: If xen_platform_pci=0 is set don't blow up (v3).

2013-12-16 Thread Konrad Rzeszutek Wilk
The user has the option of disabling the platform driver: 00:02.0 Unassigned class [ff80]: XenSource, Inc. Xen Platform Device (rev 01) which is used to unplug the emulated drivers (IDE, Realtek 8169, etc) and allow the PV drivers to take over. If the user wishes to disable that they can set:

Re: [PATCH] Input: fix typos in Documentation/input/gamepad.txt

2013-12-16 Thread Antonio Ospite
On Mon, 16 Dec 2013 14:03:43 +0100 David Herrmann dh.herrm...@gmail.com wrote: Hi CCing linux-input which I forgot. On Mon, Dec 16, 2013 at 1:34 PM, Antonio Ospite osp...@studenti.unina.it wrote: Fix some typos and while at it also use PS as the name for the central HOME button on Sony

[PATCH] Input: add short note about ABS_MISC+n axes

2013-12-16 Thread David Herrmann
We must not reassign those axes or we will break backwards-compat. Add a small note for that so we don't accidentally some day reuse these. Signed-off-by: David Herrmann dh.herrm...@gmail.com --- include/uapi/linux/input.h | 4 1 file changed, 4 insertions(+) diff --git

Re: [PATCH 1/7] Input: pmic8xxx-pwrkey - Pass input device directly to interrupt

2013-12-16 Thread Stephen Boyd
On 12/15, Dmitry Torokhov wrote: Hi Stephen, On Tue, Dec 10, 2013 at 03:43:10PM -0800, Stephen Boyd wrote: Instead of passing the pointer to the container structure just pass the input device here. This saves a dereference in the fast path. Signed-off-by: Stephen Boyd

Re: [PATCH] Input: pmic8xxx-pwrkey - switch to using managed resources

2013-12-16 Thread Stephen Boyd
On 12/15, Dmitry Torokhov wrote: This simplifies error handling and device removal paths. Signed-off-by: Dmitry Torokhov dmitry.torok...@gmail.com --- Thanks. Like I said on the other mail, I forgot to send this patch along. This looks almost identical to what I had so I'm happy. Acked-by:

[PATCH] input: Port rotary_encoder to of_property_read_bool

2013-12-16 Thread Ben Gamari
--- drivers/input/misc/rotary_encoder.c | 9 +++-- 1 file changed, 3 insertions(+), 6 deletions(-) diff --git a/drivers/input/misc/rotary_encoder.c b/drivers/input/misc/rotary_encoder.c index f920ba7..52049db 100644 --- a/drivers/input/misc/rotary_encoder.c +++

Re: [PATCH v3] if xen_platform_pci=0 is set don't blow up.

2013-12-16 Thread Bjorn Helgaas
On Mon, Dec 16, 2013 at 8:04 AM, Konrad Rzeszutek Wilk konrad.w...@oracle.com wrote: The first patch: [PATCH v3 1/2] xen/pvhvm: If xen_platform_pci=0 is set don't blow up I would like to commit to stable as it is fixing an eggregious bug - where we blow up if the guest config has:

[PATCH -next] Input: pmic8xxx-pwrkey - fix to pass correct device identity to free_irq()

2013-12-16 Thread Wei Yongjun
From: Wei Yongjun yongjun_...@trendmicro.com.cn free_irq() in the error handling case is missing when change pass input device directly to interrupt. Fixes: b27f8fee4965('Input: pmic8xxx-pwrkey - pass input device directly to interrupt') Signed-off-by: Wei Yongjun yongjun_...@trendmicro.com.cn

Re: [PATCH -next] Input: pmic8xxx-pwrkey - fix to pass correct device identity to free_irq()

2013-12-16 Thread Stephen Boyd
On 12/17, Wei Yongjun wrote: From: Wei Yongjun yongjun_...@trendmicro.com.cn free_irq() in the error handling case is missing when change pass input device directly to interrupt. Fixes: b27f8fee4965('Input: pmic8xxx-pwrkey - pass input device directly to interrupt') Signed-off-by: Wei

Re: [PATCH 6/7] Input: pmic8xxx-keypad - Migrate to devm_* APIs

2013-12-16 Thread Dmitry Torokhov
On Tue, Dec 10, 2013 at 03:43:15PM -0800, Stephen Boyd wrote: Simplify the error paths and reduce the lines of code in this driver by using the devm_* APIs. Signed-off-by: Stephen Boyd sb...@codeaurora.org --- drivers/input/keyboard/pmic8xxx-keypad.c | 62 +---

Re: [PATCH v2] elantech: Properly differentiate between clickpads and normal touchpads

2013-12-16 Thread Dmitry Torokhov
On Tue, Dec 10, 2013 at 10:31:14AM +0100, Hans de Goede wrote: The current assumption in the elantech driver that hw version 3 touchpads are never clickpads and hw version 4 touchpads are always clickpads is wrong. There are several bug reports for this, ie:

Re: [PATCH] Input: add i2c/smbus driver for elan touchpad

2013-12-16 Thread Dmitry Torokhov
Hi Duson, On Fri, Nov 22, 2013 at 01:56:55PM +0800, Duson Lin wrote: This driver adds support for elan i2c/smbus touchpad found on some laptops PC --- drivers/input/mouse/Kconfig| 10 + drivers/input/mouse/Makefile |1 + drivers/input/mouse/elan_i2c.c | 1846

Re: [PATCH 6/7] Input: pmic8xxx-keypad - Migrate to devm_* APIs

2013-12-16 Thread spamassassin system account
On 12/16, Dmitry Torokhov wrote: On Tue, Dec 10, 2013 at 03:43:15PM -0800, Stephen Boyd wrote: - -static int pmic8xxx_kp_remove(struct platform_device *pdev) -{ - struct pmic8xxx_kp *kp = platform_get_drvdata(pdev); - - device_init_wakeup(pdev-dev, 0); Why are we removing

[PATCH -next] Input: zforce - fix error return code in zforce_start()

2013-12-16 Thread Wei Yongjun
From: Wei Yongjun yongjun_...@trendmicro.com.cn The error code was not set if unable to set config, so the error condition wasn't reflected in the return value. Fix to return a negative error code from the error handling case instead of 0. Signed-off-by: Wei Yongjun yongjun_...@trendmicro.com.cn