[PATCH V3 01/14] sh: Eliminate unused irq_reg_{readl,writel} accessors

2014-11-01 Thread Kevin Cernekee
Defining these macros way down in arch/sh/.../irq.c doesn't cause kernel/irq/generic-chip.c to use them. As far as I can tell this code has no effect. Signed-off-by: Kevin Cernekee cerne...@gmail.com --- arch/sh/boards/mach-se/7343/irq.c | 3 --- arch/sh/boards/mach-se/7722/irq.c | 3 --- 2

[PATCH V3 03/14] genirq: Generic chip: Allow irqchip drivers to override irq_reg_{readl,writel}

2014-11-01 Thread Kevin Cernekee
Currently, these I/O accessors always assume little endian 32-bit registers (readl/writel). On some systems the IRQ registers need to be accessed in BE mode or using 16-bit loads/stores, so we will provide a way to override the default behavior. Signed-off-by: Kevin Cernekee cerne...@gmail.com

[PATCH V3 12/14] irqchip: bcm7120-l2: Decouple driver from brcmstb-l2

2014-11-01 Thread Kevin Cernekee
Some chips, such as BCM6328, only require bcm7120-l2. Some BCM7xxx STB configurations only require brcmstb-l2. Treat them as two separate entities, and update the mach-bcm dependencies to reflect the change. Signed-off-by: Kevin Cernekee cerne...@gmail.com Acked-by: Arnd Bergmann a...@arndb.de

[PATCH V3 14/14] irqchip: brcmstb-l2: Convert driver to use irq_reg_{readl,writel}

2014-11-01 Thread Kevin Cernekee
This effectively converts the __raw_ accessors to the non-__raw_ equivalents. To handle BE, we pass IRQ_GC_BE_IO, similar to what was done in irq-bcm7120-l2.c. Since irq_reg_writel now takes an irq_chip_generic argument, writel must be used for the initial hardware reset in the probe function.

[PATCH V3 09/14] irqchip: bcm7120-l2: Fix missing nibble in gc-unused mask

2014-11-01 Thread Kevin Cernekee
This mask should have been 0x_, not 0x0fff_. The change should not have an effect on current users (STB) because bits 31:27 are unused. Signed-off-by: Kevin Cernekee cerne...@gmail.com Acked-by: Arnd Bergmann a...@arndb.de Acked-by: Florian Fainelli f.faine...@gmail.com ---

[PATCH V3 06/14] irqchip: bcm7120-l2: Eliminate bad IRQ check

2014-11-01 Thread Kevin Cernekee
This check may be prone to race conditions, e.g. 1) Some external event (e.g. GPIO level) causes an IRQ to become pending 2) Peripheral asserts the L2 IRQ 3) CPU takes an interrupt 4) The event from #1 goes away 5) bcm7120_l2_intc_irq_handle() reads back a 0 status Unlike the hardware supported

[PATCH V3 11/14] irqchip: bcm7120-l2: Extend driver to support 64+ bit controllers

2014-11-01 Thread Kevin Cernekee
Most implementations of the bcm7120-l2 controller only have a single 32-bit enable word + 32-bit status word. But some instances have added more enable/status pairs in order to support 64+ IRQs (which are all ORed into one parent IRQ input). Make the following changes to allow the driver to

[PATCH V3 13/14] irqchip: bcm7120-l2: Convert driver to use irq_reg_{readl,writel}

2014-11-01 Thread Kevin Cernekee
On BE MIPS systems this needs to use the new IRQ_GC_BE_IO gc_flag. In all other cases it will use the standard readl/writel accessors. The initial irq_fwd_mask setup runs before gc is initialized, so it is unchanged for now. This could potentially be a problem on an ARM system that boots in LE

[PATCH V3 08/14] irqchip: bcm7120-l2: Make sure all register accesses use base+offset

2014-11-01 Thread Kevin Cernekee
A couple of accesses to IRQEN (base+0x00) just used base directly, so they would break if IRQEN ever became nonzero. Make sure that all reads/writes specify the register offset constant. Signed-off-by: Kevin Cernekee cerne...@gmail.com Acked-by: Florian Fainelli f.faine...@gmail.com ---

[PATCH V3 10/14] irqchip: bcm7120-l2: Use gc-mask_cache to simplify suspend/resume functions

2014-11-01 Thread Kevin Cernekee
The cached value already incorporates irq_fwd_mask, and was saved the last time an IRQ was enabled/disabled. Signed-off-by: Kevin Cernekee cerne...@gmail.com Acked-by: Florian Fainelli f.faine...@gmail.com --- drivers/irqchip/irq-bcm7120-l2.c | 11 +++ 1 file changed, 3 insertions(+), 8

[PATCH V3 07/14] irqchip: bcm7120-l2, brcmstb-l2: Remove ARM Kconfig dependency

2014-11-01 Thread Kevin Cernekee
This can compile for MIPS (or anything else) now. Signed-off-by: Kevin Cernekee cerne...@gmail.com Acked-by: Arnd Bergmann a...@arndb.de Acked-by: Florian Fainelli f.faine...@gmail.com --- drivers/irqchip/Kconfig | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/irqchip/Kconfig

[PATCH V3 04/14] genirq: Generic chip: Add big endian I/O accessors

2014-11-01 Thread Kevin Cernekee
Use io{read,write}32be if the caller specified IRQ_GC_BE_IO when creating the irqchip. Signed-off-by: Kevin Cernekee cerne...@gmail.com --- include/linux/irq.h | 1 + kernel/irq/generic-chip.c | 16 2 files changed, 17 insertions(+) diff --git a/include/linux/irq.h

[PATCH V3 00/14] genirq endian fixes; bcm7120/brcmstb IRQ updates

2014-11-01 Thread Kevin Cernekee
V2-V3: - Move updated irq_reg_{readl,writel} functions back into linux/irq.h so they can be called by irqchip drivers - Add gc-reg_{readl,writel} function pointers so that irqchip drivers like arch/sh/boards/mach-se/{7343,7722}/irq.c can override them - CC: linux-sh list in lieu of

[PATCH V3 05/14] irqchip: brcmstb-l2: Eliminate dependency on ARM code

2014-11-01 Thread Kevin Cernekee
The irq-brcmstb-l2 driver has a single dependency on the ARM code, the do_bad_IRQ macro. Expand this macro in-place so that the driver can be built on non-ARM platforms. Signed-off-by: Kevin Cernekee cerne...@gmail.com Acked-by: Arnd Bergmann a...@arndb.de Acked-by: Florian Fainelli

[PATCH V3 02/14] genirq: Generic chip: Change irq_reg_{readl,writel} arguments

2014-11-01 Thread Kevin Cernekee
Pass in the irq_chip_generic struct so we can use different readl/writel settings for each irqchip driver, when appropriate. Compute (gc-reg_base + reg_offset) in the helper function because this is pretty much what all callers want to do anyway. Compile-tested using the following

Re: [PATCH 00/12] Add kdbus implementation

2014-11-01 Thread Greg Kroah-Hartman
On Thu, Oct 30, 2014 at 12:00:16AM +0100, Jiri Kosina wrote: On Wed, 29 Oct 2014, Greg Kroah-Hartman wrote: kdbus is a kernel-level IPC implementation that aims for resemblance to the the protocol layer with the existing userspace D-Bus daemon while enabling some features that couldn't be

Easy Work,Great Pay,Start Today.

2014-11-01 Thread BHP Billiton Plc
Dear Sir/Madam, Would you like to work online from home/temporarily and earn constant Payment?We are glad to offer you a job position in our company,BHP Billiton Plc. You will be on a monthly salary, if you are interested you are to please fill the below form. Further information's on this job

Re: kdbus: add documentation

2014-11-01 Thread Greg Kroah-Hartman
On Thu, Oct 30, 2014 at 01:20:23PM +0100, Peter Meerwald wrote: kdbus is a system for low-latency, low-overhead, easy to use interprocess communication (IPC). The interface to all functions in this driver is implemented through ioctls on /dev nodes. This patch adds detailed

[GIT PULL] irqchip: Fixes for v3.18

2014-11-01 Thread Jason Cooper
Thomas, Here's a couple of fixes for v3.18 that have been in -next longer than needed :-/ Please pull. thx, Jason. The following changes since commit f114040e3ea6e07372334ade75d1ee0775c355e1: Linux 3.18-rc1 (2014-10-19 18:08:38 -0700) are available in the git repository at:

Re: [PATCH] arch: tile: kernel: signal.c: Use explicitly type case unsigned long * for register copy

2014-11-01 Thread Chen Gang
On 11/2/14 4:23, Al Viro wrote: On Sat, Nov 01, 2014 at 08:49:45PM +0800, Chen Gang wrote: setup_sigcontext() wants to copy all kernel related registers to user space. So let it copy explicitly instead of copying by exceeding member array border. So let code more clearer and avoid warning.

[PATCH v2] arch: tile: kernel: signal.c: Use __copy_from/to_user() instead of __get/put_user()

2014-11-01 Thread Chen Gang
setup/restore_sigcontext() want to copy all related registers between user and kernel. So use block copy instead of each registers copy. Then can let code simple and clearer (which can avoid compiler's warning): The related warning (with allmodconfig under tile): CC

Re: [PATCH v2] irqchip: dw-apb-ictl: select GENERIC_IRQ_CHIP

2014-11-01 Thread Jason Cooper
Jisheng, On Wed, Oct 22, 2014 at 08:59:10PM +0800, Jisheng Zhang wrote: The dw-apb-ictl driver uses the generic-chip functions. Thus it needs to select GENERIC_IRQ_CHIP in Kconfig. Change-Id: If748beffc4e0d0b47062bb067a59c10994a9148b Please don't include this is future patches.

Re: [PATCH 0/5] irqchip: atmel-aic: add RTT irq fixup

2014-11-01 Thread Jason Cooper
On Mon, Sep 15, 2014 at 09:53:56PM +0200, Boris BREZILLON wrote: On Mon, 15 Sep 2014 21:49:07 +0200 Boris BREZILLON boris.brezil...@free-electrons.com wrote: Hi, On Sun, 14 Sep 2014 01:46:48 -0400 Jason Cooper ja...@lakedaemon.net wrote: On Wed, Sep 03, 2014 at 11:07:46AM +0200,

[patch] mm: memcontrol: remove stale page_cgroup_lock comment

2014-11-01 Thread Johannes Weiner
There is no cgroup-specific page lock anymore. Signed-off-by: Johannes Weiner han...@cmpxchg.org --- mm/memcontrol.c | 4 1 file changed, 4 deletions(-) diff --git a/mm/memcontrol.c b/mm/memcontrol.c index 38f0647a2f12..d20928597a07 100644 --- a/mm/memcontrol.c +++ b/mm/memcontrol.c @@

[patch 2/3] mm: page_cgroup: rename file to mm/swap_cgroup.c

2014-11-01 Thread Johannes Weiner
Now that the external page_cgroup data structure and its lookup is gone, the only code remaining in there is swap slot accounting. Rename it and move the conditional compilation into mm/Makefile. Signed-off-by: Johannes Weiner han...@cmpxchg.org --- MAINTAINERS | 2 +-

[patch 3/3] mm: move page-mem_cgroup bad page handling into generic code

2014-11-01 Thread Johannes Weiner
Now that the external page_cgroup data structure and its lookup is gone, let the generic bad_page() check for page-mem_cgroup sanity. Signed-off-by: Johannes Weiner han...@cmpxchg.org --- include/linux/memcontrol.h | 4 mm/debug.c | 5 - mm/memcontrol.c| 15

[patch 1/3] mm: embed the memcg pointer directly into struct page

2014-11-01 Thread Johannes Weiner
Memory cgroups used to have 5 per-page pointers. To allow users to disable that amount of overhead during runtime, those pointers were allocated in a separate array, with a translation layer between them and struct page. There is now only one page pointer remaining: the memcg pointer, that

RE: [PATCH 1/4] pmem: Initial version of persistent memory driver

2014-11-01 Thread Elliott, Robert (Server Storage)
-Original Message- From: linux-kernel-ow...@vger.kernel.org [mailto:linux-kernel- ow...@vger.kernel.org] On Behalf Of Ross Zwisler Sent: Wednesday, 27 August, 2014 4:12 PM To: Jens Axboe; Matthew Wilcox; Boaz Harrosh; Nick Piggin; linux- fsde...@vger.kernel.org;

RE: [PATCH 2/4] pmem: Add support for getgeo()

2014-11-01 Thread Elliott, Robert (Server Storage)
-Original Message- From: linux-kernel-ow...@vger.kernel.org [mailto:linux-kernel- ow...@vger.kernel.org] On Behalf Of Ross Zwisler Sent: Wednesday, 27 August, 2014 4:12 PM To: Jens Axboe; Matthew Wilcox; Boaz Harrosh; Nick Piggin; linux- fsde...@vger.kernel.org;

Re: [PATCH] usb: option: Add ID for Peiker LTE NAD

2014-11-01 Thread Lars Melin
On 2014-11-01 23:01, Matthias Klein wrote: Add ID of the Peiker LTE NAD for legacy serial interface Signed-off-by: Matthias Klein matthias.kl...@linux.com --- drivers/usb/serial/option.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/usb/serial/option.c

[PATCH] fsnotify: don't call mutex_lock from TASK_INTERRUPTIBLE context

2014-11-01 Thread Sasha Levin
Sleeping functions should only be called from TASK_RUNNING. The following code in fanotify_read(): prepare_to_wait(group-notification_waitq, wait, TASK_INTERRUPTIBLE); mutex_lock(group-notification_mutex); would call it under TASK_INTERRUPTIBLE, and trigger a warning:

Re: [PATCH] x86, cpu: trivial printk formatting fixes

2014-11-01 Thread Steven Honeyman
On 1 November 2014 17:51, Borislav Petkov b...@alien8.de wrote: On Sat, Nov 01, 2014 at 05:38:18PM +, Steven Honeyman wrote: On 1 November 2014 17:19, Borislav Petkov b...@alien8.de wrote: On Sat, Nov 01, 2014 at 03:44:56PM +, Steven Honeyman wrote: A 2 line printk makes dmesg output

Re: [PATCH] powerpc: use device_online/offline() instead of cpu_up/down()

2014-11-01 Thread Bharata B Rao
On Fri, Oct 31, 2014 at 03:41:34PM -0400, Dan Streetman wrote: In powerpc pseries platform dlpar operations, Use device_online() and device_offline() instead of cpu_up() and cpu_down(). Calling cpu_up/down directly does not update the cpu device offline field, which is used to online/offline

Re: [Patch v7 14/18] x86, irq, ACPI: Introduce a rwsem to protect IOAPIC operations from hotplug

2014-11-01 Thread Jiang Liu
On 2014/11/2 2:59, Thomas Gleixner wrote: On Mon, 27 Oct 2014, Jiang Liu wrote: We are going to support ACPI based IOAPIC hotplug, so introduce a rwsem to protect IOAPIC data structures from IOAPIC hotplug. We choose to serialize in ACPI instead of in the IOAPIC core because: 1) currently we

Re: [PATCH v2] irqchip: dw-apb-ictl: select GENERIC_IRQ_CHIP

2014-11-01 Thread Jisheng Zhang
On Sat, 1 Nov 2014 19:23:11 -0700 Jason Cooper ja...@lakedaemon.net wrote: Jisheng, On Wed, Oct 22, 2014 at 08:59:10PM +0800, Jisheng Zhang wrote: The dw-apb-ictl driver uses the generic-chip functions. Thus it needs to select GENERIC_IRQ_CHIP in Kconfig. Change-Id:

[git pull] vfs.git

2014-11-01 Thread Al Viro
A bunch of assorted fixes, most of them - followups to overlayfs merge. Please, pull from the usual place: git://git.kernel.org/pub/scm/linux/kernel/git/viro/vfs.git for-linus Shortlog: Al Viro (3): overlayfs: barriers for opening upper-layer directory isofs_cmp(): we'll

<    1   2   3   4   5   6