[PATCH] kmemleak: Add config to select auto scan

2018-10-17 Thread Prateek Patel
From: Sri Krishna chowdary Kmemleak scan is cpu intensive and can stall user tasks at times. To prevent this, add config DEBUG_KMEMLEAK_SCAN_ON to enable/disable auto scan on boot up. Also protect first_run with CONFIG_DEBUG_KMEMLEAK_SCAN_ON as this is meant for only first automatic scan. Signed

Re: [PATCH v4 3/3] iio: magnetometer: Add driver support for PNI RM3100

2018-10-17 Thread Song Qiang
On 2018/10/12 下午8:53, Himanshu Jha wrote: Hi Qiang, On Fri, Oct 12, 2018 at 04:36:01PM +0800, Song Qiang wrote: On 2018年10月12日 15:35, Song Qiang wrote: PNI RM3100 is a high resolution, large signal immunity magnetometer, composed of 3 single sensors and a processing chip with a MagI2C inter

Re: [PATCH v3 1/2] mtd: spi-nor: add support to non-uniform SFDP SPI NOR flash memories

2018-10-17 Thread Tudor Ambarus
Hi, Yogesh, On 10/17/2018 10:46 AM, Yogesh Narayan Gaur wrote: > Hi Boris, > >> -Original Message- >> From: Boris Brezillon [mailto:boris.brezil...@bootlin.com] >> Sent: Wednesday, October 17, 2018 1:00 PM >> To: Yogesh Narayan Gaur >> Cc: Cyrille Pitchen ; Tudor Ambarus >> ; marek.va...

Re: [RFC][PATCHv2 2/4] printk: move printk_safe macros to printk header

2018-10-17 Thread Peter Zijlstra
On Wed, Oct 17, 2018 at 01:32:51PM +0900, Sergey Senozhatsky wrote: > This probably will be a bit more hairy. logbuf is written to by many > sources and is read from by many sides, including user-space [both read() > and write()]. So we will need more flags/magic around memcpy(). A simple, > "grab

Re: [PATCH 4.14 000/109] 4.14.77-stable review

2018-10-17 Thread Greg Kroah-Hartman
On Tue, Oct 16, 2018 at 10:56:42PM -0500, Dan Rue wrote: > On Tue, Oct 16, 2018 at 07:04:28PM +0200, Greg Kroah-Hartman wrote: > > This is the start of the stable review cycle for the 4.14.77 release. > > There are 109 patches in this series, all will be posted as a response > > to this one. If an

Re: [PATCH 4.9 00/71] 4.9.134-stable review

2018-10-17 Thread Greg Kroah-Hartman
On Wed, Oct 17, 2018 at 12:50:42PM +0530, Amit Pundir wrote: > Hi, > > On Tue, 16 Oct 2018 at 22:52, Greg Kroah-Hartman > wrote: > > > > This is the start of the stable review cycle for the 4.9.134 release. > > There are 71 patches in this series, all will be posted as a response > > to this one.

Re: [PATCH 4.18 000/135] 4.18.15-stable review

2018-10-17 Thread Greg Kroah-Hartman
On Tue, Oct 16, 2018 at 08:33:42PM +0200, Holger Hoffstätte wrote: > On 10/16/18 19:03, Greg Kroah-Hartman wrote: > > This is the start of the stable review cycle for the 4.18.15 release. > > Gave this a try since I have r8169 NICs. Applied over .14 and now running > on three different machines. N

Re: [PATCH 4.18 079/135] Add tests for memory.oom.group

2018-10-17 Thread Greg Kroah-Hartman
On Tue, Oct 16, 2018 at 07:39:10PM +, Roman Gushchin wrote: > On Tue, Oct 16, 2018 at 07:05:09PM +0200, Greg Kroah-Hartman wrote: > > 4.18-stable review patch. If anyone has any objections, please let me know. > > Memory.oom.group has been merged into 4.19, so the test will fail on 4.18. > I

RE: [PATCH v3 1/2] mtd: spi-nor: add support to non-uniform SFDP SPI NOR flash memories

2018-10-17 Thread Yogesh Narayan Gaur
Hi Boris, > -Original Message- > From: Boris Brezillon [mailto:boris.brezil...@bootlin.com] > Sent: Wednesday, October 17, 2018 1:00 PM > To: Yogesh Narayan Gaur > Cc: Cyrille Pitchen ; Tudor Ambarus > ; marek.va...@gmail.com; > dw...@infradead.org; computersforpe...@gmail.com; rich...@no

Re: [PATCH 4.18 101/135] hv_netvsc: pair VF based on serial number

2018-10-17 Thread Greg Kroah-Hartman
On Tue, Oct 16, 2018 at 07:13:12PM +, Haiyang Zhang wrote: > > > > -Original Message- > > From: linux-kernel-ow...@vger.kernel.org > ow...@vger.kernel.org> On Behalf Of Greg Kroah-Hartman > > Sent: Tuesday, October 16, 2018 1:06 PM > > To: linux-kernel@vger.kernel.org > > Cc: Greg Kr

[PATCH v2 08/21] PCI: keystone: Use uniform function naming convention

2018-10-17 Thread Kishon Vijay Abraham I
No functional change. Some function names begin with ks_dw_pcie_* and some function names begin with ks_pcie_*. Modify it so that all function names begin with ks_pcie_*. Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 221 +++--- 1 file chan

[PATCH v2 12/21] PCI: keystone: Invoke pm_runtime APIs to enable clock

2018-10-17 Thread Kishon Vijay Abraham I
Invoke pm_runtime APIs to enable clocks and remove explicit clock enabling using clk_prepare_enable(). Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 28 ++- 1 file changed, 12 insertions(+), 16 deletions(-) diff --git a/drivers/pci/con

[PATCH v2 10/21] PCI: keystone: Use SYSCON APIs to get device ID from control module

2018-10-17 Thread Kishon Vijay Abraham I
Control module registers should be read using syscon APIs. pci-keystone.c uses platform_get_resource to get control module registers. Fix it here by using syscon APIs to get device id from control module. Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 45 ++

[PATCH v2 15/21] PCI: keystone: Cleanup outbound window configuration

2018-10-17 Thread Kishon Vijay Abraham I
Outbound translation window is configured in order to access the PCIe card's MEM space. Cleanup outbound translation configuration here by using BIT() macros, adding a macro for window size and using lower_32_bits/upper_32_bits macros for configuring the 64 bit offset in the outbound translation re

[PATCH v2 03/21] PCI: keystone: Move dw_pcie_setup_rc out of ks_pcie_establish_link()

2018-10-17 Thread Kishon Vijay Abraham I
No functional change. Move dw_pcie_setup_rc out of ks_pcie_establish_link() so that ks_pcie_establish_link can be used only to start the link. Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --gi

[PATCH v2 18/21] PCI: keystone: Use ERR_IRQ_STATUS instead of ERR_IRQ_STATUS_RAW to get interrupt status

2018-10-17 Thread Kishon Vijay Abraham I
Use ERR_IRQ_STATUS instead of ERR_IRQ_STATUS_RAW to get interrupt status. ERR_IRQ_STATUS_RAW has the status of the interrupts before masking whereas ERR_IRQ_STATUS has the status of the interrupts after masking. Since all the interrupts are unmasked here, use ERR_IRQ_STATUS. Signed-off-by: Kishon

[PATCH v2 02/21] PCI: keystone: Use quirk to set MRRS for PCI host bridge

2018-10-17 Thread Kishon Vijay Abraham I
Reuse the already existing quirk to set MRRS for PCI host bridge instead of explicitly setting MRRS in ks_pcie_host_init. Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 37 +-- 1 file changed, 15 insertions(+), 22 deletions(-) diff --gi

Re: Fate of ihex2fw tool

2018-10-17 Thread Greg Kroah-Hartman
On Tue, Oct 16, 2018 at 10:36:15PM -0700, Andrey Smirnov wrote: > Everyone: > > Since commit 5620a0d1aacd554ebebcff373e31107bb1ef7769 ("firmware: > delete in-kernel firmware"): > > https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?h=v4.19-rc7&id=5620a0d1aacd554ebebcff373e

[PATCH v2 00/21] PCI: Cleanup pci-keystone driver

2018-10-17 Thread Kishon Vijay Abraham I
The PCIe controller in AM654 uses Synopsys core revision 4.90a and uses the same TI wrapper as used in keystone2 with certain modification. Hence AM654 will use the same pci wrapper driver pci-keystone.c In preparation for adding AM654 support, cleanup pci-keystone driver here. Most of the cleanu

[PATCH v2 17/21] PCI: keystone: Cleanup ks_pcie_link_up()

2018-10-17 Thread Kishon Vijay Abraham I
ks_pcie_link_up() uses registers from the designware core to get the status of the link. Move the register defines to pcie-designware.h and cleanup ks_pcie_link_up(). Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c| 11 +++ drivers/pci/controller/d

[PATCH v2 19/21] PCI: keystone: Add debug error message for all errors

2018-10-17 Thread Kishon Vijay Abraham I
commit 025dd3daeda77f61a280da87ae701 ("PCI: keystone: Add error IRQ handler") added dev_err() message only for ERR_AXI and ERR_FATAL. Add debug error message for ERR_SYS, ERR_NONFATAL, ERR_CORR and ERR_AER here. While at that avoid using ERR_IRQ_STATUS_RAW and use ERR_IRQ_STATUS instead. Signed-o

[PATCH v2 20/21] PCI: keystone: Reorder header file in alphabetical order

2018-10-17 Thread Kishon Vijay Abraham I
No functional change. Reorder header file in alphabetical order. Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/pci/controller/dwc/pci-keystone.c b/drivers/pci/controller/dwc

[PATCH v2 14/21] PCI: keystone: Get number of outbound windows from DT

2018-10-17 Thread Kishon Vijay Abraham I
Instead of having a fixed outbound window count, get the number of outbound windows from device tree. Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 13 +++-- 1 file changed, 11 insertions(+), 2 deletions(-) diff --git a/drivers/pci/controller/dwc/

[PATCH v2 16/21] PCI: keystone: Cleanup set_dbi_mode and get_dbi_mode

2018-10-17 Thread Kishon Vijay Abraham I
No functional change. Use BIT() macro for DBI_CS2 and cleanup set_dbimode and get_dbi_mode Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 12 +++- 1 file changed, 7 insertions(+), 5 deletions(-) diff --git a/drivers/pci/controller/dwc/pci-keystone.

[PATCH v2 21/21] PCI: keystone: Cleanup macros defined in pci-keystone.c

2018-10-17 Thread Kishon Vijay Abraham I
No functional change. Cleanup macros defined in pci-keystone.c by removing unused macros, grouping the macros and aligning it properly. Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 41 +-- 1 file changed, 16 insertions(+), 25 deletions

[PATCH v2 05/21] PCI: keystone: Remove unused argument from ks_dw_pcie_host_init()

2018-10-17 Thread Kishon Vijay Abraham I
No functional change. Remove unused "msi_intc_np" argument from ks_dw_pcie_host_init(). Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone-dw.c | 3 +-- drivers/pci/controller/dwc/pci-keystone.c| 2 +- drivers/pci/controller/dwc/pci-keystone.h| 3 +-- 3 fil

[PATCH v2 04/21] PCI: keystone: Do not initiate link training multiple times

2018-10-17 Thread Kishon Vijay Abraham I
commit 886bc5ceb5cc3ad4b219502d72 ("PCI: designware: Add generic dw_pcie_wait_for_link()") while adding a generic dw_pcie_wait_for_link() performed a special handling (initiate link training multiple times) for keystone which is not required. This also resulted in unncessarily waiting for more time

[PATCH v2 06/21] PCI: keystone: Merge pci-keystone-dw.c and pci-keystone.c

2018-10-17 Thread Kishon Vijay Abraham I
No functional change. Having two different files for keystone PCI driver doesn't serve any purpose. Merge pci-keystone-dw.c and pci-keystone.c into a single pci-keystone.c file and remove pci-keystone.h Signed-off-by: Kishon Vijay Abraham I --- MAINTAINERS | 2

[PATCH v2 07/21] PCI: keystone: Remove redundant platform_set_drvdata

2018-10-17 Thread Kishon Vijay Abraham I
No functional change. Remove redundant platform_set_drvdata invocation in ks_pcie_probe(). Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/pci/controller/dwc/pci-keystone.c b/drivers/pci/controller/

[PATCH v2 11/21] PCI: keystone: Cleanup PHY handling

2018-10-17 Thread Kishon Vijay Abraham I
Cleanup PHY handling by using devm_phy_optional_get to get PHYs if the PHYs are optional, creating a device link between the PHY device and the controller device and disable PHY on error cases here. Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 122 +++

[PATCH v2 13/21] PCI: keystone: Cleanup configuration space access

2018-10-17 Thread Kishon Vijay Abraham I
Cleanup configuration space access by removing ks_pcie_cfg_setup which has an unncessary check of "if (bus == 0)" which will never be the case of *_other_conf() and adding macros for configuring the CFG_SETUP register required for accessing the configuration space of the device. Signed-off-by: Kis

[PATCH v2 01/21] PCI: keystone: Use quirk to limit MRRS for K2G

2018-10-17 Thread Kishon Vijay Abraham I
PCI controller in K2G also has a limitation that memory read request size (MRRS) must not exceed 256 bytes. Use the quirk to limit MRRS (added for K2HK, K2L and K2E) for K2G as well. Signed-off-by: Kishon Vijay Abraham I --- drivers/pci/controller/dwc/pci-keystone.c | 3 +++ 1 file changed, 3 in

[PATCH v2 09/21] dt-bindings: PCI: keystone: Add bindings to get device control module

2018-10-17 Thread Kishon Vijay Abraham I
Add bindings to get device control module which has the device id and vendor id to be configured in the keystone PCIe controller. Signed-off-by: Kishon Vijay Abraham I Reviewed-by: Rob Herring --- Documentation/devicetree/bindings/pci/pci-keystone.txt | 3 +++ 1 file changed, 3 insertions(+) d

Re: [PATCH 1/2] locking/qspinlock_stat: Count instances of nested lock slowpaths

2018-10-17 Thread Peter Zijlstra
On Tue, Oct 16, 2018 at 09:45:06AM -0400, Waiman Long wrote: > Queued spinlock supports up to 4 levels of lock slowpath nesting - > user context, soft IRQ, hard IRQ and NMI. However, we are not sure how > often the nesting happens. So 3 more per-cpu stat counters are added > to track the number of

Re: [PATCH 0/7] drivers: tty: Fix kernel-docs comments

2018-10-17 Thread Tobin C. Harding
On Wed, Oct 17, 2018 at 09:00:26AM +0200, Geert Uytterhoeven wrote: > Hi Tobin, > > Thanks for your series! > > On Wed, Oct 17, 2018 at 1:23 AM Tobin C. Harding wrote: > > My first patch set using kernel.org email address. I've been so careful > > with this one I'm expecting some epic fail :) >

Re: [PATCH] tty: serial: qcom_geni_serial: Don't slow all ports just for kgdb

2018-10-17 Thread msavaliy
On 2018-10-16 02:14, Douglas Anderson wrote: If you turn on CONFIG_KGDB then you'll get CONFIG_CONSOLE_POLL selected. If you have CONFIG_CONSOLE_POLL selected then the GENI serial driver was setting RX_BYTES_PW to 1 for _all_ UART ports. This doesn't seem like such a good idea. Let's only set

Re: [PATCH v3] kernel/hung_task.c: disable on suspend

2018-10-17 Thread Rafael J. Wysocki
On Tue, Oct 16, 2018 at 6:55 PM Vitaly Kuznetsov wrote: > > It is possible to observe hung_task complaints when system goes to > suspend-to-idle state: > > # echo freeze > /sys/power/state > > PM: Syncing filesystems ... done. > Freezing user space processes ... (elapsed 0.001 seconds) done. >

Re: [mm PATCH v3 1/6] mm: Use mm_zero_struct_page from SPARC on all 64b architectures

2018-10-17 Thread Mike Rapoport
On Tue, Oct 16, 2018 at 03:01:11PM -0400, Pavel Tatashin wrote: > > > On 10/15/18 4:26 PM, Alexander Duyck wrote: > > This change makes it so that we use the same approach that was already in > > use on Sparc on all the archtectures that support a 64b long. > > > > This is mostly motivated by th

Re: [PATCH v3 1/2] mtd: spi-nor: add support to non-uniform SFDP SPI NOR flash memories

2018-10-17 Thread Boris Brezillon
On Wed, 17 Oct 2018 09:10:45 +0200 Boris Brezillon wrote: > On Wed, 17 Oct 2018 09:07:24 +0200 > Boris Brezillon wrote: > > > On Wed, 17 Oct 2018 02:07:43 + > > Yogesh Narayan Gaur wrote: > > > > > > > > > Actually there is no entry of s25fs512s in current spi-nor.c file. > > > F

Re: protected pins and debugfs

2018-10-17 Thread Stephen Boyd
Quoting Sodagudi Prasad (2018-10-16 19:00:45) > On 2018-10-10 12:40, Sodagudi Prasad wrote: > > On 2018-10-07 23:04, Stephen Boyd wrote: > >> Quoting Sodagudi Prasad (2018-10-03 05:38:24) > >>> > >>> for (i = 0; i < chip->ngpio; i++, gpio++) { > >>> + label = gpiochip_is_req

Re: [PATCH 4.9 00/71] 4.9.134-stable review

2018-10-17 Thread Amit Pundir
Hi, On Tue, 16 Oct 2018 at 22:52, Greg Kroah-Hartman wrote: > > This is the start of the stable review cycle for the 4.9.134 release. > There are 71 patches in this series, all will be posted as a response > to this one. If anyone has any issues with these being applied, please > let me know. >

Re: [RFC PATCH for 4.21 06/16] cpu_opv: Provide cpu_opv system call (v8)

2018-10-17 Thread Srikar Dronamraju
Hi Mathieu, > +static int do_cpu_opv(struct cpu_op *cpuop, int cpuopcnt, > + struct cpu_opv_vaddr *vaddr_ptrs, int cpu) > +{ > + struct mm_struct *mm = current->mm; > + int ret; > + > +retry: > + if (cpu != raw_smp_processor_id()) { > + ret = push_task_t

Re: [PATCH v3 1/2] mtd: spi-nor: add support to non-uniform SFDP SPI NOR flash memories

2018-10-17 Thread Boris Brezillon
On Wed, 17 Oct 2018 09:10:45 +0200 Boris Brezillon wrote: > On Wed, 17 Oct 2018 09:07:24 +0200 > Boris Brezillon wrote: > > > On Wed, 17 Oct 2018 02:07:43 + > > Yogesh Narayan Gaur wrote: > > > > > > > > > Actually there is no entry of s25fs512s in current spi-nor.c file. > > > F

Re: [PATCH v3 1/2] mtd: spi-nor: add support to non-uniform SFDP SPI NOR flash memories

2018-10-17 Thread Boris Brezillon
On Wed, 17 Oct 2018 09:07:24 +0200 Boris Brezillon wrote: > On Wed, 17 Oct 2018 02:07:43 + > Yogesh Narayan Gaur wrote: > > > > > > Actually there is no entry of s25fs512s in current spi-nor.c file. > > For my connected flash part, jedec ID read points to s25fl512s. I > > have asked my

Re: [PATCH 1/2] mm: thp: relax __GFP_THISNODE for MADV_HUGEPAGE mappings

2018-10-17 Thread Michal Hocko
On Tue 16-10-18 16:16:43, Andrew Morton wrote: > On Tue, 16 Oct 2018 19:11:49 -0400 Andrea Arcangeli > wrote: > > > This was a severe regression > > compared to previous kernels that made important workloads unusable > > and it starts when __GFP_THISNODE was added to THP allocations under > > MA

Re: [PATCH v3 1/2] mtd: spi-nor: add support to non-uniform SFDP SPI NOR flash memories

2018-10-17 Thread Boris Brezillon
On Wed, 17 Oct 2018 02:07:43 + Yogesh Narayan Gaur wrote: > > > Actually there is no entry of s25fs512s in current spi-nor.c file. > For my connected flash part, jedec ID read points to s25fl512s. I > have asked my board team to confirm the name of exact connected flash > part. When I chec

Re: [RFC PATCH] mm, proc: report PR_SET_THP_DISABLE in proc

2018-10-17 Thread Michal Hocko
On Tue 16-10-18 14:24:19, David Rientjes wrote: > On Tue, 16 Oct 2018, Michal Hocko wrote: > > > > I don't understand the point of extending smaps with yet another line. > > > > Because abusing a vma flag part is just wrong. What are you going to do > > when a next bug report states that the fl

Re: [PATCH] Input: synaptics - avoid using uninitialized variable when probing

2018-10-17 Thread Benjamin Tissoires
On Wed, Oct 17, 2018 at 2:14 AM Dmitry Torokhov wrote: > > synaptics_detect() does not check whether sending commands to the > device succeeds and instead relies on getting unique data from the > device. Let's make sure we seed entire buffer with zeroes to make sure > we not use garbage on stack t

[PATCH] Revert "HID: add NOGET quirk for Eaton Ellipse MAX UPS"

2018-10-17 Thread Benjamin Tissoires
This reverts commit 67ddbb3e6568fb1820b2cc45b00c50702b114801. 67ddbb3e656 ("HID: add NOGET quirk for Eaton Ellipse MAX UPS") was reported by Laurent Bigonville. It turns out that a later model Laurent got doesn't need the quirk after all. My take is that Eaton upgraded their firmwares, so we don'

Re: [PATCH 0/7] drivers: tty: Fix kernel-docs comments

2018-10-17 Thread Geert Uytterhoeven
Hi Tobin, Thanks for your series! On Wed, Oct 17, 2018 at 1:23 AM Tobin C. Harding wrote: > My first patch set using kernel.org email address. I've been so careful > with this one I'm expecting some epic fail :) WARNING: Missing Signed-off-by: line by nominal patch author 'Tobin C. Harding '

<    4   5   6   7   8   9