Re: [PATCH v2 2/2] usb: typec: tps6598x: Add OF probe binding

2020-05-09 Thread Martin Kepplinger
From: Bryan O'Donoghue > Adds a MODULE_DEVICE_TABLE() to allow probing of this driver from a DTS > setting. Tested-by: Martin Kepplinger thanks! martin

Re: [PATCH 1/4] fs: btrfs: fix a data race in btrfs_block_group_done()

2020-05-09 Thread Markus Elfring
> To fix this race, the spinlock cache->lock is used to protect the > access to cache->cached in btrfs_block_group_done(). How do you think about to replace this wording by a variant like the following? Thus use the spin lock “cache->lock” to protect the access to the data structure member

Re: [PATCH USB v3 3/5] usb: raw-gadget: fix gadget endpoint selection

2020-05-09 Thread Felipe Balbi
Andrey Konovalov writes: > Currently automatic gadget endpoint selection based on required features > doesn't work. Raw Gadget tries iterating over the list of available > endpoints and finding one that has the right direction and transfer type. > Unfortunately selecting arbitrary gadget

Re: [PATCH] USB: gadget: fix illegal array access in binding with UDC

2020-05-09 Thread Felipe Balbi
Kyungtae Kim writes: > FuzzUSB (a variant of syzkaller) found an illegal array access > using an incorrect index while binding a gadget with UDC. > > Reference: https://www.spinics.net/lists/linux-usb/msg194331.html > > This bug occurs when a size variable used for a buffer > is misused to

Re: linux-next boot error: WARNING: suspicious RCU usage in ipmr_get_table

2020-05-09 Thread Madhuparna Bhowmik
On Sat, May 09, 2020 at 12:59:37PM +0530, Amol Grover wrote: > On Tue, Apr 28, 2020 at 10:28:41AM -0400, Qian Cai wrote: > > > > > > > On Apr 28, 2020, at 10:11 AM, Madhuparna Bhowmik > > > wrote: > > > > > > On Tue, Apr 28, 2020 at 09:56:59AM -0400, Qian Cai wrote: > > >> > > >> > > >>> On

Re: [PATCH] bpfilter: document build requirements for bpfilter_umh

2020-05-09 Thread Masahiro Yamada
On Sat, May 9, 2020 at 1:47 PM Valdis Klētnieks wrote: > > It's not intuitively obvious that bpfilter_umh is a statically linked binary. > Mention the toolchain requirement in the Kconfig help, so people > have an easier time figuring out what's needed. > > Signed-off-by: Valdis Kletnieks >

Re: linux-next: manual merge of the net-next tree with the rdma tree

2020-05-09 Thread Saeed Mahameed
On Fri, 2020-05-08 at 09:35 -0300, Jason Gunthorpe wrote: > On Fri, May 08, 2020 at 01:18:51PM +1000, Stephen Rothwell wrote: > > Hi all, > > > > Today's linux-next merge of the net-next tree got a conflict in: > > > > drivers/net/bonding/bond_main.c > > > > between commits: > > > >

Re: [PATCH 5.6 00/49] 5.6.12-rc1 review

2020-05-09 Thread Naresh Kamboju
On Fri, 8 May 2020 at 18:25, Greg Kroah-Hartman wrote: > > This is the start of the stable review cycle for the 5.6.12 release. > There are 49 patches in this series, all will be posted as a response > to this one. If anyone has any issues with these being applied, please > let me know. > >

Re: WARNING in memtype_reserve

2020-05-09 Thread Greg KH
On Sat, May 09, 2020 at 12:20:14AM -0700, syzbot wrote: > Hello, > > syzbot found the following crash on: > > HEAD commit:d5eeab8d Merge tag 'scsi-fixes' of git://git.kernel.org/pu.. > git tree: upstream > console output: https://syzkaller.appspot.com/x/log.txt?x=1509363210 >

Re: [PATCH v2 1/4] scripts/checkstack.pl: don't display $dre as different entity

2020-05-09 Thread Masahiro Yamada
On Fri, May 8, 2020 at 8:10 PM Maninder Singh wrote: > > currently script prints stack usage for functions > in two ways:($re and $dre) > > dre breaks sorting mechanism. > 0xa00011f26f88 sunxi_mux_clk_setup.isra.0 [vmlinux]:Dynamic (0x140) > .. > 0xa00011f27210 sunxi_divs_clk_setup

Re: [PATCH] staging: rtl8188eu: use usleep_range() for ATIM window size

2020-05-09 Thread Greg KH
On Sat, May 09, 2020 at 03:19:31PM +0800, Qiuhao Li wrote: > According to Documentation/timers/timers-howto.rst, sleeping for small > milliseconds should use usleep_range() instead of msleep(). > > Signed-off-by: Qiuhao Li > --- > drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 3 ++- > 1 file

[PATCH] bpfilter: check if $(CC) can static link in Kconfig

2020-05-09 Thread Masahiro Yamada
On Fedora, linking static libraries requires the glibc-static RPM package, which is not part of the glibc-devel package. CONFIG_CC_CAN_LINK does not check the capability of static linking, so you can enable CONFIG_BPFILTER_UMH, then fail to build. HOSTLD net/bpfilter/bpfilter_umh /usr/bin/ld:

Re: linux-next: manual merge of the net-next tree with the rdma tree

2020-05-09 Thread Saeed Mahameed
On Fri, 2020-05-08 at 13:18 +1000, Stephen Rothwell wrote: > Hi all, > > Today's linux-next merge of the net-next tree got a conflict in: > > drivers/net/bonding/bond_main.c > > between commits: > > ed7d4f023b1a ("bonding: Rename slave_arr to usable_slaves") > c071d91d2a89 ("bonding: Add

Re: [PATCH net] net: broadcom: Imply BROADCOM_PHY for BCMGENET

2020-05-09 Thread Geert Uytterhoeven
Hi Florian, Thanks for your patch! On Sat, May 9, 2020 at 12:32 AM Florian Fainelli wrote: > The GENET controller on the Raspberry Pi 4 (2711) is typically > interfaced with an external Broadcom PHY via a RGMII electrical > interface. To make sure that delays are properly configured at the PHY

Re: [PATCH] perf evsel: Get group fd from CPU0 for system wide event

2020-05-09 Thread Jin, Yao
Hi Jiri, On 5/5/2020 8:03 AM, Jiri Olsa wrote: On Sat, May 02, 2020 at 10:33:59AM +0800, Jin, Yao wrote: SNIP @@ -1461,6 +1461,9 @@ static int get_group_fd(struct evsel *evsel, int cpu, int thread) BUG_ON(!leader->core.fd); fd = FD(leader, cpu, thread); + if (fd == -1

[PATCH] MAINTAINERS: adjust to livepatch .klp.arch removal

2020-05-09 Thread Lukas Bulwahn
Commit 1d05334d2899 ("livepatch: Remove .klp.arch") removed arch/x86/kernel/livepatch.c, but missed to adjust the LIVE PATCHING entry in MAINTAINERS. Since then, ./scripts/get_maintainer.pl --self-test=patterns complains: warning: no file matches F: arch/x86/kernel/livepatch.c So, drop that

Re: linux-next boot error: WARNING: suspicious RCU usage in ipmr_get_table

2020-05-09 Thread Amol Grover
On Tue, Apr 28, 2020 at 10:28:41AM -0400, Qian Cai wrote: > > > > On Apr 28, 2020, at 10:11 AM, Madhuparna Bhowmik > > wrote: > > > > On Tue, Apr 28, 2020 at 09:56:59AM -0400, Qian Cai wrote: > >> > >> > >>> On Apr 28, 2020, at 4:57 AM, Dmitry Vyukov wrote: > net/ipv4/ipmr.c:136

[PATCH net 2/2 RESEND] ipmr: Add lockdep expression to ipmr_for_each_table macro

2020-05-09 Thread Amol Grover
ipmr_for_each_table() uses list_for_each_entry_rcu() for traversing outside of an RCU read-side critical section but under the protection of pernet_ops_rwsem. Hence add the corresponding lockdep expression to silence the following false-positive warning at boot: [0.645292]

[PATCH net 1/2 RESEND] ipmr: Fix RCU list debugging warning

2020-05-09 Thread Amol Grover
ipmr_for_each_table() macro uses list_for_each_entry_rcu() for traversing outside of an RCU read side critical section but under the protection of rtnl_mutex. Hence, add the corresponding lockdep expression to silence the following false-positive warning at boot: [4.319347]

WARNING in memtype_reserve

2020-05-09 Thread syzbot
Hello, syzbot found the following crash on: HEAD commit:d5eeab8d Merge tag 'scsi-fixes' of git://git.kernel.org/pu.. git tree: upstream console output: https://syzkaller.appspot.com/x/log.txt?x=1509363210 kernel config: https://syzkaller.appspot.com/x/.config?x=b0212dbee046bc1f

[PATCH v2 0/2] MIPS: Loongson: Fix some issues of cpu_hwmon.c

2020-05-09 Thread Tiezhu Yang
v2: - Drop the patch "MIPS: Loongson: Add hwmon support for generic CPU" - Reduce possible loop times in do_thermal_timer() Tiezhu Yang (2): MIPS: Loongson: Cleanup cpu_hwmon.c MIPS: Loongson: Reduce possible loop times and add log in do_thermal_timer()

[PATCH v2 2/2] MIPS: Loongson: Reduce possible loop times and add log in do_thermal_timer()

2020-05-09 Thread Tiezhu Yang
Once the temperature of any CPUs is too high, it can power off immediately, no need to check the rest of CPUs, and it is better to print a log before power off, this is useful when analysis the abnormal issues. Signed-off-by: Tiezhu Yang --- v2: - Reduce possible loop times in

[PATCH v2 1/2] MIPS: Loongson: Cleanup cpu_hwmon.c

2020-05-09 Thread Tiezhu Yang
Fix the following checkpatch warnings and errors: ERROR: do not initialise statics to 0 #14: FILE: drivers/platform/mips/cpu_hwmon.c:14: +static int csr_temp_enable = 0; WARNING: Symbolic permissions 'S_IRUGO' are not preferred. Consider using octal permissions '0444'. #60: FILE:

Re: [PATCH] power: reset: ltc2952: remove set variable but unused value

2020-05-09 Thread Markus Elfring
> Fixes gcc '-Wunused-but-set-variable' warning: > drivers/power/reset/ltc2952-poweroff.c:97:16: warning: variable > ‘overruns’ set but not used [-Wunused-but-set-variable] I suggest to improve also this commit message. * Can it be helpful to replace the word “Fixes” by the text “An issue was

Dear Friend,

2020-05-09 Thread Ali Hamadu
Dear Friend, Please i need your kind Assistance. I will be very glad if you can assist me to receive this sum of ( $22. Million US dollars.) into your bank account for the benefit of our both families, reply me if you are ready to receive this fund.

[PATCH v2] f2fs: compress: let lz4 compressor handle output buffer budget properly

2020-05-09 Thread Chao Yu
Commonly, in order to handle lz4 worst compress case, caller should allocate buffer with size of LZ4_compressBound(inputsize) for target compressed data storing, however in this case, if caller didn't allocate enough space, lz4 compressor still can handle output buffer budget properly, and end up

[PATCH 2/3] ARM: dts: stm32: enable l3gd20 on stm32429-disco board

2020-05-09 Thread dillon . minfei
From: dillon min Enable l3gd20 on stm32429-disco board. Signed-off-by: dillon min --- arch/arm/boot/dts/stm32f429-disco.dts | 24 1 file changed, 24 insertions(+) diff --git a/arch/arm/boot/dts/stm32f429-disco.dts b/arch/arm/boot/dts/stm32f429-disco.dts index

[PATCH 3/3] spi: stm32: Add SPI_SIMPLEX_RX, SPI_3WIRE_RX support for stm32f4

2020-05-09 Thread dillon . minfei
From: dillon min in l3gd20 driver startup, there is a setup failed error return from stm32 spi driver " [2.687630] st-gyro-spi spi0.0: supply vdd not found, using dummy regulator [2.696869] st-gyro-spi spi0.0: supply vddio not found, using dummy regulator [2.706707] spi_stm32

[PATCH 0/3] Enable l3gd20 on stm32f429-disco board

2020-05-09 Thread dillon . minfei
From: dillon min This patchset is for enable l3gd20 on stm32f429-disco board has following changes: 1, enable spi5 controller on stm32f429-disco (dts) 2, add spi5 pinmap for stm32f429-disco (dts) 3, add SPI_SIMPLEX_RX, SPI_3WIRE_RX support for stm32f4 dillon min (3): ARM: dts: stm32: Add

[PATCH 1/3] ARM: dts: stm32: Add pin map for spi5 on stm32f429-disco board

2020-05-09 Thread dillon . minfei
From: dillon min This patch adds the pin configuration for ltdc, spi5 controller on stm32f429-disco board. Signed-off-by: dillon min --- arch/arm/boot/dts/stm32f4-pinctrl.dtsi | 17 + 1 file changed, 17 insertions(+) diff --git a/arch/arm/boot/dts/stm32f4-pinctrl.dtsi

Re: [PATCH] mm: vmscan: consistent update to pgsteal and pgscan

2020-05-09 Thread Yafang Shao
On Fri, May 8, 2020 at 9:38 PM Johannes Weiner wrote: > > On Fri, May 08, 2020 at 06:25:14AM -0700, Shakeel Butt wrote: > > On Fri, May 8, 2020 at 3:34 AM Yafang Shao wrote: > > > > > > On Fri, May 8, 2020 at 4:49 AM Shakeel Butt wrote: > > > > > > > > One way to measure the efficiency of

Re: [PATCH 4.4 000/308] 4.4.223-rc2 review

2020-05-09 Thread Greg Kroah-Hartman
On Fri, May 08, 2020 at 02:10:40PM -0700, Guenter Roeck wrote: > On 5/8/20 7:32 AM, Greg Kroah-Hartman wrote: > > This is the start of the stable review cycle for the 4.4.223 release. > > There are 308 patches in this series, all will be posted as a response > > to this one. If anyone has any

[PATCH 4.4 000/306] 4.4.223-rc3 review

2020-05-09 Thread Greg Kroah-Hartman
This is the start of the stable review cycle for the 4.4.223 release. There are 306 patches in this series, all will be posted as a response to this one. If anyone has any issues with these being applied, please let me know. Responses should be made by Mon, 11 May 2020 06:44:14 +. Anything

Re: linux-next boot error: WARNING: suspicious RCU usage in ipmr_get_table

2020-05-09 Thread Amol Grover
On Thu, May 07, 2020 at 06:26:01AM +1000, Stephen Rothwell wrote: > Hi all, > > On Thu, 7 May 2020 06:16:35 +1000 Stephen Rothwell > wrote: > > > > Hi Qian, > > > > On Tue, 28 Apr 2020 09:56:59 -0400 Qian Cai wrote: > > > > > > > On Apr 28, 2020, at 4:57 AM, Dmitry Vyukov wrote: > > > >

[PATCH v2 1/2] serial: lantiq: Make UART's use as console selectable

2020-05-09 Thread Rahul Tanwar
Lantiq UART driver can be used for system console. Add changes to make this driver's use as console selectable/configurable. Signed-off-by: Rahul Tanwar --- drivers/tty/serial/Kconfig | 9 - drivers/tty/serial/lantiq.c | 11 ++- 2 files changed, 18 insertions(+), 2

[PATCH v2 2/2] serial: lantiq: Make driver modular

2020-05-09 Thread Rahul Tanwar
Add changes so Lantiq serial driver can be compiled as a module. Signed-off-by: Rahul Tanwar --- drivers/tty/serial/Kconfig | 4 +++- drivers/tty/serial/lantiq.c | 26 -- 2 files changed, 27 insertions(+), 3 deletions(-) diff --git a/drivers/tty/serial/Kconfig

Re: [PATCH] drm/panel: visionox-rm69299: Add module license

2020-05-09 Thread Randy Dunlap
On 5/8/20 11:30 PM, Jason Yan wrote: > Fix the following build warning: > > WARNING: modpost: missing MODULE_LICENSE() in > drivers/gpu/drm/panel/panel-visionox-rm69299.o > see include/linux/module.h for more information > > Signed-off-by: Jason Yan > --- >

[PATCH 2/3] mm: vmstat: Convert to use DEFINE_SEQ_ATTRIBUTE macro

2020-05-09 Thread Kefeng Wang
Use DEFINE_SEQ_ATTRIBUTE macro to simplify the code. Signed-off-by: Kefeng Wang --- mm/vmstat.c | 32 ++-- 1 file changed, 6 insertions(+), 26 deletions(-) diff --git a/mm/vmstat.c b/mm/vmstat.c index 7f2e87cb7049..35219271796f 100644 --- a/mm/vmstat.c +++

[PATCH 0/3] seq_file: Introduce DEFINE_SEQ_ATTRIBUTE() helper macro

2020-05-09 Thread Kefeng Wang
As discussion in https://lore.kernel.org/lkml/20191129222310.ga3712...@kroah.com/, we could introduce a new helper macro to reduce losts of boilerplate code, vmstat and kprobes is the example which covert to use it, if this is accepted, I will send out more clean ups. Kefeng Wang (3):

[PATCH 3/3] kernel: kprobes: Convert to use DEFINE_SEQ_ATTRIBUTE macro

2020-05-09 Thread Kefeng Wang
Use DEFINE_SEQ_ATTRIBUTE macro to simplify the code. Cc: Anil S Keshavamurthy Cc: "David S. Miller" Cc: Masami Hiramatsu Signed-off-by: Kefeng Wang --- kernel/kprobes.c | 33 ++--- 1 file changed, 6 insertions(+), 27 deletions(-) diff --git a/kernel/kprobes.c

[PATCH 1/3] seq_file: Introduce DEFINE_SEQ_ATTRIBUTE() helper macro

2020-05-09 Thread Kefeng Wang
Introduce DEFINE_SEQ_ATTRIBUTE() helper macro to decrease code duplication. Signed-off-by: Kefeng Wang --- include/linux/seq_file.h | 19 +++ 1 file changed, 19 insertions(+) diff --git a/include/linux/seq_file.h b/include/linux/seq_file.h index 1672cf6f7614..c77869cf7d10

[PATCH] drm/panel: visionox-rm69299: Add module license

2020-05-09 Thread Jason Yan
Fix the following build warning: WARNING: modpost: missing MODULE_LICENSE() in drivers/gpu/drm/panel/panel-visionox-rm69299.o see include/linux/module.h for more information Signed-off-by: Jason Yan --- drivers/gpu/drm/panel/panel-visionox-rm69299.c | 1 + 1 file changed, 1 insertion(+) diff

Re: [EXT] [PATCH 09/15] qed: use new module_firmware_crashed()

2020-05-09 Thread Igor Russkikh
> This makes use of the new module_firmware_crashed() to help > annotate when firmware for device drivers crash. When firmware > crashes devices can sometimes become unresponsive, and recovery > sometimes requires a driver unload / reload and in the worst cases > a reboot. > > Using a taint

[PATCH] drm/amd/amdgpu: remove defined but not used 'crtc_offsets'

2020-05-09 Thread Jason Yan
Fix the following gcc warning: drivers/gpu/drm/amd/amdgpu/gmc_v6_0.c:65:18: warning: ‘crtc_offsets’ defined but not used [-Wunused-const-variable=] static const u32 crtc_offsets[6] = ^~~~ Reported-by: Hulk Robot Signed-off-by: Jason Yan ---

[PATCH -next] leds: blinkm: remove set but not used variable

2020-05-09 Thread Hongbo Yao
Fixes gcc '-Wunused-but-set-variable' warning: drivers/leds/leds-blinkm.c:483:6: warning: variable ‘ret’ set but not used [-Wunused-but-set-variable] int ret; Reported-by: Hulk Robot Signed-off-by: Hongbo Yao --- drivers/leds/leds-blinkm.c | 5 ++--- 1 file changed, 2 insertions(+), 3

Re: [PATCH] net/sonic: Fix some resource leaks in error handling paths

2020-05-09 Thread Markus Elfring
> While at it, rename a label in order to be slightly more informative and > split some too long lines. Would you like to add the tag “Fixes” to the change description? … > +++ b/drivers/net/ethernet/natsemi/macsonic.c > @@ -506,10 +506,14 @@ static int mac_sonic_platform_probe(struct >

[PATCH v2] lib/flex_proportions.c: cleanup __fprop_inc_percpu_max

2020-05-09 Thread Tan Hu
If the given type has fraction smaller than max_frac/FPROP_FRAC_BASE, the code could be modified to call __fprop_inc_percpu() directly and easier to understand. After this patch, fprop_reflect_period_percpu() will be called twice, and quicky return on pl->period == p->period test, so it would not

[PATCH][V2] perf: perf can not parser the backtrace of app with dwarf mode in the 32bit system and 64bit kernel.

2020-05-09 Thread Jiping Ma
Record PC value from regs[15], it should be regs[32] in REGS_ABI_32 mode, which cause perf parser the backtrace failed. Signed-off-by: Jiping Ma --- arch/arm64/kernel/perf_regs.c | 4 1 file changed, 4 insertions(+) diff --git a/arch/arm64/kernel/perf_regs.c

<    1   2   3   4   5   6