[PATCH 1/2] staging: rtl8712: Fixed CamelCase lockRxFF0Filter renamed to lock_rx_ff0_filter

2019-06-11 Thread Deepak Mishra
In process of cleaning up struct _adapter in drv_types.h, lockRxFF0Filter is renamed to to lock_rx_ff0_filter to fix a checkpatch reported issue. Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/usb_intf.c | 2 +- drivers/staging/rtl8712

[PATCH 0/2] staging: rtl8712: cleanup struct _adapter

2019-06-11 Thread Deepak Mishra
In process of cleaning up rtl8712 struct _adapter in drv_types.h I have fixed the camelcasing of lockRxFF0Filter and wkFilterRxFF0 Deepak Mishra (2): staging: rtl8712: Fixed CamelCase lockRxFF0Filter renamed to lock_rx_ff0_filter staging: rtl8712: Fixed CamelCase wkFilterRxFF0 renamed

[PATCH 2/2] staging: rtl8712: Fixed CamelCase wkFilterRxFF0 renamed to wk_filter_rx_ff0

2019-06-11 Thread Deepak Mishra
In process of cleaning up struct _adapter in drv_types.h, wkFilterRxFF0 is renamed to to wk_filter_rx_ff0 to fix a checkpatch reported issue. Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 2 +- drivers/staging/rtl8712/rtl871x_xmit.c | 2 +- drivers/staging

[PATCH v5 4/6] staging: rtl8712: removed unused variables from struct _adapter

2019-06-09 Thread Deepak Mishra
This patch removed following unused member variables from struct _adapter IsrContent, xmitThread, evtThread, recvThread Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 4 1 file changed, 4 deletions(-) diff --git a/drivers/staging/rtl8712/drv_types.h b/drivers

[PATCH v5 6/6] staging: rtl8712: Renamed CamelCase lockRxFF0Filter to lock_rx_ff0_filter

2019-06-09 Thread Deepak Mishra
This patch renames CamelCase variable lockRxFF0Filter to lock_rx_ff0_filter in drv_types.h, usb_intf.c and xmit_linux.c This was reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/usb_intf.c | 2 +- drivers/staging

[PATCH v5 3/6] staging: rtl8712: Fixed CamelCase cmdThread rename to cmd_thread

2019-06-09 Thread Deepak Mishra
This patch renames CamelCase cmdThread to cmd_thread in struct _adapter in drv_types.h and in os_intfs.c This was reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/os_intfs.c | 6 +++--- 2 files changed, 4 insertions

[PATCH v5 2/6] staging: rtl8712: Removed redundant code from function oid_rt_pro_write_register_hdl

2019-06-09 Thread Deepak Mishra
s removed from the structure _adapter Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 1 - drivers/staging/rtl8712/rtl871x_mp_ioctl.c | 5 - 2 files changed, 6 deletions(-) diff --git a/drivers/staging/rtl8712/drv_types.h b/drivers/staging/rtl8712/drv_type

[PATCH v5 5/6] staging: rtl8712: Renamed CamelCase wkFilterRxFF0 to wk_filter_rx_ff0

2019-06-09 Thread Deepak Mishra
This patch renames CamelCase variable wkFilterRxFF0 to wk_filter_rx_ff0 in drv_types.h, rtl871x_xmit.c and xmit_linux.c This was reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 2 +- drivers/staging/rtl8712/rtl871x_xmit.c | 2 +- drivers

[PATCH v5 0/6] staging: rtl8712: cleanup struct _adapter

2019-06-09 Thread Deepak Mishra
CamelCase issue, remove the variables not in use. 5. Fixing of CamelCase of variable blnEnableRxFF0Filter is removed from this patch set as spinning on a random variable for synchronization needs to be fixed separately Deepak Mishra (6): staging: rtl8712: Fixed CamelCase for EepromAddressSize

[PATCH v5 1/6] staging: rtl8712: Fixed CamelCase for EepromAddressSize

2019-06-09 Thread Deepak Mishra
This patch renames CamelCase EepromAddressSizefrom to eeprom_address_size in struct _adapter and in related files drv_types.h, rtl871x_eeprom.c, usb_intf.c This was reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging

[PATCH v4 6/6] staging: rtl8712: Renamed CamelCase lockRxFF0Filter to lock_rx_ff0_filter

2019-06-08 Thread Deepak Mishra
This patch renames CamelCase variable lockRxFF0Filter to lock_rx_ff0_filter in drv_types.h, usb_intf.c and xmit_linux.c This was reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/usb_intf.c | 2 +- drivers/staging

[PATCH v4 5/6] staging: rtl8712: Renamed CamelCase wkFilterRxFF0 to wk_filter_rx_ff0

2019-06-08 Thread Deepak Mishra
This patch renames CamelCase variable wkFilterRxFF0 to wk_filter_rx_ff0 in drv_types.h, rtl871x_xmit.c and xmit_linux.c This was reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 2 +- drivers/staging/rtl8712/rtl871x_xmit.c | 2 +- drivers

[PATCH v4 3/6] staging: rtl8712: Fixed CamelCase cmdThread rename to cmd_thread

2019-06-08 Thread Deepak Mishra
This patch renames CamelCase cmdThread to cmd_thread in struct _adapter in drv_types.h and in os_intfs.c This was reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/os_intfs.c | 6 +++--- 2 files changed, 4 insertions

[PATCH v4 4/6] staging: rtl8712: removed unused variables from struct _adapter

2019-06-08 Thread Deepak Mishra
This patch removed following unused member variables from struct _adapter IsrContent, xmitThread, evtThread, recvThread Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 4 1 file changed, 4 deletions(-) diff --git a/drivers/staging/rtl8712/drv_types.h b/drivers

[PATCH v4 2/6] staging: rtl8712: Removed redundant code from function oid_rt_pro_write_register_hdl

2019-06-08 Thread Deepak Mishra
s removed from the structure _adapter Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 1 - drivers/staging/rtl8712/rtl871x_mp_ioctl.c | 5 - 2 files changed, 6 deletions(-) diff --git a/drivers/staging/rtl8712/drv_types.h b/drivers/staging/rtl8712/drv_type

[PATCH v4 0/6] staging: rtl8712: cleanup struct _adapter

2019-06-08 Thread Deepak Mishra
In process of cleaning up rtl8712 struct _adapter in drv_types.h I have tried to remove some unused variables and redundant lines of code associated with those variables. I have also fixed some CamelCase reported by checkpatch.pl Deepak Mishra (6): staging: rtl8712: Fixed CamelCase

[PATCH v4 1/6] staging: rtl8712: Fixed CamelCase for EepromAddressSize

2019-06-08 Thread Deepak Mishra
This patch renames CamelCase EepromAddressSizefrom to eeprom_address_size in struct _adapter and in related files drv_types.h, rtl871x_eeprom.c, usb_intf.c This was reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging

[PATCH v3 3/4] staging: rtl8712: removed unused variables from struct _adapter

2019-06-03 Thread Deepak Mishra
This patch removed following unused variables from struct _adapter IsrContent, xmitThread, evtThread, recvThread Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 4 1 file changed, 4 deletions(-) diff --git a/drivers/staging/rtl8712/drv_types.h b/drivers/staging

[PATCH v3 0/4] staging: rtl8712: cleanup struct _adapter

2019-06-03 Thread Deepak Mishra
which I am investigating and will clean up in a different patch set. Deepak Mishra (4): staging: rtl8712: Fixed CamelCase for EepromAddressSize and removed unused variable staging: rtl8712: Fixed CamelCase cmdThread rename to cmd_thread staging: rtl8712: removed unused variables from struct

[PATCH v3 1/4] staging: rtl8712: Fixed CamelCase for EepromAddressSize and removed unused variable

2019-06-03 Thread Deepak Mishra
rtl871x_mp_ioctl.c Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 3 +-- drivers/staging/rtl8712/rtl871x_eeprom.c | 6 +++--- drivers/staging/rtl8712/rtl871x_mp_ioctl.c | 5 - drivers/staging/rtl8712/rtl871x_pwrctrl.h | 1 - drivers/staging/rtl8712

[PATCH v3 4/4] staging: rtl8712: Fixed CamelCase wkFilterRxFF0 and lockRxFF0Filter

2019-06-03 Thread Deepak Mishra
and xmit_linux.c as reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 2 +- drivers/staging/rtl8712/rtl871x_xmit.c | 2 +- drivers/staging/rtl8712/usb_intf.c | 2 +- drivers/staging/rtl8712/xmit_linux.c | 6 +++--- 4 files changed, 6 insertions(+), 6

[PATCH v3 2/4] staging: rtl8712: Fixed CamelCase cmdThread rename to cmd_thread

2019-06-03 Thread Deepak Mishra
This patch renames CamelCase cmdThread to cmd_thread in struct _adapter and related files drv_types.h,os_intfs.c CHECK: Avoid CamelCase: Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/os_intfs.c | 6 +++--- 2 files changed, 4 insertions

[PATCH v2 9/9] staging: rtl8712: Fixed CamelCase lockRxFF0Filter

2019-06-02 Thread Deepak Mishra
This patch fixes CamelCase lockRxFF0Filter by renaming to lock_rx_ff0_filter in drv_types.h and related files usb_intf.c and xmit_linux.c This was reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/usb_intf.c | 2

[PATCH v2 8/9] staging: rtl8712: fixed enable_rx_ff0_filter as bool and CamelCase

2019-06-02 Thread Deepak Mishra
...@perches.com Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/rtl871x_cmd.c | 2 +- drivers/staging/rtl8712/xmit_linux.c | 4 ++-- 3 files changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/rtl8712/drv_types.h b/drivers

[PATCH v2 4/9] staging: rtl8712: Fixed CamelCase renames evtThread to evt_thread

2019-06-02 Thread Deepak Mishra
This patch fixes CamelCase renames evtThread to evt_thread in struct _adapter as reported by checkpatch.pl CHECK: Avoid CamelCase: Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8712

[PATCH v2 3/9] staging: rtl8712: Fixed CamelCase cmdThread rename to cmd_thread

2019-06-02 Thread Deepak Mishra
This patch renames CamelCase cmdThread to cmd_thread in struct _adapter and related files drv_types.h,os_intfs.c CHECK: Avoid CamelCase: Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/os_intfs.c | 6 +++--- 2 files changed, 4 insertions

[PATCH v2 1/9] staging: rtl8712: Fixed CamelCase rename ImrContent to imr_content

2019-06-02 Thread Deepak Mishra
This patch renames CamelCase ImrContent to imr_content in struct _adapter and related files drv_types.h, rtl871x_mp_ioctl.c, rtl871x_pwrctrl.h CHECK: Avoid CamelCase: Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 2 +- drivers/staging/rtl8712

[PATCH v2 7/9] staging: rtl8712: Fixed CamelCase wkFilterRxFF0 to wk_filter_rx_ff0 in

2019-06-02 Thread Deepak Mishra
This patch renames CamelCase variable wkFilterRxFF0 to wk_filter_rx_ff0 in drv_types.h and related files rtl871x_xmit.c and xmit_linux.c as reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 2 +- drivers/staging/rtl8712/rtl871x_xmit.c | 2

[PATCH v2 2/9] staging: rtl8712: Fixed CamelCase EepromAddressSize rename to eeprom_address_size

2019-06-02 Thread Deepak Mishra
This patch renames CamelCase EepromAddressSizefrom to eeprom_address_size in struct _adapter and in related files drv_types.h, rtl871x_eeprom.c, usb_intf.c CHECK: Avoid CamelCase: Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712

[PATCH v2 0/9] staging: rtl8712: Fixed CamelCase in struct _adapter

2019-06-02 Thread Deepak Mishra
This patchset fixes CamelCase checks in struct _adapter in drv_types.h and in files where struct _adapter is used by renaming the variables without camel case. These check were reported by checkpatch.pl This patch also changes type of enable_rx_ff0_filter as bool Deepak Mishra (9): staging

[PATCH v2 5/9] staging: rtl8712: Fixed CamelCase renames IsrContent to isr_content

2019-06-02 Thread Deepak Mishra
This patch fixes CamelCase IsrContent to isr_content as suggested by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8712/drv_types.h b/drivers/staging/rtl8712/drv_types.h

[PATCH v2 6/9] staging: rtl8712: Fixed CamelCase renames xmitThread and recvThread

2019-06-02 Thread Deepak Mishra
This patch fixes CamelCase as reported by checkpatch.pl xmitThread renamed to xmit_thread recvThread renamed to recv_thread Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8712

Re: [PATCH 8/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

2019-06-02 Thread Deepak Mishra
On Sat, Jun 01, 2019 at 12:26:02PM -0700, Joe Perches wrote: > On Sun, 2019-06-02 at 00:13 +0530, Deepak Mishra wrote: > > This patch fixes CamelCase blnEnableRxFF0Filter by renaming it > > to bln_enable_rx_ff0_filter in drv_types.h and related files rtl871x_cmd.c > > xmit_

[PATCH 2/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

2019-06-01 Thread Deepak Mishra
This patch fixes CamelCase ImrContent from struct _adapter and in related files drv_types.h, rtl871x_eeprom.c, usb_intf.c CHECK: Avoid CamelCase: Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/rtl871x_eeprom.c | 6 +++--- drivers

[PATCH 0/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

2019-06-01 Thread Deepak Mishra
This patchset fixes CamelCase checks in struct _adapter in drv_types.h and in files where struct _adapter is used by renaming the variables without camel case. These check were reported by checkpatch.pl Deepak Mishra (8): staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

[PATCH 4/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

2019-06-01 Thread Deepak Mishra
This patch fixes CamelCase evtThread in struct _adapter as reported by checkpatch.pl CHECK: Avoid CamelCase: Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8712/drv_types.h b/drivers

[PATCH 6/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

2019-06-01 Thread Deepak Mishra
This patch fixes CamelCase as reported by checkpatch.pl xmitThread renamed to xmit_thread recvThread renamed to recv_thread Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8712

[PATCH 8/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

2019-06-01 Thread Deepak Mishra
This patch fixes CamelCase blnEnableRxFF0Filter by renaming it to bln_enable_rx_ff0_filter in drv_types.h and related files rtl871x_cmd.c xmit_linux.c It was reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712

[PATCH 1/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

2019-06-01 Thread Deepak Mishra
This patch fixes CamelCase ImrContent from struct _adapter and in related files drv_types.h, rtl871x_mp_ioctl.c, rtl871x_pwrctrl.h CHECK: Avoid CamelCase: Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 2 +- drivers/staging/rtl8712/rtl871x_mp_ioctl.c | 2

[PATCH 7/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

2019-06-01 Thread Deepak Mishra
This patch renames CamelCase variable wkFilterRxFF0 to wk_filter_rx_ff0 in drv_types.h and related files rtl871x_xmit.c and xmit_linux.c as reported by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h| 2 +- drivers/staging/rtl8712/rtl871x_xmit.c | 2

[PATCH 5/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

2019-06-01 Thread Deepak Mishra
This patch fixes CamelCase IsrContent to isr_content as suggested by checkpatch.pl Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8712/drv_types.h b/drivers/staging/rtl8712/drv_types.h

[PATCH 3/8] staging: rtl8712: Fixed CamelCase in struct _adapter from drv_types.h

2019-06-01 Thread Deepak Mishra
This patch fixes CamelCase cmdThread from struct _adapter and in related files drv_types.h,os_intfs.c CHECK: Avoid CamelCase: Signed-off-by: Deepak Mishra --- drivers/staging/rtl8712/drv_types.h | 2 +- drivers/staging/rtl8712/os_intfs.c | 6 +++--- 2 files changed, 4 insertions(+), 4