Re: [RFC][PATCH] nameing reserved pages [1/3]

2005-04-20 Thread KAMEZAWA Hiroyuki
Hi! Pavel Machek wrote: ~ missing e? Oh, it's typo :(. thanks! + Reserved_At_Boot, + Max_Reserved_Types, + Page_Invalid = 0xff +}; You certainly use unusual naming convention here. Could we get reserved_at_boot instead? (I.e. all lowercase). Okay. +static inl

Re: [RFC][PATCH] nameing reserved pages [0/3]

2005-04-20 Thread Kamezawa Hiroyuki
Arjan van de Ven wrote: On Wed, 2005-04-20 at 23:15 +0900, Kamezawa Hiroyuki wrote: MCA's probably shouldn't set PG_reserved; I don't see why they should. They could just steal the page and "leak" it. Actually leaked pages cannot be hot-removed/replaced. So we have

Re: [RFC][PATCH] nameing reserved pages [0/3]

2005-04-20 Thread Kamezawa Hiroyuki
Arjan van de Ven wrote: For example, Memory Hotplug can ignore (a). Memory Hotplug can also use page_is_ram(). Yes. we can use page_is_ram() for finding (a)memory hole. But I'd like to catch other removable PG_reserved pages like (d)Isorated by MCA (e)used by perfmon and some of (b) used b

[RFC][PATCH] nameing reserved pages [3/3]

2005-04-20 Thread KAMEZAWA Hiroyuki
showing state of memmap by /dev/memstate. -- Kame /dev/memstate shows status of memmap. A user can read state of a page as a byte. This feature is useful for Memory-hotplug and other stuffs, where we have to investigate for what a page is. Signed-off-by: KAMEZAWA Hiroyuki <[EMAIL PROTEC

[RFC][PATCH] nameing reserved pages [2/3]

2005-04-20 Thread KAMEZAWA Hiroyuki
naming reserved-at-boot page. -- Kame Nameing Reserved at boot pages as Reserved_At_Boot. Signed-off-by: KAMEZAWA Hiroyuki <[EMAIL PROTECTED]> --- linux-2.6.12-rc2-kamezawa/mm/page_alloc.c |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) diff -puN mm/page_alloc.c~mark_reserve

[RFC][PATCH] nameing reserved pages [1/3]

2005-04-20 Thread KAMEZAWA Hiroyuki
ng patch. Signed-off-by: KAMEZAWA Hiroyuki <[EMAIL PROTECTED]> --- linux-2.6.12-rc2-kamezawa/include/linux/mm.h | 31 +++ 1 files changed, 31 insertions(+) diff -puN include/linux/mm.h~name_reserved include/linux/mm.h --- linux-2.6.12-rc2/include/linux/mm.h~name_reserve

[RFC][PATCH] nameing reserved pages [0/3]

2005-04-20 Thread KAMEZAWA Hiroyuki
Hi, There are several types of PG_reserved pages, (a) Memory Hole (b) Used by Kernel (c) Set by drivers (d) Isorated by MCA (e) used by perfmon etc I think it's useful to distinguish many types of PG_reserved pages. For example, Memory Hotplug can ignore (a). 2 patches [1/3][2/3] are for naming

Re: [PATCH] 2/2 Prezeroing large blocks of pages during allocation Version 4

2005-03-08 Thread KAMEZAWA Hiroyuki
Mel Gorman wrote: Now, 5bits per MAX_ORDER pages. I think it is simpler to use "char[]" for representing type of memory alloc type than bitmap. Possibly, but it would also use up that bit more space. That map could be condensed to 3 bits but would make it that bit (no pun) more comple

Re: [PATCH] 2/2 Prezeroing large blocks of pages during allocation Version 4

2005-03-07 Thread KAMEZAWA Hiroyuki
Hi, Mel Gorman wrote: +#define BITS_PER_ALLOC_TYPE 5 #define ALLOC_KERNNORCLM 0 #define ALLOC_KERNRCLM 1 #define ALLOC_USERRCLM 2 #define ALLOC_FALLBACK 3 +#define ALLOC_USERZERO 4 +#define ALLOC_KERNZERO 5 Now, 5bits per MAX_ORDER pages. I think it is simpler to use "char[]" for representing type

<    3   4   5   6   7   8