Re: [PATCH v4] staging: nrf24: add new driver for 2.4GHz radio transceiver

2019-02-22 Thread Marcin Ciupak
On Tue, Feb 19, 2019 at 11:20:10AM +0100, Greg Kroah-Hartman wrote: > On Wed, Feb 13, 2019 at 08:40:35PM +0100, Marcin Ciupak wrote: > > This patch adds driver for Nordic Semiconductor nRF24L01+ radio > > transceiver. > > > > Signed-off-by: Marcin Ciupak > > -

[PATCH v4] staging: nrf24: add new driver for 2.4GHz radio transceiver

2019-02-13 Thread Marcin Ciupak
This patch adds driver for Nordic Semiconductor nRF24L01+ radio transceiver. Signed-off-by: Marcin Ciupak --- Changes in v2: - add terminating newlines to all logging formats Changes in v3: - patch subject - comments cleanup - goto labels cleanup - scnprintf bugfix

Re: [PATCH v3] staging: nrf24: add new driver for 2.4GHz radio transceiver

2018-10-19 Thread Marcin Ciupak
On Fri, Oct 19, 2018 at 09:58:01AM +0300, Dan Carpenter wrote: > Hi Marcin, > > Thank you for the patch! Perhaps something to improve: > > url: > https://github.com/0day-ci/linux/commits/Marcin-Ciupak/staging-nrf24-add-new-driver-for-2-4GHz-radio-transceiver/20181018-

[PATCH v3] staging: nrf24: add new driver for 2.4GHz radio transceiver

2018-10-17 Thread Marcin Ciupak
This patch adds driver for Nordic Semiconductor nRF24L01+ radio transceiver. Signed-off-by: Marcin Ciupak --- Changes in v2: - add terminating newlines to all logging formats Changes in v3: - patch subject - comments cleanup - goto labels cleanup - scnprintf bugfix

Re: [PATCH v2] staging: add nrf24 driver

2018-10-16 Thread Marcin Ciupak
On Tue, Oct 16, 2018 at 02:41:50PM +0300, Dan Carpenter wrote: > When we add drivers, can we use the new subsystem prefix for the driver? > In other words: > > [PATCH] staging: nrf24: Add new driver for 2.4Ghz radio transceiver > Sure. > This driver seems basically OK to me. I don't think you ne

[PATCH v2] staging: add nrf24 driver

2018-10-16 Thread Marcin Ciupak
This patch adds driver for Nordic Semiconductor nRF24L01+ radio module. Signed-off-by: Marcin Ciupak --- Changes in v2: - add terminating newlines to all logging formats drivers/staging/Kconfig | 2 + drivers/staging/Makefile | 1 + drivers

[PATCH] staging: add nrf24 driver

2018-10-15 Thread Marcin Ciupak
This patch adds driver for Nordic Semiconductor nRF24L01+ radio module. Signed-off-by: Marcin Ciupak --- drivers/staging/Kconfig | 2 + drivers/staging/Makefile | 1 + drivers/staging/nrf24/Kconfig | 16 + drivers/staging/nrf24

[PATCH 2/2] staging: pi433: fix naming when more than one radio is used

2017-11-20 Thread Marcin Ciupak
When using more than one hardware radio module pi433_probe fails as the same name is used for all modules. Create unique name by adding minor number to the device name. Signed-off-by: Marcin Ciupak --- drivers/staging/pi433/pi433_if.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions

[PATCH 1/2] staging: pi433: fix (NULL device *) in log message

2017-11-20 Thread Marcin Ciupak
(NULL device *) is printed in log message in pi433_probe and pi433_get_minor functions due to device->dev being used prior to call to device_create function. Signed-off-by: Marcin Ciupak --- drivers/staging/pi433/pi433_if.c | 26 +- 1 file changed, 13 insertions(+),

[PATCH 0/2] staging: pi433: fix logging and naming issues

2017-11-20 Thread Marcin Ciupak
These patches fix messages logging and device naming issues when probing for new radio module. Those two changes are send as one patchset since both modify the same part of code (second patch depends on first one) Marcin Ciupak (2): staging: pi433: fix (NULL device *) in log message staging

[PATCH 5/5] staging: pi433: rf69.c style fix - space before asterisk

2017-10-11 Thread Marcin Ciupak
This patch fixes the following checkpatch.pl error: ERROR: "(foo*)" should be "(foo *)" in rf69.c file as requested by TODO file. Additionally some style warnings remain valid here and could be fixed by another patch. Signed-off-by: Marcin Ciupak --- drivers/staging/pi

[PATCH 4/5] staging: pi433: rf69.c style fix - code indent should use tabs

2017-10-11 Thread Marcin Ciupak
This patch fixes the following checkpatch.pl error: ERROR: code indent should use tabs where possible in rf69.c file as requested by TODO file. Additionally some style warnings remain valid here and could be fixed by another patch. Signed-off-by: Marcin Ciupak --- drivers/staging/pi433/rf69

[PATCH 3/5] staging: pi433: rf69.c style fix - spaces before/after

2017-10-11 Thread Marcin Ciupak
tx:VxV) ERROR: space required before the open parenthesis '(' in rf69.c file as requested by TODO file. Additionally some style warnings remain valid here and could be fixed by another patch. Signed-off-by: Marcin Ciupak --- drivers/staging/pi433/rf69.c | 154 +---

[PATCH 2/5] staging: pi433: rf69.c style fix - spaces required around

2017-10-11 Thread Marcin Ciupak
style warnings remain valid here and could be fixed by another patch. Signed-off-by: Marcin Ciupak --- drivers/staging/pi433/rf69.c | 26 -- 1 file changed, 16 insertions(+), 10 deletions(-) diff --git a/drivers/staging/pi433/rf69.c b/drivers/staging/pi433/rf69.c index

[PATCH 1/5] staging: pi433: rf69.c style fix - trailing statements

2017-10-11 Thread Marcin Ciupak
some style warnings remain valid here and could be fixed by another patch. Signed-off-by: Marcin Ciupak --- drivers/staging/pi433/rf69.c | 58 +++- 1 file changed, 41 insertions(+), 17 deletions(-) diff --git a/drivers/staging/pi433/rf69.c b/drivers/staging/

[PATCH 0/5] staging: pi433: rf69.c coding style errors cleanup

2017-10-11 Thread Marcin Ciupak
sis ')' ERROR: space required after that ',' (ctx:VxV) ERROR: space required before the open parenthesis '(' ERROR: code indent should use tabs where possible ERROR: "(foo*)" should be "(foo *)" Marcin Ciupak (5): staging: pi433: rf69.c style fix - t

[PATCH v2] staging: pi433: replace INVALID_PARAM macro with inline code

2017-08-17 Thread Marcin Ciupak
nd therefore this macro is replaced by inline code. Additionally following 3 minor issues: ERROR: code indent should use tabs where possible ERROR: spaces required around that '!=' (ctx:VxV) ERROR: space prohibited before that close parenthesis ')' were fiexed inline. Signed-

Re: [PATCH] staginig: pi433: replace INVALID_PARAM macro with inline code

2017-08-17 Thread Marcin Ciupak
There is a typo in patch subject. Please drop this patch. I will send v2 with corrected subject. Thanks, Marcin

[PATCH] staginig: pi433: replace INVALID_PARAM macro with inline code

2017-08-17 Thread Marcin Ciupak
nd therefore this macro is replaced by inline code. Additionally following 3 minor issues: ERROR: code indent should use tabs where possible ERROR: spaces required around that '!=' (ctx:VxV) ERROR: space prohibited before that close parenthesis ')' were fiexed inline. Signe

[PATCH 3/3] staging: pi433: rf69.c style fix - spaces open brace

2017-08-10 Thread Marcin Ciupak
This patch fixes the following checkpatch.pl error: ERROR: space required before the open brace '{' in rf69.c file as requested by TODO file. Signed-off-by: Marcin Ciupak --- drivers/staging/pi433/rf69.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/sta

[PATCH 2/3] staging: pi433: rf69.c style fix - else close brace

2017-08-10 Thread Marcin Ciupak
This patch fixes the following checkpatch.pl error: ERROR: else should follow close brace '}' in rf69.c file as requested by TODO file. Signed-off-by: Marcin Ciupak --- drivers/staging/pi433/rf69.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/sta

[PATCH 1/3] staging: pi433: rf69.c style fix - that open brace

2017-08-10 Thread Marcin Ciupak
some style warnings remain valid here and could be fixed by another patch. Signed-off-by: Marcin Ciupak --- drivers/staging/pi433/rf69.c | 33 +++-- 1 file changed, 11 insertions(+), 22 deletions(-) diff --git a/drivers/staging/pi433/rf69.c b/drivers/staging/pi433/rf

[PATCH 0/3] staging: pi433: rf69.c style errors fixes - braces

2017-08-10 Thread Marcin Ciupak
'}' ERROR: space required before the open brace '{' Marcin Ciupak (3): staging: pi433: rf69.c style fix - that open brace staging: pi433: rf69.c style fix - else close brace staging: pi433: rf69.c style fix - spaces open brace drivers/stagi

[PATCH] staging: pi433: style fix - space after asterisk

2017-08-08 Thread Marcin Ciupak
lid here and could be fixed by another patch. Signed-off-by: Marcin Ciupak --- drivers/staging/pi433/rf69.c | 2 +- drivers/staging/pi433/rf69.h | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/pi433/rf69.c b/drivers/staging/pi433/rf69.c index f83523e3395d..9f4

Re: [PATCH v2] staging: lustre: replace simple_strtoul with kstrtoint

2017-07-27 Thread Marcin Ciupak
I did test it and not everything works as expected. I need to reconsider that change. Please drop this patch. Thanks, Marcin P.S. Sorry for late (sic!) response. On Fri, Apr 14, 2017 at 10:16:31AM +0200, Greg Kroah-Hartman wrote: > On Tue, Mar 21, 2017 at 01:46:09PM +0100, Marcin Ciupak wr

[PATCH v2] staging: lustre: replace simple_strtoul with kstrtoint

2017-03-21 Thread Marcin Ciupak
Replace simple_strtoul with kstrtoint. simple_strtoul is marked for obsoletion as reported by checkpatch.pl Signed-off-by: Marcin Ciupak --- v2: -improving kstrtoint error handling -updating commit message drivers/staging/lustre/lustre/obdclass/obd_mount.c | 16

Re: [PATCH] staging: lustre: replace simple_strtoul with kstrtoint

2017-03-12 Thread Marcin Ciupak
On Sun, Mar 12, 2017 at 02:36:47PM +0100, Greg Kroah-Hartman wrote: > On Thu, Mar 09, 2017 at 03:53:00PM +0100, Marcin Ciupak wrote: > > Replace simple_strtoul with kstrtoint. > > Why? Because > > simple_strtoul is marked for obsoletion. as reported by checkpatch.pl. &

[PATCH] staging: lustre: replace simple_strtoul with kstrtoint

2017-03-09 Thread Marcin Ciupak
Replace simple_strtoul with kstrtoint. simple_strtoul is marked for obsoletion. Signed-off-by: Marcin Ciupak --- drivers/staging/lustre/lustre/obdclass/obd_mount.c | 20 1 file changed, 16 insertions(+), 4 deletions(-) diff --git a/drivers/staging/lustre/lustre/obdclass

Re: [PATCH] staging: speakup: replace simple_strtoul with kstrtou8

2017-03-03 Thread Marcin Ciupak
On Thu, Mar 02, 2017 at 04:17:12PM +0100, Samuel Thibault wrote: > Marcin Ciupak, on jeu. 02 mars 2017 15:28:23 +0100, wrote: > > - int val; > > + int ret; > > > > - val = simple_strtoul(skip_spaces(start), &start, 10); > > + ret = kstrtou8(skip_space

[PATCH] staging: speakup: replace simple_strtoul with kstrtou8

2017-03-02 Thread Marcin Ciupak
Replace simple_strtoul with kstrtou8. simple_strtoul is marked for obsoletion. Signed-off-by: Marcin Ciupak --- drivers/staging/speakup/varhandlers.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/speakup/varhandlers.c b/drivers/staging/speakup