Re: [PATCH] kunit: tool: simplify kconfig is_subset_of() logic

2021-02-05 Thread Brendan Higgins
On Tue, Dec 8, 2020 at 3:21 PM Daniel Latypov wrote: > > Don't use an O(nm) algorithm* and make it more readable by using a dict. > > *Most obviously, it does a nested for-loop over the entire other config. > A bit more subtle, it calls .entries(), which constructs a set from the > list for _every

Re: [PATCH] kunit: tool: simplify kconfig is_subset_of() logic

2020-12-08 Thread David Gow
On Wed, Dec 9, 2020 at 7:21 AM Daniel Latypov wrote: > > Don't use an O(nm) algorithm* and make it more readable by using a dict. > > *Most obviously, it does a nested for-loop over the entire other config. > A bit more subtle, it calls .entries(), which constructs a set from the > list for _every

[PATCH] kunit: tool: simplify kconfig is_subset_of() logic

2020-12-08 Thread Daniel Latypov
Don't use an O(nm) algorithm* and make it more readable by using a dict. *Most obviously, it does a nested for-loop over the entire other config. A bit more subtle, it calls .entries(), which constructs a set from the list for _every_ outer iteration. Signed-off-by: Daniel Latypov --- tools/tes