Re: [PATCH 0/3] mm: rename confusing function names

2013-02-08 Thread Robin Holt
> > static unsigned int nr_free_zone_pages(int offset) > > { > > ... > > unsigned int sum = 0; > > ... > > return sum; > > } > > > > How long will it be until these things start exploding from > > sums-of-zones which exceed 16TB? > > > > You mean overflow? Hmm.. it might

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-08 Thread Robin Holt
static unsigned int nr_free_zone_pages(int offset) { ... unsigned int sum = 0; ... return sum; } How long will it be until these things start exploding from sums-of-zones which exceed 16TB? You mean overflow? Hmm.. it might happens. Change the sum to

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Andrew Morton
On Wed, 06 Feb 2013 09:34:16 +0800 Zhang Yanfei wrote: > > > > > > hm, > > > > static unsigned int nr_free_zone_pages(int offset) > > { > > ... > > unsigned int sum = 0; > > ... > > return sum; > > } > > > > How long will it be until these things start exploding from > >

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Zhang Yanfei
于 2013年02月06日 09:20, Andrew Morton 写道: > On Wed, 06 Feb 2013 09:06:05 +0800 > Zhang Yanfei wrote: > >> So could I rename the functions to the names like >> nr_available_buffer_high_pages >> And accurately document them with code comments just as you suggested. > > gee. "available" implies

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Andrew Morton
On Wed, 06 Feb 2013 09:06:05 +0800 Zhang Yanfei wrote: > So could I rename the functions to the names like > nr_available_buffer_high_pages > And accurately document them with code comments just as you suggested. gee. "available" implies "available for you to allocate". It has the same

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Zhang Yanfei
于 2013年02月06日 06:13, Andrew Morton 写道: > On Tue, 5 Feb 2013 14:26:40 -0500 > Johannes Weiner wrote: > >> On Wed, Feb 06, 2013 at 01:09:55AM +0800, Zhang Yanfei wrote: >>> Function nr_free_zone_pages, nr_free_buffer_pages and >>> nr_free_pagecache_pages >>> are horribly badly named, they count

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Andrew Morton
On Tue, 5 Feb 2013 14:26:40 -0500 Johannes Weiner wrote: > On Wed, Feb 06, 2013 at 01:09:55AM +0800, Zhang Yanfei wrote: > > Function nr_free_zone_pages, nr_free_buffer_pages and > > nr_free_pagecache_pages > > are horribly badly named, they count present_pages - pages_high within zones > >

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Johannes Weiner
On Wed, Feb 06, 2013 at 01:09:55AM +0800, Zhang Yanfei wrote: > Function nr_free_zone_pages, nr_free_buffer_pages and nr_free_pagecache_pages > are horribly badly named, they count present_pages - pages_high within zones > instead of free pages, so why not rename them to reasonable names, not >

[PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Zhang Yanfei
Function nr_free_zone_pages, nr_free_buffer_pages and nr_free_pagecache_pages are horribly badly named, they count present_pages - pages_high within zones instead of free pages, so why not rename them to reasonable names, not cofusing people. patch2 and patch3 are based on patch1. So please apply

[PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Zhang Yanfei
Function nr_free_zone_pages, nr_free_buffer_pages and nr_free_pagecache_pages are horribly badly named, they count present_pages - pages_high within zones instead of free pages, so why not rename them to reasonable names, not cofusing people. patch2 and patch3 are based on patch1. So please apply

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Johannes Weiner
On Wed, Feb 06, 2013 at 01:09:55AM +0800, Zhang Yanfei wrote: Function nr_free_zone_pages, nr_free_buffer_pages and nr_free_pagecache_pages are horribly badly named, they count present_pages - pages_high within zones instead of free pages, so why not rename them to reasonable names, not

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Andrew Morton
On Tue, 5 Feb 2013 14:26:40 -0500 Johannes Weiner han...@cmpxchg.org wrote: On Wed, Feb 06, 2013 at 01:09:55AM +0800, Zhang Yanfei wrote: Function nr_free_zone_pages, nr_free_buffer_pages and nr_free_pagecache_pages are horribly badly named, they count present_pages - pages_high within

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Zhang Yanfei
于 2013年02月06日 06:13, Andrew Morton 写道: On Tue, 5 Feb 2013 14:26:40 -0500 Johannes Weiner han...@cmpxchg.org wrote: On Wed, Feb 06, 2013 at 01:09:55AM +0800, Zhang Yanfei wrote: Function nr_free_zone_pages, nr_free_buffer_pages and nr_free_pagecache_pages are horribly badly named, they

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Andrew Morton
On Wed, 06 Feb 2013 09:06:05 +0800 Zhang Yanfei zhangyan...@cn.fujitsu.com wrote: So could I rename the functions to the names like nr_available_buffer_high_pages And accurately document them with code comments just as you suggested. gee. available implies available for you to allocate. It

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Zhang Yanfei
于 2013年02月06日 09:20, Andrew Morton 写道: On Wed, 06 Feb 2013 09:06:05 +0800 Zhang Yanfei zhangyan...@cn.fujitsu.com wrote: So could I rename the functions to the names like nr_available_buffer_high_pages And accurately document them with code comments just as you suggested. gee. available

Re: [PATCH 0/3] mm: rename confusing function names

2013-02-05 Thread Andrew Morton
On Wed, 06 Feb 2013 09:34:16 +0800 Zhang Yanfei zhangyan...@cn.fujitsu.com wrote: hm, static unsigned int nr_free_zone_pages(int offset) { ... unsigned int sum = 0; ... return sum; } How long will it be until these things start exploding from