Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-05 Thread Ian Kent
On Wed, 2014-11-05 at 15:20 -0800, Joe Perches wrote: > > > But idea of using pr_xxx() and pr_fmt() (actually that's too open to > > name clashes so it would need to be named something like autofs_pr_fmt() > > anyway) looks like it results in less readable code so I'd really prefer > > not to do

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-05 Thread Joe Perches
On Thu, 2014-11-06 at 07:02 +0800, Ian Kent wrote: > On Mon, 2014-11-03 at 06:33 -0800, Joe Perches wrote: > > > > That's fine. I left out the trailing semicolon/space. > > The pr_fmt could be something like: > > #define pr_fmt(fmt) KBUILD_MODNAME ":%d:%s: " fmt, current->pid, __func__ > > or

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-05 Thread Ian Kent
On Mon, 2014-11-03 at 06:33 -0800, Joe Perches wrote: > > That's fine. I left out the trailing semicolon/space. > The pr_fmt could be something like: > #define pr_fmt(fmt) KBUILD_MODNAME ":%d:%s: " fmt, current->pid, __func__ > or add a "pid:" descriptor prefix if you like too: > #define

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-05 Thread Ian Kent
On Mon, 2014-11-03 at 06:33 -0800, Joe Perches wrote: That's fine. I left out the trailing semicolon/space. The pr_fmt could be something like: #define pr_fmt(fmt) KBUILD_MODNAME :%d:%s: fmt, current-pid, __func__ or add a pid: descriptor prefix if you like too: #define pr_fmt(fmt)

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-05 Thread Joe Perches
On Thu, 2014-11-06 at 07:02 +0800, Ian Kent wrote: On Mon, 2014-11-03 at 06:33 -0800, Joe Perches wrote: That's fine. I left out the trailing semicolon/space. The pr_fmt could be something like: #define pr_fmt(fmt) KBUILD_MODNAME :%d:%s: fmt, current-pid, __func__ or add a pid:

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-05 Thread Ian Kent
On Wed, 2014-11-05 at 15:20 -0800, Joe Perches wrote: But idea of using pr_xxx() and pr_fmt() (actually that's too open to name clashes so it would need to be named something like autofs_pr_fmt() anyway) looks like it results in less readable code so I'd really prefer not to do that.

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-03 Thread Joe Perches
On Mon, 2014-11-03 at 17:20 +0800, Ian Kent wrote: > On Mon, 2014-11-03 at 00:25 -0800, Joe Perches wrote: > > On Mon, 2014-11-03 at 16:12 +0800, Ian Kent wrote: > > > Use the AUTOFS_*() print defines instead of raw printks. Hi again Ian > > It's probably better to simply use > > #define

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-03 Thread Ian Kent
On Mon, 2014-11-03 at 00:25 -0800, Joe Perches wrote: > On Mon, 2014-11-03 at 16:12 +0800, Ian Kent wrote: > > Use the AUTOFS_*() print defines instead of raw printks. > > Please check the output of these conversions. > > For instance: > > > diff --git a/fs/autofs4/waitq.c b/fs/autofs4/waitq.c

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-03 Thread Joe Perches
On Mon, 2014-11-03 at 16:12 +0800, Ian Kent wrote: > Use the AUTOFS_*() print defines instead of raw printks. Please check the output of these conversions. For instance: > diff --git a/fs/autofs4/waitq.c b/fs/autofs4/waitq.c [] > @@ -162,7 +162,7 @@ static void autofs4_notify_daemon(struct

[PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-03 Thread Ian Kent
Use the AUTOFS_*() print defines instead of raw printks. Signed-off-by: Ian Kent --- fs/autofs4/inode.c | 13 +++-- fs/autofs4/waitq.c |2 +- 2 files changed, 8 insertions(+), 7 deletions(-) diff --git a/fs/autofs4/inode.c b/fs/autofs4/inode.c index 80389af..7849591 100644 ---

[PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-03 Thread Ian Kent
Use the AUTOFS_*() print defines instead of raw printks. Signed-off-by: Ian Kent ra...@themaw.net --- fs/autofs4/inode.c | 13 +++-- fs/autofs4/waitq.c |2 +- 2 files changed, 8 insertions(+), 7 deletions(-) diff --git a/fs/autofs4/inode.c b/fs/autofs4/inode.c index

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-03 Thread Joe Perches
On Mon, 2014-11-03 at 16:12 +0800, Ian Kent wrote: Use the AUTOFS_*() print defines instead of raw printks. Please check the output of these conversions. For instance: diff --git a/fs/autofs4/waitq.c b/fs/autofs4/waitq.c [] @@ -162,7 +162,7 @@ static void autofs4_notify_daemon(struct

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-03 Thread Ian Kent
On Mon, 2014-11-03 at 00:25 -0800, Joe Perches wrote: On Mon, 2014-11-03 at 16:12 +0800, Ian Kent wrote: Use the AUTOFS_*() print defines instead of raw printks. Please check the output of these conversions. For instance: diff --git a/fs/autofs4/waitq.c b/fs/autofs4/waitq.c [] @@

Re: [PATCH 04/13] autofs4 - change printks AUTOFS defined prints

2014-11-03 Thread Joe Perches
On Mon, 2014-11-03 at 17:20 +0800, Ian Kent wrote: On Mon, 2014-11-03 at 00:25 -0800, Joe Perches wrote: On Mon, 2014-11-03 at 16:12 +0800, Ian Kent wrote: Use the AUTOFS_*() print defines instead of raw printks. Hi again Ian It's probably better to simply use #define pr_fmt(fmt)