RE: [PATCH 2/2] Use the new percpu interface for shared data -- version 3

2007-05-22 Thread Yu, Fenghua
>> -DEFINE_PER_CPU(struct tss_struct, init_tss) >>cacheline_internodealigned_in_smp = INIT_TSS; >> +DEFINE_PER_CPU_SHARED_ALIGNED(struct tss_struct, init_tss) = INIT_TSS; >Good work but could we call this something shorter? >Like >DEFINE_CPU_SHARED(...) The PER_CPU_SHARED_ALIGNED is

Re: [PATCH 2/2] Use the new percpu interface for shared data -- version 3

2007-05-22 Thread Christoph Lameter
On Tue, 22 May 2007, Fenghua Yu wrote: > -DEFINE_PER_CPU(struct tss_struct, init_tss) > cacheline_internodealigned_in_smp = INIT_TSS; > +DEFINE_PER_CPU_SHARED_ALIGNED(struct tss_struct, init_tss) = INIT_TSS; Good work but could we call this something shorter? Like DEFINE_CPU_SHARED(...)

[PATCH 2/2] Use the new percpu interface for shared data -- version 3

2007-05-22 Thread Fenghua Yu
Currently most of the per cpu data, which is accessed by different cpus, has a cacheline_aligned_in_smp attribute. Move all this data to the new per cpu shared data section: .data.percpu.shared_aligned. This will seperate the percpu data which is referenced frequently by other cpus from the

[PATCH 2/2] Use the new percpu interface for shared data -- version 3

2007-05-22 Thread Fenghua Yu
Currently most of the per cpu data, which is accessed by different cpus, has a cacheline_aligned_in_smp attribute. Move all this data to the new per cpu shared data section: .data.percpu.shared_aligned. This will seperate the percpu data which is referenced frequently by other cpus from the

Re: [PATCH 2/2] Use the new percpu interface for shared data -- version 3

2007-05-22 Thread Christoph Lameter
On Tue, 22 May 2007, Fenghua Yu wrote: -DEFINE_PER_CPU(struct tss_struct, init_tss) cacheline_internodealigned_in_smp = INIT_TSS; +DEFINE_PER_CPU_SHARED_ALIGNED(struct tss_struct, init_tss) = INIT_TSS; Good work but could we call this something shorter? Like DEFINE_CPU_SHARED(...) -

RE: [PATCH 2/2] Use the new percpu interface for shared data -- version 3

2007-05-22 Thread Yu, Fenghua
-DEFINE_PER_CPU(struct tss_struct, init_tss) cacheline_internodealigned_in_smp = INIT_TSS; +DEFINE_PER_CPU_SHARED_ALIGNED(struct tss_struct, init_tss) = INIT_TSS; Good work but could we call this something shorter? Like DEFINE_CPU_SHARED(...) The PER_CPU_SHARED_ALIGNED is corresponding