Re: [PATCH 2/3] cpumask: Introduce DYING mask

2021-04-12 Thread Qais Yousef
On 04/12/21 12:55, Peter Zijlstra wrote: > On Sun, Mar 21, 2021 at 07:30:37PM +, Qais Yousef wrote: > > On 03/10/21 15:53, Peter Zijlstra wrote: > > > --- a/kernel/cpu.c > > > +++ b/kernel/cpu.c > > > @@ -160,6 +160,9 @@ static int cpuhp_invoke_callback(unsigne > > > int (*cb)(unsigned int

Re: [PATCH 2/3] cpumask: Introduce DYING mask

2021-04-12 Thread Peter Zijlstra
On Sun, Mar 21, 2021 at 07:30:37PM +, Qais Yousef wrote: > On 03/10/21 15:53, Peter Zijlstra wrote: > > --- a/kernel/cpu.c > > +++ b/kernel/cpu.c > > @@ -160,6 +160,9 @@ static int cpuhp_invoke_callback(unsigne > > int (*cb)(unsigned int cpu); > > int ret, cnt; > > > > + if

Re: [PATCH 2/3] cpumask: Introduce DYING mask

2021-03-22 Thread Steven Rostedt
On Sun, 21 Mar 2021 19:30:37 + Qais Yousef wrote: > On 03/10/21 15:53, Peter Zijlstra wrote: > > --- a/kernel/cpu.c > > +++ b/kernel/cpu.c > > @@ -160,6 +160,9 @@ static int cpuhp_invoke_callback(unsigne > > int (*cb)(unsigned int cpu); > > int ret, cnt; > > > > + if (bringup !=

Re: [PATCH 2/3] cpumask: Introduce DYING mask

2021-03-21 Thread Qais Yousef
On 03/10/21 15:53, Peter Zijlstra wrote: > --- a/kernel/cpu.c > +++ b/kernel/cpu.c > @@ -160,6 +160,9 @@ static int cpuhp_invoke_callback(unsigne > int (*cb)(unsigned int cpu); > int ret, cnt; > > + if (bringup != !cpu_dying(cpu)) nit: this condition is hard to read > +

[PATCH 2/3] cpumask: Introduce DYING mask

2021-03-10 Thread Peter Zijlstra
Introduce a cpumask that indicates (for each CPU) what direction the CPU hotplug is currently going. Notably, it tracks rollbacks. Eg. when an up fails and we do a roll-back down, it will accurately reflect the direction. Signed-off-by: Peter Zijlstra (Intel) --- include/linux/cpumask.h | 20