Re: [PATCH 2/6] Refactor code to use new sas_device refcount

2015-07-11 Thread Calvin Owens
On Friday 07/03 at 08:38 -0700, Christoph Hellwig wrote: > > > > +struct _sas_device * > > +mpt2sas_scsih_sas_device_get_by_sas_address_nolock(struct MPT2SAS_ADAPTER > > *ioc, > > +u64 sas_address) > > Any chance to use a shorter name for this function? E.g. > __mpt2sas_get_sdev_by_addr ?

Re: [PATCH 2/6] Refactor code to use new sas_device refcount

2015-07-11 Thread Calvin Owens
On Friday 07/03 at 08:38 -0700, Christoph Hellwig wrote: +struct _sas_device * +mpt2sas_scsih_sas_device_get_by_sas_address_nolock(struct MPT2SAS_ADAPTER *ioc, +u64 sas_address) Any chance to use a shorter name for this function? E.g. __mpt2sas_get_sdev_by_addr ? Will do.

Re: [PATCH 2/6] Refactor code to use new sas_device refcount

2015-07-03 Thread Christoph Hellwig
> > +struct _sas_device * > +mpt2sas_scsih_sas_device_get_by_sas_address_nolock(struct MPT2SAS_ADAPTER > *ioc, > +u64 sas_address) Any chance to use a shorter name for this function? E.g. __mpt2sas_get_sdev_by_addr ? > +{ > + struct _sas_device *sas_device; > + > +

Re: [PATCH 2/6] Refactor code to use new sas_device refcount

2015-07-03 Thread Christoph Hellwig
+struct _sas_device * +mpt2sas_scsih_sas_device_get_by_sas_address_nolock(struct MPT2SAS_ADAPTER *ioc, +u64 sas_address) Any chance to use a shorter name for this function? E.g. __mpt2sas_get_sdev_by_addr ? +{ + struct _sas_device *sas_device; + +

[PATCH 2/6] Refactor code to use new sas_device refcount

2015-06-08 Thread Calvin Owens
This patch refactors the code in the driver to use the new reference count on the sas_device struct. Signed-off-by: Calvin Owens --- drivers/scsi/mpt2sas/mpt2sas_base.h | 4 +- drivers/scsi/mpt2sas/mpt2sas_scsih.c | 329 ---

[PATCH 2/6] Refactor code to use new sas_device refcount

2015-06-08 Thread Calvin Owens
This patch refactors the code in the driver to use the new reference count on the sas_device struct. Signed-off-by: Calvin Owens calvinow...@fb.com --- drivers/scsi/mpt2sas/mpt2sas_base.h | 4 +- drivers/scsi/mpt2sas/mpt2sas_scsih.c | 329 ---

[PATCH 2/6] Refactor code to use new sas_device refcount

2015-05-14 Thread Calvin Owens
This patch refactors the code in the driver to use the new reference count on the sas_device struct. Signed-off-by: Calvin Owens --- drivers/scsi/mpt2sas/mpt2sas_base.h | 4 +- drivers/scsi/mpt2sas/mpt2sas_scsih.c | 329 ---

[PATCH 2/6] Refactor code to use new sas_device refcount

2015-05-14 Thread Calvin Owens
This patch refactors the code in the driver to use the new reference count on the sas_device struct. Signed-off-by: Calvin Owens calvinow...@fb.com --- drivers/scsi/mpt2sas/mpt2sas_base.h | 4 +- drivers/scsi/mpt2sas/mpt2sas_scsih.c | 329 ---