Re: [PATCH 2/6] ipc/mqueue.c: Remove duplicated code

2019-10-14 Thread Peter Zijlstra
On Sat, Oct 12, 2019 at 07:49:54AM +0200, Manfred Spraul wrote: > +static inline void __pipelined_op(struct wake_q_head *wake_q, > struct mqueue_inode_info *info, > + struct ext_wait_queue *this) > { > + list_del(&this->list); > +

Re: [PATCH 2/6] ipc/mqueue.c: Remove duplicated code

2019-10-13 Thread Davidlohr Bueso
On Sat, 12 Oct 2019, Manfred Spraul wrote: Patch entirely from Davidlohr: pipelined_send() and pipelined_receive() are identical, so merge them. Sorry, yeah feel free to add my: Signed-off-by: Davidlohr Bueso Signed-off-by: Manfred Spraul Cc: Davidlohr Bueso --- ipc/mqueue.c | 31 ++

[PATCH 2/6] ipc/mqueue.c: Remove duplicated code

2019-10-11 Thread Manfred Spraul
Patch entirely from Davidlohr: pipelined_send() and pipelined_receive() are identical, so merge them. Signed-off-by: Manfred Spraul Cc: Davidlohr Bueso --- ipc/mqueue.c | 31 ++- 1 file changed, 18 insertions(+), 13 deletions(-) diff --git a/ipc/mqueue.c b/ipc/mqueu