Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-09-06 Thread Palmer Dabbelt
On Fri, 31 Aug 2018 14:18:02 PDT (-0700), atish.pa...@wdc.com wrote: On 8/30/18 10:54 PM, Christoph Hellwig wrote: On Thu, Aug 30, 2018 at 09:11:11AM -0700, Atish Patra wrote: On 8/30/18 7:41 AM, Christoph Hellwig wrote: struct device_node *dn = NULL; - int hart, im_okay_therefor

Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-09-06 Thread Palmer Dabbelt
On Thu, 30 Aug 2018 09:11:11 PDT (-0700), atish.pa...@wdc.com wrote: On 8/30/18 7:41 AM, Christoph Hellwig wrote: struct device_node *dn = NULL; - int hart, im_okay_therefore_i_am = 0; + int hart, found_boot_cpu = 0; If you rename this anyway please switch to use a bool.

Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-31 Thread Atish Patra
On 8/30/18 10:54 PM, Christoph Hellwig wrote: On Thu, Aug 30, 2018 at 09:11:11AM -0700, Atish Patra wrote: On 8/30/18 7:41 AM, Christoph Hellwig wrote: struct device_node *dn = NULL; - int hart, im_okay_therefore_i_am = 0; + int hart, found_boot_cpu = 0; If you rename this

Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-30 Thread Christoph Hellwig
On Thu, Aug 30, 2018 at 09:11:11AM -0700, Atish Patra wrote: > On 8/30/18 7:41 AM, Christoph Hellwig wrote: > > > struct device_node *dn = NULL; > > > - int hart, im_okay_therefore_i_am = 0; > > > + int hart, found_boot_cpu = 0; > > > > If you rename this anyway please switch to use a bo

Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-30 Thread Atish Patra
On 8/30/18 7:41 AM, Christoph Hellwig wrote: struct device_node *dn = NULL; - int hart, im_okay_therefore_i_am = 0; + int hart, found_boot_cpu = 0; If you rename this anyway please switch to use a bool. I can address the comment on this patch and fold it in my series to

Re: [PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-30 Thread Christoph Hellwig
> struct device_node *dn = NULL; > - int hart, im_okay_therefore_i_am = 0; > + int hart, found_boot_cpu = 0; If you rename this anyway please switch to use a bool.

[PATCH 5/8] RISC-V: Rename im_okay_therefore_i_am to found_boot_cpu

2018-08-27 Thread Palmer Dabbelt
The old name was a bit odd. Signed-off-by: Palmer Dabbelt --- arch/riscv/kernel/smpboot.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/arch/riscv/kernel/smpboot.c b/arch/riscv/kernel/smpboot.c index 5f29f8562cf6..e1f6a5ad0416 100644 --- a/arch/riscv/kernel/smpboot.