Re: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB helpers

2015-04-08 Thread ira.weiny
ina; Selvin Xavier; Mitesh Ahuja; Li RongQing; > > Rasmus Villemoes; Alex Estrin; Doug Ledford; Eric > Dumazet; Erez > > Shitrit; Tom Gundersen; Chuck Lever > > Subject: Re: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB > > helpers > > > > On

Re: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB helpers

2015-04-08 Thread Michael Wang
Hi, Steve Thanks for the comment :-) On 04/07/2015 10:16 PM, Steve Wise wrote: [snip] >>> >>> - force_grh = rdma_port_get_link_layer(device, port_num) == >>> IB_LINK_LAYER_ETHERNET; >>> + force_grh = !rdma_transport_ib(device, port_num); >> >> Maybe these tests should be called cap_mandatory

Re: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB helpers

2015-04-08 Thread Michael Wang
On 04/07/2015 08:40 PM, Hefty, Sean wrote: [snip] >> @@ -200,11 +200,9 @@ int ib_init_ah_from_wc(struct ib_device *device, u8 >> port_num, struct ib_wc *wc, >> u32 flow_class; >> u16 gid_index; >> int ret; >> -int is_eth = (rdma_port_get_link_layer(device, port_num) == >> -

RE: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB helpers

2015-04-07 Thread Hefty, Sean
> > index f704254..4e61104 100644 > > +++ b/drivers/infiniband/core/sa_query.c > > @@ -540,7 +540,7 @@ int ib_init_ah_from_path(struct ib_device *device, > u8 port_num, > > ah_attr->port_num = port_num; > > ah_attr->static_rate = rec->rate; > > > > - force_grh = rdma_port_get_link_layer(d

RE: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB helpers

2015-04-07 Thread Steve Wise
rsen; Chuck Lever > Subject: Re: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB > helpers > > On Tue, Apr 07, 2015 at 02:35:22PM +0200, Michael Wang wrote: > > index f704254..4e61104 100644 > > +++ b/drivers/infiniband/core/sa_query.c > > @@ -540,7 +5

Re: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB helpers

2015-04-07 Thread Jason Gunthorpe
On Tue, Apr 07, 2015 at 02:35:22PM +0200, Michael Wang wrote: > index f704254..4e61104 100644 > +++ b/drivers/infiniband/core/sa_query.c > @@ -540,7 +540,7 @@ int ib_init_ah_from_path(struct ib_device *device, u8 > port_num, > ah_attr->port_num = port_num; > ah_attr->static_rate = rec-

RE: [PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB helpers

2015-04-07 Thread Hefty, Sean
> diff --git a/drivers/infiniband/core/sa_query.c > b/drivers/infiniband/core/sa_query.c > index f704254..4e61104 100644 > --- a/drivers/infiniband/core/sa_query.c > +++ b/drivers/infiniband/core/sa_query.c > @@ -540,7 +540,7 @@ int ib_init_ah_from_path(struct ib_device *device, u8 > port_num, >

[PATCH v2 10/17] IB/Verbs: Adopt management helpers for IB helpers

2015-04-07 Thread Michael Wang
Adopt management helpers for: ib_init_ah_from_path() ib_init_ah_from_wc() ib_resolve_eth_l2_attrs() Cc: Jason Gunthorpe Cc: Doug Ledford Cc: Ira Weiny Cc: Sean Hefty Signed-off-by: Michael Wang --- drivers/infiniband/core/sa_query.c | 2 +- drivers/infiniband/core/ve