Re: [PATCH v4 2/4] nvme-pci: Add support for variable IO SQ element size

2019-08-22 Thread Benjamin Herrenschmidt
On Thu, 2019-08-22 at 19:52 -0700, Sagi Grimberg wrote: > > > I'll fix it. Note that I'm going to take it out of the tree soon > > > because it will have conflicts with Jens for-5.4/block, so we > > > will send it to Jens after the initial merge window, after he > > > rebases off of Linus. > > >

Re: [PATCH v4 2/4] nvme-pci: Add support for variable IO SQ element size

2019-08-22 Thread Sagi Grimberg
I'll fix it. Note that I'm going to take it out of the tree soon because it will have conflicts with Jens for-5.4/block, so we will send it to Jens after the initial merge window, after he rebases off of Linus. Conflicts too hard to fixup at merge time ? Otherwise I could just rebase on top

Re: [PATCH v4 2/4] nvme-pci: Add support for variable IO SQ element size

2019-08-22 Thread Benjamin Herrenschmidt
On Thu, 2019-08-22 at 11:02 -0700, Sagi Grimberg wrote: > > > > I'll fix it. Note that I'm going to take it out of the tree soon > because it will have conflicts with Jens for-5.4/block, so we > will send it to Jens after the initial merge window, after he > rebases off of Linus. Conflicts too

Re: [PATCH v4 2/4] nvme-pci: Add support for variable IO SQ element size

2019-08-22 Thread Sagi Grimberg
wrote: +#define NVME_NVM_ADMSQES 6 #define NVME_NVM_IOSQES 6 #define NVME_NVM_IOCQES 4 The NVM in the two defines here stands for the NVM command set, so this should just be named NVME_ADM_SQES or so. But except for this the patch looks good:

Re: [PATCH v4 2/4] nvme-pci: Add support for variable IO SQ element size

2019-08-21 Thread Benjamin Herrenschmidt
On Thu, 2019-08-22 at 02:28 +0200, Christoph Hellwig wrote: > On Wed, Aug 07, 2019 at 05:51:20PM +1000, Benjamin Herrenschmidt > wrote: > > +#define NVME_NVM_ADMSQES 6 > > #define NVME_NVM_IOSQES6 > > #define NVME_NVM_IOCQES4 > > The NVM in the two defines here stands

Re: [PATCH v4 2/4] nvme-pci: Add support for variable IO SQ element size

2019-08-21 Thread Christoph Hellwig
On Wed, Aug 07, 2019 at 05:51:20PM +1000, Benjamin Herrenschmidt wrote: > +#define NVME_NVM_ADMSQES 6 > #define NVME_NVM_IOSQES 6 > #define NVME_NVM_IOCQES 4 The NVM in the two defines here stands for the NVM command set, so this should just be named NVME_ADM_SQES

[PATCH v4 2/4] nvme-pci: Add support for variable IO SQ element size

2019-08-07 Thread Benjamin Herrenschmidt
The size of a submission queue element should always be 6 (64 bytes) by spec. However some controllers such as Apple's are not properly implementing the standard and require a different size. This provides the ground work for the subsequent quirks for these controllers. Signed-off-by: Benjamin