Re: [PATCH v7 3/8] time: Remove duplicated code in ktime_get_raw_and_real()

2016-02-16 Thread Christopher Hall
On Mon, 15 Feb 2016 23:52:10 -0800, Richard Cochran wrote: @@ -888,6 +888,8 @@ void ktime_get_snapshot(struct system_time_snapshot *systime_snapshot) s64 nsec_real; cycle_t now; + WARN_ON(timekeeping_suspended); ... - WARN_ON_ONCE(timekeeping_suspended); Is th

Re: [PATCH v7 3/8] time: Remove duplicated code in ktime_get_raw_and_real()

2016-02-15 Thread Richard Cochran
On Fri, Feb 12, 2016 at 12:25:24PM -0800, Christopher S. Hall wrote: > The code in ktime_get_snapshot() is a superset of the code in > ktime_get_raw_and_real() code. Further, ktime_get_raw_and_real() is > called only by the PPS code, pps_get_ts(). Consolidate the > pps_get_ts() code into a single f

[PATCH v7 3/8] time: Remove duplicated code in ktime_get_raw_and_real()

2016-02-12 Thread Christopher S. Hall
The code in ktime_get_snapshot() is a superset of the code in ktime_get_raw_and_real() code. Further, ktime_get_raw_and_real() is called only by the PPS code, pps_get_ts(). Consolidate the pps_get_ts() code into a single function calling ktime_get_snapshot() and eliminate ktime_get_raw_and_real().