Re: [PATCH] scsi: virtio-scsi: Fix address translation failure of HighMem pages used by sg list

2012-07-25 Thread Paolo Bonzini
Il 25/07/2012 10:29, Wang Sen ha scritto: > When using the commands below to write some data to a virtio-scsi LUN of the > QEMU guest(32-bit) with 1G physical memory(qemu -m 1024), the qemu will crash. > > # sudo mkfs.ext4 /dev/sdb (/dev/sdb is the virtio-scsi LUN.) > # sudo mount /d

Crypto Update for 3.6

2012-07-25 Thread Herbert Xu
Hi Linus: Here is the crypto update for 3.6: * Fixed algorithm construction hang when self-test fails. * Added SHA variants to talitos AEAD list. * New driver for Exynos random number generator. * Performance enhancements for arc4. * Added hwrng support to caam. * Added ahash support to caam. * F

Re: rcu: INFO: rcu_preempt detected stalls on CPUs/tasks on v3.6

2012-07-25 Thread Michael Wang
On 07/25/2012 01:10 AM, Sasha Levin wrote: > Hi all, > > I was fuzzing with trinity inside a KVM tools guest, on the current 3.6, and > stumbled on the following: Hi, Sasha I'm currently trying to reproduce this issue on my machine but keep failing, it's really make me think the issue has been

Re: [PATCH -alternative] mm: hugetlbfs: Close race during teardown of hugetlbfs shared page tables V2 (resend)

2012-07-25 Thread Mel Gorman
On Tue, Jul 24, 2012 at 12:23:58PM -0700, Hugh Dickins wrote: > On Tue, 24 Jul 2012, Mel Gorman wrote: > > On Mon, Jul 23, 2012 at 06:08:05PM -0700, Hugh Dickins wrote: > > > > > > So, after a bout of anxiety, I think my &= ~VM_MAYSHARE remains good. > > > > > > > I agree with you. When I was th

Re: [08/36] AArch64: Kernel booting and initialisation

2012-07-25 Thread Catalin Marinas
On Tue, Jul 24, 2012 at 07:53:16PM +0100, Arnd Bergmann wrote: > On Tuesday 24 July 2012, Catalin Marinas wrote: > > On Mon, Jul 23, 2012 at 09:52:22PM +0100, Christopher Covington wrote: > > > Catalin Marinas - July 8, 2012, 9:18 a.m. > > > > On Fri, Jul 06, 2012 at 10:32:54PM +0100, Stephen Warre

[PATCH] scsi: virtio-scsi: Fix address translation failure of HighMem pages used by sg list

2012-07-25 Thread Wang Sen
When using the commands below to write some data to a virtio-scsi LUN of the QEMU guest(32-bit) with 1G physical memory(qemu -m 1024), the qemu will crash. # sudo mkfs.ext4 /dev/sdb (/dev/sdb is the virtio-scsi LUN.) # sudo mount /dev/sdb /mnt # dd if=/dev/zero of=/mnt/fi

Re: [REGRESSION] [KMS] [INTEL] Wrong resolution in console and XWindow

2012-07-25 Thread Daniel Vetter
On Wed, Jul 25, 2012 at 10:20:47AM +0200, Maciej Rutecki wrote: > Last known good: 3.4.4 > First bad: 3.5.0 > > When booting 3.5.0 resolution (in console, and after in KDE) is set to > 1024x768 (60Hz). In 3.4.4 was correct: 1440x900 (60Hz). Can you please attach the output of xrandr --verbose fo

Re: [next:akpm 129/309] net/core/sock.c:274:36: error: initializer element is not constant

2012-07-25 Thread Mel Gorman
On Tue, Jul 24, 2012 at 05:08:04PM -0400, John David Anglin wrote: > On 24-Jul-12, at 3:48 AM, Fengguang Wu wrote: > > >Here is the line in sock.i: > > > >struct static_key memalloc_socks = ((struct static_key) { .enabled > >= ((atomic_t) { (0) }) }); > > > The above line contains two compound l

Re: [PATCH] fixed coding style issues

2012-07-25 Thread Baodong Chen
On Wed, Jul 25, 2012 at 4:01 PM, Joe Perches wrote: > On Wed, 2012-07-25 at 15:44 +0800, Baodong Chen wrote: >> i want to participate in and to start from >> fixing simple issues! > > That's fine Baodong. Welcome. > >> how could i choose issues form checkpatch's output to find which >> should be

[REGRESSION] [KMS] [INTEL] Wrong resolution in console and XWindow

2012-07-25 Thread Maciej Rutecki
Last known good: 3.4.4 First bad: 3.5.0 When booting 3.5.0 resolution (in console, and after in KDE) is set to 1024x768 (60Hz). In 3.4.4 was correct: 1440x900 (60Hz). Dmesg from 3.5.0: http://mrutecki.pl/download/kernel/3.5/swinka/dmesg-3.5.0.txt Dmesg from 3.4.4: http://mrutecki.pl/download/ke

[PULL] drm-intel-fixes for 3.6

2012-07-25 Thread Daniel Vetter
Hi Dave, First pile of fixes for 3.6 already, and I'm afraid it's a bit larger than what I'd wish for. But I've moved all the feature-y stuff to -next, so this really is all -fixes. Most of it is handling fallout from the hw context stuff, discovered now that mesa git has started using them for re

Re: [PATCH] ia64: rename platform_name to ia64_platform_name

2012-07-25 Thread Joe Perches
On Wed, 2012-07-25 at 16:06 +0800, Fengguang Wu wrote: > The macro name is too generic and conflicts with > snd_soc_dai_link.platform_name, which triggers lots of ALSA build errors. Is platform_name particularly special? Perhaps it's be better to rename all the other platform_ uses to ia64_platfo

Re: [PATCH] add blockconsole version 1.1

2012-07-25 Thread Tvrtko Ursulin
On Tuesday 24 Jul 2012 15:38:22 Jörn Engel wrote: > On Tue, 24 July 2012 09:01:16 +0100, Tvrtko Ursulin wrote: > > On Monday 23 Jul 2012 21:02:30 Jörn Engel wrote: > > > On Mon, 23 July 2012 15:33:16 +0100, Tvrtko Ursulin wrote: > > > > On Thursday 12 Jul 2012 18:46:34 Jörn Engel wrote: > > At the

Re: [PATCH 1/1] Drivers: hv: Cleanup the guest ID computation

2012-07-25 Thread Olaf Hering
On Tue, Jul 24, K. Y. Srinivasan wrote: > +/* > + * The guest OS needs to register the guest ID with the hypervisor. > + * The guest ID is a 64 bit entity and the structure of this ID is > + * specified in the Hyper-V specification: > + * > + * http://msdn.microsoft.com/en-us/library/windows/ > +

Re: Re: [Qemu-devel] [RFC PATCH 0/6] virtio-trace: Support virtio-trace

2012-07-25 Thread Masami Hiramatsu
(2012/07/25 5:26), Blue Swirl wrote:> >> The following patch set provides a low-overhead system for collecting kernel >> tracing data of guests by a host in a virtualization environment. >> >> A guest OS generally shares some devices with other guests or a host, so >> reasons of any problems occurr

Re: [PATCH] avr32: fix build error in ATSTK1002 code

2012-07-25 Thread Fengguang Wu
Andrew, will you accept this fix? It's obviously caused by a typo in commit 1754aab9bb86. On Sun, Jul 22, 2012 at 10:25:41AM +0800, Fengguang Wu wrote: > arch/avr32/boards/atstk1000/atstk1002.c:100: error: 'num_partitions' > undeclared here (not in a function) > > which is introduced by commit 1

[PATCH] ia64: rename platform_name to ia64_platform_name

2012-07-25 Thread Fengguang Wu
The macro name is too generic and conflicts with snd_soc_dai_link.platform_name, which triggers lots of ALSA build errors. Signed-off-by: Fengguang Wu --- (not sure if the previous sent was successful, so resend) arch/ia64/include/asm/machvec.h |2 +- arch/ia64/include/asm/ma

[PATCH RESEND] mmc: core: Remove bounce buffer in mmc_send_cxd_data()

2012-07-25 Thread Kyungsik Lee
It is expected that Extended CSD register(the size of this register is larger than CID/CSD) will be referenced more frequently as more fields have been added to Extended CSD and it seems that it is not a good option to double the memory used. This patch is intended to avoid the use of bounce buffe

Re: [PATCH] sctp: Make "Invalid Stream Identifier" ERROR follows SACK when bundling

2012-07-25 Thread Xufeng Zhang
On 7/25/12, Vlad Yasevich wrote: > > Actually not true. AUTH can be before SACK. So can any addip chunks that > aid in locating an association. > > Now AUTH isn't a big issue since its autogenerated to the packet but ADDIP > is since it could be queued up for retransmission. > > There could be o

Re: [PATCH 1/3] drivers/misc: Add realtek card reader core driver

2012-07-25 Thread Borislav Petkov
On Wed, Jul 25, 2012 at 10:28:39AM +0800, wwang wrote: > 于 2012年07月24日 22:07, Borislav Petkov 写道: > >Kernel is Linus' from yesterday: v3.5-709-ga6be1fcbc57f and config > >is attached. > > The compilation process is still OK with your config. Yes, but not with the kernel I'm using. If you'd tried

Re: [PATCH] debug: Do not permit CONFIG_DEBUG_STACK_USAGE=y on IA64 or PARISC

2012-07-25 Thread James Bottomley
On Wed, 2012-07-25 at 09:45 +0200, Ingo Molnar wrote: > * Tony Luck wrote: > > > The stack_not_used() function in assumes that stacks > > grow downwards. This is not true on IA64 or PARISC, so this function > > would walk off in the wrong direction and into the weeds. > > > > Found on IA64 beca

Re: [PATCH] fixed coding style issues

2012-07-25 Thread Joe Perches
On Wed, 2012-07-25 at 15:44 +0800, Baodong Chen wrote: > i want to participate in and to start from > fixing simple issues! That's fine Baodong. Welcome. > how could i choose issues form checkpatch's output to find which > should be fixed which are > not? checkpatch output is merely a guide for

[PATCH] nouveau: fix build error on IA64

2012-07-25 Thread Fengguang Wu
I'm not sure if this is the best way, however it does fix the last 2 allmodconfig errors on IA64: ERROR: "wmi_has_guid" [drivers/gpu/drm/nouveau/nouveau.ko] undefined! ERROR: "wmi_evaluate_method" [drivers/gpu/drm/nouveau/nouveau.ko] undefined! Signed-off-by: Fengguang Wu --- drivers/gpu/drm/no

Re: [PATCH] x86: simplify mtrr_bp_init()

2012-07-25 Thread Jan Beulich
>>> On 07.07.12 at 00:02, Yinghai Lu wrote: > On Fri, Jul 6, 2012 at 7:18 AM, Jan Beulich wrote: >> Now that the x86_phys_bits cpuinfo field is uniformly available on >> 32- and 64-bit, the function no longer needs to determine this anew. >> >> Additionally, both size_or_mask and size_and_mask ca

Re: [PATCH 03/17] Drivers: hv: kvp: Cleanup error handling in KVP

2012-07-25 Thread Olaf Hering
On Tue, Jul 24, K. Y. Srinivasan wrote: > +++ b/drivers/hv/hv_kvp.c > @@ -48,13 +48,24 @@ static struct { > void *kvp_context; /* for the channel callback */ > } kvp_transaction; > > +/* > + * Before we can accept KVP messages from the host, we need > + * to handshake with the user level

Re: [PATCH 03/34] mm: Reduce the amount of work done when updating min_free_kbytes

2012-07-25 Thread Mel Gorman
On Tue, Jul 24, 2012 at 03:47:12PM -0700, Greg KH wrote: > On Mon, Jul 23, 2012 at 02:38:16PM +0100, Mel Gorman wrote: > > commit 938929f14cb595f43cd1a4e63e22d36cab1e4a1f upstream. > > > > Stable note: Fixes https://bugzilla.novell.com/show_bug.cgi?id=726210 . > > Large machines with 1TB or mo

Re: [RFC PATCH 06/13] driver core: firmware loader: always let firmware_buf own the pages buffer

2012-07-25 Thread Stephen Boyd
Mostly trivia. On 7/24/2012 10:00 AM, Ming Lei wrote: > + > +static int fw_lookup_and_alloate_buf(const char *fw_name, allocate? > + struct firmware_cache *fwc, > + struct firmware_buf **buf) > +{ > + struct firmware_buf *tmp; > + > + spin_lock(&fwc->lock); > +

Re: [RFC PATCH 07/13] driver core: firmware loader: introduce cache_firmware and uncache_firmware

2012-07-25 Thread Stephen Boyd
On 7/24/2012 10:00 AM, Ming Lei wrote: > > + > +int cache_firmware(const char *name) > +{ > + return -ENOENT; > +} > + > +int uncache_firmware(const char *name) > +{ > + return -EINVAL; > +} These stubs need to be static inline to avoid compiler warnings. -- Sent by an employee of the Qu

[PATCH] ia64: mark PARAVIRT and KVM as broken

2012-07-25 Thread Fengguang Wu
Well, this at least makes allmodconfig happy. Proposed-by: David Howells Signed-off-by: Fengguang Wu --- arch/ia64/Kconfig |3 +-- arch/ia64/kvm/Kconfig |1 + 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/arch/ia64/Kconfig b/arch/ia64/Kconfig index 8186ec5..310cf57

Re: [PATCH] x86: adjust generic_get_mtrr() for 64-bit

2012-07-25 Thread Jan Beulich
>>> On 06.07.12 at 23:38, Yinghai Lu wrote: > On Fri, Jul 6, 2012 at 7:14 AM, Jan Beulich wrote: >> Needing to deal with potentially large memory configurations, the >> variables here should be "unsigned long" instead of "unsigned int". >> >> Signed-off-by: Jan Beulich >> >> --- >> arch/x86/ker

Re: [PATCH 00/13] UAPI header file split

2012-07-25 Thread Michael Kerrisk
On Tue, Jul 24, 2012 at 3:19 PM, David Howells wrote: > Michael Kerrisk wrote: > >> In the uapi-split branch, there are now 44 empty Kbuild files. Was >> that intended? Or, should these files rather be removed by your >> patches? > > To be removed by a later patch, I think. Getting rid of some o

[PATCH] fix nouveau build error on !CONFIG_MXM_WMI

2012-07-25 Thread Fengguang Wu
Fix build error on IA64: ERROR: "mxm_wmi_supported" [drivers/gpu/drm/nouveau/nouveau.ko] undefined! Signed-off-by: Fengguang Wu --- include/linux/mxm-wmi.h |8 1 file changed, 8 insertions(+) diff --git a/include/linux/mxm-wmi.h b/include/linux/mxm-wmi.h index 617a295..f6a6214 100

Re: [PATCH] debug: Do not permit CONFIG_DEBUG_STACK_USAGE=y on IA64 or PARISC

2012-07-25 Thread Ingo Molnar
* Tony Luck wrote: > The stack_not_used() function in assumes that stacks > grow downwards. This is not true on IA64 or PARISC, so this function > would walk off in the wrong direction and into the weeds. > > Found on IA64 because of a compilation failure with recursive dependencies > on IA64_

Re: [PATCH] fixed coding style issues

2012-07-25 Thread Baodong Chen
i want to participate in and to start from fixing simple issues! how could i choose issues form checkpatch's output to find which should be fixed which are not? or checkpatch.pl should be updated?? On Wed, Jul 25, 2012 at 3:30 PM, Joe Perches wrote: > On Wed, 2012-07-25 at 15:11 +0800, Baodong Ch

Re: [PATCH 1/3] perf tools: Fix trace events storms due to weight demux

2012-07-25 Thread Ingo Molnar
* Frederic Weisbecker wrote: > In case you wonder. This doesn't fix a regression so this is > 3.6 material. The newline and tracing one might be argued a regression, but yeah, these are probably best for v3.6. Thanks, Ingo -- To unsubscribe from this list: send the line "unsubscribe

Re: [REPOST #3 PATCH v2] Input: atkbd - make repeat period more accurate.

2012-07-25 Thread Dmitry Torokhov
Hi George, On Sat, Jul 21, 2012 at 11:42:28PM -0400, George Spelvin wrote: > This replaces some inaccurate lookup tables with an exact > computation. Although the diff adds source comments, > it shrinks binary size. (By only 50 bytes, but hey.) > > AT keyboard repeat rates are multiples of 1/24

Re: linux-next: manual merge of the akpm tree with the tip tree

2012-07-25 Thread Johannes Weiner
On Wed, Jul 25, 2012 at 09:10:44AM +0200, Ingo Molnar wrote: > > * Stephen Rothwell wrote: > > > Hi Andrew, > > > > Today's linux-next merge of the akpm tree got a conflict in > > mm/migrate.c between the tip tree and commit "mm: memcg: fix > > compaction/migration failing due to memcg limits

Re: [PATCH] fixed coding style issues

2012-07-25 Thread Joe Perches
On Wed, 2012-07-25 at 15:11 +0800, Baodong Chen wrote: > Fexed coding style issues from scripts/checkpatch.pl in drivers/input Not all checkpatch messages need to be "fexed". :) Please use some taste and judgment before submitting patches based solely on checkpatch output. > diff --git a/drivers

Re: [PATCH 07/10] random: add new get_random_bytes_arch() function

2012-07-25 Thread Ingo Molnar
* H. Peter Anvin wrote: > For those who have read the Google+ thread[1] it is pretty > clear that there are varying opinions on the idea of removing > the RDRAND bypass. > > I have gathered some performance numbers to make the debate > more concrete: RDRAND is between 12 and 15 times faster

Re: [PATCH] sctp: Make "Invalid Stream Identifier" ERROR follows SACK when bundling

2012-07-25 Thread Vlad Yasevich
Xufeng Zhang wrote: >On 7/24/12, Vlad Yasevich wrote: > And I should clarify the above judgment code. > AFAIK, there should be two cases for the bundling when invalid >>>stream > identifier error happens: > 1). COOKIE_ACK ERROR SACK > 2). ERROR SACK > So I need to deal wi

[PATCH] fixed coding style issues

2012-07-25 Thread Baodong Chen
Fexed coding style issues from scripts/checkpatch.pl in drivers/input Signed-off-by: Baodong Chen --- drivers/input/apm-power.c |2 +- drivers/input/evdev.c | 52 +++- drivers/input/ff-core.c |4 +- drivers/input/ff-memless.c|

Re: linux-next: manual merge of the akpm tree with the tip tree

2012-07-25 Thread Ingo Molnar
* Stephen Rothwell wrote: > Hi Andrew, > > Today's linux-next merge of the akpm tree got a conflict in > mm/migrate.c between the tip tree and commit "mm: memcg: fix > compaction/migration failing due to memcg limits" from the > akpm tree. > > The commit 4783af477d3d ("mm: Migrate misplaced

Re: [PATCH v2 1/4] ACPI: Add acpi_pr_() interfaces

2012-07-25 Thread Joe Perches
On Fri, 2012-07-20 at 10:54 -0600, Toshi Kani wrote: > This patch introduces acpi_pr_(), where is a message > level such as err/warn/info, to support improved logging messages > for ACPI, esp. in hotplug operations. acpi_pr_() appends > "ACPI" prefix and ACPI object path to the messages. This im

[git pull] Input updates for 3.6-rc0

2012-07-25 Thread Dmitry Torokhov
Hi Linus, Please pull from: git://git.kernel.org/pub/scm/linux/kernel/git/dtor/input.git for-linus to receive first set of updates for the input subsystem. You will get a new touchscreen driver (Melfas mms114), a new keypad driver for LPC32xx SoC, large update to Atmel mXT touchscreen dr

<    2   3   4   5   6   7