[PATCH 0/2] RFC SLUB: increase range of kmalloc slab sizes

2012-10-13 Thread Richard Kennedy
This patch increases the range of slab sizes available to kmalloc, adding slabs half way between the existing power of two sized ones, so allowing slightly more efficient use of memory. Most of the new slabs already exist as kmem_cache slabs so only the 1.5k,3k 6k are entirely new. The code

[PATCH 1/2] SLUB: remove hard coded magic numbers from resiliency_test

2012-10-13 Thread Richard Kennedy
Use the always inlined function kmalloc_index to translate sizes to indexes, so that we don't have to have the slab indexes hard coded in two places. Signed-off-by: Richard Kennedy rich...@rsk.demon.co.uk --- mm/slub.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff

[PATCH 2/2] SLUB: increase the range of slab sizes available to kmalloc, allowing a somewhat more effient use of memory.

2012-10-13 Thread Richard Kennedy
This patch add new slabs sized at 1.5 * 2^n. i.e - 24,48,96,192,384,768,1.5k,3k,6k Most of which already exist as kmem_cache slabs, except for 1.5k, 3k 6k. There is no extra overhead for statically sized kmalloc, and only a small change for dynamically sized ones. Minimal code changes:

Re: [PATCH 1/2] uapi: update includes for drm content when no kernel API exists

2012-10-13 Thread Luis R. Rodriguez
On Sat, Oct 13, 2012 at 3:33 AM, Laurent Pinchart laurent.pinch...@ideasonboard.com wrote: Hi Luis, On Friday 12 October 2012 16:49:31 Luis R. Rodriguez wrote: From: Luis R. Rodriguez mcg...@do-not-panic.com The UAPI changes split kernel API and userspace API content onto two separate

Re: [git pull] vfs pile 3

2012-10-13 Thread Al Viro
On Sat, Oct 13, 2012 at 12:04:55PM -0400, Christoph Hellwig wrote: On Sat, Oct 13, 2012 at 05:01:15PM +0100, Al Viro wrote: You know, I'm in the middle of dealing with one such TODO. Yours, as it were. From six years ago. kernel_thread() unexporting. TODO comments of any form are

Re: [PATCH] binfmt_script: do not leave interp on stack

2012-10-13 Thread Kees Cook
On Fri, Oct 12, 2012 at 10:50 PM, halfdog m...@halfdog.net wrote: Kees Cook wrote: More importantly, I also wonder if interp handling to just be changed to be an allocation that needs to be cleaned up, as done with argv? You mean like an allocation on the stack of the new process' growing

Re: [PATCH 1/1] tools: hv: Return the full kernel version

2012-10-13 Thread Greg KH
On Sat, Oct 13, 2012 at 04:03:31PM +, KY Srinivasan wrote: -Original Message- From: Greg KH [mailto:gre...@linuxfoundation.org] Sent: Saturday, October 13, 2012 2:45 AM To: KY Srinivasan Cc: linux-kernel@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;

Re: [PATCH 01/16] f2fs: add document

2012-10-13 Thread Arnd Bergmann
On Friday 05 October 2012 20:56:06 김재극 wrote: This adds a document describing the mount options, proc entries, usage, and design of Flash-Friendly File System, namely F2FS. Nice document! This is a lot like the design I came up with for an experimental file system last year, so I'll try to go

Re: [PATCH 00/33] AutoNUMA27

2012-10-13 Thread Srikar Dronamraju
* Andrea Arcangeli aarca...@redhat.com [2012-10-04 01:50:42]: Hello everyone, This is a new AutoNUMA27 release for Linux v3.6. Here results of autonumabenchmark on a 328GB 64 core with ht disabled comparing v3.6 with autonuma27. $ numactl -H available: 8 nodes (0-7) node 0 cpus: 0 1 2 3

Re: Intel graphics drm issue?

2012-10-13 Thread Mark Hounschell
On 10/13/2012 02:57 PM, Mark Hounschell wrote: Hi Bruno, Thanks for the response. On 10/12/2012 05:14 PM, Bruno Prémont wrote: Hi Mark, [CCing intel-gfx] On Fri, 12 October 2012 Mark Hounschell ma...@compro.net wrote: Not sure this is the correct place to ask about a possible drm issue. I

Re: Local DoS through write heavy I/O on CFQ Deadline

2012-10-13 Thread Alex Bligh
--On 13 October 2012 21:53:09 +0800 Hillf Danton dhi...@gmail.com wrote: Take a look at the wait for writeback problem please. Linux 3.0+ Disk performance problem - wrong pdflush behaviour https://lkml.org/lkml/2012/10/10/412 I'm guessing that's related but may not be the

[RFC] desired behaviour of syscall tracing wrt fork()

2012-10-13 Thread Al Viro
There's a lovely incosistency regarding whether we call trace_sys_exit() for child process on return from fork()/clone()/etc. The current situation: * called on amd64 for 32bit newborns * *NOT* called on i386 or amd64 for 64bit ones * not called on arm *

Re: [PATCH 11/16] f2fs: add inode operations for special inodes

2012-10-13 Thread Arnd Bergmann
On Friday 05 October 2012, 김재극 wrote: +const char *media_ext_lists[] = { + jpg, + gif, + png, + avi, + divx, + mp4, + mp3, ... + * Set multimedia files as cold files for hot/cold data separation + */ +static inline void set_cold_file(struct

Re: [dm-crypt] PROBLEM: read starvation during writeback

2012-10-13 Thread Michael Zugelder
Hi, I have a small update on my previously posted test case. I noticed 'cryptsetup -c null' uses cipher_null in ecb mode, and in that case, I don't observe any read starvation. I'm not sure what the default cipher mode is (cryptsetup uses cbc-essiv:sha256), but I can reproduce the problem using

[PULL REQ] IXP4xx changes for Linux 3.7

2012-10-13 Thread Krzysztof Halasa
Linus, please pull my ARM IXP4xx changes for 3.7: The following changes since commit 4d7127dace8cf4b05eb7c8c8531fc204fbb195f4: Merge branch 'for-linus' of git://git.kernel.org/.../jmorris/linux-security (2012-10-13 11:29:00 +0900) are available in the git repository at:

Re: [GIT PULL] Disintegrate UAPI for usb

2012-10-13 Thread Greg KH
On Tue, Oct 09, 2012 at 02:30:48PM +0100, David Howells wrote: Can you merge the following branch into the usb tree please. This is to complete part of the Userspace API (UAPI) disintegration for which the preparatory patches were pulled recently. After these patches, userspace headers will

Re: [PATCH 1/2] UAPI: Unexport part of linux/ppp-comp.h

2012-10-13 Thread David Miller
From: David Howells dhowe...@redhat.com Date: Sat, 13 Oct 2012 10:08:10 +0100 Unexport part of linux/ppp-comp.h as userspace can't make use of that bit. Signed-off-by: David Howells dhowe...@redhat.com Acked-by: David S. Miller da...@davemloft.net -- To unsubscribe from this list: send the

Re: [PATCH 20/25] sparc: Use Kbuild infrastructure to handle asm-generic headers

2012-10-13 Thread David Miller
From: Steven Rostedt rost...@goodmis.org Date: Sat, 13 Oct 2012 09:54:00 -0400 On Fri, 2012-10-12 at 23:19 -0400, David Miller wrote: From: Steven Rostedt rost...@goodmis.org Date: Fri, 12 Oct 2012 22:26:52 -0400 From: Steven Rostedt srost...@redhat.com Use Kbuild infrastructure to

Re: [PATCH 11/16] f2fs: add inode operations for special inodes

2012-10-13 Thread Vyacheslav Dubeyko
On Oct 14, 2012, at 12:52 AM, Arnd Bergmann wrote: On Friday 05 October 2012, 김재극 wrote: +const char *media_ext_lists[] = { + jpg, + gif, + png, + avi, + divx, + mp4, + mp3, ... + * Set multimedia files as cold files for hot/cold data

Re: [PATCH 20/25] sparc: Use Kbuild infrastructure to handle asm-generic headers

2012-10-13 Thread Steven Rostedt
On Sat, 2012-10-13 at 17:54 -0400, David Miller wrote: I really would like to take less rather than take more. This whole UAPI, Kbuild, etc. stuff is just bogging subsystem maintainers down. This kind of stuff should just go via the person who does all the work and knows how it all ties

[PATCH] rtc: davinci: clean up probe/remove routines

2012-10-13 Thread Hannu Heikkinen
Use the devres managed resource functions in the probe routine. Also affects the remove routine where the previously used free and release functions are not needed. The devm_* functions eliminate the need for manual resource releasing and simplify error handling. Resources allocated by devm_*

Re: [PATCH 11/16] f2fs: add inode operations for special inodes

2012-10-13 Thread Vyacheslav Dubeyko
On Oct 14, 2012, at 12:52 AM, Arnd Bergmann wrote: On Friday 05 October 2012, 김재극 wrote: +const char *media_ext_lists[] = { + jpg, + gif, + png, + avi, + divx, + mp4, + mp3, ... + * Set multimedia files as cold files for hot/cold data

[PATCH] usb: acm: fix the computation of the number of data bits

2012-10-13 Thread Nicolas Boullis
From: Nicolas Boullis nboul...@debian.org The current code assumes that CSIZE is 060, which appears to be wrong on some arches (such as powerpc). Signed-off-by: Nicolas Boullis nboul...@debian.org --- diff --git a/drivers/usb/class/cdc-acm.c b/drivers/usb/class/cdc-acm.c index

Re: [PATCH] mm: cleanup register_node()

2012-10-13 Thread KOSAKI Motohiro
On Fri, Oct 12, 2012 at 4:22 AM, Yasuaki Ishimatsu isimatu.yasu...@jp.fujitsu.com wrote: register_node() is defined as extern in include/linux/node.h. But the function is only called from register_one_node() in driver/base/node.c. So the patch defines register_node() as static. CC: David

Re: [PATCH 0/2] RFC SLUB: increase range of kmalloc slab sizes

2012-10-13 Thread Andi Kleen
Richard Kennedy rich...@rsk.demon.co.uk writes: This patch increases the range of slab sizes available to kmalloc, adding slabs half way between the existing power of two sized ones, so allowing slightly more efficient use of memory. Most of the new slabs already exist as kmem_cache slabs

Re: [GIT PULL] (xen) stable/for-linus-3.7-uapi-tag for v3.7-rc0

2012-10-13 Thread Randy Dunlap
On 10/12/2012 07:16 PM, Linus Torvalds wrote: On Fri, Oct 12, 2012 at 10:45 PM, Konrad Rzeszutek Wilk konrad.w...@oracle.com wrote: Please pull! Btw, please use the -M switch to get renames as renames (and --summary). You diffstat: include/uapi/xen/Kbuild|2 +

Re: [GIT PULL] UAPI disintegration for include/linux/{,byteorder/}*.h

2012-10-13 Thread Linus Torvalds
David, I want to make it very clear that if you *ever* suggest another big include file cleanup, I will say f*ck no and block you from my emails forever. Ok? So don't bother. We're done with these kinds of games. Forever. It's not worth it, don't ever suggest it again for some other cleanup. In

Re: Local DoS through write heavy I/O on CFQ Deadline

2012-10-13 Thread Hillf Danton
On Sun, Oct 14, 2012 at 3:33 AM, Alex Bligh a...@alex.org.uk wrote: Or perhaps I have the wrong end of the stick. Never mind a friendly link:) -- To unsubscribe from this list: send the line unsubscribe linux-kernel in the body of a message to majord...@vger.kernel.org More majordomo info at

[PATCH RFC] brd: Add miscdevice to control creation and deletion of ramdisks

2012-10-13 Thread Hannes Frederic Sowa
While toying around with a library which needs small block devices for quorum management, I came up with this small patch to dynamically create and destroy ram disks (I wanted to have non-swappable backed devices). I am not really comfortable with the the double-use of the ioctl parameter of

Re: [PATCH] MM: Support more pagesizes for MAP_HUGETLB/SHM_HUGETLB v5

2012-10-13 Thread Hillf Danton
Hi Andi, On Sat, Oct 13, 2012 at 11:38 PM, Andi Kleen a...@firstfloor.org wrote: v2: Port to new tree. Fix unmount. v3: Ported to latest tree. v4: Ported to latest tree. Minor changes for review feedback. Updated description. v5: Remove unnecessary prototypes to fix merge error (Hillf

Re: [PATCH RFC] brd: Add miscdevice to control creation and deletion of ramdisks

2012-10-13 Thread Hannes Frederic Sowa
On Sun, Oct 14, 2012 at 04:48:36AM +0200, Hannes Frederic Sowa wrote: + case BRD_CTL_DEL: + error = get_user(val, (int __user *)param); + if (error 0) + break; + if ((val max_part) != 0) { + error = -EINVAL; +

Re: [PATCH 00/33] AutoNUMA27

2012-10-13 Thread Andrea Arcangeli
Hi Srikar, On Sun, Oct 14, 2012 at 12:10:19AM +0530, Srikar Dronamraju wrote: * Andrea Arcangeli aarca...@redhat.com [2012-10-04 01:50:42]: Hello everyone, This is a new AutoNUMA27 release for Linux v3.6. Here results of autonumabenchmark on a 328GB 64 core with ht disabled

<    1   2   3