[PATCH v7 2/4] Input: goodix - Add regulators suppot

2019-03-21 Thread Jagan Teki
Goodix CTP controllers require AVDD28, VDDIO regulators for power-on sequence. The delay between these regualtor operations as per Power-on Timing from datasheet[1] is 0 (T1 >= 0 usec). So, enable and disable these regulators in proper order using normal regulator functions without any delay in

[PATCH v7 4/4] Input: goodix - Add GT5663 CTP support

2019-03-21 Thread Jagan Teki
GT5663 is capacitive touch controller with customized smart wakeup gestures. Add support for it by adding compatible and supported chip data. The chip data on GT5663 is similar to GT1151, like - config data register has 0x8050 address - config data register max len is 240 - config data checksum

[PATCH v7 0/4] input: touchscreen: Add goodix GT5553 CTP support

2019-03-21 Thread Jagan Teki
This is v7 patchset for supporting goodix GT5553 CTP. Here is the previous version[1] Changes for v5: - rebase on linux-next Changes for v5: - document bindings for required regulators, which are need during power-on sequence - enable, disable required regulators as described in power-on

[PATCH v7 1/4] dt-bindings: input: touchscreen: goodix: Document regulator properties

2019-03-21 Thread Jagan Teki
Goodix CTP controllers support analog, digital and gpio regulator supplies on relevant controller pin configurations. Out of which AVDD28 and VDDIO regulators are required in few goodix CTP chips during power-on sequence. AVDD22, DVDD12 regulators have no relevant functionality described from

Re: [PATCH v4 4/4] leds: lm3532: Introduce the lm3532 LED driver

2019-03-21 Thread Lee Jones
On Wed, 20 Mar 2019, Jacek Anaszewski wrote: > Hi Dan, > > I have one minor issue below. > > On 3/13/19 1:32 PM, Dan Murphy wrote: > > Introduce the Texas Instruments LM3532 White LED driver. > > The driver supports ALS configurability or manual brightness > > control. > > > > The driver also

Re: ratelimit API: was: [RFC PATCH] printk: Introduce "store now but print later" prefix.

2019-03-21 Thread Tetsuo Handa
On 2019/03/21 0:25, Petr Mladek wrote: >> This requires serialization among threads using "rs". I already >> proposed ratelimit_reset() for memcg's OOM problem at >> https://lkml.kernel.org/r/201810180246.w9i2koi3011...@www262.sakura.ne.jp >> but it was not accepted. > > IMHO, the main problem

Re: [PATCH] mm/isolation: Remove redundant pfn_valid_within() in __first_valid_page()

2019-03-21 Thread Anshuman Khandual
On 03/21/2019 01:37 PM, Michal Hocko wrote: > On Thu 21-03-19 11:03:18, Anshuman Khandual wrote: >> >> >> On 03/21/2019 10:31 AM, Zi Yan wrote: >>> On 20 Mar 2019, at 21:13, Anshuman Khandual wrote: >>> pfn_valid_within() calls pfn_valid() when CONFIG_HOLES_IN_ZONE making it redundant

Re: [PATCH -next] ubifs: remove unused function __ubifs_shash_final

2019-03-21 Thread Richard Weinberger
Am Donnerstag, 21. März 2019, 08:54:55 CET schrieb Mukesh Ojha: > >> Acked-by: Mukesh Ojha > > I guess you mean Reviewed-by? > > As i am unsure about future scope of this func. i.e why Acked. Acked-by is usually something I expect from the code author or the person that owns the code. Thanks,

[RFC] mm/hotplug: Make get_nid_for_pfn() work with HAVE_ARCH_PFN_VALID

2019-03-21 Thread Anshuman Khandual
Memory hot remove uses get_nid_for_pfn() while tearing down linked sysfs entries between memory block and node. It first checks pfn validity with pfn_valid_within() before fetching nid. With CONFIG_HOLES_IN_ZONE config (arm64 has this enabled) pfn_valid_within() calls pfn_valid(). pfn_valid() is

Re: [PATCH] mm/isolation: Remove redundant pfn_valid_within() in __first_valid_page()

2019-03-21 Thread Michal Hocko
On Thu 21-03-19 11:03:18, Anshuman Khandual wrote: > > > On 03/21/2019 10:31 AM, Zi Yan wrote: > > On 20 Mar 2019, at 21:13, Anshuman Khandual wrote: > > > >> pfn_valid_within() calls pfn_valid() when CONFIG_HOLES_IN_ZONE making it > >> redundant for both definitions (w/wo

My name is Francis Aaron,I have a financial proposal which will benefit both of us.If you are interested,get back to me for more details.Thanks

2019-03-21 Thread Francis Aron

[PATCH] vfs: Convert functionfs to fs_context

2019-03-21 Thread David Howells
Signed-off-by: David Howells cc: Felipe Balbi cc: Michał Nazarewicz cc: linux-...@vger.kernel.org --- drivers/usb/gadget/function/f_fs.c | 232 ++-- 1 file changed, 119 insertions(+), 113 deletions(-) diff --git a/drivers/usb/gadget/function/f_fs.c

[PATCH v3 12/18] locking/lockdep: Remove unnecessary function pointer argument

2019-03-21 Thread Yuyang Du
check_prev_add() always has save_trace() as an input argument, which is unnecessary, so remove it. Signed-off-by: Yuyang Du Reviewed-by: Bart Van Assche --- kernel/locking/lockdep.c | 11 +-- 1 file changed, 5 insertions(+), 6 deletions(-) diff --git a/kernel/locking/lockdep.c

[PATCH v3 07/18] locking/lockdep: Use lockdep_init_task for task initiation consistently

2019-03-21 Thread Yuyang Du
Despite that there is a lockdep_init_task() which does nothing, lockdep initiates tasks by assigning lockdep fields and does so inconsistently. Fix this by using lockdep_init_task(). Signed-off-by: Yuyang Du --- include/linux/lockdep.h | 7 ++- init/init_task.c | 2 ++

[PATCH v3 05/18] locking/lockdep: Print the right depth for chain key colission

2019-03-21 Thread Yuyang Du
Since chains are separated by irq context, so when printing a chain the depth should be consistent with it. Signed-off-by: Yuyang Du --- kernel/locking/lockdep.c | 7 --- 1 file changed, 4 insertions(+), 3 deletions(-) diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c index

[PATCH v3 16/18] locking/lockdep: Combine check_noncircular and check_redundant

2019-03-21 Thread Yuyang Du
These two functions are essentially duplicates, combine them into check_nonexistent(). Also update the comment on it. No functional change. Signed-off-by: Yuyang Du --- kernel/locking/lockdep.c | 31 +++ 1 file changed, 11 insertions(+), 20 deletions(-) diff --git

[PATCH v3 15/18] locking/lockdep: Avoid constant checks in __bfs by using offset reference

2019-03-21 Thread Yuyang Du
In search of a dependency in the lock graph, there is contant checks for forward or backward search. Directly reference the field offset of the struct that differentiates the type of search to avoid those checks. No functional change. Signed-off-by: Yuyang Du --- kernel/locking/lockdep.c | 33

[PATCH v3 06/18] locking/lockdep: Update obsolete struct field description

2019-03-21 Thread Yuyang Du
The lock_chain struct definition has outdated comment, update it and add struct member description. Signed-off-by: Yuyang Du --- include/linux/lockdep.h | 10 -- 1 file changed, 8 insertions(+), 2 deletions(-) diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h index

[PATCH v3 18/18] locking/lockdep: Add explanation to lock usage rules in lockdep design doc

2019-03-21 Thread Yuyang Du
The rules that if violated a deacklock may happen are explained in more detail concerning both irqs and circular dependencies. Signed-off-by: Yuyang Du --- Documentation/locking/lockdep-design.txt | 35 +++- 1 file changed, 25 insertions(+), 10 deletions(-) diff

[PATCH v3 17/18] locking/lockdep: Update comments on dependency search

2019-03-21 Thread Yuyang Du
The breadth-first search is implemented as flat-out non-recursive now, but the comments are still describing it as recursive, update the comments in that regard. Signed-off-by: Yuyang Du --- kernel/locking/lockdep.c | 21 ++--- 1 file changed, 10 insertions(+), 11 deletions(-)

[PATCH v3 11/18] locking/lockdep: Update comment

2019-03-21 Thread Yuyang Du
An out-of-nowhere comment is removed. While at it, add more explanatory comments. Such a trivial patch! Signed-off-by: Yuyang Du --- kernel/locking/lockdep.c | 12 +--- 1 file changed, 9 insertions(+), 3 deletions(-) diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c

[PATCH v3 13/18] locking/lockdep: Change type of the element field in circular_queue

2019-03-21 Thread Yuyang Du
The element field is an array in struct circular_queue to keep track of locks in the search. Making it the same type as the locks avoids type cast. Also fix a typo and elaborate the comment above struct circular_queue. No functional change. Signed-off-by: Yuyang Du Reviewed-by: Bart Van Assche

Re: [PATCH] PM / arch: x86: Rework the MSR_IA32_ENERGY_PERF_BIAS handling

2019-03-21 Thread Peter Zijlstra
On Thu, Mar 21, 2019 at 01:00:52AM +0100, Rafael J. Wysocki wrote: > + * The Performance and Energy Bias Hint (EPB) allows software to specify its > + * preference with respect to the power-performance tradeoffs present in the > + * processor. Generally, the EPB is expected to be set by user

[PATCH v3 09/18] locking/lockdep: Change the range of class_idx in held_lock struct

2019-03-21 Thread Yuyang Du
held_lock->class_idx is used to point to the class of the held lock. The index is shifted by 1 to make index 0 mean no class, which results in class index shifting back and forth but is not worth doing so. The reason is: (1) there will be no "no-class" held_lock to begin with, and (2) index 0

[PATCH v3 10/18] locking/lockdep: Remove unused argument in validate_chain() and check_deadlock()

2019-03-21 Thread Yuyang Du
The lockdep_map argument in them is not used, remove it. Signed-off-by: Yuyang Du Reviewed-by: Bart Van Assche --- kernel/locking/lockdep.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c index

[PATCH v3 14/18] locking/lockdep: Change the return type of __cq_dequeue()

2019-03-21 Thread Yuyang Du
With the change, we can slightly adjust the code to iterate the queue in BFS search, which simplifies the code. No functional change. Signed-off-by: Yuyang Du --- kernel/locking/lockdep.c | 21 + 1 file changed, 13 insertions(+), 8 deletions(-) diff --git

[PATCH v3 08/18] locking/lockdep: Define INITIAL_CHAIN_KEY for chain keys to start with

2019-03-21 Thread Yuyang Du
Chain keys are computed using Jenkins hash function, which needs an initial hash to start with. Dedicate a macro to make this clear and configurable. A later patch changes this initial chain key. Signed-off-by: Yuyang Du --- include/linux/lockdep.h | 1 + init/init_task.c | 2 +-

[PATCH v3 03/18] locking/lockdep: Adjust lock usage bit character checks

2019-03-21 Thread Yuyang Du
The lock usage bit characters are defined and determined with tricks. Use a macro and add some explanation to make it a bit clearer. Then adjust the logic to check the usage, which optimizes the code a bit. No functional change. Signed-off-by: Yuyang Du --- kernel/locking/lockdep.c |

[PATCH v3 02/18] locking/lockdep: Add description and explanation in lockdep design doc

2019-03-21 Thread Yuyang Du
More words are added to lockdep design document regarding key concepts, which helps people understand the design as well as read the reports. Signed-off-by: Yuyang Du --- Documentation/locking/lockdep-design.txt | 80 1 file changed, 60 insertions(+), 20

[PATCH v3 04/18] locking/lockdep: Remove useless conditional macro

2019-03-21 Thread Yuyang Du
Since #defined(CONFIG_PROVE_LOCKING) is used in the scope of #ifdef CONFIG_PROVE_LOCKING, it can be removed. Signed-off-by: Yuyang Du --- kernel/locking/lockdep.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c index

[PATCH v3 00/18] locking/lockdep: Add comments and make some code

2019-03-21 Thread Yuyang Du
Hi Peter, I recently looked at some system hang issues. While at it, I tried to use and understand lockdep. These patches are made as a result. I believe they should have helped me, so hopefully they do for others as well. Many thanks to Bart, Joe, and Peter for their valuable comments. Change

[PATCH v3 01/18] locking/lockdep: Change all print_*() return type to void

2019-03-21 Thread Yuyang Du
Since none of the print_*() function's return value is necessary, change their return type to void. No functional change. In cases where an invariable return value is used, this change slightly improves readability, i.e.: print_x(); return 0; is definitely better than:

Re: [PATCH -next] ubifs: remove unused function __ubifs_shash_final

2019-03-21 Thread Mukesh Ojha
On 3/21/2019 1:48 AM, Richard Weinberger wrote: Am Mittwoch, 20. März 2019, 21:05:37 CET schrieb Mukesh Ojha: On 3/20/2019 7:39 PM, Yue Haibing wrote: From: YueHaibing There is no callers in tree, and can be removed. Signed-off-by: YueHaibing --- fs/ubifs/auth.c | 18

[LKP] [hugetlbfs] 2284cf59cb: BUG:KASAN:global-out-of-bounds_in_f

2019-03-21 Thread kernel test robot
FYI, we noticed the following commit (built with gcc-5): commit: 2284cf59cbcec2f17e50139e2db6d6d761521cd3 ("hugetlbfs: Convert to fs_context") https://git.kernel.org/cgit/linux/kernel/git/viro/vfs.git R48 in testcase: rcutorture with following parameters: runtime: 300s test:

Re: [PATCH v12 1/4] PM / Domains: Add a generic data pointer to the genpd_power_state struct

2019-03-21 Thread Daniel Lezcano
On 27/02/2019 20:58, Ulf Hansson wrote: > Let's add a data pointer to the genpd_power_state struct, to allow a genpd > backend driver to store per state specific data. To introduce the pointer, > we need to change the way genpd deals with freeing of the corresponding > allocated data. > > More

Re: [PATCH] of: Drop redundant check in linker section OF match table

2019-03-21 Thread Mukesh Ojha
On 3/21/2019 1:25 AM, Frank Rowand wrote: On 3/20/19 3:49 AM, Mukesh Ojha wrote: Existing check of `fn` against NULL inside OF match table is redundant. Remove the check. Signed-off-by: Mukesh Ojha Cc: Rob Herring Cc: Frank Rowand Cc: Pantelis Antoniou Cc: devicet...@vger.kernel.org ---

Re: [PATCH v2] staging: rtlwifi: Fix potential NULL pointer dereference of kzalloc

2019-03-21 Thread Dan Carpenter
On Tue, Mar 19, 2019 at 03:15:08PM -0500, Aditya Pakki wrote: > phydm.internal is allocated using kzalloc which is used multiple > times without a check for NULL pointer. This patch avoids such a > scenario. > > -- > v1: Patch collision with different things, fix as per Greg > Signed-off-by:

Re: [PATCH] staging: rtl8712: uninitialized memory in read_bbreg_hdl()

2019-03-21 Thread Dan Carpenter
On Thu, Mar 21, 2019 at 09:26:38AM +0300, Dan Carpenter wrote: > Colin King reported a bug in read_bbreg_hdl(): > > memcpy(pcmd->rsp, (u8 *), pcmd->rspsz); > > The problem is that "val" is uninitialized. > > This code is obviously not useful, but so far as I can tell > "pcmd->cmdcode" is

Re: [PATCH 1/3] mm/sparse: Clean up the obsolete code comment

2019-03-21 Thread Baoquan He
Hi all, On 03/20/19 at 05:58am, Matthew Wilcox wrote: > On Wed, Mar 20, 2019 at 02:36:58PM +0200, Mike Rapoport wrote: > > There are more than a thousand -EEXIST in the kernel, I really doubt all of > > them mean "File exists" ;-) > > And yet that's what the user will see if it's ever printed

Re: [PATCHv2] x86/boot/KASLR: skip the specified crashkernel reserved region

2019-03-21 Thread Chao Fan
On Wed, Mar 13, 2019 at 12:19:31PM +0800, Pingfan Liu wrote: I tested it in Qemu test with 12G memory, and set crashkernel=6G@6G. Without this PATCH, it successed to reserve memory just 4 times(total 10 times). With this PATCH, it successed to reserve memory 15 times(total 15 times). So I think

lening aanvragen

2019-03-21 Thread Simple Federal Credit Union
-- Goedendag,    Wij zijn Simple Federal Credit Union die leningen verstrekt per postadvertentie. Wij bieden verschillende soorten leningen of projecten leningen (korte en lange termijn leningen, persoonlijke leningen, leningen aan bedrijven, enz.) Met 3% rente. dus als u

[PATCH] staging: rtl8712: uninitialized memory in read_bbreg_hdl()

2019-03-21 Thread Dan Carpenter
Colin King reported a bug in read_bbreg_hdl(): memcpy(pcmd->rsp, (u8 *), pcmd->rspsz); The problem is that "val" is uninitialized. This code is obviously not useful, but so far as I can tell "pcmd->cmdcode" is never GEN_CMD_CODE(_Read_BBREG) so it's not harmful either. For now the

Re: [PATCH v2] ALSA: hda/realtek: Enable headset MIC of Acer AIO with ALC286

2019-03-21 Thread Takashi Iwai
On Thu, 21 Mar 2019 03:37:33 +0100, Kailang wrote: > > Yes, you could use Reviewed-by. OK, applied now. Thanks. Takashi > > -Original Message- > From: Jian-Hong Pan > Sent: Wednesday, March 20, 2019 1:06 PM > To: Takashi Iwai > Cc: Kailang ; alsa-de...@alsa-project.org; Linux >

Re: general protection fault in __x86_indirect_thunk_rbx

2019-03-21 Thread Dmitry Vyukov
On Thu, Mar 21, 2019 at 7:08 AM NeilBrown wrote: > > On Wed, Mar 20 2019, syzbot wrote: > > > syzbot has bisected this bug to: > > > > commit dee160df820de41ff2f59a715643680822a0ab06 > > Author: NeilBrown > > Date: Mon Nov 5 01:30:47 2018 + > > > > locks: use properly initialized

Re: general protection fault in __x86_indirect_thunk_rbx

2019-03-21 Thread NeilBrown
On Wed, Mar 20 2019, syzbot wrote: > syzbot has bisected this bug to: > > commit dee160df820de41ff2f59a715643680822a0ab06 > Author: NeilBrown > Date: Mon Nov 5 01:30:47 2018 + > > locks: use properly initialized file_lock when unlocking. This commit did not make it to mainline. It

Re: [PATCH v5 09/14] soc: mediatek: Add basic_clk_name to scp_power_data

2019-03-21 Thread Nicolas Boichat
On Tue, Mar 19, 2019 at 4:02 PM Weiyi Lu wrote: > > Try to stop extending the clk_id or clk_names if there are > more and more new BASIC clocks. To get its own clocks by the > basic_clk_name of each power domain. > > Signed-off-by: Weiyi Lu > --- > drivers/soc/mediatek/mtk-scpsys.c | 27

Re: [PATCH] thunderbolt: Fix to check the return value of kmemdup

2019-03-21 Thread Mika Westerberg
On Tue, Mar 19, 2019 at 01:38:34PM -0500, Aditya Pakki wrote: > uuid in add_switch is allocted via kmemdup which can fail. The patch > logs the error in such a scenario. > > Signed-off-by: Aditya Pakki > --- > drivers/thunderbolt/icm.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git

<    4   5   6   7   8   9