Re: [PATCH V6 02/15] PCI/PME: Export pcie_pme_disable_msi() & pcie_pme_no_msi() APIs

2019-05-17 Thread Vidya Sagar
On 5/18/2019 12:25 AM, Bjorn Helgaas wrote: On Fri, May 17, 2019 at 11:23:36PM +0530, Vidya Sagar wrote: On 5/17/2019 6:54 PM, Bjorn Helgaas wrote: Do you have "lspci -vvxxx" output for the root ports handy? If there's some clue in the standard config space that would tell us that MSI works

Re: [RFC PATCH 4/4] powerpc/ftrace: Additionally nop out the preceding mflr with -mprofile-kernel

2019-05-17 Thread Nicholas Piggin
Naveen N. Rao's on May 18, 2019 5:02 am: > With -mprofile-kernel, gcc emits 'mflr r0', followed by 'bl _mcount' to > enable function tracing and profiling. So far, with dynamic ftrace, we > used to only patch out the branch to _mcount(). However, Nick Piggin > points out that "mflr is executed by

Re: [PATCH V3 0/5] nvme-trace: Add support for fabrics command

2019-05-17 Thread Minwoo Im
On 19-05-12 16:34:08, Minwoo Im wrote: > Hi, > > Here's a third patchset to support fabrics command tracing. The first > patch updated host/trace module to a outside of it to provide common > interfaces for host and target both. The second one adds support for > tracing fabrics command from

Re: [PATCH v3 2/2] initramfs: introduce do_readxattrs()

2019-05-17 Thread Rob Landley
On 5/17/19 4:41 PM, H. Peter Anvin wrote: > On 5/17/19 1:18 PM, h...@zytor.com wrote: >> >> Ok... I just realized this does not work for a modular initramfs, composed >> at load time from multiple files, which is a very real problem. Should be >> easy enough to deal with: instead of one large

[PATCH 5/5] staging: kpc2000: kpc_i2c: fixup block comment style in i2c_driver.c

2019-05-17 Thread Geordan Neukum
Throughout i2c_driver.c, there are numerous deviations from the two standards of: - placing a '*' at the beginning of every line containing a block comment. - placing the closing comment marker '*/' on a new line. Instead, use a block comment style that is more

[PATCH 2/5] staging: kpc2000: kpc_i2c: reformat copyright for better readability

2019-05-17 Thread Geordan Neukum
The copyright header in i2c_driver.c is difficult to read and not chronologically ordered. Reformat and reorganize the copyright header to be similar to other drivers in the i2c subsystem. Signed-off-by: Geordan Neukum --- drivers/staging/kpc2000/kpc_i2c/i2c_driver.c | 30

[PATCH 3/5] staging: kpc2000: kpc_i2c: prevent memory leak in probe() error case

2019-05-17 Thread Geordan Neukum
The probe() function performs a kzalloc to dynamically allocate memory at runtime. If the allocation succeeds, yet invoking the function i2c_add_adapter fails, the dynamically allocated memory is never freed. Change the allocation to use the managed allocation API instead and remove the manual

[PATCH 0/5] Updates to staging driver: kpc_i2c

2019-05-17 Thread Geordan Neukum
Attached are an assortment of updates to the kpc_i2c driver in the staging subtree. As a quick summary: Patches 1, 4, and 5 address style concerns raised by the checkpatch script. Patch 1 (a reindentation fix) likely added additional 'line length' warnings, but given the fact that they were only

[PATCH 1/5] staging: kpc2000: kpc_i2c: reindent i2c_driver.c

2019-05-17 Thread Geordan Neukum
i2c_driver.c uses a mixture of space and tab indentations which conflicts with the kernel coding style guide. Reindent i2c_driver.c. Signed-off-by: Geordan Neukum --- drivers/staging/kpc2000/kpc_i2c/i2c_driver.c | 1014 +- 1 file changed, 507 insertions(+), 507 deletions(-)

[PATCH 4/5] staging: kpc2000: kpc_i2c: use %s with __func__ identifier in log messages

2019-05-17 Thread Geordan Neukum
Throughout i2c_driver.c, there are instances where the log strings contain the function's name hardcoded into the string. Instead, use the printk conversion specifier '%s' with the __func__ preprocessor identifier to more maintainably print the function's name. Signed-off-by: Geordan Neukum ---

Re: [PATCH 4/5] staging: kpc2000: kpc_i2c: use %s with __func__ identifier in log messages

2019-05-17 Thread Joe Perches
On Sat, 2019-05-18 at 02:29 +, Geordan Neukum wrote: > Throughout i2c_driver.c, there are instances where the log strings > contain the function's name hardcoded into the string. Instead, use the > printk conversion specifier '%s' with the __func__ preprocessor > identifier to more

Re: [PATCH 4/5] staging: kpc2000: kpc_i2c: use %s with __func__ identifier in log messages

2019-05-17 Thread Geordan Neukum
On Fri, May 17, 2019 at 07:58:19PM -0700, Joe Perches wrote: > On Sat, 2019-05-18 at 02:29 +, Geordan Neukum wrote: > > Throughout i2c_driver.c, there are instances where the log strings > > contain the function's name hardcoded into the string. Instead, use the > > printk conversion specifier

[GIT PULL] SMB3 Fixes

2019-05-17 Thread Steve French
Please pull the following changes since commit 78d9affbb0e79d48fd82b34ef9cd673a7c86d6f2: Merge tag '5.2-smb3' of git://git.samba.org/sfrench/cifs-2.6 (2019-05-08 13:06:18 -0700) are available in the Git repository at: git://git.samba.org/sfrench/cifs-2.6.git tags/5.2-rc-smb3-fixes for you

Re: [PATCH] block: bio: use struct_size() in kmalloc()

2019-05-17 Thread Jens Axboe
On 5/17/19 6:43 PM, Chaitanya Kulkarni wrote: > - linux-bl...@vger.kernel.org to reduce > the noise. > > I apologies Jens, I didn't apply and tested these patches before > submitting the review and assumed that patches are compiled and > tested, I'll do so for each patch before submitting the

Re: [RFC] Disable lockref on arm64

2019-05-17 Thread Jayachandran Chandrasekharan Nair
On Mon, May 06, 2019 at 07:10:40PM +0100, Will Deacon wrote: > On Mon, May 06, 2019 at 06:13:12AM +, Jayachandran Chandrasekharan Nair > wrote: > > Perhaps someone from ARM can chime in here how the cas/yield combo > > is expected to work when there is contention. ThunderX2 does not > > do

mainline/master boot bisection: v5.1-12505-g0ef0fd351550 on meson-g12a-x96-max

2019-05-17 Thread kernelci.org bot
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * This automated bisection report was sent to you on the basis * * that you may be involved with the breaking commit it has * * found. No manual investigation has been done to verify it, * * and the root cause of the

Re: [PATCH v3 2/2] initramfs: introduce do_readxattrs()

2019-05-17 Thread kbuild test robot
Hi Roberto, Thank you for the patch! Perhaps something to improve: [auto build test WARNING on linus/master] [also build test WARNING on v5.1 next-20190517] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci

<    2   3   4   5   6   7