[PATCH v4 2/2] tools: add script to test udelay

2014-06-16 Thread David Riley
This script makes use of the udelay_test module to exercise udelay() and ensure that it is delaying long enough (as compared to ktime). Signed-off-by: David Riley --- tools/time/udelay_test.sh | 66 +++ 1 file changed, 66 insertions(+) create mode

[PATCH v4 0/2] Add test to validate udelay

2014-06-16 Thread David Riley
- update commit message to indicate what this test targets - fixed checkpatch whitespace error - rebased Changes since v3: - fixed xtensa compile warning (and other 32-bit platforms which use the generic do_div) - renamed and moved config option David Riley (2): kernel: time: Add udelay_test

Re: [PATCH] time: Rename udelay_test.c to test_udelay.c

2014-08-06 Thread David Riley
tephen Rothwell > Cc: Thomas Gleixner > Cc: Ingo Molnar > Cc: Linux-Next > Cc: David Riley > Signed-off-by: John Stultz Acked-by: David Riley > --- > kernel/time/Makefile | 2 +- > kernel/time/test_udelay.c | 168 > +

Re: [PATCH v2] tools/time: access /sys/kernel/debug/udelay_test before test

2020-10-21 Thread David Riley
Reviewed-by: David Riley On Wed, Oct 21, 2020 at 8:05 AM Hui Su wrote: > > before(when i did not compile udelay_test.ko): > sh@ubuntu:~/workspace/compile/tools/time$ sudo ./udelay_test.sh > ./udelay_test.sh: line 25: /sys/kernel/debug/udelay_test: Permission denied > ./udelay_t

Re: [PATCH] drm/virtio: Use vmalloc for command buffer allocations.

2019-09-03 Thread David Riley
On Sun, Sep 1, 2019 at 10:28 PM Gerd Hoffmann wrote: > > On Fri, Aug 30, 2019 at 10:49:25AM -0700, David Riley wrote: > > Hi Gerd, > > > > On Fri, Aug 30, 2019 at 4:16 AM Gerd Hoffmann wrote: > > > > > > Hi, > > > > > > > > >

[PATCH v4 2/2] drm/virtio: Use vmalloc for command buffer allocations.

2019-09-11 Thread David Riley
Userspace requested command buffer allocations could be too large to make as a contiguous allocation. Use vmalloc if necessary to satisfy those allocations. Signed-off-by: David Riley --- drivers/gpu/drm/virtio/virtgpu_ioctl.c | 4 +- drivers/gpu/drm/virtio/virtgpu_vq.c| 78

[PATCH v1 1/1] power: Add simple gpio-restart driver

2014-08-26 Thread David Riley
This driver registers a restart handler to set a GPIO line high/low to reset a board based on devicetree bindings. Signed-off-by: David Riley --- .../devicetree/bindings/gpio/gpio-restart.txt | 48 +++ drivers/power/reset/Kconfig| 8 ++ drivers/power/reset

[PATCH v1 0/1] gpio-restart restart handler

2014-08-26 Thread David Riley
/patch/4746721/ https://patchwork.kernel.org/patch/4746731/ https://patchwork.kernel.org/patch/4747011/ https://patchwork.kernel.org/patch/4746741/ https://patchwork.kernel.org/patch/4746861/ David Riley (1): power: Add simple gpio-restart driver .../devicetree/bindings/gpio/gpio-restart.txt

Re: [PATCH v1 1/1] power: Add simple gpio-restart driver

2014-08-27 Thread David Riley
Hi Sebastian, Thanks for the feedback. On Tue, Aug 26, 2014 at 6:43 PM, Sebastian Reichel wrote: > Hi David, > > On Tue, Aug 26, 2014 at 04:45:05PM -0700, David Riley wrote: >> This driver registers a restart handler to set a GPIO line high/low >> to reset a board based o

Re: [PATCH v1 1/1] power: Add simple gpio-restart driver

2014-08-27 Thread David Riley
Hi Olof, On Tue, Aug 26, 2014 at 7:14 PM, Olof Johansson wrote: > Hi, > > > > On Tue, Aug 26, 2014 at 4:45 PM, David Riley wrote: >> This driver registers a restart handler to set a GPIO line high/low >> to reset a board based on devicetree bindings. >&

Re: [PATCH v1 1/1] power: Add simple gpio-restart driver

2014-08-27 Thread David Riley
On Tue, Aug 26, 2014 at 7:40 PM, Guenter Roeck wrote: > On 08/26/2014 04:45 PM, David Riley wrote: >> >> This driver registers a restart handler to set a GPIO line high/low >> to reset a board based on devicetree bindings. >> >> Signed-off-by: David Riley >>

[PATCH v2 1/1] power: Add simple gpio-restart driver

2014-08-27 Thread David Riley
This driver registers a restart handler to set a GPIO line high/low to reset a board based on devicetree bindings. Signed-off-by: David Riley --- .../devicetree/bindings/gpio/gpio-restart.txt | 54 drivers/power/reset/Kconfig| 8 ++ drivers/power/reset

[PATCH v2 0/1] gpio-restart restart handler

2014-08-27 Thread David Riley
- Changed priority property from u8 type to standard u32 - Rename input property to open-source - Made delays configurable from binding - Removed unneeded BUG_ON - Used devm_gpiod_get flags parameter to configure initial direction David Riley (1): power: Add simple gpio

Re: [PATCH v4 02/16] clk: tegra: Add library for the DFLL clock source (open-loop mode)

2014-08-27 Thread David Riley
Hi Tuomas, A bunch of small nit picks from me. On Wed, Aug 20, 2014 at 2:04 PM, Tuomas Tynkkynen wrote: > Add shared code to support the Tegra DFLL clocksource in open-loop > mode. This root clocksource is present on the Tegra124 SoCs. The > DFLL is the intended primary clock source for the

Re: [PATCH 01/12] time: Rename udelay_test.c to test_udelay.c

2014-11-24 Thread David Riley
Cc: Stephen Rothwell > Cc: Thomas Gleixner > Cc: Ingo Molnar > Cc: Linux-Next > Cc: David Riley > Signed-off-by: John Stultz Reviewed-by: David Riley -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord..

[PATCH] kernel: time: Modify test_udelay to allow for 1% tolerance.

2017-02-20 Thread David Riley
details: http://lists.openwall.net/linux-kernel/2011/01/12/372 Cc: John Stultz Cc: Thomas Gleixner Cc: Russell King Signed-off-by: David Riley --- kernel/time/test_udelay.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/kernel/time/test_udelay.c b/kernel/time

<    1   2