[PATCHv2 1/2] pwm: vt8500: Register write busy test performed incorrectly

2013-01-02 Thread Tony Prisk
. Change pwm_busy_wait() to use readl rather than readb. Improve readability of code with defines for registers and bitfields. Signed-off-by: Tony Prisk --- v2: Change parenthesis around defines Replace pr_warn with dev_warn in pwm_busy_wait() drivers/pwm/pwm-vt8500.c | 64

[PATCH 4/4] video: vt8500: Update descriptions in video/Kconfig

2013-01-02 Thread Tony Prisk
This patch updates the descriptions for the VIA VT8500 and Wondermedia WM8xxx-series framebuffer drivers to correctly reflect which hardware they support. Signed-off-by: Tony Prisk --- drivers/video/Kconfig |9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/drivers

[PATCH 1/4] drivers/video/wm8505fb.c: use devm_ functions

2013-01-02 Thread Tony Prisk
block of error-handling code that needs to call fb_dealloc_cmap, and so this is moved up to the place where it is needed, eliminating the need for all gotos and labels in the function. This was suggested by Tony Prisk. The initializations of fbi and ret at the beginning of the function

[PATCH 3/4] video: vt8500: Remove unused platform_data/video-vt8500lcdfb.h

2013-01-02 Thread Tony Prisk
With the conversion to devicetree only for arch-vt8500, this header is no longer required. This patch removes the #include from the two framebuffer drivers that used it, and the header file. Signed-off-by: Tony Prisk --- drivers/video/vt8500lcdfb.c |2 -- drivers/video

[PATCH 2/4] video: vt8500: Make wmt_ge_rops optional

2013-01-02 Thread Tony Prisk
At the moment, accelerated raster ops are always enabled on VT8500 and WM8xxx series SoCs. This patch makes them optional. Signed-off-by: Tony Prisk --- drivers/video/Kconfig | 23 +-- drivers/video/vt8500lcdfb.c | 15 +++ drivers/video/wm8505fb.c

[PATCH] gpio: vt8500: memory cleanup missing

2013-01-02 Thread Tony Prisk
with dev_err in vt8500_add_chips since the device is available. There is also no .remove callback defined. To allow removing the registered chips, I have moved *vtchip to be a static global. Signed-off-by: Tony Prisk --- drivers/gpio/gpio-vt8500.c | 53

[PATCH 0/2] Move some mach-vt8500 functions to new directories

2013-01-02 Thread Tony Prisk
and clocksource so maybe he wants to take both. CC: John Stultz CC: Thomas Gleixner Tony Prisk (2): timer: vt8500: Move system timer to clocksource irqchip: vt8500: Move irq code to drivers/irqchip arch/arm/mach-vt8500/Kconfig |1 + arch/arm/mach-vt8500/Makefile |2 +- arch

[PATCH 1/2] timer: vt8500: Move system timer to clocksource

2013-01-02 Thread Tony Prisk
Move mach-vt8500/timer.c to drivers/clocksource/vt8500_timer.c and make necessary changes to Kconfig and Makefile. vt8500_timer is moved from vt8500.c to clocksource/vt8500_timer.c and added to common.h for reference from the board descriptor. Signed-off-by: Tony Prisk --- CC: John Stultz CC

[PATCH 2/2] irqchip: vt8500: Move irq code to drivers/irqchip

2013-01-02 Thread Tony Prisk
Move mach-vt8500/irq.c to drivers/irqchip/irq-vt8500.c and make necessary Makefile changes. No code changes required. Signed-off-by: Tony Prisk --- CC: Thomas Gleixner arch/arm/mach-vt8500/Makefile |2 +- arch/arm/mach-vt8500/common.h |7 +- arch/arm/mach-vt8500/irq.c| 253

Re: [PATCH 2/2] irqchip: vt8500: Move irq code to drivers/irqchip

2013-01-02 Thread Tony Prisk
On Wed, 2013-01-02 at 22:38 -0600, Rob Herring wrote: > > CC: Thomas Gleixner > > arch/arm/mach-vt8500/Makefile |2 +- > > arch/arm/mach-vt8500/common.h |7 +- > > arch/arm/mach-vt8500/irq.c| 253 > > - > > drivers/irqchip/Makefile |

[PATCH 4/4 v3] serial: tty: Cleanup code using devm_ function

2013-01-16 Thread Tony Prisk
Convert the last memory allocation (vt8500_port) to use devm_kzalloc and remove the fail path cleanup code from vt8500_serial_probe. Reorder iomem mapping above clk_enable to simplify fail code. The clock is only enabled if all other resources are available. Signed-off-by: Tony Prisk

[PATCH 1/4 v3] serial: vt8500: Fix range-checking on vt8500_uart_ports

2013-01-16 Thread Tony Prisk
Fix two instances where the index to vt8500_uart_ports is tested against > VT8500_MAX_PORTS. Correct usage should be >= VT8500_MAX_PORTS. Signed-off-by: Tony Prisk --- drivers/tty/serial/vt8500_serial.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drive

[GIT PULL v3] Fixes/cleanup for vt8500 serial

2013-01-16 Thread Tony Prisk
ver ---- Tony Prisk (4): serial: vt8500: Fix range-checking on vt8500_uart_ports serial: vt8500: ioremap'd resource is never freed serial: vt8500: UART uses gated clock rather than 24Mhz reference serial: tty: Cleanup code using devm_ function arch/arm/boot/dts/vt8500.d

[PATCH 2/4 v3] serial: vt8500: ioremap'd resource is never freed

2013-01-16 Thread Tony Prisk
Memory mapped via ioremap call is never released. Rather than add an iounmap call, change allocation function to devm_request_and_ioremap. Also, change the error on failure for this call to -EADDRNOTAVAIL rather than -ENOMEM. Signed-off-by: Tony Prisk --- drivers/tty/serial/vt8500_serial.c

[PATCH 3/4 v3] serial: vt8500: UART uses gated clock rather than 24Mhz reference

2013-01-16 Thread Tony Prisk
, enables the clock in probe. This change removes the fallback when a clock was not specified as it doesn't apply any longer (and would only work if the UART clock was already enabled). DTSI files are updated for VT8500, WM8505 and WM8650. Signed-off-by: Tony Prisk --- arch/arm/boot/dts/vt8500

Re: [PATCH] tty: serial/vt8500_serial.c: fix bug caused by missing "{}"

2013-01-16 Thread Tony Prisk
On Wed, 2013-01-16 at 23:25 +0100, Cong Ding wrote: > It is obviously here should be braced by "{}" in the "if" branch (more than 1 > line in the "if" branch), and by the > coding style document of the kernel I also add "{}" to the else branch. > > Signed-off-by: Cong Ding > --- >

[PATCH 3/4 v4] serial: vt8500: UART uses gated clock rather than 24Mhz reference

2013-01-17 Thread Tony Prisk
, enables the clock in probe. This change removes the fallback when a clock was not specified as it doesn't apply any longer (and would only work if the UART clock was already enabled). DTSI files are updated for VT8500, WM8505 and WM8650. Signed-off-by: Tony Prisk --- arch/arm/boot/dts/vt8500

[PATCH RESEND] Fixes/Cleanup for vt8500 serial driver

2013-01-17 Thread Tony Prisk
Apologies Greg, Stupid mistake. This is a resend of the two patches you sent back as 'me being useless'. Tidied up now. Regards Tony P -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at

[PATCH 4/4 v4] serial: tty: Cleanup code using devm_ function

2013-01-17 Thread Tony Prisk
Convert the last memory allocation (vt8500_port) to use devm_kzalloc and remove the fail path cleanup code from vt8500_serial_probe. Reorder iomem mapping above clk_enable to simplify fail code. The clock is only enabled if all other resources are available. Signed-off-by: Tony Prisk

[PATCH v3] gpio: vt8500: memory cleanup missing

2013-01-17 Thread Tony Prisk
with dev_err in vt8500_add_chips since the device is available. There is also no .remove callback defined so the function is added. Signed-off-by: Tony Prisk --- v2: Remove global vtchip and store pointer in platform_data - As pointed out by Russell King. v3: Following problems pointed out by Grant

Re: [PATCH 5/7] clk: vt8500: Use common of_clk_init() function

2013-01-18 Thread Tony Prisk
before I take this in? > Tested-by: Tony Prisk FYI: This will need another patch to complete as we added another set of clocks to this clk-vt8500.c for 3.9. > Thanks, > Mike > > > --- > > drivers/clk/clk-vt8500.c | 15 --- > > 1 files changed, 4 inser

[PATCH 3/4] video: vt8500: Remove unused platform_data/video-vt8500lcdfb.h

2013-01-18 Thread Tony Prisk
With the conversion to devicetree only for arch-vt8500, this header is no longer required. This patch removes the #include from the two framebuffer drivers that used it, and the header file. Signed-off-by: Tony Prisk --- drivers/video/vt8500lcdfb.c |2 -- drivers/video

[PATCH 2/4] video: vt8500: Make wmt_ge_rops optional

2013-01-18 Thread Tony Prisk
At the moment, accelerated raster ops are always enabled on VT8500 and WM8xxx series SoCs. This patch makes them optional. Signed-off-by: Tony Prisk --- drivers/video/Kconfig | 23 +-- drivers/video/vt8500lcdfb.c | 15 +++ drivers/video/wm8505fb.c

[PATCH 4/4] video: vt8500: Update descriptions in video/Kconfig

2013-01-18 Thread Tony Prisk
This patch updates the descriptions for the VIA VT8500 and Wondermedia WM8xxx-series framebuffer drivers to correctly reflect which hardware they support. Signed-off-by: Tony Prisk --- drivers/video/Kconfig |9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/drivers

[GIT PULL] video: vt8500: Cleanup for 3.9

2013-01-18 Thread Tony Prisk
Hi Florian, This is a series of patches for the vt8500 framebuffer driver. Mostly cleanup stuff. Non-cleanup: video: vt8500: Make wmt_ge_rops optional - This patch makes hardware accelerated raster ops optional as it doesn't work on the newly added WM8850 (yet). Regards Tony Prisk

[PATCH 1/4] drivers/video/wm8505fb.c: use devm_ functions

2013-01-18 Thread Tony Prisk
block of error-handling code that needs to call fb_dealloc_cmap, and so this is moved up to the place where it is needed, eliminating the need for all gotos and labels in the function. This was suggested by Tony Prisk. The initializations of fbi and ret at the beginning of the function

[PATCH] rtc: vt8500: Fix year field in vt8500_rtc_set_time

2013-01-18 Thread Tony Prisk
year field is incorrectly masked when setting the date. If the year is beyond 2099, the year field will be incorrectly updated in hardware. This patch masks the year field correctly. Signed-off-by: Edgar Toernig Signed-off-by: Tony Prisk --- Hi Andrew, This patch has been floating around

[PATCH] dts: vt8500: Add initial dts support for WM8850

2013-01-18 Thread Tony Prisk
This patch adds a soc dtsi for the Wondermedia WM8850. A board dts file is also included for the W70v2 tablet, with support for all the drivers currently in mainline. Signed-off-by: Tony Prisk --- Hi Olof, Sorry this is a bit late. Regards Tony P arch/arm/boot/dts/Makefile |3

[RFC PATCH] Add pin control driver for Wondermedia SoCS

2013-02-14 Thread Tony Prisk
this part of the design from the Tegra pinctrl driver. Regards Tony Prisk Tony Prisk (1): pinctrl: gpio: vt8500: Add pin control driver for Wondermedia SoCs arch/arm/Kconfig |4 +- arch/arm/boot/dts/wm8850-w70v2.dts | 15 + arch/arm/boot/dts/wm8850.dtsi |7

[PATCH] pinctrl: gpio: vt8500: Add pin control driver for Wondermedia SoCs

2013-02-14 Thread Tony Prisk
Signed-off-by: Tony Prisk --- arch/arm/Kconfig |4 +- arch/arm/boot/dts/wm8850-w70v2.dts | 15 + arch/arm/boot/dts/wm8850.dtsi |7 +- arch/arm/mach-vt8500/Kconfig |1 + drivers/pinctrl/Kconfig| 10 + drivers/pinctrl/Makefile

Re: [PATCH] arm, vt8500, LLVMLlinux: Use mcr instead of mcr% for mach-vt8500

2014-09-24 Thread Tony Prisk
l request to arm-soc, or should we apply it to fixes-non-critical directly? Arnd Arnd, You can apply it directly to fixes-non-critical if that's ok. Regards Tony Prisk -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@

[PATCH v2] i2c: vt8500: Add support for I2C bus on Wondermedia SoCs

2013-06-12 Thread Tony Prisk
This patch adds support for the I2C bus controllers found on Wondermedia 8xxx-series SoCs. Only master-mode is supported. Signed-off-by: Tony Prisk --- .../devicetree/bindings/i2c/i2c-vt8500.txt | 24 + MAINTAINERS|1 + drivers/i2c/busses

[PATCH v3] i2c: vt8500: Add support for I2C bus on Wondermedia SoCs

2013-06-14 Thread Tony Prisk
This patch adds support for the I2C bus controllers found on Wondermedia 8xxx-series SoCs. Only master-mode is supported. Signed-off-by: Tony Prisk --- v3 changes: Included the v2 changes for clarity. Tidy up the I2C_NO_START code properly. Remove the alias handling and allow the core to do

Re: [PATCH] pinctrl: vt8500: Ensure value reg is updated when setting direction

2014-04-30 Thread Tony Prisk
int value) +{ + wmt_gpio_set_value(chip, offset, value); + return pinctrl_gpio_direction_output(chip->base + offset); +} + static struct gpio_chip wmt_gpio_chip = { .label = "gpio-wmt", .owner = THIS_MODULE, Acked-by: Tony Prisk Didn't notice that this was an opti

<    3   4   5   6   7   8