Re: [PATCH] checkpatch: types found in one source file do not affect processing of others

2015-05-18 Thread Alex Dowad
On 18/05/15 20:42, Joe Perches wrote: On Mon, 2015-05-18 at 15:33 +0200, Alex Dowad wrote: checkpatch uses various cues in its input files to discover the names of user-defined types. It then uses that information when processing expressions, to discover more style issues. Unfortunately, in

[PATCH] checkpatch: types found in one source file do not affect processing of others

2015-05-18 Thread Alex Dowad
roper use of the pointer dereference operator! Therefore, keep user-defined types in a separate array from built-in ones, and reset the array of user-defined types at the beginning of each new source file. Signed-off-by: Alex Dowad --- Dear patch checkers, I am not a Perl programmer -- please let me

[PATCH] Remove empty branch from conditional

2015-05-17 Thread Alex Dowad
This fixes a checkpatch style warning in ft1000_ioctl. Signed-off-by: Alex Dowad --- drivers/staging/ft1000/ft1000-usb/ft1000_debug.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/ft1000/ft1000-usb/ft1000_debug.c b/drivers/staging/ft1000/ft1000-usb

[PATCH] Clarify expression which uses both multiplication and pointer dereference

2015-05-17 Thread Alex Dowad
This fixes a checkpatch style error in vpfe_buffer_queue_setup. Signed-off-by: Alex Dowad --- drivers/staging/media/davinci_vpfe/vpfe_video.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/media/davinci_vpfe/vpfe_video.c b/drivers/staging/media/davinci_vpfe

[PATCH] sched/fair: correct inaccurate comment in __update_group_entity_contrib

2015-04-05 Thread Alex Dowad
Signed-off-by: Alex Dowad --- kernel/sched/fair.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c index bcfe320..1bae5ea 100644 --- a/kernel/sched/fair.c +++ b/kernel/sched/fair.c @@ -2648,7 +2648,7 @@ static inline void

[PATCH 03/32v2] arc: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-25 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity. Signed-off-by: Alex Dowad --- arch/arc/kernel/process.c | 9 ++--- 1 file changed, 6 insertions(+), 3 deletions(-) diff --git a/arch/ar

Re: [PATCH 03/32] arc: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-25 Thread Alex Dowad
On 25/03/15 13:47, Vineet Gupta wrote: On Friday 13 March 2015 11:35 PM, Alex Dowad wrote: The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and

Re: [23/32] powerpc: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-24 Thread Alex Dowad
On 20/03/15 01:54, Michael Ellerman wrote: On Thu, 2015-03-19 at 09:22 +0200, Alex Dowad wrote: On 19/03/15 08:45, Michael Ellerman wrote: On Fri, 2015-13-03 at 18:14:46 UTC, Alex Dowad wrote: The 'arg' argument to copy_thread() is only ever used when forking a new kernel thr

Re: [23/32] powerpc: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-19 Thread Alex Dowad
On 19/03/15 08:45, Michael Ellerman wrote: On Fri, 2015-13-03 at 18:14:46 UTC, Alex Dowad wrote: The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and

Re: [PATCH 28/32] tile: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-16 Thread Alex Dowad
On 16/03/15 22:19, Chris Metcalf wrote: On 3/13/2015 2:14 PM, Alex Dowad wrote: The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specifi

Re: [PATCHv2 16/32] metag: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-16 Thread Alex Dowad
On 16/03/15 16:31, James Hogan wrote: Hi Alex, On 16/03/15 13:13, Alex Dowad wrote: The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity. Signed-off-by: Alex Dowad --- James Hogan, Thank

[PATCHv3 16/32] metag: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-16 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity. Signed-off-by: Alex Dowad --- Fixed problem with whitespace, sending again. AD arch/metag/kernel/process.c | 8 ++-- 1 file changed

[PATCHv2 16/32] metag: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-16 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity. Signed-off-by: Alex Dowad --- James Hogan, Thanks for reviewing this patch. The comment has been updated as you suggested. You said: &quo

[PATCHv2 06/32] avr32: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-16 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity. Signed-off-by: Alex Dowad --- Dear Hans-Christian Egtvedt, Thanks for your feedback! I have removed the unneeded comments. AD arch/av

Re: [PATCH 13/32] ia64: copy_thread(): rename 'user_stack_size' argument to 'kthread_arg'

2015-03-14 Thread Alex Dowad
Sorry, this patch was in error. (I learned about the IA64-only clone2 syscall too late.) Please disregard. Thanks! Alex Dowad On 13/03/15 20:14, Alex Dowad wrote: 'user_stack_size' is very misleading, since the argument is never used for the size of the user stack. Rather, it is a

Re: [PATCH 01/32] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-14 Thread Alex Dowad
On 14/03/15 01:21, David Rientjes wrote: On Fri, 13 Mar 2015, j...@joshtriplett.org wrote: On Fri, Mar 13, 2015 at 08:04:16PM +0200, Alex Dowad wrote: The 'stack_size' argument is never used to pass a stack size. It's only used when forking a kernel thread, in which case it

Re: [PATCH 01/32] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-14 Thread Alex Dowad
On 14/03/15 01:04, j...@joshtriplett.org wrote: On Fri, Mar 13, 2015 at 08:04:16PM +0200, Alex Dowad wrote: The 'stack_size' argument is never used to pass a stack size. It's only used when forking a kernel thread, in which case it is an argument which should be passed to the

[PATCH 17/32] microblaze: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/microblaze/k

[PATCH 21/32] openrisc: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/openrisc/

[PATCH 19/32] mn10300: copy_thread(): rename 'ustk_size' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
'ustk_size' is misleading, since this argument is never used for a user stack size. Rather, it is an argument passed to the main function executed by a new kernel thread. Therefore, rename it to 'kthread_arg'. Signed-off-by: Alex Dowad --- arch/mn10300/kernel/process.c | 1

[PATCH 14/32] m32r: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/m32r/k

[PATCH 29/32] um: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/um/

[PATCH 30/32] unicore32: copy_thread(): rename 'stk_sz' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
'stk_sz' is misleading, since this argument is never used for a stack size. Rather, it is an argument passed to the main function executed by a new kernel thread. Therefore, rename it to 'kthread_arg'. Signed-off-by: Alex Dowad --- arch/unicore32/kernel/process.c | 9 +

[PATCH 27/32] sparc: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/sparc/kern

[PATCH 28/32] tile: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/tile/k

[PATCH 25/32] score: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/score/

[PATCH 23/32] powerpc: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/powerpc/

[PATCH 31/32] x86: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/x86/ker

[PATCH 32/32] xtensa: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
Rename the 'thread_fn_arg' it to 'kthread_arg' for consistency with do_fork() and other arch-specific implementations of copy_thread(). Signed-off-by: Alex Dowad --- arch/xtensa/kernel/process.c | 11 ++- 1 file changed, 6 insertions(+), 5 deletions(-) diff --git

[PATCH 26/32] sh: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/sh/kern

[PATCH 16/32] metag: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/metag/

[PATCH 18/32] mips: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/mips/k

[PATCH 11/32] frv: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/frv/kernel/proc

[PATCH 13/32] ia64: copy_thread(): rename 'user_stack_size' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
he kernel thread arg was (uselessly) added to the new user stack pointer. This "worked", since the kernel thread arg is always zero when forking a user thread, but it was obviously not intended. Signed-off-by: Alex Dowad --- arch/ia64/kernel/process.c | 11 +++ 1 file changed

[PATCH 12/32] hexagon: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/hexagon/

[PATCH 15/32] m68k: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/m68k/

[PATCH 20/32] nios2: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/nios2/k

[PATCH 24/32] s390: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/s390/

[PATCH 22/32] parisc: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/parisc/k

[PATCH 10/32] cris/arch-v32: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/cris/arch-v32/

[PATCH 07/32] blackfin: copy_thread(): rename 'topstk' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
'topstk' is a misnomer: it is not a pointer to the top of a stack. Rather, it is an argument passed to the main function executed by a new kernel thread. Signed-off-by: Alex Dowad --- arch/blackfin/kernel/process.c | 9 +++-- 1 file changed, 7 insertions(+), 2 deletions(-) di

[PATCH 01/32] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-13 Thread Alex Dowad
The 'stack_size' argument is never used to pass a stack size. It's only used when forking a kernel thread, in which case it is an argument which should be passed to the 'main' function which the kernel thread executes. Hence, rename it to 'kthread_arg'. Signe

[PATCH 06/32] avr32: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/avr32/

[PATCH 04/32] arm: copy_thread(): rename 'stk_sz' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
'stk_sz' is a misnomer: it is never used for a stack size. Rather, it is an argument which is passed to the main function executed by a kernel thread, when forking a new kthread. The most appropriate name is 'kthread_arg'. Signed-off-by: Alex Dowad --- arch/arm/kernel/proces

[PATCH 09/32] cris/arch-v10: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/cris/arch-v10/

[PATCH 08/32] c6x: copy_thread(): rename 'ustk_size' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
'ustk_size' is a misnomer: it is never used for the size of the user stack. It is only used when forking a new kernel thread, as the argument passed to the kthread's main function. Signed-off-by: Alex Dowad --- arch/c6x/kernel/process.c | 8 1 file changed, 4 i

[PATCH 03/32] arc: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/arc/

[PATCH 05/32] arm64: copy_thread(): rename 'stk_sz' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
'stk_sz' is a misnomer: it is never used for a stack size. Rather, it is an argument which is passed to the main function executed by a kernel thread, when forking a new kthread. The most appropriate name is 'kthread_arg'. Signed-off-by: Alex Dowad --- arch/arm64/

[PATCH 02/32] alpha: copy_thread(): rename 'arg' argument to 'kthread_arg'

2015-03-13 Thread Alex Dowad
The 'arg' argument to copy_thread() is only ever used when forking a new kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency with do_fork() and other arch-specific implementations of copy_thread()). Signed-off-by: Alex Dowad --- arch/alpha/

Re: [PATCH] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-05 Thread Alex Dowad
On 05/03/15 22:29, David Rientjes wrote: On Thu, 5 Mar 2015, Alex Dowad wrote: diff --git a/kernel/fork.c b/kernel/fork.c index cf65139..b38a2ae 100644 --- a/kernel/fork.c +++ b/kernel/fork.c @@ -1186,10 +1186,12 @@ init_task_pid(struct task_struct *task, enum pid_type type, struct pid *pid

Re: [PATCH] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-05 Thread Alex Dowad
On 05/03/15 01:07, David Rientjes wrote: On Wed, 4 Mar 2015, Alex Dowad wrote: The 'stack_size' argument is never used to pass a stack size. It's only used when forking a kernel thread, in which case it is an argument which should be passed to the 'main' functio

[PATCH] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-04 Thread Alex Dowad
The 'stack_size' argument is never used to pass a stack size. It's only used when forking a kernel thread, in which case it is an argument which should be passed to the 'main' function which the kernel thread executes. Hence, rename it to 'kthread_arg'.