Recommended driver for current AMD processors

2018-12-07 Thread Paul Menzel
Dear Linux folks, What driver is recommended for current AMD Ryzen based processors like *AMD Ryzen 5 PRO 1500 Quad-Core Processor* or *AMD EPYC 7601 32-Core Processor*? Only from the acpi-cpufreq Kconfig description, I assume, that that driver should be used. > config X86_ACPI_CPUFREQ >

Re: What happens before or in `schedule_preempt_disabled()`?

2018-10-17 Thread Paul Menzel
Dear Thomas, As always thank you for the quick reply. On 10/17/18 18:39, Thomas Gleixner wrote: > On Wed, 17 Oct 2018, Paul Menzel wrote: >> >> Please find the debug patches attached. The `random: %i` messages are from >> `crng_fast_load()`. >> >> My questi

Re: [PATCH] x86/mm: Do not warn about PCI BIOS W+X mappings

2018-10-11 Thread Paul Menzel
is not in the context of the WX checking output. Reported-by: Paul Menzel Signed-off-by: Thomas Gleixner Cc: Joerg Roedel Cc: Kees Cook Cc: Bjorn Helgaas --- arch/x86/mm/dump_pagetables.c | 35 +++ 1 file changed, 27 insertions(+), 8 deletions(-) Thank you

unwind_init() takes 100 ms

2018-10-08 Thread Paul Menzel
Dear Josh, dear Linux folks, Trying to decrease the boot time of the 64-bit Linux kernel (Linux 4.19-rc7 (0238df64)) on a Asus F2A85-M PRO with an AMD processor, I noticed `unwind_init()` called from `setup_arch()` `arch/x86/kernel/setup.c` takes over 100 ms to initialize according to Linux

Re: x86/mm: Found insecure W+X mapping at address (ptrval)/0xc00a0000

2018-10-05 Thread Paul Menzel
Dear Thomas, On 10/05/18 11:27, Thomas Gleixner wrote: > On Thu, 4 Oct 2018, Joerg Roedel wrote: > >> On Wed, Oct 03, 2018 at 11:22:55PM +0200, Borislav Petkov wrote: >>> On Fri, Sep 28, 2018 at 04:55:19PM +0200, Thomas Gleixner wrote: Sorry for the delay and thanks for the data. A quick

Re: x86/mm: Found insecure W+X mapping at address (ptrval)/0xc00a0000

2018-10-04 Thread Paul Menzel
Dear Borislav, On 10/04/18 12:54, Borislav Petkov wrote: > On Thu, Oct 04, 2018 at 10:59:18AM +0200, Paul Menzel wrote: >> I meant just the test you did. > > https://lkml.kernel.org/r/20181003212255.gb28...@zn.tnic I see. But there you write, the machine does boot. While

Re: x86/mm: Found insecure W+X mapping at address (ptrval)/0xc00a0000

2018-10-04 Thread Paul Menzel
Dear Borislav, On 10/04/18 10:49, Borislav Petkov wrote: > On Thu, Oct 04, 2018 at 10:40:49AM +0200, Paul Menzel wrote: >> Do you have a commit, I could test. > > Not yet I meant just the test you did. > but I have a question for you: why are you running 32-bit and > ha

Re: x86/mm: Found insecure W+X mapping at address (ptrval)/0xc00a0000

2018-10-04 Thread Paul Menzel
Dear Borislav, On 10/04/18 10:14, Borislav Petkov wrote: > On Thu, Oct 04, 2018 at 10:03:21AM +0200, Joerg Roedel wrote: >> I also triggered this when working in the PTI-x32 code. It always >> happens on a 32-bit PAE kernel for me. >> >> Tracking it down I ended up in (iirc)

Re: Symbols not found for some files

2018-10-03 Thread Paul Menzel
Dear Arnaldo, Am 03.10.2018 um 22:57 schrieb Arnaldo Carvalho de Melo: Em Wed, Oct 03, 2018 at 10:42:39PM +0200, Paul Menzel escreveu: For profiling the boot on my Debian Sid/unstable system (32-bit user space), the following service unit is used. You forgot to mention what is the version

Re: x86/mm: Found insecure W+X mapping at address (ptrval)/0xc00a0000

2018-10-03 Thread Paul Menzel
Dear Borislav, Am 03.10.2018 um 23:22 schrieb Borislav Petkov: On Fri, Sep 28, 2018 at 04:55:19PM +0200, Thomas Gleixner wrote: Sorry for the delay and thanks for the data. A quick diff did not reveal anything obvious. I'll have a closer look and we probably need more (other) information to

Symbols not found for some files

2018-10-03 Thread Paul Menzel
Dear Linux folks, For profiling the boot on my Debian Sid/unstable system (32-bit user space), the following service unit is used. ``` $ systemctl cat perf # /etc/systemd/system/perf.service [Unit] Description=Perf 10 s DefaultDependencies=no [Service] ExecStart=/usr/local/bin/perf record

Re: How to debug outliers in `wb_wait_for_completion()` in `ksys_sync()`?

2018-08-28 Thread Paul Menzel
Dear Linux folks, On 08/28/18 07:27, Paul Menzel wrote: > Using `sleepgraph.py` [1][2] to profile the suspend to RAM (STR) > times, shows that `ksys_enter` takes a noticeable amount of time. > > 13 ms on a TUXEDO Book BU1406 with the NVMe device *SAMSUNG > MZVKW512HMJP-0*,

How to debug outliers in `wb_wait_for_completion()` in `ksys_sync()`?

2018-08-27 Thread Paul Menzel
Dear Linux folks, Using `sleepgraph.py` [1][2] to profile the suspend to RAM (STR) times, shows that `ksys_enter` takes a noticeable amount of time. 13 ms on a TUXEDO Book BU1406 with the NVMe device *SAMSUNG MZVKW512HMJP-0*, which is quite good, and over a 60 ms on ASRock E350M1 with

Re: MSI B350M MORTAR: `AMD-Vi: Unable to write to IOMMU perf counter.` and `pci 0000:00:00.2: can't derive routing for PCI INT A`

2018-07-23 Thread Paul Menzel
Dear Jörg, On 07/20/18 14:31, Jörg Rödel wrote: > On Tue, Jul 17, 2018 at 06:02:07PM +0200, Paul Menzel wrote: >> $ dmesg >> […] >> [0.145696] calling pci_iommu_init+0x0/0x3f @ 1 >> [0.145719] AMD-Vi: Unable to write to IOMMU perf counter. > > This i

Re: UBSAN: Undefined behaviour in arch/x86/events/amd/ibs.c:582:24: member access within null pointer of type 'struct perf_event'

2018-07-21 Thread Paul Menzel
Dear Thomas, Am 20.07.2018 um 10:39 schrieb Thomas Gleixner: On Fri, 20 Jul 2018, Paul Menzel wrote: Enabling the undefined behavior sanitizer and building GNU/Linux 4.18-rc5+ (with some unrelated commits) with GCC 8.1.0 from Debian Sid/unstable, the warning below is shown. [2.111913

UBSAN: Undefined behaviour in lib/radix-tree.c:123:14: member access within null pointer of type 'const struct radix_tree_node'

2018-07-20 Thread Paul Menzel
Dear Linux folks, Enabling the undefined behavior sanitizer and building GNU/Linux 4.18-rc5+ (with some unrelated commits) with GCC 8.1.0 from Debian Sid/unstable, the warning below is shown. [0.958688] [

UBSAN: Undefined behaviour in arch/x86/events/amd/ibs.c:582:24: member access within null pointer of type 'struct perf_event'

2018-07-20 Thread Paul Menzel
Dear Linux folks, Enabling the undefined behavior sanitizer and building GNU/Linux 4.18-rc5+ (with some unrelated commits) with GCC 8.1.0 from Debian Sid/unstable, the warning below is shown. [2.111913] [

UBSAN: Undefined behaviour in arch/x86/events/core.c:668:25

2018-07-20 Thread Paul Menzel
Dear Linux folks, Enabling the undefined behavior sanitizer and building GNU/Linux 4.18-rc5+ (with some unrelated commits) with GCC 8.1.0 from Debian Sid/unstable, the warning below is shown. [1.945853] [

Re: NULL pointer dereference in msi_set_mask_bit

2018-07-19 Thread Paul Menzel
Dear Thomas, On 07/19/18 15:48, Thomas Gleixner wrote: > On Thu, 19 Jul 2018, Paul Menzel wrote: > >> I had to copy the files, and then was able to create an archive with >> non-zero files. Please find the tar archive attached. > > Thanks for providing the data. All lo

Re: NULL pointer dereference in msi_set_mask_bit

2018-07-19 Thread Paul Menzel
Dear Thomas, On 07/18/18 22:05, Paul Menzel wrote: > Am 18.07.2018 um 21:00 schrieb Thomas Gleixner: > >> On Wed, 18 Jul 2018, Paul Menzel wrote: >>> On 07/18/18 17:39, Thomas Gleixner wrote: >>>> Bah. Could you please enable GENERIC_IRQ_DEBUGFS and after a s

Re: NULL pointer dereference in msi_set_mask_bit

2018-07-18 Thread Paul Menzel
Dear Thomas, Am 18.07.2018 um 21:00 schrieb Thomas Gleixner: On Wed, 18 Jul 2018, Paul Menzel wrote: On 07/18/18 17:39, Thomas Gleixner wrote: Bah. Could you please enable GENERIC_IRQ_DEBUGFS and after a successful boot up provide me the content of all files in /sys/kernel/debug/irq

Re: NULL pointer dereference in msi_set_mask_bit

2018-07-18 Thread Paul Menzel
[I removed the folks from the unrelated patches.] Dear Thomas, On 07/18/18 17:39, Thomas Gleixner wrote: > On Wed, 18 Jul 2018, Paul Menzel wrote: >> On 07/18/18 17:02, Thomas Gleixner wrote: >>>>> 93.885: [ 23.020572] BUG: unable to handle kernel NULL po

Re: NULL pointer dereference in msi_set_mask_bit

2018-07-18 Thread Paul Menzel
Dear Thomas, dear Bjorn, Thank you for your quick responses. On 07/18/18 17:02, Thomas Gleixner wrote: > On Wed, 18 Jul 2018, Bjorn Helgaas wrote: >> [+cc Marc, Thomas] > > Uurgh. That's definitely what I need right now ... :) > >> On Wed, Jul 18, 2018 at 03:28:15PM

general protection fault with prefetch_freepointer

2018-07-18 Thread Paul Menzel
Dear Linux, Loading the amdgpu module on Ryzen 3 2{2,4}00G (Raven) systems sometimes causes a general protection fault [1]. At least on my system I am unable to reliably reproduce the issue. ``` [ 35.265941] kfd kfd: kgd2kfd_probe failed [ 35.537445] general protection fault: [#1] SMP

NULL pointer dereference in msi_set_mask_bit

2018-07-18 Thread Paul Menzel
Dear Linux folks, On a MSI B350M MORTAR with AMD Ryzen 3 2200g (Raven) with Linux 4.18-rc5+ and Debian Sid/unstable the system freezes with the messages below. ``` $ git log --oneline -1 30b06abfb92b (HEAD -> master, origin/master, origin/HEAD) Merge tag 'pinctrl-v4.18-3' of

[PATCH] init/main: Log init process file name

2018-07-13 Thread Paul Menzel
handed over control to the init process. Signed-off-by: Paul Menzel --- Ingo, hopefully it’s fine, putting you in Cc. I do not know, who the right person is. init/main.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/init/main.c b/init/main.c index 3b4ada11ed52..3821bb55c787 100644

[PATCH] ata: Only output sg element mapped number in verbose debug

2018-07-12 Thread Paul Menzel
Date: Sun, 8 Jul 2018 09:18:21 +0200 Defining `ATA_DEBUG` there are a lof of messages like below in the log. [ 16.345472] ata_sg_setup: 1 sg elements mapped As that is too verbose, only output these messages in verbose debug. Signed-off-by: Paul Menzel --- drivers/ata/libata-core.c | 2

[PATCH] ata: Guard ata_scsi_dump_cdb() by ATA_VERBOSE_DEBUG

2018-07-12 Thread Paul Menzel
Date: Sun, 8 Jul 2018 09:11:34 +0200 Defining `ATA_DEBUG` nothing can be really seen, as the log is spammed with CDB messages. Therefore, guard the print by `ATA_VERBOSE_DEBUG`. Signed-off-by: Paul Menzel --- drivers/ata/libata-scsi.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions

[PATCH v3] tools/build/Build.include: fix # escaping in .cmd files for future Make

2018-07-10 Thread Paul Menzel
es commit 9564a8cf (Kbuild: fix # escaping in .cmd files for future Make). Link: https://bugzilla.kernel.org/show_bug.cgi?id=197847 Cc: Randy Dunlap Cc: Rasmus Villemoes Cc: Masahiro Yamada Cc: sta...@vger.kernel.org Signed-off-by: Paul Menzel --- v2: Add sta...@vger.kernel.org v3: Add

Re: tools/build/Build.include: fix # escaping in .cmd files for future Make

2018-07-10 Thread Paul Menzel
es commit 9564a8cf (Kbuild: fix # escaping in .cmd files for future Make). Link: https://bugzilla.kernel.org/show_bug.cgi?id=197847 Cc: Randy Dunlap Cc: Rasmus Villemoes Cc: Masahiro Yamada Cc: sta...@vger.kernel.org Signed-off-by: Paul Menzel --- v2: Added sta...@vger.kernel.org to

tools/build/Build.include: fix # escaping in .cmd files for future Make

2018-06-07 Thread Paul Menzel
es commit 9564a8cf (Kbuild: fix # escaping in .cmd files for future Make). Link: https://bugzilla.kernel.org/show_bug.cgi?id=197847 Cc: Randy Dunlap Cc: Rasmus Villemoes Cc: Masahiro Yamada Signed-off-by: Paul Menzel --- tools/build/Build.include | 4 ++-- 1 file changed, 2 insertions(+), 2

Status of aspeed-bmc-opp-firestone (IBM S822LC)

2018-05-29 Thread Paul Menzel
Dear Joel, dear Linux folks, We have an IBM S822LC system (Firestone(?)). Building of OpenBMC currently fails, as the not everything was ported from dev-4.10 to dev-4.13 [1], and therefore a file cannot be found. Looking at upstream Linux, there are BMCs for Power 8 systems, like Palmetto,

Re: arch/powerpc/kernel/head_32.S:1106: Error: missing operand

2018-05-26 Thread Paul Menzel
Dear Christophe, Am 26.05.2018 um 18:02 schrieb christophe leroy: Le 26/05/2018 à 06:35, Paul Menzel a écrit : Building the configuration created with `make tinyconfig` on the Power 8 system IBM S822LC with Ubuntu 18.04 fails with the error below. ``` $ git describe --dirty v4.17-rc6-296

arch/powerpc/kernel/head_32.S:1106: Error: missing operand

2018-05-25 Thread Paul Menzel
Dear Linux folks, Building the configuration created with `make tinyconfig` on the Power 8 system IBM S822LC with Ubuntu 18.04 fails with the error below. ``` $ git describe --dirty v4.17-rc6-296-gbc2dbc5420e8 $ git log --oneline -1 bc2dbc5420e8 (HEAD -> master, origin/master, origin/HEAD)

Re: `ucsi_acpi: probe of USBC000:00 failed with error -12` on Dell XPS 13 9370

2018-05-16 Thread Paul Menzel
Dear Heikki, On 05/16/18 13:58, Heikki Krogerus wrote: On Wed, May 16, 2018 at 10:02:26AM +0200, Greg KH wrote: On Tue, May 15, 2018 at 06:47:37PM +0200, Paul Menzel wrote: On 05/15/18 18:00, Greg KH wrote: On Tue, May 15, 2018 at 04:34:03PM +0200, Paul Menzel wrote: Linux 4.17-rc5

Re: `ucsi_acpi: probe of USBC000:00 failed with error -12` on Dell XPS 13 9370

2018-05-15 Thread Paul Menzel
Dear Greg, As always, thank you for the prompt response. On 05/15/18 18:00, Greg KH wrote: On Tue, May 15, 2018 at 04:34:03PM +0200, Paul Menzel wrote: Linux 4.17-rc5 shows the error below on the Dell XPS 13 9370 with Debian Sid/unstable. ``` […] [0.440240] usb: port power management

`ucsi_acpi: probe of USBC000:00 failed with error -12` on Dell XPS 13 9370

2018-05-15 Thread Paul Menzel
Dear Linux folks, Linux 4.17-rc5 shows the error below on the Dell XPS 13 9370 with Debian Sid/unstable. ``` […] [0.440240] usb: port power management may be unreliable [0.441358] usbcore: registered new interface driver usb-storage [0.441367] usbcore: registered new interface

Re: [solved] QEMU ATA hard disk not detected

2018-05-14 Thread Paul Menzel
Dear Linux folks, On 05/13/18 10:34, Paul Menzel wrote: In QEMU 2.11 a disk is only detected by the AHCI driver and not by libata. On QEMU’s Standard PC (i440FX + PIIX, 1996), that causes an attached drive not to be detected as that machine doesn’t support AHCI. Here is the output

QEMU ATA hard disk not detected

2018-05-13 Thread Paul Menzel
Dear Linux folks, In QEMU 2.11 a disk is only detected by the AHCI driver and not by libata. On QEMU’s Standard PC (i440FX + PIIX, 1996), that causes an attached drive not to be detected as that machine doesn’t support AHCI. Here is the output with the machine Standard PC (Q35 + ICH9,

Re: pciehp 0000:00:1c.0:pcie004: Timeout on hotplug command 0x1038 (issued 65284 msec ago)

2018-05-08 Thread Paul Menzel
Dear Bjorn, Am 08.05.2018 um 14:34 schrieb Bjorn Helgaas: On Tue, May 08, 2018 at 08:59:34AM +0200, Paul Menzel wrote: Am 07.05.2018 um 23:33 schrieb Bjorn Helgaas: On Fri, May 04, 2018 at 08:33:27AM -0500, Bjorn Helgaas wrote: commit b0d6f2230e12c85ae3b65a854a53c67c7c1f6406 Author: Bjorn

Re: pciehp 0000:00:1c.0:pcie004: Timeout on hotplug command 0x1038 (issued 65284 msec ago)

2018-05-08 Thread Paul Menzel
t should check the Command Completed status after writing to the Slot Control register. Link: http://www.intel.com/content/www/us/en/processors/xeon/xeon-e7-v2-spec-update.html Link: https://lkml.kernel.org/r/8770820b-85a0-172b-7230-3a44524e6.

Re: pciehp 0000:00:1c.0:pcie004: Timeout on hotplug command 0x1038 (issued 65284 msec ago)

2018-05-06 Thread Paul Menzel
ps://lkml.kernel.org/r/8770820b-85a0-172b-7230-3a44524e6...@molgen.mpg.de Reported-by: Paul Menzel <pmenzel+linux-...@molgen.mpg.de> Signed-off-by: Bjorn Helgaas <bhelg...@google.com> diff --git a/drivers/pci/hotplug/pciehp_hpc.c b/drivers/pci/hotplug/pciehp_hpc.c index 18a42f8f5dc5..e70e

Re: Linux messages full of `random: get_random_u32 called from`

2018-04-25 Thread Paul Menzel
Dear Theodore, Am 25.04.2018 um 09:41 schrieb Theodore Y. Ts'o: Does this help on your system? Thank you, after figuring out how to apply the paste, yes it helped on my Lenovo X60. commit 4e00b339e264802851aff8e73cde7d24b57b18ce Author: Theodore Ts'o Date: Wed Apr 25

Probe HD-audio devices in parallel (was: azx_probe() called twice)

2018-04-25 Thread Paul Menzel
Dear Takashi, On 04/25/18 14:34, Takashi Iwai wrote: On Wed, 25 Apr 2018 14:29:31 +0200, Paul Menzel wrote: On 04/25/18 13:58, Takashi Iwai wrote: On Wed, 25 Apr 2018 13:48:27 +0200, Paul Menzel wrote: With the attached debug patch, `azx_probe()` seems to have been called twice

Re: Regression 4.17-rc1: SSD doesn’t properly resume causing system hang (NULL pointer dereference)

2018-04-25 Thread Paul Menzel
Dear Bart, On 04/25/18 14:26, Bart Van Assche wrote: On Wed, 2018-04-25 at 07:37 +0200, Paul Menzel wrote: Am 24.04.2018 um 23:17 schrieb Bart Van Assche: On Tue, 2018-04-24 at 23:04 +0200, Paul Menzel wrote: I applied your change, and rebuilt the Linux kernel. Unfortunately, it looks like

Re: Regression 4.17-rc1: SSD doesn properly resume causing system hang (NULL pointer dereference)

2018-04-24 Thread Paul Menzel
Dear Bart, Am 24.04.2018 um 23:17 schrieb Bart Van Assche: On Tue, 2018-04-24 at 23:04 +0200, Paul Menzel wrote: I applied your change, and rebuilt the Linux kernel. Unfortunately, it looks like, it didn’t make a difference. In that case I don't know what is causing the failure. Can you run

Re: Regression 4.17-rc1: SSD doesn properly resume causing system hang (NULL pointer dereference)

2018-04-24 Thread Paul Menzel
Dear Bart, On 04/24/18 19:31, Bart Van Assche wrote: On Tue, 2018-04-24 at 19:10 +0200, Paul Menzel wrote: Please find the configuration file attached. The log only has `initcall_debug no_console_suspend` added. What I was looking for in the .config is the following: CONFIG_SCSI_MQ_DEFAULT

Re: Linux messages full of `random: get_random_u32 called from`

2018-04-24 Thread Paul Menzel
Dear Theodore, On 04/24/18 17:49, Theodore Y. Ts'o wrote: On Tue, Apr 24, 2018 at 09:56:21AM -0400, Theodore Y. Ts'o wrote: On Tue, Apr 24, 2018 at 01:48:16PM +0200, Paul Menzel wrote: Since Linux 4.17-rcX, Linux spams a lot of `random: get_random_u32 called from` messages. I believe

Re: [PATCH] ALSA: hda: Request driver probe from an async task

2018-04-24 Thread Paul Menzel
Dear Takashi, On 04/24/18 14:15, Takashi Iwai wrote: On Tue, 24 Apr 2018 13:59:58 +0200, Paul Menzel wrote: On 04/23/18 14:33, Takashi Iwai wrote: On Mon, 23 Apr 2018 14:30:36 +0200, Paul Menzel wrote: On 04/23/18 14:21, Takashi Iwai wrote: On Mon, 23 Apr 2018 14:05:52 +0200, Paul

Re: How to disable Linux kernel self-extraction (KERNEL_GZIP, KERNEL_BZIP2, …)?

2018-04-24 Thread Paul Menzel
Dear Adam, Thank you very much to join the discussion. On 04/24/18 04:08, Adam Borowski wrote: On Mon, Apr 23, 2018 at 07:02:30PM +0200, Pavel Machek wrote: I try to decrease boot time, and my system has an SSD and enough space, so loading 18 instead of 12 MB doesn’t make a difference, but

Re: [PATCH] ALSA: hda: Request driver probe from an async task

2018-04-23 Thread Paul Menzel
Dear Takashi, On 04/23/18 14:21, Takashi Iwai wrote: On Mon, 23 Apr 2018 14:05:52 +0200, Paul Menzel wrote: From: Paul Menzel <pmen...@molgen.mpg.de> Date: Sat, 24 Mar 2018 09:28:43 +0100 On an ASRock E350M1, with Linux 4.17-rc1 according to `initcall_debug` calling `azx_driver_init`

[PATCH] ALSA: hda: Request driver probe from an async task

2018-04-23 Thread Paul Menzel
From: Paul Menzel <pmen...@molgen.mpg.de> Date: Sat, 24 Mar 2018 09:28:43 +0100 On an ASRock E350M1, with Linux 4.17-rc1 according to `initcall_debug` calling `azx_driver_init` takes sometimes more than a few milliseconds, and up to 200 ms. ``` [2.892598] calling azx_driver_init+0x0

Re: How to disable Linux kernel self-extraction (KERNEL_GZIP, KERNEL_BZIP2, …)?

2018-04-22 Thread Paul Menzel
Dear Pavel, Am 22.04.2018 um 12:20 schrieb Pavel Machek: On Fri 2018-04-20 16:36:00, Paul Menzel wrote: I try to decrease boot time, and my system has an SSD and enough space, so loading 18 instead of 12 MB doesn’t make a difference, but the self-extraction is noticeable. So, I like

How to disable Linux kernel self-extraction (KERNEL_GZIP, KERNEL_BZIP2, …)?

2018-04-20 Thread Paul Menzel
Dear Linux folks, I try to decrease boot time, and my system has an SSD and enough space, so loading 18 instead of 12 MB doesn’t make a difference, but the self-extraction is noticeable. So, I like to disable it. From `init/Kconfig`: The linux kernel is a kind of self-extracting

How to disable tracing at runtime from the Linux kernel command line?

2018-04-14 Thread Paul Menzel
Dear Linux folks, I am trying to reduce the boot time of a standard Linux distribution kernel. Currently, distributions – at least Debian und Ubuntu – enable function tracing. ``` CONFIG_FTRACE=y CONFIG_FUNCTION_TRACER=y CONFIG_FUNCTION_GRAPH_TRACER=y CONFIG_EVENT_TRACING=y ``` This is

Re: Commit *driver core: emit uevents when device is bound to a driver* causes regression

2018-04-06 Thread Paul Menzel
Dear Greg, On 04/06/18 15:18, Greg Kroah-Hartman wrote: On Fri, Apr 06, 2018 at 02:20:40PM +0200, Paul Menzel wrote: Commit 1455cf8 (driver core: emit uevents when device is bound to a driver) [1], introduced in Linux 4.14-rc1, causes a regression in user space. After disconnecting USB

Commit *driver core: emit uevents when device is bound to a driver* causes regression

2018-04-06 Thread Paul Menzel
Dear Linux folks, Commit 1455cf8 (driver core: emit uevents when device is bound to a driver) [1], introduced in Linux 4.14-rc1, causes a regression in user space. After disconnecting USB devices, they are still shown as plugged in [2][3]. I seem to be having a similar issue, but with an

Decrease boot time with AHCI drives?

2018-04-04 Thread Paul Menzel
Dear Linux folks, I am trying to decrease the boot time of the Linux kernel so the LUKS passphrase dialog (in the initrd) is shown as quickly as possible. The devices I test with is a Lenovo X60 and ASRock E350M1 both running with coreboot and the GRUB payload. The goal is to do this without

How to move serial8250_init out of the critical path to decrease boot time?

2018-04-01 Thread Paul Menzel
Mon Sep 17 00:00:00 2001 From: Paul Menzel <pmen...@molgen.mpg.de> Date: Sun, 1 Apr 2018 08:57:53 +0200 Subject: [PATCH] tty/serial/8250: Request driver probe from an async task Currently, according to `initcall_debug` running `serial8250_init` takes around 33 ms on a Lenovo X60 and TUXEDO Bo

Reduce init time of `lp_init()` and `ppdev_init()`

2018-03-29 Thread Paul Menzel
Dear Linux folks, I am trying to reduce the start-up time of the Linux kernel on an old Lenovo X60. Looking through the time stamps of Linux 4.16-rc7+, the modules `lp` and `ppdev` both take more than ten milliseconds to initialize according to `initcall_debug`. ``` [8.337692] calling

Re: `do_IRQ: 1.55 No irq handler for vector` on ASRock E350M1

2018-03-29 Thread Paul Menzel
Dear Yazen, Eric, Tom, On 02/26/18 17:42, Tom Lendacky wrote: On 2/26/2018 10:37 AM, Morton, Eric wrote: Yazen dug out PLAT-21393 as sounding like this issue. I haven't had a chance to digest it. Yes, internally to AMD, that was the bug that tracked the issue I was referring to. If you

Re: efisubsys_init takes more than a few milliseconds

2018-03-25 Thread Paul Menzel
Dear Ard, On 03/25/2018 09:41 AM, Paul Menzel wrote: On 03/24/2018 11:35 PM, Ard Biesheuvel wrote: On 24 March 2018 at 22:10, Paul Menzel wrote: According to `initcall_debug`, `efisubsys_init` takes more than a few milliseconds to execute on a Dell XPS 13 9370 (Intel(R) Core(TM) i7

Re: efisubsys_init takes more than a few milliseconds

2018-03-25 Thread Paul Menzel
Dear Ard, Thank you for the quick reply. On 03/24/2018 11:35 PM, Ard Biesheuvel wrote: On 24 March 2018 at 22:10, Paul Menzel <pmenzel+linux-...@molgen.mpg.de> wrote: Dear Ard, According to `initcall_debug`, `efisubsys_init` takes more than a few milliseconds to execute on a Dell

efisubsys_init takes more than a few milliseconds

2018-03-24 Thread Paul Menzel
Dear Ard, According to `initcall_debug`, `efisubsys_init` takes more than a few milliseconds to execute on a Dell XPS 13 9370 (Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz). ``` […] [0.144474] calling efisubsys_init+0x0/0x2cf @ 1 [0.144474] Registered efivars operations [0.173690]

Re: uvcvideo: Unknown video format,00000032-0002-0010-8000-00aa00389b71

2018-03-21 Thread Paul Menzel
Dear Laurent, On 03/21/2018 10:25 AM, Laurent Pinchart wrote: On Tuesday, 20 March 2018 18:46:24 EET Paul Menzel wrote: On 03/20/18 14:30, Laurent Pinchart wrote: On Tuesday, 20 March 2018 14:20:14 EET Paul Menzel wrote: On the Dell XPS 13 9370, Linux 4.16-rc6 outputs the messages below

Re: uvcvideo: Unknown video format,00000032-0002-0010-8000-00aa00389b71

2018-03-20 Thread Paul Menzel
Dear Laurent, On 03/20/18 14:30, Laurent Pinchart wrote: On Tuesday, 20 March 2018 14:20:14 EET Paul Menzel wrote: On the Dell XPS 13 9370, Linux 4.16-rc6 outputs the messages below. ``` […] [2.340736] input: Integrated_Webcam_HD: Integrate as /devices/pci:00/:00:14.0/usb1

uvcvideo: Unknown video format,00000032-0002-0010-8000-00aa00389b71

2018-03-20 Thread Paul Menzel
Dear Linux folks, On the Dell XPS 13 9370, Linux 4.16-rc6 outputs the messages below. ``` [2.338094] calling uvc_init+0x0/0x1000 [uvcvideo] @ 295 [2.338569] calling iTCO_wdt_init_module+0x0/0x1000 [iTCO_wdt] @ 280 [2.338570] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.11 [

Re: int3403_driver_init needs over 330 ms to finish

2018-03-14 Thread Paul Menzel
Dear Rui, On 03/14/2018 08:32 AM, Zhang Rui wrote: On 二, 2018-03-13 at 20:39 +0100, Paul Menzel wrote: Booting the Dell XPS 13 9370 with Linux 4.16-rc4+ and `initcall_debug`, shows it is shown that int3403_driver_init needs over 330 ms to run.  [2.524839] initcall

string_selftest_init needs 636 ms to run

2018-03-12 Thread Paul Menzel
Dear Geert, Sorry for writing you directory, but I saw you created the module *string_selftest* in commit d6b28e09 (lib: add module support to string tests). I believe, I only did `make olddefconfig`, and the option is selected. ``` $ grep STRING_SELFTEST .config CONFIG_STRING_SELFTEST=y

Re: Regression from efi: call get_event_log before ExitBootServices

2018-03-12 Thread Paul Menzel
Dear Jarkko, On 03/12/18 11:17, Jarkko Sakkinen wrote: On Sat, 2018-03-10 at 10:45 +, Thiebaud Weksteen wrote: On Fri, Mar 9, 2018 at 5:54 PM Jeremy Cline wrote: and it's hanging at "memset(log_tbl, 0, sizeof(*log_tbl) + log_size);" Thanks. Well, it looks like the

`do_IRQ: 1.55 No irq handler for vector` on ASRock E350M1

2018-02-23 Thread Paul Menzel
Dear Thomas, On the ASRock E350M1 (AMD A50M), since Linux 4.15 I get the message below. do_IRQ: 1.55 No irq handler for vector Kind regards, Paul smime.p7s Description: S/MIME Cryptographic Signature

Re: i8042 AUX port [serio1] suspend takes a second on Dell XPS 13 9360

2018-02-21 Thread Paul Menzel
Dear Mario, Thank you for your reply. Am 15.02.2018 um 16:22 schrieb mario.limoncie...@dell.com: -Original Message- From: Paul Menzel [mailto:pmenzel+linux-in...@molgen.mpg.de] Sent: Thursday, February 15, 2018 2:26 AM To: Limonciello, Mario <mario_limoncie...@dell.com>;

[PATCH] input/mouse/synaptics: Add SYN1217 to PNP detection list

2018-02-15 Thread Paul Menzel
-by: Paul Menzel <pmen...@molgen.mpg.de> --- drivers/input/mouse/synaptics.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/input/mouse/synaptics.c b/drivers/input/mouse/synaptics.c index 3d2e23a0ae39..80ddbb966d83 100644 --- a/drivers/input/mouse/synaptics.c +++ b/drivers/input

Re: i8042 AUX port [serio1] suspend takes a second on Dell XPS 13 9360

2018-02-15 Thread Paul Menzel
Dear Mario, dear Dmitry, On 02/15/18 09:26, Paul Menzel wrote: On 02/14/18 18:11, mario.limoncie...@dell.com wrote: -Original Message- From: Paul Menzel [mailto:pmenzel+linux-in...@molgen.mpg.de] Sent: Wednesday, February 14, 2018 10:41 AM To: Dmitry Torokhov <dmitry.to

Add touchpad of Dell XPS 13 9360 to Synaptics Intertouch list

2018-02-15 Thread Paul Menzel
Dear Linux folks, On the Dell XPS 13 9360, Linux asks me to report the device DLL075b to be added to `forcepad_pnp_ids`. [7.180131] psmouse serio1: synaptics: Your touchpad (PNP: DLL075b PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want

Re: i8042 AUX port [serio1] suspend takes a second on Dell XPS 13 9360

2018-02-14 Thread Paul Menzel
Dear Dmitry, On 01/30/18 19:07, Dmitry Torokhov wrote: On Tue, Jan 30, 2018 at 09:52:45AM -0800, Dmitry Torokhov wrote: On Tue, Jan 30, 2018 at 06:36:34PM +0100, Paul Menzel wrote: I do not know, when it started, but with Linux 4.14-rc8 and 4.15, benchmarking suspend and resume time

Re: dell-smbios makes wireless card unusable on Dell XPS 13 9360

2018-02-07 Thread Paul Menzel
Dear Mario, Am 08.02.2018 um 05:57 schrieb mario.limoncie...@dell.com: -Original Message- From: Paul Menzel [mailto:pmenzel+platform-driver-...@molgen.mpg.de] Sent: Wednesday, February 7, 2018 3:41 AM To: Limonciello, Mario <mario_limoncie...@dell.com> Cc: Pali Rohár &l

Re: dell-smbios makes wireless card unusable on Dell XPS 13 9360

2018-02-07 Thread Paul Menzel
Dear Mario, On 02/06/18 20:51, mario.limoncie...@dell.com wrote: -Original Message- From: platform-driver-x86-ow...@vger.kernel.org [mailto:platform-driver-x86- ow...@vger.kernel.org] On Behalf Of Paul Menzel Sent: Tuesday, February 6, 2018 10:08 AM To: Limonciello, Mario

Re: dell-smbios makes wireless card unusable on Dell XPS 13 9360

2018-02-06 Thread Paul Menzel
Dear Mario, On 02/06/18 16:58, mario.limoncie...@dell.com wrote: -Original Message- From: Paul Menzel [mailto:pmenzel+platform-driver-...@molgen.mpg.de] Sent: Tuesday, February 6, 2018 9:50 AM To: Pali Rohár <pali.ro...@gmail.com>; Limonciello, Mario <mario_limoncie...

Re: i8042 AUX port [serio1] suspend takes a second on Dell XPS 13 9360 and TUXEDO Book 1406

2018-02-03 Thread Paul Menzel
Dear Dmitry, Am 30.01.2018 um 19:39 schrieb Paul Menzel: On 01/30/18 19:07, Dmitry Torokhov wrote: On Tue, Jan 30, 2018 at 09:52:45AM -0800, Dmitry Torokhov wrote: On Tue, Jan 30, 2018 at 06:36:34PM +0100, Paul Menzel wrote: I do not know, when it started, but with Linux 4.14-rc8

Re: i8042 AUX port [serio1] suspend takes a second on Dell XPS 13 9360 and TUXEDO Book 1406

2018-01-30 Thread Paul Menzel
Dear Dmitry, On 01/30/18 19:07, Dmitry Torokhov wrote: On Tue, Jan 30, 2018 at 09:52:45AM -0800, Dmitry Torokhov wrote: On Tue, Jan 30, 2018 at 06:36:34PM +0100, Paul Menzel wrote: I do not know, when it started, but with Linux 4.14-rc8 and 4.15, benchmarking suspend and resume time

Re: Report long suspend times of NVMe devices (mostly firmware/device issues)

2018-01-24 Thread Paul Menzel
Dear Keith, Thank you for your reply. Am 22.01.2018 um 22:30 schrieb Keith Busch: On Mon, Jan 22, 2018 at 10:02:12PM +0100, Paul Menzel wrote: Benchmarking the ACPI S3 suspend and resume times with `sleepgraph.py -config config/suspend-callgraph.cfg` [1], shows that the NVMe disk SAMSUNG

Re: Suspend/resume with FTRACE enabled doesn’t work anymore

2018-01-18 Thread Paul Menzel
Dear Steven, On 01/17/18 17:25, Steven Rostedt wrote: On Wed, 17 Jan 2018 11:19:43 -0500 Steven Rostedt wrote: On Wed, 17 Jan 2018 11:10:31 -0500 Steven Rostedt wrote: It's been fixed, and the the patch is in Linus's tree already:

Re: Suspend/resume with FTRACE enabled doesn’t work anymore

2018-01-17 Thread Paul Menzel
Dear Linux folks, On 01/17/18 15:20, Paul Menzel wrote: Testing Linux 4.15-rc8 on a Lenovo T60 (32 bit) and Dell XPS 13 9360 (64 bit) suspend to and resume from ACPI S3 doesn’t work anymore. `./sleepgraph.py -config config/suspend-callgraph.cfg` [1] is used to enable the FTRACE framework

Re: UBSAN: Undefined behaviour in net/wireless/nl80211.c:718:4: -1665903437 * 100 cannot be represented in type 'int'

2018-01-17 Thread Paul Menzel
Dear Johannes, On 01/04/18 16:08, Johannes Berg wrote: Hi, Can you reproduce this? [ 54.426491] UBSAN: Undefined behaviour in net/wireless/nl80211.c:718:4 [ 54.426492] signed integer overflow: [ 54.426493] -1665903437 * 100 cannot be represented in type 'int' Obviously. However, it

Re: UBSAN: Undefined behaviour in drivers/acpi/sysfs.c:849:33

2018-01-15 Thread Paul Menzel
Dear Linux folks, On 12/13/17 14:13, Paul Menzel wrote: I enabled the undefined behavior sanitizer, and built Linus’ master branch under Ubuntu 17.10 with gcc (Ubuntu 7.2.0-8ubuntu3) 7.2.0. ``` $ grep UBSAN /boot/config-4.15.0-rc3+ CONFIG_ARCH_HAS_UBSAN_SANITIZE_ALL=y

Re: `pci_apply_final_quirks()` taking half a second

2018-01-01 Thread Paul Menzel
Dear Alan, First, please note, that your mailer (MUA) doesn’t set the references header, which breaks threading for people not having their own answers in the inbox. Am 31.12.2017 um 22:16 schrieb Alan Stern: On Sun, 31 Dec 2017, Paul Menzel wrote: Am 29.12.2017 um 17:14 schrieb Alan

Re: `pci_apply_final_quirks()` taking half a second

2017-12-30 Thread Paul Menzel
Am 29.12.2017 um 17:14 schrieb Alan Stern: On Thu, 28 Dec 2017, Bjorn Helgaas wrote: On Tue, Dec 26, 2017 at 04:55:20PM +0100, Paul Menzel wrote: Am 08.04.2017 um 17:41 schrieb Bjorn Helgaas: On Fri, Apr 07, 2017 at 11:07:15PM +0200, Paul Menzel wrote: Measuring where time is spent

Re: `pci_apply_final_quirks()` taking half a second

2017-12-26 Thread Paul Menzel
Dear Bjorn, Am 08.04.2017 um 17:41 schrieb Bjorn Helgaas: On Fri, Apr 07, 2017 at 11:07:15PM +0200, Paul Menzel wrote: Measuring where time is spent during boot with `systemd-bootchart` on an Asus A780FullHD, it turns out that half a second is spent in `pci_apply_final_quirks()`. I agree

Re: Decreasing time for `rsa_init`

2017-12-26 Thread Paul Menzel
Dear Stephan, dear Linux folks, Am 13.07.2017 um 20:20 schrieb Paul Menzel: Am Mittwoch, den 12.07.2017, 19:38 +0200 schrieb Paul Menzel: On 07/12/17 19:28, Stephan Müller wrote: Am Mittwoch, 12. Juli 2017, 12:59:58 CEST schrieb Paul Menzel: Building CRYPTO_RSA not as module

Re: [Regression 4.15-rc2] New messages `tpm tpm0: A TPM error (2314) occurred continue selftest`

2017-12-22 Thread Paul Menzel
Dear Alexander, dear Mimi, On 12/22/17 15:00, alexander.stef...@infineon.com wrote: On Mon, 2017-12-11 at 13:54 +0100, Paul Menzel wrote: Dear Jason, On 12/08/17 17:18, Jason Gunthorpe wrote: On Fri, Dec 08, 2017 at 05:07:39PM +0100, Paul Menzel wrote: I have no access to the system

Re: UBSAN: Undefined behaviour in drivers/net/wireless/intel/iwlwifi/mvm/utils.c:838:5

2017-12-21 Thread Paul Menzel
Dear Kalle, On 12/21/17 11:38, Kalle Valo wrote: Paul Menzel <pmenzel+linux-wirel...@molgen.mpg.de> writes: http://pastebin.coelho.fi/7b624f474846da52.txt Thank you. The warning is gone now. Thank you. For the next time, it’d be great to provide the output of `git format-patch -1`,

Re: [Intel-wired-lan] v4.15-rc2 on thinkpad x60: ethernet stopped working

2017-12-21 Thread Paul Menzel
Dear Pavel, On 12/10/17 09:39, Pavel Machek wrote: In v4.15-rc2+, network manager can not see my ethernet card, and manual attempts to ifconfig it up did not really help, either. Card is: 02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controller Dmesg says:

Re: TPM driver breaks S3 suspend

2017-12-21 Thread Paul Menzel
Dear Chris, Thank you for bringin gup the issue. We have a desktop which has S3 suspend (to RAM) problem due to error messages as follows. [ 198.908282] tpm tpm0: Error (38) sending savestate before suspend [ 198.908289] __pnp_bus_suspend(): tpm_pm_suspend+0x0/0x160 returns 38 [

Re: UBSAN: Undefined behaviour in drivers/net/wireless/intel/iwlwifi/mvm/utils.c:838:5

2017-12-20 Thread Paul Menzel
Dear Luca, Am 18.12.2017 um 19:30 schrieb Luca Coelho: On Wed, 2017-12-13 at 16:32 +0200, Luciano Coelho wrote: On Wed, 2017-12-13 at 14:25 +0100, Paul Menzel wrote: I enabled the undefined behavior sanitizer, and built Linus’ master branch under Ubuntu 17.10 with gcc (Ubuntu 7.2.0

Re: [Regression 4.15-rc2] New messages `tpm tpm0: A TPM error (2314) occurred continue selftest`

2017-12-15 Thread Paul Menzel
Dear Mario, On 12/15/17 16:24, mario.limoncie...@dell.com wrote: -Original Message- From: Paul Menzel [mailto:pmen...@molgen.mpg.de] Sent: Friday, December 15, 2017 9:11 AM To: Limonciello, Mario <mario_limoncie...@dell.com>; Alexander Steffen <alexander.stef...@infineon.co

Re: [Regression 4.15-rc2] New messages `tpm tpm0: A TPM error (2314) occurred continue selftest`

2017-12-15 Thread Paul Menzel
Dear Alexander, On 12/15/17 15:54, alexander.stef...@infineon.com wrote: […] the added line breaks to the quoted parts really mess up the citation. Can we please try to use MUAs avoiding that, or fixing that manually? Sorry, I'm not sure whether my company has a way for me to avoid using

Re: [Regression 4.15-rc2] New messages `tpm tpm0: A TPM error (2314) occurred continue selftest`

2017-12-15 Thread Paul Menzel
Dear Mario, On 12/15/17 15:39, mario.limoncie...@dell.com wrote: -Original Message- From: Paul Menzel [mailto:pmen...@molgen.mpg.de] Sent: Friday, December 15, 2017 5:54 AM To: Limonciello, Mario <mario_limoncie...@dell.com>; Alexander Steffen <alexander.stef...@infineon.co

Re: [Regression 4.15-rc2] New messages `tpm tpm0: A TPM error (2314) occurred continue selftest`

2017-12-15 Thread Paul Menzel
Subject: RE: [Regression 4.15-rc2] New messages `tpm tpm0: A TPM error (2314) occurred continue selftest` [Mario from Dell added to CC list.] Dear Alexander, On 12/11/17 17:08, alexander.stef...@infineon.com wrote: On 12/08/17 17:18, Jason Gunthorpe wrote: On Fri, Dec 08, 2017 at 05:07:39PM +0100,

Re: [Regression 4.15-rc2] New messages `tpm tpm0: A TPM error (2314) occurred continue selftest`

2017-12-14 Thread Paul Menzel
[Mario from Dell added to CC list.] Dear Alexander, On 12/11/17 17:08, alexander.stef...@infineon.com wrote: On 12/08/17 17:18, Jason Gunthorpe wrote: On Fri, Dec 08, 2017 at 05:07:39PM +0100, Paul Menzel wrote: I have no access to the system right now, but want to point out, that the log

  1   2   >