[PATCH] sysfs.txt: mention that store method buffers are null-terminated

2015-09-07 Thread ulfalizer . lkml
From: Ulf Magnusson Without knowing this, the use of sysfs_streq() becomes puzzling. The termination happens in kernfs_fop_write(). Signed-off-by: Ulf Magnusson --- Documentation/filesystems/sysfs.txt | 3 +++ 1 file changed, 3 insertions(+) diff --git a/Documentation/filesystems/sysfs.txt

[PATCH] debugfs: document that debugfs_remove*() accepts NULL and error values

2015-09-07 Thread ulfalizer . lkml
From: Ulf Magnusson According to commit a59d6293e537 ("debugfs: change parameter check in debugfs_remove() functions"), this is meant to make cleanup easier for callers. In that case it ought to be documented. Signed-off-by: Ulf Magnusson --- fs/debugfs/inode.c | 6 -- 1 file changed, 4

[PATCH] debugfs: document that debugfs_remove*() accepts NULL and error values

2015-09-07 Thread ulfalizer . lkml
From: Ulf Magnusson According to commit a59d6293e537 ("debugfs: change parameter check in debugfs_remove() functions"), this is meant to make cleanup easier for callers. In that case it ought to be documented. Signed-off-by: Ulf Magnusson ---

[PATCH] sysfs.txt: mention that store method buffers are null-terminated

2015-09-07 Thread ulfalizer . lkml
From: Ulf Magnusson Without knowing this, the use of sysfs_streq() becomes puzzling. The termination happens in kernfs_fop_write(). Signed-off-by: Ulf Magnusson --- Documentation/filesystems/sysfs.txt | 3 +++ 1 file changed, 3 insertions(+) diff

[PATCH] debugfs: document that debugfs_remove*() accepts NULL and error values

2015-09-03 Thread ulfalizer . lkml
From: Ulf Magnusson According to commit a59d6293e537 ("debugfs: change parameter check in debugfs_remove() functions"), this is meant to make cleanup easier for callers. In that case it ought to be documented. Signed-off-by: Ulf Magnusson --- fs/debugfs/inode.c | 6 -- 1 file changed, 4

[PATCH] debugfs: document that debugfs_remove*() accepts NULL and error values

2015-09-03 Thread ulfalizer . lkml
From: Ulf Magnusson According to commit a59d6293e537 ("debugfs: change parameter check in debugfs_remove() functions"), this is meant to make cleanup easier for callers. In that case it ought to be documented. Signed-off-by: Ulf Magnusson ---

[PATCH] kobject: explain what kobject's sd field is

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson (More) unclear, especially name-wise, after sysfs_dirent became kernfs_node. Signed-off-by: Ulf Magnusson --- include/linux/kobject.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/kobject.h b/include/linux/kobject.h index

[PATCH] Makefile: .PHONY is not a variable, but PHONY is

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson .PHONY is a target, not a variable. Signed-off-by: Ulf Magnusson --- Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Makefile b/Makefile index 24c9e3d..4835d24 100644 --- a/Makefile +++ b/Makefile @@ -1609,6 +1609,6 @@ endif # skip-makefile

[PATCH 1/3] sysfs.txt: fix pre-kernfs sysfs_dirent reference

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson sysfs_dirent went away when kernfs was extracted from sysfs. The reference to the kobject now lives in a kernfs_node (in the 'priv' member). See commit 324a56e16e44 ("kernfs: s/sysfs_dirent/kernfs_node/ and rename its friends accordingly"). Signed-off-by: Ulf Magnusson ---

[PATCH 3/3] configfs: fix pre-kernfs sysfs_dirent reference

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson sysfs_dirent was renamed in 324a56e16e44 ("kernfs: s/sysfs_dirent/kernfs_node/ and rename its friends accordingly"). Do s/sysfs_dirent/configfs_dirent/ - possibly a copy-paste error to begin with. Clean up the language a bit too. Signed-off-by: Ulf Magnusson ---

[PATCH 0/3] Fix some outdated pre-kernfs doc references

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson sysfs-tagging.txt contains more outdated references (e.g., to various kobj_ns_*() functions that no longer exist), but hopefully it should be in a better shape than before. I'm new to sysfs internals in general. The configfs change is a guess that seemed reasonable. Ulf

[PATCH 2/3] sysfs-tagging.txt: fix pre-kernfs references

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson - sysfs_dirent is now kernfs_node - see commit 324a56e16e44 ("kernfs: s/sysfs_dirent/kernfs_node/ and rename its friends accordingly") - sysfs_super_info is now kernfs_super_info - see commit c525aaddc366 ("kernfs: s/sysfs/kernfs/ in various data structures") - the

[PATCH] kobject: explain what kobject's sd field is

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson (More) unclear, especially name-wise, after sysfs_dirent became kernfs_node. Signed-off-by: Ulf Magnusson --- include/linux/kobject.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/kobject.h

[PATCH 1/3] sysfs.txt: fix pre-kernfs sysfs_dirent reference

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson sysfs_dirent went away when kernfs was extracted from sysfs. The reference to the kobject now lives in a kernfs_node (in the 'priv' member). See commit 324a56e16e44 ("kernfs: s/sysfs_dirent/kernfs_node/ and rename its friends accordingly").

[PATCH 0/3] Fix some outdated pre-kernfs doc references

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson sysfs-tagging.txt contains more outdated references (e.g., to various kobj_ns_*() functions that no longer exist), but hopefully it should be in a better shape than before. I'm new to sysfs internals in general. The configfs change is a guess that seemed

[PATCH 2/3] sysfs-tagging.txt: fix pre-kernfs references

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson - sysfs_dirent is now kernfs_node - see commit 324a56e16e44 ("kernfs: s/sysfs_dirent/kernfs_node/ and rename its friends accordingly") - sysfs_super_info is now kernfs_super_info - see commit c525aaddc366 ("kernfs: s/sysfs/kernfs/ in various data

[PATCH 3/3] configfs: fix pre-kernfs sysfs_dirent reference

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson sysfs_dirent was renamed in 324a56e16e44 ("kernfs: s/sysfs_dirent/kernfs_node/ and rename its friends accordingly"). Do s/sysfs_dirent/configfs_dirent/ - possibly a copy-paste error to begin with. Clean up the language a bit too. Signed-off-by: Ulf

[PATCH] Makefile: .PHONY is not a variable, but PHONY is

2015-09-02 Thread ulfalizer . lkml
From: Ulf Magnusson .PHONY is a target, not a variable. Signed-off-by: Ulf Magnusson --- Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Makefile b/Makefile index 24c9e3d..4835d24 100644 --- a/Makefile +++ b/Makefile @@