Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-09 Thread yakir


On 2015年03月09日 15:05, Daniel Kurtz wrote:

On Mon, Mar 9, 2015 at 12:42 PM, Yakir Yang  wrote:

- const struct dw_hdmi_mpll_config *mpll_config =
-hdmi->plat_data->mpll_cfg;
- const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
- const struct dw_hdmi_sym_term *sym_term =  hdmi->plat_data->sym_term;

+ const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
+ const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
+ const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
+ const struct dw_hdmi_sym_term *sym_term =  plat_data->sym_term;

Signed-off-by: Yakir Yang 

I agree with Joe Perches that this commit message is not very clear.
It should summarize what the patches is doing and why, not just be a
copy of the change.
e.g., "Using a local struct pointer to reduce one level of indirection
makes the code slightly more readable."

, but otherwise this is:
Reviewed-by: Daniel Kurtz 


Okay, I will correct it now.

Thanks for your reivew  :)


---

Changes in v2: None

  drivers/gpu/drm/bridge/dw_hdmi.c | 8 
  1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c b/drivers/gpu/drm/bridge/dw_hdmi.c
index 9ffc257..b9d8d8a 100644
--- a/drivers/gpu/drm/bridge/dw_hdmi.c
+++ b/drivers/gpu/drm/bridge/dw_hdmi.c
@@ -900,10 +900,10 @@ static int hdmi_phy_configure(struct dw_hdmi *hdmi, 
unsigned char prep,
  {
 unsigned res_idx, i;
 u8 val, msec;
-   const struct dw_hdmi_mpll_config *mpll_config =
-   hdmi->plat_data->mpll_cfg;
-   const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
-   const struct dw_hdmi_sym_term *sym_term =  hdmi->plat_data->sym_term;
+   const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
+   const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
+   const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
+   const struct dw_hdmi_sym_term *sym_term =  plat_data->sym_term;

 if (prep)
 return -EINVAL;
--
2.1.2



___
Linux-rockchip mailing list
linux-rockc...@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-rockchip






--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-09 Thread yakir


On 2015年03月09日 14:48, Joe Perches wrote:

On Sun, 2015-03-08 at 21:48 -0700, Joe Perches wrote:


Shouldn't all of these be static?

Don't mind me.  These shouldn't be static.

I was a bit mislead by the commit message.

I think it'd be better not to put patch-like
+ and - lines in the commit description.

cheers, Joe



Okay, I will delete it from commit message.

Thanks for reply :)






--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-09 Thread Daniel Kurtz
On Mon, Mar 9, 2015 at 12:42 PM, Yakir Yang  wrote:
> - const struct dw_hdmi_mpll_config *mpll_config =
> -hdmi->plat_data->mpll_cfg;
> - const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
> - const struct dw_hdmi_sym_term *sym_term =  hdmi->plat_data->sym_term;
>
> + const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
> + const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
> + const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
> + const struct dw_hdmi_sym_term *sym_term =  plat_data->sym_term;
>
> Signed-off-by: Yakir Yang 

I agree with Joe Perches that this commit message is not very clear.
It should summarize what the patches is doing and why, not just be a
copy of the change.
e.g., "Using a local struct pointer to reduce one level of indirection
makes the code slightly more readable."

, but otherwise this is:
Reviewed-by: Daniel Kurtz 

> ---
>
> Changes in v2: None
>
>  drivers/gpu/drm/bridge/dw_hdmi.c | 8 
>  1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c 
> b/drivers/gpu/drm/bridge/dw_hdmi.c
> index 9ffc257..b9d8d8a 100644
> --- a/drivers/gpu/drm/bridge/dw_hdmi.c
> +++ b/drivers/gpu/drm/bridge/dw_hdmi.c
> @@ -900,10 +900,10 @@ static int hdmi_phy_configure(struct dw_hdmi *hdmi, 
> unsigned char prep,
>  {
> unsigned res_idx, i;
> u8 val, msec;
> -   const struct dw_hdmi_mpll_config *mpll_config =
> -   hdmi->plat_data->mpll_cfg;
> -   const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
> -   const struct dw_hdmi_sym_term *sym_term =  hdmi->plat_data->sym_term;
> +   const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
> +   const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
> +   const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
> +   const struct dw_hdmi_sym_term *sym_term =  plat_data->sym_term;
>
> if (prep)
> return -EINVAL;
> --
> 2.1.2
>
>
>
> ___
> Linux-rockchip mailing list
> linux-rockc...@lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/linux-rockchip
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-09 Thread Joe Perches
On Sun, 2015-03-08 at 21:48 -0700, Joe Perches wrote:

> Shouldn't all of these be static?

Don't mind me.  These shouldn't be static.

I was a bit mislead by the commit message.

I think it'd be better not to put patch-like
+ and - lines in the commit description.

cheers, Joe

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-09 Thread Joe Perches
On Sun, 2015-03-08 at 21:48 -0700, Joe Perches wrote:

 Shouldn't all of these be static?

Don't mind me.  These shouldn't be static.

I was a bit mislead by the commit message.

I think it'd be better not to put patch-like
+ and - lines in the commit description.

cheers, Joe

--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-09 Thread Daniel Kurtz
On Mon, Mar 9, 2015 at 12:42 PM, Yakir Yang y...@rock-chips.com wrote:
 - const struct dw_hdmi_mpll_config *mpll_config =
 -hdmi-plat_data-mpll_cfg;
 - const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi-plat_data-cur_ctr;
 - const struct dw_hdmi_sym_term *sym_term =  hdmi-plat_data-sym_term;

 + const struct dw_hdmi_plat_data *plat_data = hdmi-plat_data;
 + const struct dw_hdmi_mpll_config *mpll_config = plat_data-mpll_cfg;
 + const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data-cur_ctr;
 + const struct dw_hdmi_sym_term *sym_term =  plat_data-sym_term;

 Signed-off-by: Yakir Yang y...@rock-chips.com

I agree with Joe Perches that this commit message is not very clear.
It should summarize what the patches is doing and why, not just be a
copy of the change.
e.g., Using a local struct pointer to reduce one level of indirection
makes the code slightly more readable.

, but otherwise this is:
Reviewed-by: Daniel Kurtz djku...@chromium.org

 ---

 Changes in v2: None

  drivers/gpu/drm/bridge/dw_hdmi.c | 8 
  1 file changed, 4 insertions(+), 4 deletions(-)

 diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c 
 b/drivers/gpu/drm/bridge/dw_hdmi.c
 index 9ffc257..b9d8d8a 100644
 --- a/drivers/gpu/drm/bridge/dw_hdmi.c
 +++ b/drivers/gpu/drm/bridge/dw_hdmi.c
 @@ -900,10 +900,10 @@ static int hdmi_phy_configure(struct dw_hdmi *hdmi, 
 unsigned char prep,
  {
 unsigned res_idx, i;
 u8 val, msec;
 -   const struct dw_hdmi_mpll_config *mpll_config =
 -   hdmi-plat_data-mpll_cfg;
 -   const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi-plat_data-cur_ctr;
 -   const struct dw_hdmi_sym_term *sym_term =  hdmi-plat_data-sym_term;
 +   const struct dw_hdmi_plat_data *plat_data = hdmi-plat_data;
 +   const struct dw_hdmi_mpll_config *mpll_config = plat_data-mpll_cfg;
 +   const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data-cur_ctr;
 +   const struct dw_hdmi_sym_term *sym_term =  plat_data-sym_term;

 if (prep)
 return -EINVAL;
 --
 2.1.2



 ___
 Linux-rockchip mailing list
 linux-rockc...@lists.infradead.org
 http://lists.infradead.org/mailman/listinfo/linux-rockchip
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-09 Thread yakir


On 2015年03月09日 15:05, Daniel Kurtz wrote:

On Mon, Mar 9, 2015 at 12:42 PM, Yakir Yang y...@rock-chips.com wrote:

- const struct dw_hdmi_mpll_config *mpll_config =
-hdmi-plat_data-mpll_cfg;
- const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi-plat_data-cur_ctr;
- const struct dw_hdmi_sym_term *sym_term =  hdmi-plat_data-sym_term;

+ const struct dw_hdmi_plat_data *plat_data = hdmi-plat_data;
+ const struct dw_hdmi_mpll_config *mpll_config = plat_data-mpll_cfg;
+ const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data-cur_ctr;
+ const struct dw_hdmi_sym_term *sym_term =  plat_data-sym_term;

Signed-off-by: Yakir Yang y...@rock-chips.com

I agree with Joe Perches that this commit message is not very clear.
It should summarize what the patches is doing and why, not just be a
copy of the change.
e.g., Using a local struct pointer to reduce one level of indirection
makes the code slightly more readable.

, but otherwise this is:
Reviewed-by: Daniel Kurtz djku...@chromium.org


Okay, I will correct it now.

Thanks for your reivew  :)


---

Changes in v2: None

  drivers/gpu/drm/bridge/dw_hdmi.c | 8 
  1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c b/drivers/gpu/drm/bridge/dw_hdmi.c
index 9ffc257..b9d8d8a 100644
--- a/drivers/gpu/drm/bridge/dw_hdmi.c
+++ b/drivers/gpu/drm/bridge/dw_hdmi.c
@@ -900,10 +900,10 @@ static int hdmi_phy_configure(struct dw_hdmi *hdmi, 
unsigned char prep,
  {
 unsigned res_idx, i;
 u8 val, msec;
-   const struct dw_hdmi_mpll_config *mpll_config =
-   hdmi-plat_data-mpll_cfg;
-   const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi-plat_data-cur_ctr;
-   const struct dw_hdmi_sym_term *sym_term =  hdmi-plat_data-sym_term;
+   const struct dw_hdmi_plat_data *plat_data = hdmi-plat_data;
+   const struct dw_hdmi_mpll_config *mpll_config = plat_data-mpll_cfg;
+   const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data-cur_ctr;
+   const struct dw_hdmi_sym_term *sym_term =  plat_data-sym_term;

 if (prep)
 return -EINVAL;
--
2.1.2



___
Linux-rockchip mailing list
linux-rockc...@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-rockchip






--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-09 Thread yakir


On 2015年03月09日 14:48, Joe Perches wrote:

On Sun, 2015-03-08 at 21:48 -0700, Joe Perches wrote:


Shouldn't all of these be static?

Don't mind me.  These shouldn't be static.

I was a bit mislead by the commit message.

I think it'd be better not to put patch-like
+ and - lines in the commit description.

cheers, Joe



Okay, I will delete it from commit message.

Thanks for reply :)






--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-08 Thread Joe Perches
On Mon, 2015-03-09 at 12:42 +0800, Yakir Yang wrote:
> diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c 
> b/drivers/gpu/drm/bridge/dw_hdmi.c
[]
> @@ -900,10 +900,10 @@ static int hdmi_phy_configure(struct dw_hdmi *hdmi, 
> unsigned char prep,
>  {
>   unsigned res_idx, i;
>   u8 val, msec;
> - const struct dw_hdmi_mpll_config *mpll_config =
> - hdmi->plat_data->mpll_cfg;
> - const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
> - const struct dw_hdmi_sym_term *sym_term =  hdmi->plat_data->sym_term;
> + const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
> + const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
> + const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
> + const struct dw_hdmi_sym_term *sym_term =  plat_data->sym_term;
>  
>   if (prep)
>   return -EINVAL;

Shouldn't all of these be static?


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-08 Thread Yakir Yang
- const struct dw_hdmi_mpll_config *mpll_config =
-hdmi->plat_data->mpll_cfg;
- const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
- const struct dw_hdmi_sym_term *sym_term =  hdmi->plat_data->sym_term;

+ const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
+ const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
+ const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
+ const struct dw_hdmi_sym_term *sym_term =  plat_data->sym_term;

Signed-off-by: Yakir Yang 
---

Changes in v2: None

 drivers/gpu/drm/bridge/dw_hdmi.c | 8 
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c b/drivers/gpu/drm/bridge/dw_hdmi.c
index 9ffc257..b9d8d8a 100644
--- a/drivers/gpu/drm/bridge/dw_hdmi.c
+++ b/drivers/gpu/drm/bridge/dw_hdmi.c
@@ -900,10 +900,10 @@ static int hdmi_phy_configure(struct dw_hdmi *hdmi, 
unsigned char prep,
 {
unsigned res_idx, i;
u8 val, msec;
-   const struct dw_hdmi_mpll_config *mpll_config =
-   hdmi->plat_data->mpll_cfg;
-   const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi->plat_data->cur_ctr;
-   const struct dw_hdmi_sym_term *sym_term =  hdmi->plat_data->sym_term;
+   const struct dw_hdmi_plat_data *plat_data = hdmi->plat_data;
+   const struct dw_hdmi_mpll_config *mpll_config = plat_data->mpll_cfg;
+   const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data->cur_ctr;
+   const struct dw_hdmi_sym_term *sym_term =  plat_data->sym_term;
 
if (prep)
return -EINVAL;
-- 
2.1.2


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-08 Thread Joe Perches
On Mon, 2015-03-09 at 12:42 +0800, Yakir Yang wrote:
 diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c 
 b/drivers/gpu/drm/bridge/dw_hdmi.c
[]
 @@ -900,10 +900,10 @@ static int hdmi_phy_configure(struct dw_hdmi *hdmi, 
 unsigned char prep,
  {
   unsigned res_idx, i;
   u8 val, msec;
 - const struct dw_hdmi_mpll_config *mpll_config =
 - hdmi-plat_data-mpll_cfg;
 - const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi-plat_data-cur_ctr;
 - const struct dw_hdmi_sym_term *sym_term =  hdmi-plat_data-sym_term;
 + const struct dw_hdmi_plat_data *plat_data = hdmi-plat_data;
 + const struct dw_hdmi_mpll_config *mpll_config = plat_data-mpll_cfg;
 + const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data-cur_ctr;
 + const struct dw_hdmi_sym_term *sym_term =  plat_data-sym_term;
  
   if (prep)
   return -EINVAL;

Shouldn't all of these be static?


--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH v2 1/3] drm: bridge/dw_hdmi: fixed codec style

2015-03-08 Thread Yakir Yang
- const struct dw_hdmi_mpll_config *mpll_config =
-hdmi-plat_data-mpll_cfg;
- const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi-plat_data-cur_ctr;
- const struct dw_hdmi_sym_term *sym_term =  hdmi-plat_data-sym_term;

+ const struct dw_hdmi_plat_data *plat_data = hdmi-plat_data;
+ const struct dw_hdmi_mpll_config *mpll_config = plat_data-mpll_cfg;
+ const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data-cur_ctr;
+ const struct dw_hdmi_sym_term *sym_term =  plat_data-sym_term;

Signed-off-by: Yakir Yang y...@rock-chips.com
---

Changes in v2: None

 drivers/gpu/drm/bridge/dw_hdmi.c | 8 
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/bridge/dw_hdmi.c b/drivers/gpu/drm/bridge/dw_hdmi.c
index 9ffc257..b9d8d8a 100644
--- a/drivers/gpu/drm/bridge/dw_hdmi.c
+++ b/drivers/gpu/drm/bridge/dw_hdmi.c
@@ -900,10 +900,10 @@ static int hdmi_phy_configure(struct dw_hdmi *hdmi, 
unsigned char prep,
 {
unsigned res_idx, i;
u8 val, msec;
-   const struct dw_hdmi_mpll_config *mpll_config =
-   hdmi-plat_data-mpll_cfg;
-   const struct dw_hdmi_curr_ctrl *curr_ctrl = hdmi-plat_data-cur_ctr;
-   const struct dw_hdmi_sym_term *sym_term =  hdmi-plat_data-sym_term;
+   const struct dw_hdmi_plat_data *plat_data = hdmi-plat_data;
+   const struct dw_hdmi_mpll_config *mpll_config = plat_data-mpll_cfg;
+   const struct dw_hdmi_curr_ctrl *curr_ctrl = plat_data-cur_ctr;
+   const struct dw_hdmi_sym_term *sym_term =  plat_data-sym_term;
 
if (prep)
return -EINVAL;
-- 
2.1.2


--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/