[BUG] __copy_to_user_inatomic broken on non Pentium machines

2007-03-25 Thread Thomas Gleixner
Environment: Pre Pentium systems, (boot_cpu_data.wp_works_ok == 0) Last known working kernel: 2.6.18 (did not try 2.6.19 yet) Enabling CONFIG_PREEMPT on latest mainline as well as 2.6.20 trigger [ 14.15] BUG: sleeping function called from invalid context at

Re: [BUG] __copy_to_user_inatomic broken on non Pentium machines

2007-03-25 Thread Linus Torvalds
On Sun, 25 Mar 2007, Thomas Gleixner wrote: Environment: Pre Pentium systems, (boot_cpu_data.wp_works_ok == 0) This shouldn't be pre-pentium, afaik. WP-works-ok on i486 too. I think only the original i386 had this bug (feature). But I agree, it does seem to be broken on such machines (I

Re: [BUG] __copy_to_user_inatomic broken on non Pentium machines

2007-03-25 Thread Ingo Molnar
* Linus Torvalds [EMAIL PROTECTED] wrote: On Sun, 25 Mar 2007, Thomas Gleixner wrote: Environment: Pre Pentium systems, (boot_cpu_data.wp_works_ok == 0) This shouldn't be pre-pentium, afaik. WP-works-ok on i486 too. I think only the original i386 had this bug (feature). But I agree,

Re: [BUG] __copy_to_user_inatomic broken on non Pentium machines

2007-03-25 Thread Thomas Gleixner
On Sun, 2007-03-25 at 11:14 -0700, Linus Torvalds wrote: Environment: Pre Pentium systems, (boot_cpu_data.wp_works_ok == 0) This shouldn't be pre-pentium, afaik. WP-works-ok on i486 too. I think only the original i386 had this bug (feature). But I agree, it does seem to be broken on such