Re: [GIT PULL] first round of SCSI updates for the 5.0+ merge window

2019-03-11 Thread Tony Luck
On Wed, Mar 6, 2019 at 10:30 PM James Bottomley
 wrote:
> Hannes Reinecke (4):
>   scsi: kill command serial number

ia64 build error with arch/ia64/configs/sim_defconfig

arch/ia64/hp/sim/simscsi.c: In function 'simscsi_interrupt':
arch/ia64/hp/sim/simscsi.c:108:51: error: 'struct scsi_cmnd' has no
member named 'serial_number'

-Tony


Re: [GIT PULL] first round of SCSI updates for the 5.0+ merge window

2019-03-09 Thread pr-tracker-bot
The pull request you sent on Wed, 06 Mar 2019 22:29:46 -0800:

> git://git.kernel.org/pub/scm/linux/kernel/git/jejb/scsi.git scsi-misc

has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/92fff53b7191cae566be9ca6752069426c7f8241

Thank you!

-- 
Deet-doot-dot, I am a bot.
https://korg.wiki.kernel.org/userdoc/prtracker


[GIT PULL] first round of SCSI updates for the 5.0+ merge window

2019-03-06 Thread James Bottomley
This is mostly update of the usual drivers: arcmsr, qla2xxx, lpfc,
hisi_sas, target/iscsi and target/core.  Additionally Christoph
refactored gdth as part of the dma changes.  The major mid-layer change
this time is the removal of bidi commands and with them the whole of
the osd/exofs driver and filesystem.  This is a major simplification
for block and mq in particular.

Additionally, there are four existing and one potential conflict:

- The unpulled block tree updates the removed osd driver

- 750afb08ca71 cross-tree: phase out dma_zalloc_coherent() conflicts
with the arcmsr update.  The fix is simple: go with our version

The remaining conflicts are internal between updates we supplied in our
fixes branches and changes made to the misc branch:

- hisi_sas_v3_hw.c: This is the nastiest: the fix to move the
protection parameters (7bb25a89aad2) conflicts with the DIX feature
addition (b3cce125cb1e).  The resolution is to make sure the DIX
enablement follows the move of the prot_mask check in
hisi_sas_v3_probe().

- lpfc_nvme.c: the fix to avoid hang/use after free (7961cba6f7d8)
conflicts with moving the stats to HW queue structures (4c47efc140fa). 
The resolution a simple combination of both patches.

- qla_init.c: The fix for the panic after free (388a49959ee4) conflicts
with move marker behind QPair (9eb9c6dc3ab0).  The fix is a straight
combination plus the transformation of sp->fcport->loop_id to fcport-
>loop_id to preserve the panic fix.

I've put the resolution in the linus-resolved branch of the scsi tree
for you to see and also attached the --cc diff below.

The patch is available here:

git://git.kernel.org/pub/scm/linux/kernel/git/jejb/scsi.git scsi-misc

The short changelog is:

Anil Gurumurthy (1):
  scsi: qla2xxx: Add support for setting port speed

Avri Altman (4):
  scsi: ufs-bsg: Allow reading descriptors
  scsi: ufs: Allow reading descriptor via raw upiu
  scsi: ufs-bsg: Change the calling convention for write descriptor
  scsi: clean obsolete return values of eh_timed_out

Bart Van Assche (27):
  scsi: core: Move resid from scsi_data_buffer to scsi_cmnd
  scsi: sd: Remove superfluous residual assignments
  scsi: uas: Use scsi_[gs]et_resid() where appropriate
  scsi: scsi_debug: Use scsi_[gs]et_resid() where appropriate
  scsi: libiscsi: Use scsi_[gs]et_resid() where appropriate
  scsi: scsi_debug: Fix a recently introduced regression
  scsi: target/iscsi: Simplify iscsit_handle_text_cmd()
  scsi: target/iscsi: Simplify iscsit_dump_data_payload()
  scsi: target/iscsi: Avoid iscsit_release_commands_from_conn() deadlock
  scsi: target/iscsi: Rename a function and a function pointer
  scsi: target/iscsi: Fix spelling of "unsolicited"
  scsi: target/iscsi: Convert comments about locking into runtime checks
  scsi: target/iscsi: Remove an incorrect comment
  scsi: RDMA/srpt: Fix a credit leak for aborted commands
  scsi: RDMA/srpt: Rework I/O context allocation
  scsi: RDMA/srpt: Fix handling of TMF submission failure
  scsi: RDMA/srpt: Fix handling of command / TMF submission failure
  scsi: target/core: Add target_send_busy()
  scsi: target/core: Inline transport_lun_remove_cmd()
  scsi: target/core: Simplify the LUN RESET implementation
  scsi: target/core: Remove several state tests from the TMF code
  scsi: target/core: Remove the write_pending_status() callback function
  scsi: sd: Protect against READ(6) or WRITE(6) with zero block transfer 
length
  scsi: libsas: Remove scsi_to_u32()
  scsi: core: Remove an atomic instruction from the hot path
  scsi: sd: Rename 'SCpnt' into 'cmd'
  scsi: sd: Remove a local variable

Benjamin Block (1):
  scsi: core: replace GFP_ATOMIC with GFP_KERNEL in scsi_scan.c

Bill Kuzeja (1):
  scsi: qla2xxx: Move debug messages before sending srb preventing panic

Chengguang Xu (1):
  scsi: ufs: fix a typo in comment

Ching Huang (15):
  scsi: arcmsr: Update driver version to v1.40.00.10-20190116
  scsi: arcmsr: Fix suspend/resume of ACB_ADAPTER_TYPE_B part 2
  scsi: arcmsr: Use dma_alloc_coherent to replace dma_zalloc_coherent
  scsi: arcmsr: Update driver version to v1.40.00.10-20181217
  scsi: arcmsr: Fix suspend/resume of ACB_ADAPTER_TYPE_B
  scsi: arcmsr: Separate 'set dma mask' as a function
  scsi: arcmsr: Add an option of set dma_mask_64 for ACB_ADAPTER_TYPE_A
  scsi: arcmsr: Update ACB_ADAPTER_TYPE_D for >4GB ccb addressing
  scsi: arcmsr: Update ACB_ADAPTER_TYPE_C for >4GB ccb addressing
  scsi: arcmsr: Update ACB_ADAPTER_TYPE_B for >4GB ccb addressing
  scsi: arcmsr: Update ACB_ADAPTER_TYPE_A for >4GB ccb addressing
  scsi: arcmsr: Update arcmsr_alloc_ccb_pool for ccb buffer address above 
4GB
  scsi: arcmsr: Merge arcmsr_alloc_io_queue to arcmsr_alloc_ccb_pool
  scsi: arcmsr: Rename arcmsr_free_mu to arcmsr_free_io_queue
  scsi: arcmsr: Rename acb