Re: [PATCH] i2c: iproc: Change driver to use 'BIT' macro

2019-04-23 Thread Wolfram Sang
On Wed, Apr 03, 2019 at 02:05:35PM -0700, Ray Jui wrote: > Change the iProc I2C driver to use the 'BIT' macro from all '1 << XXX' > bit operations to get rid of compiler warning and improve readability of > the code > > Signed-off-by: Ray Jui Applied to for-next, thanks! signature.asc

Re: [PATCH] i2c: iproc: Change driver to use 'BIT' macro

2019-04-18 Thread Peter Rosin
On 2019-04-18 19:25, Ray Jui wrote: > > > On 4/17/2019 11:21 PM, Peter Rosin wrote: >> On 2019-04-18 01:48, Ray Jui wrote: >>> >>> >>> On 4/14/2019 11:56 PM, Peter Rosin wrote: On 2019-04-13 00:59, Peter Rosin wrote: > On 2019-04-03 23:05, Ray Jui wrote: >> Change the iProc I2C

Re: [PATCH] i2c: iproc: Change driver to use 'BIT' macro

2019-04-18 Thread Ray Jui
On 4/17/2019 11:21 PM, Peter Rosin wrote: > On 2019-04-18 01:48, Ray Jui wrote: >> >> >> On 4/14/2019 11:56 PM, Peter Rosin wrote: >>> On 2019-04-13 00:59, Peter Rosin wrote: On 2019-04-03 23:05, Ray Jui wrote: > Change the iProc I2C driver to use the 'BIT' macro from all '1 << XXX'

Re: [PATCH] i2c: iproc: Change driver to use 'BIT' macro

2019-04-18 Thread Peter Rosin
On 2019-04-18 01:48, Ray Jui wrote: > > > On 4/14/2019 11:56 PM, Peter Rosin wrote: >> On 2019-04-13 00:59, Peter Rosin wrote: >>> On 2019-04-03 23:05, Ray Jui wrote: Change the iProc I2C driver to use the 'BIT' macro from all '1 << XXX' bit operations to get rid of compiler warning

Re: [PATCH] i2c: iproc: Change driver to use 'BIT' macro

2019-04-17 Thread Ray Jui
On 4/14/2019 11:56 PM, Peter Rosin wrote: > On 2019-04-13 00:59, Peter Rosin wrote: >> On 2019-04-03 23:05, Ray Jui wrote: >>> Change the iProc I2C driver to use the 'BIT' macro from all '1 << XXX' >>> bit operations to get rid of compiler warning and improve readability of >>> the code >> >>

Re: [PATCH] i2c: iproc: Change driver to use 'BIT' macro

2019-04-15 Thread Peter Rosin
On 2019-04-13 00:59, Peter Rosin wrote: > On 2019-04-03 23:05, Ray Jui wrote: >> Change the iProc I2C driver to use the 'BIT' macro from all '1 << XXX' >> bit operations to get rid of compiler warning and improve readability of >> the code > > All? I see lots more '1 << XXX_SHIFT' matches. I

Re: [PATCH] i2c: iproc: Change driver to use 'BIT' macro

2019-04-12 Thread Peter Rosin
On 2019-04-03 23:05, Ray Jui wrote: > Change the iProc I2C driver to use the 'BIT' macro from all '1 << XXX' > bit operations to get rid of compiler warning and improve readability of > the code All? I see lots more '1 << XXX_SHIFT' matches. I might be behind though? Anyway, if you are cleaning

[PATCH] i2c: iproc: Change driver to use 'BIT' macro

2019-04-03 Thread Ray Jui
Change the iProc I2C driver to use the 'BIT' macro from all '1 << XXX' bit operations to get rid of compiler warning and improve readability of the code Signed-off-by: Ray Jui --- drivers/i2c/busses/i2c-bcm-iproc.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git