Re: [PATCH] x86: restore correct module name for apm

2008-02-03 Thread Sam Ravnborg
On Sun, Feb 03, 2008 at 11:52:16AM +, A.E.Lawrence wrote:
> Sam Ravnborg wrote:
> > The apm module were renamed to apm_32 during the merge of 32 and 64 bit x86 
> > which
> > is unfortunate.
> > As apm is 32 bit specific we like to keep the _32 in the filename
> > but the module should be named apm.
> > 
> > Fix this in the Makefile.
> > Reported by "A.E.Lawrence" <[EMAIL PROTECTED]>
> 
> ..snip..
> > 
> > build tested only but obviously correct.
> > 
> > Sam
> 
> It is also at
>   http://bugzilla.kernel.org/show_bug.cgi?id=9877
> which someone (me?) should probably now close.

I please do so.
But I think you should wait until it hits mainline

Sam
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] x86: restore correct module name for apm

2008-02-03 Thread A.E.Lawrence
Sam Ravnborg wrote:
> The apm module were renamed to apm_32 during the merge of 32 and 64 bit x86 
> which
> is unfortunate.
> As apm is 32 bit specific we like to keep the _32 in the filename
> but the module should be named apm.
> 
> Fix this in the Makefile.
> Reported by "A.E.Lawrence" <[EMAIL PROTECTED]>

..snip..
> 
> build tested only but obviously correct.
> 
>   Sam

It is also at
  http://bugzilla.kernel.org/show_bug.cgi?id=9877
which someone (me?) should probably now close.

A E Lawrence
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] x86: restore correct module name for apm

2008-02-03 Thread Frans Pop
Sam Ravnborg wrote:
> The apm module were renamed to apm_32 during the merge of 32 and 64 bit
> x86 which is unfortunate.
> As apm is 32 bit specific we like to keep the _32 in the filename
> but the module should be named apm.
> 
> Fix this in the Makefile.
> Reported by "A.E.Lawrence" <[EMAIL PROTECTED]>
> 
> Signed-off-by: Sam Ravnborg <[EMAIL PROTECTED]>
> Cc: Cc: Ingo Molnar <[EMAIL PROTECTED]>
> Cc: Thomas Gleixner <[EMAIL PROTECTED]>
> Cc: "H. Peter Anvin" <[EMAIL PROTECTED]>
> Cc: "A.E.Lawrence" <[EMAIL PROTECTED]>

I assume this will be pushed for stable 2.6.24 as well?

Cheers,
FJP
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] x86: restore correct module name for apm

2008-02-03 Thread Ingo Molnar

* Sam Ravnborg <[EMAIL PROTECTED]> wrote:

> The apm module were renamed to apm_32 during the merge of 32 and 64 
> bit x86 which is unfortunate. As apm is 32 bit specific we like to 
> keep the _32 in the filename but the module should be named apm.
> 
> Fix this in the Makefile.

thanks, applied.

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH] x86: restore correct module name for apm

2008-02-03 Thread Sam Ravnborg
The apm module were renamed to apm_32 during the merge of 32 and 64 bit x86 
which
is unfortunate.
As apm is 32 bit specific we like to keep the _32 in the filename
but the module should be named apm.

Fix this in the Makefile.
Reported by "A.E.Lawrence" <[EMAIL PROTECTED]>

Signed-off-by: Sam Ravnborg <[EMAIL PROTECTED]>
Cc: Cc: Ingo Molnar <[EMAIL PROTECTED]>
Cc: Thomas Gleixner <[EMAIL PROTECTED]>
Cc: "H. Peter Anvin" <[EMAIL PROTECTED]>
Cc: "A.E.Lawrence" <[EMAIL PROTECTED]>
---

build tested only but obviously correct.

Sam

diff --git a/arch/x86/kernel/Makefile b/arch/x86/kernel/Makefile
index 6f81300..f080635 100644
--- a/arch/x86/kernel/Makefile
+++ b/arch/x86/kernel/Makefile
@@ -37,7 +37,8 @@ obj-$(CONFIG_X86_MSR) += msr.o
 obj-$(CONFIG_X86_CPUID)+= cpuid.o
 obj-$(CONFIG_MICROCODE)+= microcode.o
 obj-$(CONFIG_PCI)  += early-quirks.o
-obj-$(CONFIG_APM)  += apm_32.o
+apm-y  := apm_32.o
+obj-$(CONFIG_APM)  += apm.o
 obj-$(CONFIG_X86_SMP)  += smp_$(BITS).o smpboot_$(BITS).o tsc_sync.o
 obj-$(CONFIG_X86_32_SMP)   += smpcommon_32.o
 obj-$(CONFIG_X86_64_SMP)   += smp_64.o smpboot_64.o tsc_sync.o
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[PATCH] x86: restore correct module name for apm

2008-02-03 Thread Sam Ravnborg
The apm module were renamed to apm_32 during the merge of 32 and 64 bit x86 
which
is unfortunate.
As apm is 32 bit specific we like to keep the _32 in the filename
but the module should be named apm.

Fix this in the Makefile.
Reported by A.E.Lawrence [EMAIL PROTECTED]

Signed-off-by: Sam Ravnborg [EMAIL PROTECTED]
Cc: Cc: Ingo Molnar [EMAIL PROTECTED]
Cc: Thomas Gleixner [EMAIL PROTECTED]
Cc: H. Peter Anvin [EMAIL PROTECTED]
Cc: A.E.Lawrence [EMAIL PROTECTED]
---

build tested only but obviously correct.

Sam

diff --git a/arch/x86/kernel/Makefile b/arch/x86/kernel/Makefile
index 6f81300..f080635 100644
--- a/arch/x86/kernel/Makefile
+++ b/arch/x86/kernel/Makefile
@@ -37,7 +37,8 @@ obj-$(CONFIG_X86_MSR) += msr.o
 obj-$(CONFIG_X86_CPUID)+= cpuid.o
 obj-$(CONFIG_MICROCODE)+= microcode.o
 obj-$(CONFIG_PCI)  += early-quirks.o
-obj-$(CONFIG_APM)  += apm_32.o
+apm-y  := apm_32.o
+obj-$(CONFIG_APM)  += apm.o
 obj-$(CONFIG_X86_SMP)  += smp_$(BITS).o smpboot_$(BITS).o tsc_sync.o
 obj-$(CONFIG_X86_32_SMP)   += smpcommon_32.o
 obj-$(CONFIG_X86_64_SMP)   += smp_64.o smpboot_64.o tsc_sync.o
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] x86: restore correct module name for apm

2008-02-03 Thread Ingo Molnar

* Sam Ravnborg [EMAIL PROTECTED] wrote:

 The apm module were renamed to apm_32 during the merge of 32 and 64 
 bit x86 which is unfortunate. As apm is 32 bit specific we like to 
 keep the _32 in the filename but the module should be named apm.
 
 Fix this in the Makefile.

thanks, applied.

Ingo
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] x86: restore correct module name for apm

2008-02-03 Thread Frans Pop
Sam Ravnborg wrote:
 The apm module were renamed to apm_32 during the merge of 32 and 64 bit
 x86 which is unfortunate.
 As apm is 32 bit specific we like to keep the _32 in the filename
 but the module should be named apm.
 
 Fix this in the Makefile.
 Reported by A.E.Lawrence [EMAIL PROTECTED]
 
 Signed-off-by: Sam Ravnborg [EMAIL PROTECTED]
 Cc: Cc: Ingo Molnar [EMAIL PROTECTED]
 Cc: Thomas Gleixner [EMAIL PROTECTED]
 Cc: H. Peter Anvin [EMAIL PROTECTED]
 Cc: A.E.Lawrence [EMAIL PROTECTED]

I assume this will be pushed for stable 2.6.24 as well?

Cheers,
FJP
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] x86: restore correct module name for apm

2008-02-03 Thread A.E.Lawrence
Sam Ravnborg wrote:
 The apm module were renamed to apm_32 during the merge of 32 and 64 bit x86 
 which
 is unfortunate.
 As apm is 32 bit specific we like to keep the _32 in the filename
 but the module should be named apm.
 
 Fix this in the Makefile.
 Reported by A.E.Lawrence [EMAIL PROTECTED]

..snip..
 
 build tested only but obviously correct.
 
   Sam

It is also at
  http://bugzilla.kernel.org/show_bug.cgi?id=9877
which someone (me?) should probably now close.

A E Lawrence
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [PATCH] x86: restore correct module name for apm

2008-02-03 Thread Sam Ravnborg
On Sun, Feb 03, 2008 at 11:52:16AM +, A.E.Lawrence wrote:
 Sam Ravnborg wrote:
  The apm module were renamed to apm_32 during the merge of 32 and 64 bit x86 
  which
  is unfortunate.
  As apm is 32 bit specific we like to keep the _32 in the filename
  but the module should be named apm.
  
  Fix this in the Makefile.
  Reported by A.E.Lawrence [EMAIL PROTECTED]
 
 ..snip..
  
  build tested only but obviously correct.
  
  Sam
 
 It is also at
   http://bugzilla.kernel.org/show_bug.cgi?id=9877
 which someone (me?) should probably now close.

I please do so.
But I think you should wait until it hits mainline

Sam
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/