This patch reimplements the thunderx_gpio_set_multiple function in
drivers/gpio/gpio-thunderx.c to use the new for_each_set_clump macro.
Instead of looping for each bank in thunderx_gpio_set_multiple
function, now we can skip bank which is not set and save cycles.

Cc: Robert Richter <rrich...@marvell.com>
Cc: Linus Walleij <linus.wall...@linaro.org>
Cc: Bartosz Golaszewski <bgolaszew...@baylibre.com>
Signed-off-by: Syed Nayyar Waris <syednwa...@gmail.com>
Signed-off-by: William Breathitt Gray <vilhelm.g...@gmail.com>
---
Changes in v4:
 - Minor change: Hardcode value for better code readability.

Changes in v3:
 - Change datatype of some variables from u64 to unsigned long
   in function thunderx_gpio_set_multiple.

CHanges in v2:
 - No change.

 drivers/gpio/gpio-thunderx.c | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)

diff --git a/drivers/gpio/gpio-thunderx.c b/drivers/gpio/gpio-thunderx.c
index 9f66deab46ea..58c9bb25a377 100644
--- a/drivers/gpio/gpio-thunderx.c
+++ b/drivers/gpio/gpio-thunderx.c
@@ -275,12 +275,15 @@ static void thunderx_gpio_set_multiple(struct gpio_chip 
*chip,
                                       unsigned long *bits)
 {
        int bank;
-       u64 set_bits, clear_bits;
+       unsigned long set_bits, clear_bits, gpio_mask;
+       unsigned long offset;
+
        struct thunderx_gpio *txgpio = gpiochip_get_data(chip);
 
-       for (bank = 0; bank <= chip->ngpio / 64; bank++) {
-               set_bits = bits[bank] & mask[bank];
-               clear_bits = ~bits[bank] & mask[bank];
+       for_each_set_clump(offset, gpio_mask, mask, chip->ngpio, 64) {
+               bank = offset / 64;
+               set_bits = bits[bank] & gpio_mask;
+               clear_bits = ~bits[bank] & gpio_mask;
                writeq(set_bits, txgpio->register_base + (bank * GPIO_2ND_BANK) 
+ GPIO_TX_SET);
                writeq(clear_bits, txgpio->register_base + (bank * 
GPIO_2ND_BANK) + GPIO_TX_CLR);
        }
-- 
2.26.2

Reply via email to