Re: Re: [RFC PATCH 07/11] [CLEANUP] trace-cmd: Split out binding a port and fork reader from open_udp()

2013-08-27 Thread Yoshihiro YUNOMAE
(2013/08/26 23:37), Steven Rostedt wrote: On Mon, 26 Aug 2013 10:48:15 +0900 Yoshihiro YUNOMAE wrote: +static int open_udp(const char *node, const char *port, int *pid, + int cpu, int pagesize, int start_port) +{ + int sfd; + int num_port; + + num_port =

Re: Re: [RFC PATCH 07/11] [CLEANUP] trace-cmd: Split out binding a port and fork reader from open_udp()

2013-08-27 Thread Yoshihiro YUNOMAE
(2013/08/26 23:37), Steven Rostedt wrote: On Mon, 26 Aug 2013 10:48:15 +0900 Yoshihiro YUNOMAE yoshihiro.yunomae...@hitachi.com wrote: +static int open_udp(const char *node, const char *port, int *pid, + int cpu, int pagesize, int start_port) +{ + int sfd; + int

Re: [RFC PATCH 07/11] [CLEANUP] trace-cmd: Split out binding a port and fork reader from open_udp()

2013-08-26 Thread Steven Rostedt
On Mon, 26 Aug 2013 10:48:15 +0900 Yoshihiro YUNOMAE wrote: > >> +static int open_udp(const char *node, const char *port, int *pid, > >> + int cpu, int pagesize, int start_port) > >> +{ > >> + int sfd; > >> + int num_port; > >> + > >> + num_port = udp_bind_a_port(start_port, );

Re: [RFC PATCH 07/11] [CLEANUP] trace-cmd: Split out binding a port and fork reader from open_udp()

2013-08-26 Thread Steven Rostedt
On Mon, 26 Aug 2013 10:48:15 +0900 Yoshihiro YUNOMAE yoshihiro.yunomae...@hitachi.com wrote: +static int open_udp(const char *node, const char *port, int *pid, + int cpu, int pagesize, int start_port) +{ + int sfd; + int num_port; + + num_port =

Re: Re: [RFC PATCH 07/11] [CLEANUP] trace-cmd: Split out binding a port and fork reader from open_udp()

2013-08-25 Thread Yoshihiro YUNOMAE
(2013/08/21 2:49), Steven Rostedt wrote: On Mon, 19 Aug 2013 18:46:37 +0900 Yoshihiro YUNOMAE wrote: Split out binding a port and fork reader from open_udp() for avoiding duplicate codes between listen mode and virt-server mode. Signed-off-by: Yoshihiro YUNOMAE --- trace-listen.c | 34

Re: Re: [RFC PATCH 07/11] [CLEANUP] trace-cmd: Split out binding a port and fork reader from open_udp()

2013-08-25 Thread Yoshihiro YUNOMAE
(2013/08/21 2:49), Steven Rostedt wrote: On Mon, 19 Aug 2013 18:46:37 +0900 Yoshihiro YUNOMAE yoshihiro.yunomae...@hitachi.com wrote: Split out binding a port and fork reader from open_udp() for avoiding duplicate codes between listen mode and virt-server mode. Signed-off-by: Yoshihiro

Re: [RFC PATCH 07/11] [CLEANUP] trace-cmd: Split out binding a port and fork reader from open_udp()

2013-08-20 Thread Steven Rostedt
On Mon, 19 Aug 2013 18:46:37 +0900 Yoshihiro YUNOMAE wrote: > Split out binding a port and fork reader from open_udp() for avoiding > duplicate > codes between listen mode and virt-server mode. > > Signed-off-by: Yoshihiro YUNOMAE > --- > trace-listen.c | 34

Re: [RFC PATCH 07/11] [CLEANUP] trace-cmd: Split out binding a port and fork reader from open_udp()

2013-08-20 Thread Steven Rostedt
On Mon, 19 Aug 2013 18:46:37 +0900 Yoshihiro YUNOMAE yoshihiro.yunomae...@hitachi.com wrote: Split out binding a port and fork reader from open_udp() for avoiding duplicate codes between listen mode and virt-server mode. Signed-off-by: Yoshihiro YUNOMAE yoshihiro.yunomae...@hitachi.com

[RFC PATCH 07/11] [CLEANUP] trace-cmd: Split out binding a port and fork reader from open_udp()

2013-08-19 Thread Yoshihiro YUNOMAE
Split out binding a port and fork reader from open_udp() for avoiding duplicate codes between listen mode and virt-server mode. Signed-off-by: Yoshihiro YUNOMAE --- trace-listen.c | 34 ++ 1 file changed, 26 insertions(+), 8 deletions(-) diff --git

[RFC PATCH 07/11] [CLEANUP] trace-cmd: Split out binding a port and fork reader from open_udp()

2013-08-19 Thread Yoshihiro YUNOMAE
Split out binding a port and fork reader from open_udp() for avoiding duplicate codes between listen mode and virt-server mode. Signed-off-by: Yoshihiro YUNOMAE yoshihiro.yunomae...@hitachi.com --- trace-listen.c | 34 ++ 1 file changed, 26 insertions(+), 8