From: AKASHI Takahiro <takahiro.aka...@linaro.org>

mmc_set_chip_select() should be called only in UHS-I mode,
and not for UHS-II mode.

Signed-off-by: Ben Chuang <ben.chu...@genesyslogic.com.tw>
Signed-off-by: AKASHI Takahiro <takahiro.aka...@linaro.org>
---
 drivers/mmc/core/core.c | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c
index 85c83c82ad0c..c6540d56646b 100644
--- a/drivers/mmc/core/core.c
+++ b/drivers/mmc/core/core.c
@@ -898,8 +898,10 @@ static inline void mmc_set_ios(struct mmc_host *host)
  */
 void mmc_set_chip_select(struct mmc_host *host, int mode)
 {
-       host->ios.chip_select = mode;
-       mmc_set_ios(host);
+       if (!(host->flags & MMC_UHS2_INITIALIZED)) {
+               host->ios.chip_select = mode;
+               mmc_set_ios(host);
+       }
 }
 
 /*
-- 
2.27.0

Reply via email to