Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-10-24 Thread Andrey Utkin
On Mon, Oct 24, 2016 at 05:32:33PM -0200, Mauro Carvalho Chehab wrote: > Em Wed, 28 Sep 2016 07:21:44 +0200 > khal...@piap.pl (Krzysztof Hałasa) escreveu: > > > Andrey Utkin writes: > > > > > Lockup happens only on 6010. In provided log you can see that 6110 > > >

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-10-24 Thread Mauro Carvalho Chehab
Em Wed, 28 Sep 2016 07:21:44 +0200 khal...@piap.pl (Krzysztof Hałasa) escreveu: > Andrey Utkin writes: > > > Lockup happens only on 6010. In provided log you can see that 6110 > > passes just fine right before 6010. Also if 6010 PCI ID is removed from > > solo6x10

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-27 Thread Krzysztof Hałasa
Andrey Utkin writes: > Lockup happens only on 6010. In provided log you can see that 6110 > passes just fine right before 6010. Also if 6010 PCI ID is removed from > solo6x10 driver's devices list, the freeze doesn't happen. Probably explains why I don't see lockups

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-27 Thread Andrey Utkin
On Tue, Sep 27, 2016 at 01:33:49PM +0200, Krzysztof Hałasa wrote: > Thanks. I can see you have quite a set of video devices there. > I will see what I can do with this. Yeah, I have got also 4-chip tw5864 board here :) Bluecherry decided to switch to it because they are available for retail

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-27 Thread Krzysztof Hałasa
Andrey Utkin writes: >> Can you share some details about the machine you are experiencing the >> problems on? CPU, chipset? I'd try to see if I can recreate the problem. > > See solo.txt.gz attached. Thanks. I can see you have quite a set of video devices there. I

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-27 Thread Andrey Utkin
On Tue, Sep 27, 2016 at 07:27:53AM +0200, Krzysztof Hałasa wrote: > Andrey Utkin writes: > > >> Does (only) adding the > >> > >>pci_read_config_word(solo_dev->pdev, PCI_STATUS, ); > >> > >> in solo_reg_write() help? > > > > Yes. > > I have posted a patch with

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-26 Thread Krzysztof Hałasa
Andrey Utkin writes: >> Does (only) adding the >> >> pci_read_config_word(solo_dev->pdev, PCI_STATUS, ); >> >> in solo_reg_write() help? > > Yes. > I have posted a patch with this change few days ago, I thought you have > noticed it. Well, I think you haven't

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-26 Thread Andrey Utkin
On Mon, Sep 26, 2016 at 07:38:05AM +0200, Krzysztof Hałasa wrote: > Andrey Utkin writes: > > > On Thu, Sep 22, 2016 at 10:51:37AM +0200, Krzysztof Hałasa wrote: > >> I wonder if the following fixes the problem (completely untested). > > > > I have given this a run, and

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-25 Thread Krzysztof Hałasa
Andrey Utkin writes: > On Thu, Sep 22, 2016 at 10:51:37AM +0200, Krzysztof Hałasa wrote: >> I wonder if the following fixes the problem (completely untested). > > I have given this a run, and it still hangs. Does (only) adding the

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-22 Thread Andrey Utkin
On Thu, Sep 22, 2016 at 10:51:37AM +0200, Krzysztof Hałasa wrote: > I wonder if the following fixes the problem (completely untested). I have given this a run, and it still hangs.

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-22 Thread Krzysztof Hałasa
Andrey Utkin writes: > It happens in solo_disp_init at uploading default motion thresholds > array. > > I've got a prints trace with solo6010-fix-lockup branch > https://github.com/bluecherrydvr/linux/tree/solo6010-fix-lockup/drivers/media/pci/solo6x10 > the trace

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-21 Thread Andrey Utkin
On Wed, Sep 21, 2016 at 03:16:57PM +0200, Krzysztof Hałasa wrote: > Hans Verkuil writes: > > > That was probably the reason for the pci_read_config_word in the reg_write > > code. Try putting that back (and just that). > > Yes. I guess a single pci_read_config_word() would

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-21 Thread Krzysztof Hałasa
Hans Verkuil writes: > That was probably the reason for the pci_read_config_word in the reg_write > code. Try putting that back (and just that). Yes. I guess a single pci_read_config_word() would suffice. Though it would obviously be much better to identify the place in the

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-15 Thread One Thousand Gnomes
On Thu, 15 Sep 2016 16:19:52 +0300 Andrey Utkin wrote: > On Thu, Sep 15, 2016 at 03:15:53PM +0200, Hans Verkuil wrote: > > It could be related to the fact that a PCI write may be delayed unless > > it is followed by a read (see also the comments in > >

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-15 Thread Hans Verkuil
On 09/15/2016 03:19 PM, Andrey Utkin wrote: > On Thu, Sep 15, 2016 at 03:15:53PM +0200, Hans Verkuil wrote: >> It could be related to the fact that a PCI write may be delayed unless >> it is followed by a read (see also the comments in >> drivers/media/pci/ivtv/ivtv-driver.h). > > Thanks for

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-15 Thread Andrey Utkin
On Thu, Sep 15, 2016 at 03:15:53PM +0200, Hans Verkuil wrote: > It could be related to the fact that a PCI write may be delayed unless > it is followed by a read (see also the comments in > drivers/media/pci/ivtv/ivtv-driver.h). Thanks for explanation! > That was probably the reason for the

Re: solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-15 Thread Hans Verkuil
It could be related to the fact that a PCI write may be delayed unless it is followed by a read (see also the comments in drivers/media/pci/ivtv/ivtv-driver.h). That was probably the reason for the pci_read_config_word in the reg_write code. Try putting that back (and just that). Regards,

solo6010 modprobe lockup since e1ceb25a (v4.3 regression)

2016-09-15 Thread Andrey Utkin
Hi Krzysztof, Me and one more solo6010 board user experience machine lockup when solo6x10 module is loaded on kernel series starting with 4.3 (despite solo6110 board probes just fine on all kernels). That is, 3.16, 3.18, 4.1 and 4.2 are tested and fine, and 4.3, 4.4, and others up to current