Re: [PATCH] xfs: fail dax mount if reflink is enabled on a partition

2022-06-30 Thread Darrick J. Wong
On Thu, Jun 09, 2022 at 10:34:35PM +0800, Shiyang Ruan wrote: > Failure notification is not supported on partitions. So, when we mount > a reflink enabled xfs on a partition with dax option, let it fail with > -EINVAL code. > > Signed-off-by: Shiyang Ruan Looks good to me, though I think this

Re: [PATCH] xfs: fail dax mount if reflink is enabled on a partition

2022-06-30 Thread Shiyang Ruan
在 2022/7/1 8:31, Darrick J. Wong 写道: On Thu, Jun 09, 2022 at 10:34:35PM +0800, Shiyang Ruan wrote: Failure notification is not supported on partitions. So, when we mount a reflink enabled xfs on a partition with dax option, let it fail with -EINVAL code. Signed-off-by: Shiyang Ruan

[PATCH] fs: Replace kmap{,_atomic}() with kmap_local_page()

2022-06-30 Thread Fabio M. De Francesco
The use of kmap() and kmap_atomic() are being deprecated in favor of kmap_local_page(). With kmap_local_page(), the mappings are per thread, CPU local and not globally visible. Furthermore, the mappings can be acquired from any context (including interrupts). Therefore, use kmap_local_page() in

Re: [PATCH] pmem: fix a name collision

2022-06-30 Thread Christoph Hellwig
On Thu, Jun 30, 2022 at 11:51:55AM -0600, Jane Chu wrote: > -static phys_addr_t to_phys(struct pmem_device *pmem, phys_addr_t offset) > +static phys_addr_t _to_phys(struct pmem_device *pmem, phys_addr_t offset) I'd rather call this pmem_to_phys as that is a much nicer name.

Re: [PATCH] pmem: fix a name collision

2022-06-30 Thread Jane Chu
On 6/30/2022 11:04 AM, Christoph Hellwig wrote: > On Thu, Jun 30, 2022 at 11:51:55AM -0600, Jane Chu wrote: >> -static phys_addr_t to_phys(struct pmem_device *pmem, phys_addr_t offset) >> +static phys_addr_t _to_phys(struct pmem_device *pmem, phys_addr_t offset) > > I'd rather call this

[PATCH v2] pmem: fix a name collision

2022-06-30 Thread Jane Chu
Kernel test robot detected name collision when compiled on 'um' architecture. Rename "to_phys()" to "pmem_to_phys()". >> drivers/nvdimm/pmem.c:48:20: error: conflicting types for 'to_phys'; have >> 'phys_addr_t(struct pmem_device *, phys_addr_t)' {aka 'long long unsigned >> int(struct

Re: [PATCH] fs: Replace kmap{,_atomic}() with kmap_local_page()

2022-06-30 Thread Eric W. Biederman
"Fabio M. De Francesco" writes: > The use of kmap() and kmap_atomic() are being deprecated in favor of > kmap_local_page(). > > With kmap_local_page(), the mappings are per thread, CPU local and not > globally visible. Furthermore, the mappings can be acquired from any > context (including

[PATCH] pmem: fix a name collision

2022-06-30 Thread Jane Chu
Kernel test robot detected name collision when compiled on 'um' architecture. Rename "to_phys()" to "_to_phys()". >> drivers/nvdimm/pmem.c:48:20: error: conflicting types for 'to_phys'; have >> 'phys_addr_t(struct pmem_device *, phys_addr_t)' {aka 'long long unsigned >> int(struct pmem_device

Re: [PATCH v2] pmem: fix a name collision

2022-06-30 Thread Christoph Hellwig
Looks good: Reviewed-by: Christoph Hellwig

Re: [PATCH v2] pmem: fix a name collision

2022-06-30 Thread Jane Chu
On 6/30/2022 11:29 AM, Christoph Hellwig wrote: > Looks good: > > Reviewed-by: Christoph Hellwig Thank you! -jane