[PATCH] Fixed coding style problems.

2018-06-08 Thread Chris Opperman
This patch fixes a coding style problem in drivers/staging/comedi/drivers.c and is submitted for task 10 of the eudyptula challenge. Signed-off-by: Chris Opperman --- drivers/staging/comedi/drivers.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi

[PATCH v4] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-12 Thread Chris Opperman
mprove readability of comedi_nsamples_left: a) Reduce nesting by using more return statements. b) Declare variables scans_left and samples_left at start of function. c) Change type of scans_Left to unsigned long long to avoid cast. Signed-off-by: Chris Opperman --- drivers/staging/comedi/drivers.

Re: [PATCH v4] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-13 Thread Chris Opperman
Hi Dan/Ian, Noted your comments regarding additional text, thanks! Just curious whether the "scissors" format given at the link below is valid? https://kernelnewbies.org/PatchTipsAndTricks It is given as an alternative to placing additional text below the cut-off line. Kind Rega

[PATCH v5] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-13 Thread Chris Opperman
Improve readability of comedi_nsamples_left: a) Reduce nesting by using more return statements. b) Declare variables scans_left and samples_left at start of function. c) Change type of scans_Left to unsigned long long to avoid cast. Signed-off-by: Chris Opperman --- Changes v5: a) Moved

Re: [PATCH v5] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-14 Thread Chris Opperman
Hi Ian, Thank you! Are there any more steps for me to take to complete this patch process? Kind Regards, Chris Opperman

Re: [PATCH v4] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-14 Thread Chris Opperman
Hi Ian/Dan, In that case I'll stick to the cut-off line format in future. Thanks! Kind Regards, Chris Opperman

Re: [PATCH] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-12 Thread Chris Opperman
Hi Dan, Thank you for the feedback, I'll update V4 of the patch accordingly and resend. I'll soon get a hang of the workflow! :) Best Regards, Chris Opperman

[PATCH] staging: comedi: shortened a long line

2018-06-09 Thread Chris Opperman
Shortened a long line to improve readability in drivers/staging/comedi/drivers.c Signed-off-by: Chris Opperman --- drivers/staging/comedi/drivers.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers.c b/drivers/staging/comedi/drivers.c index

[PATCH] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-09 Thread Chris Opperman
Signed-off-by: Chris Opperman --- drivers/staging/comedi/drivers.c | 29 ++--- 1 file changed, 14 insertions(+), 15 deletions(-) diff --git a/drivers/staging/comedi/drivers.c b/drivers/staging/comedi/drivers.c index 9d73347..3207ae2 100644 --- a/drivers/staging/comedi

Re: [PATCH] staging: wlan-ng: improved readability of function prism2_add_key

2018-06-20 Thread Chris Opperman
at be more acceptable? Kind Regards, Chris Opperman

[PATCH] staging: wlan-ng: improved readability of function prism2_add_key

2018-06-20 Thread Chris Opperman
Improve readability of prism2_add_key: a) Reduce nesting and removed goto statement by using more return statements. b) Added temporary "key" variable to reduce line length. Signed-off-by: Chris Opperman --- Improve readability of prism2_add_key: a) Reduce nesting and removed goto

Re: [PATCH] staging: wlan-ng: improved readability of function prism2_add_key

2018-06-21 Thread Chris Opperman
Hi Dan, The header also states "DO NOT EDIT OR MODIFY". As you suggested, I will rather leave this patch for now. P.S. Please advise if there is anything specific I can help out with, or I'll keep looking for more obvious fixes I can make while I'm learning the ropes. Kind Rega

Re: [PATCH] staging: wlan-ng: improved readability of function prism2_add_key

2018-06-22 Thread Chris Opperman
Okay, in that case I will fix and resend the patch. Kind Regards, Chris Opperman

[PATCH v2] staging: wlan-ng: improved readability of function prism2_add_key

2018-06-22 Thread Chris Opperman
Improve readability of prism2_add_key: a) Reduce nesting and removed goto statement by using more return statements. Signed-off-by: Chris Opperman --- drivers/staging/wlan-ng/cfg80211.c | 40 +- 1 file changed, 13 insertions(+), 27 deletions(-) diff --git

[PATCH] staging: wlan-ng: improved readability of function prism2_add_key

2018-06-20 Thread Chris Opperman
Improve readability of prism2_add_key: a) Reduce nesting and removed goto statement by using more return statements. b) Added temporary "key" variable to reduce line length. Signed-off-by: Chris Opperman --- Improve readability of prism2_add_key: a) Reduce nesting and removed goto

Re: [PATCH] staging: wlan-ng: improved readability of function prism2_add_key

2018-06-20 Thread Chris Opperman
at be more acceptable? Kind Regards, Chris Opperman

Re: [PATCH] staging: wlan-ng: improved readability of function prism2_add_key

2018-06-21 Thread Chris Opperman
Hi Dan, The header also states "DO NOT EDIT OR MODIFY". As you suggested, I will rather leave this patch for now. P.S. Please advise if there is anything specific I can help out with, or I'll keep looking for more obvious fixes I can make while I'm learning the ropes. Kind Rega

Re: [PATCH] staging: wlan-ng: improved readability of function prism2_add_key

2018-06-22 Thread Chris Opperman
Okay, in that case I will fix and resend the patch. Kind Regards, Chris Opperman

[PATCH v2] staging: wlan-ng: improved readability of function prism2_add_key

2018-06-22 Thread Chris Opperman
Improve readability of prism2_add_key: a) Reduce nesting and removed goto statement by using more return statements. Signed-off-by: Chris Opperman --- drivers/staging/wlan-ng/cfg80211.c | 40 +- 1 file changed, 13 insertions(+), 27 deletions(-) diff --git

Re: [PATCH] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-12 Thread Chris Opperman
Hi Dan, Thank you for the feedback, I'll update V4 of the patch accordingly and resend. I'll soon get a hang of the workflow! :) Best Regards, Chris Opperman

[PATCH v4] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-12 Thread Chris Opperman
mprove readability of comedi_nsamples_left: a) Reduce nesting by using more return statements. b) Declare variables scans_left and samples_left at start of function. c) Change type of scans_Left to unsigned long long to avoid cast. Signed-off-by: Chris Opperman --- drivers/staging/comedi/drivers.

Re: [PATCH v4] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-13 Thread Chris Opperman
Hi Dan/Ian, Noted your comments regarding additional text, thanks! Just curious whether the "scissors" format given at the link below is valid? https://kernelnewbies.org/PatchTipsAndTricks It is given as an alternative to placing additional text below the cut-off line. Kind Rega

[PATCH v5] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-13 Thread Chris Opperman
Improve readability of comedi_nsamples_left: a) Reduce nesting by using more return statements. b) Declare variables scans_left and samples_left at start of function. c) Change type of scans_Left to unsigned long long to avoid cast. Signed-off-by: Chris Opperman --- Changes v5: a) Moved

Re: [PATCH v5] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-14 Thread Chris Opperman
Hi Ian, Thank you! Are there any more steps for me to take to complete this patch process? Kind Regards, Chris Opperman

Re: [PATCH v4] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-14 Thread Chris Opperman
Hi Ian/Dan, In that case I'll stick to the cut-off line format in future. Thanks! Kind Regards, Chris Opperman

[PATCH] Fixed coding style problems.

2018-06-08 Thread Chris Opperman
This patch fixes a coding style problem in drivers/staging/comedi/drivers.c and is submitted for task 10 of the eudyptula challenge. Signed-off-by: Chris Opperman --- drivers/staging/comedi/drivers.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi

[PATCH] staging: comedi: shortened a long line

2018-06-09 Thread Chris Opperman
Shortened a long line to improve readability in drivers/staging/comedi/drivers.c Signed-off-by: Chris Opperman --- drivers/staging/comedi/drivers.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers.c b/drivers/staging/comedi/drivers.c index

[PATCH] staging: comedi: Improved readability of function comedi_nsamples_left.

2018-06-09 Thread Chris Opperman
Signed-off-by: Chris Opperman --- drivers/staging/comedi/drivers.c | 29 ++--- 1 file changed, 14 insertions(+), 15 deletions(-) diff --git a/drivers/staging/comedi/drivers.c b/drivers/staging/comedi/drivers.c index 9d73347..3207ae2 100644 --- a/drivers/staging/comedi