Re: [PATCH] i40iw: Replace mdelay with msleep in i40iw_wait_pe_ready

2018-01-05 Thread Shiraz Saleem
vers/infiniband/hw/i40iw/i40iw_main.c |2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > Thanks! Acked-by: Shiraz Saleem

Re: [PATCH v4 3/6] RDMA/i40iw: Eliminate duplicate barriers on weakly-ordered archs

2018-03-21 Thread Shiraz Saleem
Create a new wrapper function with relaxed write operator. Use the new > wrapper when a write is following a wmb(). > > Since code already has an explicit barrier call, changing writel() to > writel_relaxed(). > > Signed-off-by: Sinan Kaya Acked-by: Shiraz Saleem

Re: [PATCH] 40iw: include linux/irq.h

2018-03-13 Thread Shiraz Saleem
On Tue, Mar 13, 2018 at 01:06:20PM +0100, Arnd Bergmann wrote: > We get a build failure on ARM unless the header is included explicitly: > > drivers/infiniband/hw/i40iw/i40iw_verbs.c: In function > 'i40iw_get_vector_affinity': > drivers/infiniband/hw/i40iw/i40iw_verbs.c:2747:9: error: implicit de

Re: [PATCH] lib/scatterlist: Provide a DMA page iterator

2019-01-12 Thread Shiraz Saleem
On Fri, Jan 04, 2019 at 10:35:43PM +, Jason Gunthorpe wrote: > Commit 2db76d7c3c6d ("lib/scatterlist: sg_page_iter: support sg lists w/o > backing pages") introduced the sg_page_iter_dma_address() function without > providing a way to use it in the general case. If the sg_dma_len is not > equal

Re: [PATCH] lib/scatterlist: Provide a DMA page iterator

2019-01-12 Thread Shiraz Saleem
On Sat, Jan 12, 2019 at 06:37:58PM +, Jason Gunthorpe wrote: > On Sat, Jan 12, 2019 at 12:27:05PM -0600, Shiraz Saleem wrote: > > On Fri, Jan 04, 2019 at 10:35:43PM +, Jason Gunthorpe wrote: > > > Commit 2db76d7c3c6d ("lib/scatterlist: sg_page_iter: support sg lists

Re: mutex and rcu list traversal idiosyncrasy

2018-09-14 Thread Shiraz Saleem
On Thu, Sep 13, 2018 at 05:55:44AM -0600, HÃ¥kon Bugge wrote: > Hi Faisal, > > > In commit f27b4746f378 ("i40iw: add connection management code") you have in > i40iw_add_mqh_6(): > > rtnl_lock(); > for_each_netdev_rcu(...) { > [] > } > rtnl_unlock(); > > Shouldn't this read: > rtnl_lock()

Re: [PATCH 2/3] infiniband: i40iw: Replace GFP_ATOMIC with GFP_KERNEL in i40iw_make_listen_node

2018-04-13 Thread Shiraz Saleem
is found by a static analysis tool named DCNS written by myself. > And I also manually check it. > > Signed-off-by: Jia-Ju Bai > --- > Acked-by: Shiraz Saleem

Re: [PATCH 1/3] infiniband: i40iw: Replace GFP_ATOMIC with GFP_KERNEL in i40iw_add_mqh_4

2018-04-13 Thread Shiraz Saleem
t. > > Signed-off-by: Jia-Ju Bai > --- Acked-by: Shiraz Saleem

Re: [PATCH 3/3] infiniband: i40iw: Replace GFP_ATOMIC with GFP_KERNEL in i40iw_l2param_change

2018-04-13 Thread Shiraz Saleem
allocation. > > This is found by a static analysis tool named DCNS written by myself. > And I also manually check it. > > Signed-off-by: Jia-Ju Bai > --- > Acked-by: Shiraz Saleem

Re: [PATCH 1/3] infiniband: i40iw: Replace GFP_ATOMIC with GFP_KERNEL in i40iw_add_mqh_4

2018-04-13 Thread Shiraz Saleem
On Wed, Apr 11, 2018 at 10:53:13AM -0400, Dennis Dalessandro wrote: > On 4/11/2018 3:32 AM, Jia-Ju Bai wrote: > > i40iw_add_mqh_4() is never called in atomic context, because it > > calls rtnl_lock() that can sleep. > > > > Despite never getting called from atomic context, > > i40iw_add_mqh_4() ca

Re: [PATCH] infiniband: hw: i40iw: fix duplicated code for different branches

2017-05-19 Thread Shiraz Saleem
v, vf_id, vchnl_msg); > return I40IW_SUCCESS; > } > for (iw_vf_idx = 0; iw_vf_idx < I40IW_MAX_PE_ENABLED_VF_COUNT; > iw_vf_idx++) { > -- Acked-by: Shiraz Saleem

Re: [PATCH] i40iw: Simplify code

2017-07-17 Thread Shiraz Saleem
On Sun, Jul 16, 2017 at 01:09:23PM +0200, Christophe JAILLET wrote: > Axe a few lines of code and re-use existing error handling path to avoid > code duplication. > Acked-by: Shiraz Saleem

Re: [PATCH] i40iw: make some structures const

2017-08-29 Thread Shiraz Saleem
On Mon, Aug 28, 2017 at 09:51:23PM +0530, Bhumika Goyal wrote: > Make some structures const as they are only used during a copy > operation. > > Signed-off-by: Bhumika Goyal Thanks! Acked-by: Shiraz Saleem

Re: [PATCH] RDMA/i40iw: Convert timers to use timer_setup()

2017-10-06 Thread Shiraz Saleem
On Wed, Oct 04, 2017 at 05:45:41PM -0700, Kees Cook wrote: > In preparation for unconditionally passing the struct timer_list pointer to > all timer callbacks, switch to using the new timer_setup() and from_timer() > to pass the timer pointer explicitly. > > Cc: Faisal Latif >

Re: [PATCH] RDMA/i40iw: Convert timers to use timer_setup()

2017-10-07 Thread Shiraz Saleem
On Fri, Oct 06, 2017 at 06:17:23PM -0500, Shiraz Saleem wrote: > On Wed, Oct 04, 2017 at 05:45:41PM -0700, Kees Cook wrote: > > In preparation for unconditionally passing the struct timer_list pointer to > > all timer callbacks, switch to using the new timer_setup() and from_time

Re: [PATCH] i40iw: Add a value assignment to avoid sleep-in-atomic bug caused by uninitialized value

2017-06-02 Thread Shiraz Saleem
On Thu, Jun 01, 2017 at 10:11:16AM +0800, Jia-Ju Bai wrote: > The value "cqp_request->waiting" indicates whether the sleeping operation > should be performed, and it is not assigned in i40iw_get_cqp_request, so > the driver may sleep in interrupt handling. The function call path is: > > i40iw_dp

Re: [PATCH 1/2] i40iw: remove unused 'timeval' struct member

2017-11-28 Thread Shiraz Saleem
, so let's just remove this one. > > Signed-off-by: Arnd Bergmann > --- Thanks! Acked-by: Shiraz Saleem

Re: [PATCH] i40w: Remove garbage at end of INFINIBAND_I40IW Kconfig section

2017-11-20 Thread Shiraz Saleem
On Sun, Nov 19, 2017 at 07:59:21PM +0100, Geert Uytterhoeven wrote: > Remove leftover garbage (containing Kconfig dependencies for another > symbol?) > > Signed-off-by: Geert Uytterhoeven > --- Acked-by: Shiraz Saleem