Re: [PATCH] x86/apic: Move pending intr check code into it's own function

2018-02-14 Thread Andy Shevchenko
On Wed, Feb 14, 2018 at 8:24 AM, Dou Liyang wrote: Yes, I see you just moved the old code, but it might make sense to update later the following. > + for (j = 31; j >= 0; j--) { > + if (value & (1<

Re: [PATCH] x86/apic: Move pending intr check code into it's own function

2018-02-14 Thread Andy Shevchenko
On Wed, Feb 14, 2018 at 8:24 AM, Dou Liyang wrote: Yes, I see you just moved the old code, but it might make sense to update later the following. > + for (j = 31; j >= 0; j--) { > + if (value & (1< +

[PATCH] x86/apic: Move pending intr check code into it's own function

2018-02-13 Thread Dou Liyang
the pending interrupt check code is mixed with the local APIC setup code, that looks messy. Extract the related code, move it into a new function named apic_pending_intr_clear(). Signed-off-by: Dou Liyang --- arch/x86/kernel/apic/apic.c | 98

[PATCH] x86/apic: Move pending intr check code into it's own function

2018-02-13 Thread Dou Liyang
the pending interrupt check code is mixed with the local APIC setup code, that looks messy. Extract the related code, move it into a new function named apic_pending_intr_clear(). Signed-off-by: Dou Liyang --- arch/x86/kernel/apic/apic.c | 98 - 1