Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Andy Shevchenko
On Wed, Jan 9, 2013 at 5:10 PM, Vinod Koul  wrote:
> On Wed, Jan 09, 2013 at 04:58:02PM +0200, Andy Shevchenko wrote:
>> On Wed, Jan 9, 2013 at 4:19 PM, Viresh Kumar  wrote:
>> > n 9 January 2013 19:20, Vinod Koul  wrote:
>> >>> +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
>> >>> +{
>> >>> + return (direction == DMA_MEM_TO_DEV) || (direction == 
>> >>> DMA_DEV_TO_MEM);
>> >>> +}
>> >> After reading the subsequent patch I understand what is intent here. 
>> >> Perhaps
>> >> is_slave_dirn() would have been a beter one...
>> >
>> > dirn isn't readable, it took me some time to understand the intent...
>> > Either have xfer or direction :)
>>
>> Agree with Viresh. I might rename it to is_slave_direction if you want to.
> direction sounds fine too.

Okay, I'll rename it tomorrow and send v2 for that subseries and the
other patch where changelog should be fixed.

>
> --
> ~Vinod



-- 
With Best Regards,
Andy Shevchenko
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Vinod Koul
On Wed, Jan 09, 2013 at 04:58:02PM +0200, Andy Shevchenko wrote:
> On Wed, Jan 9, 2013 at 4:19 PM, Viresh Kumar  wrote:
> > n 9 January 2013 19:20, Vinod Koul  wrote:
> >>> +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
> >>> +{
> >>> + return (direction == DMA_MEM_TO_DEV) || (direction == 
> >>> DMA_DEV_TO_MEM);
> >>> +}
> >> After reading the subsequent patch I understand what is intent here. 
> >> Perhaps
> >> is_slave_dirn() would have been a beter one...
> >
> > dirn isn't readable, it took me some time to understand the intent...
> > Either have xfer or direction :)
> 
> Agree with Viresh. I might rename it to is_slave_direction if you want to.
direction sounds fine too.

--
~Vinod
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Andy Shevchenko
On Wed, Jan 9, 2013 at 4:19 PM, Viresh Kumar  wrote:
> n 9 January 2013 19:20, Vinod Koul  wrote:
>>> +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
>>> +{
>>> + return (direction == DMA_MEM_TO_DEV) || (direction == DMA_DEV_TO_MEM);
>>> +}
>> After reading the subsequent patch I understand what is intent here. Perhaps
>> is_slave_dirn() would have been a beter one...
>
> dirn isn't readable, it took me some time to understand the intent...
> Either have xfer or direction :)

Agree with Viresh. I might rename it to is_slave_direction if you want to.

-- 
With Best Regards,
Andy Shevchenko
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Viresh Kumar
n 9 January 2013 19:20, Vinod Koul  wrote:
>> +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
>> +{
>> + return (direction == DMA_MEM_TO_DEV) || (direction == DMA_DEV_TO_MEM);
>> +}
> After reading the subsequent patch I understand what is intent here. Perhaps
> is_slave_dirn() would have been a beter one...

dirn isn't readable, it took me some time to understand the intent...
Either have xfer or direction :)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Vinod Koul
On Wed, Jan 09, 2013 at 10:17:02AM +0200, Andy Shevchenko wrote:
> This function helps to distinguish the slave type of transfer by checking the
> direction parameter.
> 
> Signed-off-by: Andy Shevchenko 
> Reviewed-by: Viresh Kumar 
> Reviewed-by: Mika Westerberg 
> Reviewed-by: Linus Walleij 
> Cc: Nicolas Ferre 
> Cc: Guennadi Liakhovetski 
> ---
>  include/linux/dmaengine.h |5 +
>  1 file changed, 5 insertions(+)
> 
> diff --git a/include/linux/dmaengine.h b/include/linux/dmaengine.h
> index 4ca9cf7..b196ea3 100644
> --- a/include/linux/dmaengine.h
> +++ b/include/linux/dmaengine.h
> @@ -621,6 +621,11 @@ static inline int dmaengine_slave_config(struct dma_chan 
> *chan,
>   (unsigned long)config);
>  }
>  
> +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
> +{
> + return (direction == DMA_MEM_TO_DEV) || (direction == DMA_DEV_TO_MEM);
> +}
After reading the subsequent patch I understand what is intent here. Perhaps
is_slave_dirn() would have been a beter one...

> +
>  static inline struct dma_async_tx_descriptor *dmaengine_prep_slave_single(
>   struct dma_chan *chan, dma_addr_t buf, size_t len,
>   enum dma_transfer_direction dir, unsigned long flags)
> -- 
> 1.7.10.4
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Andy Shevchenko
This function helps to distinguish the slave type of transfer by checking the
direction parameter.

Signed-off-by: Andy Shevchenko 
Reviewed-by: Viresh Kumar 
Reviewed-by: Mika Westerberg 
Reviewed-by: Linus Walleij 
Cc: Nicolas Ferre 
Cc: Guennadi Liakhovetski 
---
 include/linux/dmaengine.h |5 +
 1 file changed, 5 insertions(+)

diff --git a/include/linux/dmaengine.h b/include/linux/dmaengine.h
index 4ca9cf7..b196ea3 100644
--- a/include/linux/dmaengine.h
+++ b/include/linux/dmaengine.h
@@ -621,6 +621,11 @@ static inline int dmaengine_slave_config(struct dma_chan 
*chan,
(unsigned long)config);
 }
 
+static inline bool is_slave_xfer(enum dma_transfer_direction direction)
+{
+   return (direction == DMA_MEM_TO_DEV) || (direction == DMA_DEV_TO_MEM);
+}
+
 static inline struct dma_async_tx_descriptor *dmaengine_prep_slave_single(
struct dma_chan *chan, dma_addr_t buf, size_t len,
enum dma_transfer_direction dir, unsigned long flags)
-- 
1.7.10.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


[resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Andy Shevchenko
This function helps to distinguish the slave type of transfer by checking the
direction parameter.

Signed-off-by: Andy Shevchenko andriy.shevche...@linux.intel.com
Reviewed-by: Viresh Kumar viresh.ku...@linaro.org
Reviewed-by: Mika Westerberg mika.westerb...@linux.intel.com
Reviewed-by: Linus Walleij linus.wall...@linaro.org
Cc: Nicolas Ferre nicolas.fe...@atmel.com
Cc: Guennadi Liakhovetski g.liakhovet...@gmx.de
---
 include/linux/dmaengine.h |5 +
 1 file changed, 5 insertions(+)

diff --git a/include/linux/dmaengine.h b/include/linux/dmaengine.h
index 4ca9cf7..b196ea3 100644
--- a/include/linux/dmaengine.h
+++ b/include/linux/dmaengine.h
@@ -621,6 +621,11 @@ static inline int dmaengine_slave_config(struct dma_chan 
*chan,
(unsigned long)config);
 }
 
+static inline bool is_slave_xfer(enum dma_transfer_direction direction)
+{
+   return (direction == DMA_MEM_TO_DEV) || (direction == DMA_DEV_TO_MEM);
+}
+
 static inline struct dma_async_tx_descriptor *dmaengine_prep_slave_single(
struct dma_chan *chan, dma_addr_t buf, size_t len,
enum dma_transfer_direction dir, unsigned long flags)
-- 
1.7.10.4

--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Vinod Koul
On Wed, Jan 09, 2013 at 10:17:02AM +0200, Andy Shevchenko wrote:
 This function helps to distinguish the slave type of transfer by checking the
 direction parameter.
 
 Signed-off-by: Andy Shevchenko andriy.shevche...@linux.intel.com
 Reviewed-by: Viresh Kumar viresh.ku...@linaro.org
 Reviewed-by: Mika Westerberg mika.westerb...@linux.intel.com
 Reviewed-by: Linus Walleij linus.wall...@linaro.org
 Cc: Nicolas Ferre nicolas.fe...@atmel.com
 Cc: Guennadi Liakhovetski g.liakhovet...@gmx.de
 ---
  include/linux/dmaengine.h |5 +
  1 file changed, 5 insertions(+)
 
 diff --git a/include/linux/dmaengine.h b/include/linux/dmaengine.h
 index 4ca9cf7..b196ea3 100644
 --- a/include/linux/dmaengine.h
 +++ b/include/linux/dmaengine.h
 @@ -621,6 +621,11 @@ static inline int dmaengine_slave_config(struct dma_chan 
 *chan,
   (unsigned long)config);
  }
  
 +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
 +{
 + return (direction == DMA_MEM_TO_DEV) || (direction == DMA_DEV_TO_MEM);
 +}
After reading the subsequent patch I understand what is intent here. Perhaps
is_slave_dirn() would have been a beter one...

 +
  static inline struct dma_async_tx_descriptor *dmaengine_prep_slave_single(
   struct dma_chan *chan, dma_addr_t buf, size_t len,
   enum dma_transfer_direction dir, unsigned long flags)
 -- 
 1.7.10.4
 
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Viresh Kumar
n 9 January 2013 19:20, Vinod Koul vinod.k...@intel.com wrote:
 +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
 +{
 + return (direction == DMA_MEM_TO_DEV) || (direction == DMA_DEV_TO_MEM);
 +}
 After reading the subsequent patch I understand what is intent here. Perhaps
 is_slave_dirn() would have been a beter one...

dirn isn't readable, it took me some time to understand the intent...
Either have xfer or direction :)
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Andy Shevchenko
On Wed, Jan 9, 2013 at 4:19 PM, Viresh Kumar viresh.ku...@linaro.org wrote:
 n 9 January 2013 19:20, Vinod Koul vinod.k...@intel.com wrote:
 +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
 +{
 + return (direction == DMA_MEM_TO_DEV) || (direction == DMA_DEV_TO_MEM);
 +}
 After reading the subsequent patch I understand what is intent here. Perhaps
 is_slave_dirn() would have been a beter one...

 dirn isn't readable, it took me some time to understand the intent...
 Either have xfer or direction :)

Agree with Viresh. I might rename it to is_slave_direction if you want to.

-- 
With Best Regards,
Andy Shevchenko
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Vinod Koul
On Wed, Jan 09, 2013 at 04:58:02PM +0200, Andy Shevchenko wrote:
 On Wed, Jan 9, 2013 at 4:19 PM, Viresh Kumar viresh.ku...@linaro.org wrote:
  n 9 January 2013 19:20, Vinod Koul vinod.k...@intel.com wrote:
  +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
  +{
  + return (direction == DMA_MEM_TO_DEV) || (direction == 
  DMA_DEV_TO_MEM);
  +}
  After reading the subsequent patch I understand what is intent here. 
  Perhaps
  is_slave_dirn() would have been a beter one...
 
  dirn isn't readable, it took me some time to understand the intent...
  Either have xfer or direction :)
 
 Agree with Viresh. I might rename it to is_slave_direction if you want to.
direction sounds fine too.

--
~Vinod
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/


Re: [resend][PATCH 03/16] dmaengine: introduce is_slave_xfer function

2013-01-09 Thread Andy Shevchenko
On Wed, Jan 9, 2013 at 5:10 PM, Vinod Koul vinod.k...@intel.com wrote:
 On Wed, Jan 09, 2013 at 04:58:02PM +0200, Andy Shevchenko wrote:
 On Wed, Jan 9, 2013 at 4:19 PM, Viresh Kumar viresh.ku...@linaro.org wrote:
  n 9 January 2013 19:20, Vinod Koul vinod.k...@intel.com wrote:
  +static inline bool is_slave_xfer(enum dma_transfer_direction direction)
  +{
  + return (direction == DMA_MEM_TO_DEV) || (direction == 
  DMA_DEV_TO_MEM);
  +}
  After reading the subsequent patch I understand what is intent here. 
  Perhaps
  is_slave_dirn() would have been a beter one...
 
  dirn isn't readable, it took me some time to understand the intent...
  Either have xfer or direction :)

 Agree with Viresh. I might rename it to is_slave_direction if you want to.
 direction sounds fine too.

Okay, I'll rename it tomorrow and send v2 for that subseries and the
other patch where changelog should be fixed.


 --
 ~Vinod



-- 
With Best Regards,
Andy Shevchenko
--
To unsubscribe from this list: send the line unsubscribe linux-kernel in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/