Re: [PATCH] mmc: block: use memdup_user

2017-05-19 Thread Ulf Hansson
On 13 May 2017 at 05:15, Geliang Tang  wrote:
> Use memdup_user() helper instead of open-coding to simplify the code.
>
> Signed-off-by: Geliang Tang 
> ---
>  drivers/mmc/core/block.c | 14 --
>  1 file changed, 4 insertions(+), 10 deletions(-)
>
> diff --git a/drivers/mmc/core/block.c b/drivers/mmc/core/block.c
> index 8273b07..47ccb2a 100644
> --- a/drivers/mmc/core/block.c
> +++ b/drivers/mmc/core/block.c
> @@ -342,21 +342,15 @@ static struct mmc_blk_ioc_data 
> *mmc_blk_ioctl_copy_from_user(
> return idata;
> }
>
> -   idata->buf = kmalloc(idata->buf_bytes, GFP_KERNEL);
> -   if (!idata->buf) {
> -   err = -ENOMEM;
> +   idata->buf = memdup_user((void __user *)(unsigned long)
> +idata->ic.data_ptr, idata->buf_bytes);
> +   if (IS_ERR(idata->buf)) {
> +   err = PTR_ERR(idata->buf);
> goto idata_err;
> }
>
> -   if (copy_from_user(idata->buf, (void __user *)(unsigned long)
> -   idata->ic.data_ptr, 
> idata->buf_bytes)) {
> -   err = -EFAULT;
> -   goto copy_err;
> -   }
> -
> return idata;
>
> -copy_err:
> kfree(idata->buf);

As we aren't using the copy_err label no more, you can also remove the
above line.

>  idata_err:
> kfree(idata);
> --
> 2.9.3
>

Kind regards
Uffe


Re: [PATCH] mmc: block: use memdup_user

2017-05-19 Thread Ulf Hansson
On 13 May 2017 at 05:15, Geliang Tang  wrote:
> Use memdup_user() helper instead of open-coding to simplify the code.
>
> Signed-off-by: Geliang Tang 
> ---
>  drivers/mmc/core/block.c | 14 --
>  1 file changed, 4 insertions(+), 10 deletions(-)
>
> diff --git a/drivers/mmc/core/block.c b/drivers/mmc/core/block.c
> index 8273b07..47ccb2a 100644
> --- a/drivers/mmc/core/block.c
> +++ b/drivers/mmc/core/block.c
> @@ -342,21 +342,15 @@ static struct mmc_blk_ioc_data 
> *mmc_blk_ioctl_copy_from_user(
> return idata;
> }
>
> -   idata->buf = kmalloc(idata->buf_bytes, GFP_KERNEL);
> -   if (!idata->buf) {
> -   err = -ENOMEM;
> +   idata->buf = memdup_user((void __user *)(unsigned long)
> +idata->ic.data_ptr, idata->buf_bytes);
> +   if (IS_ERR(idata->buf)) {
> +   err = PTR_ERR(idata->buf);
> goto idata_err;
> }
>
> -   if (copy_from_user(idata->buf, (void __user *)(unsigned long)
> -   idata->ic.data_ptr, 
> idata->buf_bytes)) {
> -   err = -EFAULT;
> -   goto copy_err;
> -   }
> -
> return idata;
>
> -copy_err:
> kfree(idata->buf);

As we aren't using the copy_err label no more, you can also remove the
above line.

>  idata_err:
> kfree(idata);
> --
> 2.9.3
>

Kind regards
Uffe